Suite Thue_Morse
Algorithme pascal
0) Fonction Thue_Morse (N : Entier ; A: Caractère) :
Chaîne
1) CH ← A
2) Pour i de 1 à ...
0) Procédure Triangle_pascal (N: Entier; VAR MAT :
Matrice);
1) MAT [1,1] ← 1
2) MAT [2,1] ← 1
3) MAT [2,2] ← 1
4) Pour li...
0) Fonction Fibo_nacci(N : Entier) : Entier Long
1) U1 ← 1
2) U2 ← 1
3) Si N ≤ 2 Alors Fibo ← 1
Sinon
Pour i de 3 à N Fair...
Remplir la partie supérieur droite de la matrice M d’ordre n :
0) Fonction Nombre_Or (précision : Réel) : Réel ;
1) U[1]← ...
i
 La partie colorée sera rempli
0) Def proc remplir (var M :mat ; n :entier)
1) pour i de 1 à n faire
pour j de i à n fa...
i
0) Def proc remplir (var m : mat ; n : entier)
1) pour i de 1 à n faire
pour j de 1 à i faire
lire (M[i,j])
fin pour
fin...
0) Def proc remplir (var M: mat ; n :entier)
1) pour i de 1 à n faire
pour j de i+1 à n faire
lire (M[i,j])
fin pour
fin p...
0) Def proc remplir (var M: mat ; n: entier)
1) pour i de 2 à n faire
pour j de 1 à i-1 faire
lire (M[i,j])
fin pour
fin p...
0) Def proc remplir (var M: mat ; n: entier)
1) pour i de 3 à n-1 faire
pour j de 2 à i-1 faire
lire (M[i,j])
fin pour
fin...
0) Def proc remplir (var M: mat ; n: entier)
1) pour i de 1 à n faire
lire (M[i,i])
fin pour
2) fin remplir
Suite de Thue-...
Fin Si
L ← Long (Ch)
j ← j + 2
Jusqu'à (j > L)
Fin Pour
3) Thue_Morse ← Ch
4) Fin Thue_Morse
Triangle pascal
0) Procédure ...
Prochain SlideShare
Chargement dans…5
×

Resumer algorithme recurent

686 vues

Publié le

Publié dans : Formation
0 commentaire
1 j’aime
Statistiques
Remarques
  • Soyez le premier à commenter

Aucun téléchargement
Vues
Nombre de vues
686
Sur SlideShare
0
Issues des intégrations
0
Intégrations
37
Actions
Partages
0
Téléchargements
24
Commentaires
0
J’aime
1
Intégrations 0
Aucune incorporation

Aucune remarque pour cette diapositive

Resumer algorithme recurent

  1. 1. Suite Thue_Morse Algorithme pascal 0) Fonction Thue_Morse (N : Entier ; A: Caractère) : Chaîne 1) CH ← A 2) Pour i de 1 à N Faire j ← 1 Répéter Si CH[j] = "0" Alors insère ("1", CH , j +1) Sinon insère ("0", CH, j +1) Fin Si L ← Long (Ch) j ← j + 2 Jusqu'à (j > L) Fin Pour 3) Thue_Morse ← Ch 4) Fin Thue_Morse FUNCTION Thue_Morse (N: Integer; A : Char ) : String ; VAR Ch : String ; i, j, L : Integer ; Begin Ch := A ; For i := 1 To N Do Begin j := 1 ; Repeat If Ch [j] = '0' Then Insert ('1', Ch, j+1) Else Insert ('0', Ch, j+1); L := Length (Ch) ; j := j+ 2; Until j > l ; End; Thue_Morse := Ch ; End ; Triangle pascal Resumer sur les algorithme recurent
  2. 2. 0) Procédure Triangle_pascal (N: Entier; VAR MAT : Matrice); 1) MAT [1,1] ← 1 2) MAT [2,1] ← 1 3) MAT [2,2] ← 1 4) Pour ligne de 3 à N Faire MAT [ligne, 1] ← 1 MAT [Ligne, Ligne] ← 1 Pour colonne de 2 à ligne -1 Faire MAT [ligne, colonne] ← MAT [ligne - 1, colonne] + MAT [ligne -1 , colonne - 1] Fin Pour Fin Pour 5) Fin Triangle_pascal PROCEDURE Triangle_pascal (N: Integer; VAR MAT : Matrice); VAR ligne, colonne : Integer ; BEGIN MAT [1,1] := 1 ; MAT [2,1] := 1 ; 4INFINFRC0004 Page 11 MAT [2,2] := 1 ; For ligne := 3 To N Do Begin MAT [ligne, 1] := 1; MAT [Ligne, Ligne] := 1; For colonne := 2 To ligne -1 Do Begin MAT [ligne, colonne] := MAT [ligne - 1, colonne] + MAT [ligne -1 , colonne - 1]; End ; End ; END ; La suite de Fibonacci
  3. 3. 0) Fonction Fibo_nacci(N : Entier) : Entier Long 1) U1 ← 1 2) U2 ← 1 3) Si N ≤ 2 Alors Fibo ← 1 Sinon Pour i de 3 à N Faire Fibo ← U1 + U2 U1 ← U2 U2 ← Fibo Fin Pour Fin Si 5) Fibo_Itérative ← Fibo 6) Fin Fibo_Itérative FUNCTION Fibo_Iterative (N : Integer ) : LongInt ; VAR U1, U2, i : Integer ; Fibo : LongInt ; BEGIN U1 := 1 ; U2 := 1 ; If N <= 2 Then Fibo := 1 Else For i := 3 To N Do Begin Fibo := U1 + U2 ; U1 := U2 ; U2 := Fibo ; End ; Fibo_Iterative := Fibo ; END ; Le nombre d'or
  4. 4. Remplir la partie supérieur droite de la matrice M d’ordre n : 0) Fonction Nombre_Or (précision : Réel) : Réel ; 1) U[1]← 1 U[2] ← 2 i ← 2; 2) Répéter i ← i + 1 U[i] ← U[i-1] + U[i-2] V[i] ← U[i] / U[i-1] Jusqu'à ABS(V[i] - V[i-1]) < précision ; 3) Nombre_Or ← V[i] 4) Fin Nombre_Or
  5. 5. i  La partie colorée sera rempli 0) Def proc remplir (var M :mat ; n :entier) 1) pour i de 1 à n faire pour j de i à n faire lire (M[i,j]) fin pour fin pour 2) fin remplir  Remplir la partie gauche inférieur de la matrice M d’ordre n :
  6. 6. i 0) Def proc remplir (var m : mat ; n : entier) 1) pour i de 1 à n faire pour j de 1 à i faire lire (M[i,j]) fin pour fin pour 2) fin remplir  Remplir la partie colorée de la matrice M :
  7. 7. 0) Def proc remplir (var M: mat ; n :entier) 1) pour i de 1 à n faire pour j de i+1 à n faire lire (M[i,j]) fin pour fin pour 2) fin remplir  Remplir la partie colorée de la matrice M :
  8. 8. 0) Def proc remplir (var M: mat ; n: entier) 1) pour i de 2 à n faire pour j de 1 à i-1 faire lire (M[i,j]) fin pour fin pour 2) fin remplir  Remplir la partie colorée de la matrice M
  9. 9. 0) Def proc remplir (var M: mat ; n: entier) 1) pour i de 3 à n-1 faire pour j de 2 à i-1 faire lire (M[i,j]) fin pour fin pour 2) fin remplir  Remplir la partie colorée da la matrice M :
  10. 10. 0) Def proc remplir (var M: mat ; n: entier) 1) pour i de 1 à n faire lire (M[i,i]) fin pour 2) fin remplir Suite de Thue-Morse : 0) Fonction Thue_Morse (N : Entier ; A: Caractère) : Chaîne 1) CH ← A 2) Pour i de 1 à N Faire j ← 1 Répéter Si CH[j] = "0" Alors insère ("1", CH , j +1) Sinon insère ("0", CH, j +1)
  11. 11. Fin Si L ← Long (Ch) j ← j + 2 Jusqu'à (j > L) Fin Pour 3) Thue_Morse ← Ch 4) Fin Thue_Morse Triangle pascal 0) Procédure Triangle_itératif (N: Entier; VAR MAT : Matrice); 1) MAT [1,1] � 1 2) MAT [2,1] � 1 3) MAT [2,2] � 1 4) Pour ligne de 3 à N Faire MAT [ligne, 1] � 1 MAT [Ligne, Ligne] � 1 Pour colonne de 2 à ligne -1 Faire MAT [ligne, colonne] � MAT [ligne - 1, colonne] + MAT [ligne -1 , colonne - 1] Fin Pour Fin Pour 5) Fin Triangle_itératif

×