SlideShare une entreprise Scribd logo
1  sur  8
How to Configure Routing Information Protocol (RIP)?
If you are not familiar with Routing Information Protocol (RIP), click the following link
to view an introduction to Routing Information Protocol (RIP).

Routing Information Protocol (RIP) Configuration
Routing Information Protocol (RIP) can be configured in a router using the
following IOS commands. The "version 2" IOScommand specifies that we are using
RIPv2.
Router>enable
Router#configure terminal
Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# network network_id

Routing Information Protocol (RIP) - Lab Practice
The following diagram shows our lab setup. We have three routers, three switches
and three hosts connected as below. The host names, IP addresses and
the interfaces of the routers are shown in diagram. The IP addresses of the hosts are
also shown in the diagram.




Notes: If you are not familiar with a router console connection, click the following link
to learn how to connect the serial port of your computer to router console port.

Click the following link to learn how to connect to the console port of the router if
there is no serial port in your computer.



http://blog.router-switch.com/
Click the following links to learn how to use HyperTerminal                   terminal
emulator and PuTTY terminal emulator to configure router.

Hostname and IP address configuration in Router01
Connect to Router01 console and use the following IOS commands to configure host
name as Router01.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#

Use the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router01 and configure IP address as 172.16.0.1/16.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface fa0/0
Router01(config-if)#ip address 172.16.0.1 255.255.0.0
Router01(config-if)#no shutdown

Use the following IOS commands to open the serial interface S0/0 configuration
mode on Router01 and configure IP addressas 172.17.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/0 interface, since this is the DCE side.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface s0/0
Router01(config-if)#clock rate 64000
Router01(config-if)#ip address 172.17.0.1 255.255.0.0
Router01(config-if)#no shutdown

Do remember to run the "copy running-config startup-config" command from enable
mode, if you want to save the changes you have made in the router.

Hostname and IP address configuration in Router02
Connect to Router02 console and use the following IOS commands to configure host
name as Router02.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router02
Router02(config)#



http://blog.router-switch.com/
Use the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router02 and configure IP address as 172.18.0.1/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown

Use the following IOS commands to open the serial interface S0/0 configuration
mode on Router02 and configure IP addressas 172.17.0.2/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown

Use the following IOS commands to open the serial interface S0/1 configuration
mode on Router02 and configure IP addressas 172.19.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/1 interface, since this is the DCE side.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown

Do remember to run the "copy running-config startup-config" command from enable
mode, if you want to save the changes you have made in the router.

Hostname and IP address configuration in Router03
Connect to Router03 console and use the following IOS commands to configure host
name as Router03.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#

Use the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router03 and configure IP address as 172.20.0.1/16.
Router03>enable

http://blog.router-switch.com/
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown

Use the following IOS commands to open the serial interface S0/1 configuration
mode on Router03 and configure IP addressas 172.19.0.2/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown

Do remember to run the "copy running-config startup-config" command from enable
mode, if you want to save the changes you have made in the router.

Routing Information Protocol Version 2 (RIPv2) configuration in Router01
Connect to Router01 console and use the following IOS commands to
configure Routing Information Protocol Version 2 (RIPv2) in Router01. Please refer
the beginning of this lesson to view the Routing Information Protocol Version 2
(RIPv2) configuration IOS commands.

Using the IOS "network" command, as shown below, we specify only the directly
connected networks of this router.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#router rip
Router01(config-router)#version 2
Router01(config-router)#network 172.16.0.0
Router01(config-router)#network 172.17.0.0
Router01(config-router)#exit
Router01(config)#exit
Router01#

Do remember to run the "copy running-config startup-config" command from enable
mode, if you want to save the changes you have made in the router.

Routing Information Protocol Version 2 (RIPv2) configuration in Router02
Connect to Router02 console and use the following IOS commands to configure
Routing Information Protocol Version 2 (RIPv2) in Router02. Please refer the
beginning of this lesson to view the Routing Information Protocol Version 2 (RIPv2)

http://blog.router-switch.com/
configurationIOS commands.

Using the IOS "network" command, as shown below, we specify only the directly
connected networks of this router.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#router rip
Router02(config-router)#version 2
Router02(config-router)#network 172.17.0.0
Router02(config-router)#network 172.18.0.0
Router02(config-router)#network 172.19.0.0
Router02(config-router)#exit
Router02(config)#exit
Router02#

Do remember to run the "copy running-config startup-config" command from enable
mode, if you want to save the changes you have made in the router.

Routing Information Protocol Version 2 (RIPv2) configuration in Router03
Connect to Router03 console and use the following IOS commands to configure
Routing Information Protocol Version 2 (RIPv2) in Router03. Please refer the
beginning of this lesson to view the Routing Information Protocol Version 2 (RIPv2)
configurationIOS commands.

Using the IOS "network" command, as shown below, we specify only the directly
connected networks of this router.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#router rip
Router03(config-router)#version 2
Router03(config-router)#network 172.19.0.0
Router03(config-router)#network 172.20.0.0
Router03(config-router)#exit
Router03(config)#exit
Router03#

Do remember to run the "copy running-config startup-config" command from enable
mode, if you want to save the changes you have made in the router.

How to View the Routing Table in Router01
After the network is converged after the initial configuration and
Routing Information Protocol Version 2 (RIPv2) configuration, we can use the "show

http://blog.router-switch.com/
ip route" to view the routing table in Router01, as shown below.
Router01>enable
Router01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
R 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
R 172.19.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
R 172.20.0.0/16 [120/2] via 172.17.0.2, 00:00:22, Serial0/0

The "R" character at the beginning of a line in routing table shows that it is a route
discovered by Routing Information Protocol Version 2 (RIPv2) and "C" character
shows that it is a directly connected network.

How to View the Routing Table in Router02
When the network is converged after the initial configuration and Routing
Information Protocol Version 2 (RIPv2) configuration, we can use the "show ip route"
to view the routing table in Router02, as shown below.
Router02>enable
Router02#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
R 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:07, Serial0/0
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0
C 172.19.0.0/16 is directly connected, Serial0/1
R 172.20.0.0/16 [120/1] via 172.19.0.2, 00:00:20, Serial0/1

The "R" character at the beginning of a line in routing table shows that it is a route
discovered by Routing Information Protocol Version 2 (RIPv2) and "C" character
shows that it is a directly connected network.

http://blog.router-switch.com/
How to View the Routing Table in Router03
When the network is converged after the initial configuration and Routing
Information Protocol Version 2 (RIPv2) configuration, we can use the "show ip route"
to view the routing table in Router03, as shown below.
Router03>enable
Router03#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
R 172.16.0.0/16 [120/2] via 172.19.0.1, 00:00:02, Serial0/1
R 172.17.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
R 172.18.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
C 172.19.0.0/16 is directly connected, Serial0/1
C 172.20.0.0/16 is directly connected, FastEthernet0/0

The "R" character at the beginning of a line in routing table shows that it is a route
discovered by Routing Information Protocol Version 2 (RIPv2) and "C" character
shows that it is a directly connected network.

Verify the Connectivity between Networks Using the Ping Command
To verify the Routing Information Protocol Version 2 (RIPv2) routes and the
connectivity between networks, run the ping command from Host01 (IP address:
172.16.0.10/16) to Host03 (IP address: 172.20.0.10/16).
C:>ping 172.20.0.10
Pinging 172.20.0.10 with 32 bytes of data:
Reply from 172.20.0.10: bytes=32 time=172ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Reply from 172.20.0.10: bytes=32 time=157ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 157ms, Maximum = 188ms, Average = 176ms

The ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Routing
Information Protocol Version 2 (RIPv2) is configured well in three routers and there is
network connectivity between different networks.
More Related Routing Protocol Tips:

http://blog.router-switch.com/
How to Configure IGRP (Interior Gateway Routing Protocol)?




http://blog.router-switch.com/

Contenu connexe

Tendances

Routing Information Protocol
Routing Information ProtocolRouting Information Protocol
Routing Information ProtocolKashif Latif
 
Rip protocol
Rip protocolRip protocol
Rip protocolr123027
 
Router Information Protocol
Router Information ProtocolRouter Information Protocol
Router Information Protocolraysoumik
 
network convergence problem and solutions
network convergence  problem and solutionsnetwork convergence  problem and solutions
network convergence problem and solutionsSiddhi Viradiya
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)Netwax Lab
 
Examen final ccna2
Examen final ccna2Examen final ccna2
Examen final ccna2Juli Yaret
 
E routing final exam ccna 2 46
E routing final exam ccna 2 46E routing final exam ccna 2 46
E routing final exam ccna 2 46lslsc
 
Open Shortest Path First
Open Shortest Path FirstOpen Shortest Path First
Open Shortest Path FirstKashif Latif
 
RIP - Routing Information Protocol
RIP - Routing Information ProtocolRIP - Routing Information Protocol
RIP - Routing Information Protocolselvakumar_b1985
 
Day 2 IP ROUTING
Day 2 IP ROUTINGDay 2 IP ROUTING
Day 2 IP ROUTINGanilinvns
 
IGRP and EIGRP
IGRP and EIGRPIGRP and EIGRP
IGRP and EIGRPIT Tech
 

Tendances (20)

Routing Information Protocol
Routing Information ProtocolRouting Information Protocol
Routing Information Protocol
 
Rip protocol
Rip protocolRip protocol
Rip protocol
 
Router Information Protocol
Router Information ProtocolRouter Information Protocol
Router Information Protocol
 
network convergence problem and solutions
network convergence  problem and solutionsnetwork convergence  problem and solutions
network convergence problem and solutions
 
Routing information protocol
Routing information protocolRouting information protocol
Routing information protocol
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)
 
Static Routing
Static RoutingStatic Routing
Static Routing
 
Ch13
Ch13Ch13
Ch13
 
Examen final ccna2
Examen final ccna2Examen final ccna2
Examen final ccna2
 
Eigrp
EigrpEigrp
Eigrp
 
E routing final exam ccna 2 46
E routing final exam ccna 2 46E routing final exam ccna 2 46
E routing final exam ccna 2 46
 
Dynamic Routing RIP
Dynamic Routing RIPDynamic Routing RIP
Dynamic Routing RIP
 
Open Shortest Path First
Open Shortest Path FirstOpen Shortest Path First
Open Shortest Path First
 
#RIPv1 vs #RIPv2
#RIPv1 vs #RIPv2#RIPv1 vs #RIPv2
#RIPv1 vs #RIPv2
 
RIP - Routing Information Protocol
RIP - Routing Information ProtocolRIP - Routing Information Protocol
RIP - Routing Information Protocol
 
Day 2 IP ROUTING
Day 2 IP ROUTINGDay 2 IP ROUTING
Day 2 IP ROUTING
 
IGRP and EIGRP
IGRP and EIGRPIGRP and EIGRP
IGRP and EIGRP
 
Chapter 08
Chapter 08Chapter 08
Chapter 08
 
Day 10 loops+ rip+ igrp
Day 10 loops+  rip+ igrpDay 10 loops+  rip+ igrp
Day 10 loops+ rip+ igrp
 
Eigrp
EigrpEigrp
Eigrp
 

Similaire à Configure RIP Routing Between Three Routers

How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)IT Tech
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config97148881557
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_configarjuntrk
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands listactsupport .com
 
Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Netwax Lab
 
Acn Experiment No 6
Acn Experiment No 6Acn Experiment No 6
Acn Experiment No 6Garima Singh
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configurationsamreenghauri786
 
CCNA at a glance
CCNA at a glanceCCNA at a glance
CCNA at a glanceVikas Raut
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsEng. Emad Al-Atoum
 
Site to Site VPN between Cisco Routers
Site to Site VPN between Cisco RoutersSite to Site VPN between Cisco Routers
Site to Site VPN between Cisco RoutersSandeep Kumar
 

Similaire à Configure RIP Routing Between Three Routers (20)

How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands list
 
Ccna command
Ccna commandCcna command
Ccna command
 
1
11
1
 
Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
 
Acn Experiment No 6
Acn Experiment No 6Acn Experiment No 6
Acn Experiment No 6
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configuration
 
CCNA at a glance
CCNA at a glanceCCNA at a glance
CCNA at a glance
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
 
Static Routing
Static RoutingStatic Routing
Static Routing
 
Labmannual
LabmannualLabmannual
Labmannual
 
Networking Lab Report
Networking Lab ReportNetworking Lab Report
Networking Lab Report
 
Cisco packet tracer ripv1
Cisco packet tracer   ripv1Cisco packet tracer   ripv1
Cisco packet tracer ripv1
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Site to Site VPN between Cisco Routers
Site to Site VPN between Cisco RoutersSite to Site VPN between Cisco Routers
Site to Site VPN between Cisco Routers
 
OSWAN.pptx
OSWAN.pptxOSWAN.pptx
OSWAN.pptx
 

Plus de IT Tech

Cisco ip phone key expansion module setup
Cisco ip phone key expansion module setupCisco ip phone key expansion module setup
Cisco ip phone key expansion module setupIT Tech
 
Cisco catalyst 9200 series platform spec, licenses, transition guide
Cisco catalyst 9200 series platform spec, licenses, transition guideCisco catalyst 9200 series platform spec, licenses, transition guide
Cisco catalyst 9200 series platform spec, licenses, transition guideIT Tech
 
Cisco isr 900 series highlights, platform specs, licenses, transition guide
Cisco isr 900 series highlights, platform specs, licenses, transition guideCisco isr 900 series highlights, platform specs, licenses, transition guide
Cisco isr 900 series highlights, platform specs, licenses, transition guideIT Tech
 
Hpe pro liant gen9 to gen10 server transition guide
Hpe pro liant gen9 to gen10 server transition guideHpe pro liant gen9 to gen10 server transition guide
Hpe pro liant gen9 to gen10 server transition guideIT Tech
 
The new cisco isr 4461 faq
The new cisco isr 4461 faqThe new cisco isr 4461 faq
The new cisco isr 4461 faqIT Tech
 
New nexus 400 gigabit ethernet (400 g) switches
New nexus 400 gigabit ethernet (400 g) switchesNew nexus 400 gigabit ethernet (400 g) switches
New nexus 400 gigabit ethernet (400 g) switchesIT Tech
 
Tested cisco isr 1100 delivers the richest set of wi-fi features
Tested cisco isr 1100 delivers the richest set of wi-fi featuresTested cisco isr 1100 delivers the richest set of wi-fi features
Tested cisco isr 1100 delivers the richest set of wi-fi featuresIT Tech
 
Aruba campus and branch switching solution
Aruba campus and branch switching solutionAruba campus and branch switching solution
Aruba campus and branch switching solutionIT Tech
 
Cisco transceiver module for compatible catalyst switches
Cisco transceiver module for compatible catalyst switchesCisco transceiver module for compatible catalyst switches
Cisco transceiver module for compatible catalyst switchesIT Tech
 
Cisco ios on cisco catalyst switches
Cisco ios on cisco catalyst switchesCisco ios on cisco catalyst switches
Cisco ios on cisco catalyst switchesIT Tech
 
Cisco's wireless solutions deployment modes
Cisco's wireless solutions deployment modesCisco's wireless solutions deployment modes
Cisco's wireless solutions deployment modesIT Tech
 
Competitive switching comparison cisco vs. hpe aruba vs. huawei vs. dell
Competitive switching comparison cisco vs. hpe aruba vs. huawei vs. dellCompetitive switching comparison cisco vs. hpe aruba vs. huawei vs. dell
Competitive switching comparison cisco vs. hpe aruba vs. huawei vs. dellIT Tech
 
Four reasons to consider the all in-one isr 1000
Four reasons to consider the all in-one isr 1000Four reasons to consider the all in-one isr 1000
Four reasons to consider the all in-one isr 1000IT Tech
 
The difference between yellow and white labeled ports on a nexus 2300 series fex
The difference between yellow and white labeled ports on a nexus 2300 series fexThe difference between yellow and white labeled ports on a nexus 2300 series fex
The difference between yellow and white labeled ports on a nexus 2300 series fexIT Tech
 
Cisco transceiver modules for compatible cisco switches series
Cisco transceiver modules for compatible cisco switches seriesCisco transceiver modules for compatible cisco switches series
Cisco transceiver modules for compatible cisco switches seriesIT Tech
 
Guide to the new cisco firepower 2100 series
Guide to the new cisco firepower 2100 seriesGuide to the new cisco firepower 2100 series
Guide to the new cisco firepower 2100 seriesIT Tech
 
892 f sfp configuration example
892 f sfp configuration example892 f sfp configuration example
892 f sfp configuration exampleIT Tech
 
Cisco nexus 7000 and nexus 7700
Cisco nexus 7000 and nexus 7700Cisco nexus 7000 and nexus 7700
Cisco nexus 7000 and nexus 7700IT Tech
 
Cisco firepower ngips series migration options
Cisco firepower ngips series migration optionsCisco firepower ngips series migration options
Cisco firepower ngips series migration optionsIT Tech
 
Eol transceiver to replacement model
Eol transceiver to replacement modelEol transceiver to replacement model
Eol transceiver to replacement modelIT Tech
 

Plus de IT Tech (20)

Cisco ip phone key expansion module setup
Cisco ip phone key expansion module setupCisco ip phone key expansion module setup
Cisco ip phone key expansion module setup
 
Cisco catalyst 9200 series platform spec, licenses, transition guide
Cisco catalyst 9200 series platform spec, licenses, transition guideCisco catalyst 9200 series platform spec, licenses, transition guide
Cisco catalyst 9200 series platform spec, licenses, transition guide
 
Cisco isr 900 series highlights, platform specs, licenses, transition guide
Cisco isr 900 series highlights, platform specs, licenses, transition guideCisco isr 900 series highlights, platform specs, licenses, transition guide
Cisco isr 900 series highlights, platform specs, licenses, transition guide
 
Hpe pro liant gen9 to gen10 server transition guide
Hpe pro liant gen9 to gen10 server transition guideHpe pro liant gen9 to gen10 server transition guide
Hpe pro liant gen9 to gen10 server transition guide
 
The new cisco isr 4461 faq
The new cisco isr 4461 faqThe new cisco isr 4461 faq
The new cisco isr 4461 faq
 
New nexus 400 gigabit ethernet (400 g) switches
New nexus 400 gigabit ethernet (400 g) switchesNew nexus 400 gigabit ethernet (400 g) switches
New nexus 400 gigabit ethernet (400 g) switches
 
Tested cisco isr 1100 delivers the richest set of wi-fi features
Tested cisco isr 1100 delivers the richest set of wi-fi featuresTested cisco isr 1100 delivers the richest set of wi-fi features
Tested cisco isr 1100 delivers the richest set of wi-fi features
 
Aruba campus and branch switching solution
Aruba campus and branch switching solutionAruba campus and branch switching solution
Aruba campus and branch switching solution
 
Cisco transceiver module for compatible catalyst switches
Cisco transceiver module for compatible catalyst switchesCisco transceiver module for compatible catalyst switches
Cisco transceiver module for compatible catalyst switches
 
Cisco ios on cisco catalyst switches
Cisco ios on cisco catalyst switchesCisco ios on cisco catalyst switches
Cisco ios on cisco catalyst switches
 
Cisco's wireless solutions deployment modes
Cisco's wireless solutions deployment modesCisco's wireless solutions deployment modes
Cisco's wireless solutions deployment modes
 
Competitive switching comparison cisco vs. hpe aruba vs. huawei vs. dell
Competitive switching comparison cisco vs. hpe aruba vs. huawei vs. dellCompetitive switching comparison cisco vs. hpe aruba vs. huawei vs. dell
Competitive switching comparison cisco vs. hpe aruba vs. huawei vs. dell
 
Four reasons to consider the all in-one isr 1000
Four reasons to consider the all in-one isr 1000Four reasons to consider the all in-one isr 1000
Four reasons to consider the all in-one isr 1000
 
The difference between yellow and white labeled ports on a nexus 2300 series fex
The difference between yellow and white labeled ports on a nexus 2300 series fexThe difference between yellow and white labeled ports on a nexus 2300 series fex
The difference between yellow and white labeled ports on a nexus 2300 series fex
 
Cisco transceiver modules for compatible cisco switches series
Cisco transceiver modules for compatible cisco switches seriesCisco transceiver modules for compatible cisco switches series
Cisco transceiver modules for compatible cisco switches series
 
Guide to the new cisco firepower 2100 series
Guide to the new cisco firepower 2100 seriesGuide to the new cisco firepower 2100 series
Guide to the new cisco firepower 2100 series
 
892 f sfp configuration example
892 f sfp configuration example892 f sfp configuration example
892 f sfp configuration example
 
Cisco nexus 7000 and nexus 7700
Cisco nexus 7000 and nexus 7700Cisco nexus 7000 and nexus 7700
Cisco nexus 7000 and nexus 7700
 
Cisco firepower ngips series migration options
Cisco firepower ngips series migration optionsCisco firepower ngips series migration options
Cisco firepower ngips series migration options
 
Eol transceiver to replacement model
Eol transceiver to replacement modelEol transceiver to replacement model
Eol transceiver to replacement model
 

Dernier

Spiritual Life Quote from Shiva Negi
Spiritual Life Quote from Shiva Negi Spiritual Life Quote from Shiva Negi
Spiritual Life Quote from Shiva Negi OneDay18
 
Call Girls Dubai O525547819 Favor Dubai Call Girls Agency
Call Girls Dubai O525547819 Favor Dubai Call Girls AgencyCall Girls Dubai O525547819 Favor Dubai Call Girls Agency
Call Girls Dubai O525547819 Favor Dubai Call Girls Agencykojalkojal131
 
integrity in personal relationship (1).pdf
integrity in personal relationship (1).pdfintegrity in personal relationship (1).pdf
integrity in personal relationship (1).pdfAmitRout25
 
The 5 sec rule - Mel Robins (Hindi Summary)
The 5 sec rule - Mel Robins (Hindi Summary)The 5 sec rule - Mel Robins (Hindi Summary)
The 5 sec rule - Mel Robins (Hindi Summary)Shakti Savarn
 
Benefits of Co working & Shared office space in India
Benefits of Co working & Shared office space in IndiaBenefits of Co working & Shared office space in India
Benefits of Co working & Shared office space in IndiaBrantfordIndia
 
Virtue ethics & Effective Altruism: What can EA learn from virtue ethics?
Virtue ethics & Effective Altruism: What can EA learn from virtue ethics?Virtue ethics & Effective Altruism: What can EA learn from virtue ethics?
Virtue ethics & Effective Altruism: What can EA learn from virtue ethics?Mikko Kangassalo
 
English basic for beginners Future tenses .pdf
English basic for beginners Future tenses .pdfEnglish basic for beginners Future tenses .pdf
English basic for beginners Future tenses .pdfbromerom1
 

Dernier (7)

Spiritual Life Quote from Shiva Negi
Spiritual Life Quote from Shiva Negi Spiritual Life Quote from Shiva Negi
Spiritual Life Quote from Shiva Negi
 
Call Girls Dubai O525547819 Favor Dubai Call Girls Agency
Call Girls Dubai O525547819 Favor Dubai Call Girls AgencyCall Girls Dubai O525547819 Favor Dubai Call Girls Agency
Call Girls Dubai O525547819 Favor Dubai Call Girls Agency
 
integrity in personal relationship (1).pdf
integrity in personal relationship (1).pdfintegrity in personal relationship (1).pdf
integrity in personal relationship (1).pdf
 
The 5 sec rule - Mel Robins (Hindi Summary)
The 5 sec rule - Mel Robins (Hindi Summary)The 5 sec rule - Mel Robins (Hindi Summary)
The 5 sec rule - Mel Robins (Hindi Summary)
 
Benefits of Co working & Shared office space in India
Benefits of Co working & Shared office space in IndiaBenefits of Co working & Shared office space in India
Benefits of Co working & Shared office space in India
 
Virtue ethics & Effective Altruism: What can EA learn from virtue ethics?
Virtue ethics & Effective Altruism: What can EA learn from virtue ethics?Virtue ethics & Effective Altruism: What can EA learn from virtue ethics?
Virtue ethics & Effective Altruism: What can EA learn from virtue ethics?
 
English basic for beginners Future tenses .pdf
English basic for beginners Future tenses .pdfEnglish basic for beginners Future tenses .pdf
English basic for beginners Future tenses .pdf
 

Configure RIP Routing Between Three Routers

  • 1. How to Configure Routing Information Protocol (RIP)? If you are not familiar with Routing Information Protocol (RIP), click the following link to view an introduction to Routing Information Protocol (RIP). Routing Information Protocol (RIP) Configuration Routing Information Protocol (RIP) can be configured in a router using the following IOS commands. The "version 2" IOScommand specifies that we are using RIPv2. Router>enable Router#configure terminal Router(config)# router rip Router(config-router)# version 2 Router(config-router)# network network_id Routing Information Protocol (RIP) - Lab Practice The following diagram shows our lab setup. We have three routers, three switches and three hosts connected as below. The host names, IP addresses and the interfaces of the routers are shown in diagram. The IP addresses of the hosts are also shown in the diagram. Notes: If you are not familiar with a router console connection, click the following link to learn how to connect the serial port of your computer to router console port. Click the following link to learn how to connect to the console port of the router if there is no serial port in your computer. http://blog.router-switch.com/
  • 2. Click the following links to learn how to use HyperTerminal terminal emulator and PuTTY terminal emulator to configure router. Hostname and IP address configuration in Router01 Connect to Router01 console and use the following IOS commands to configure host name as Router01. Router>enable Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname Router01 Router01(config)# Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router01 and configure IP address as 172.16.0.1/16. Router01>enable Router01#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router01(config)#interface fa0/0 Router01(config-if)#ip address 172.16.0.1 255.255.0.0 Router01(config-if)#no shutdown Use the following IOS commands to open the serial interface S0/0 configuration mode on Router01 and configure IP addressas 172.17.0.1/16. You have to set a clock rate also using the "clock rate" command on S0/0 interface, since this is the DCE side. Router01>enable Router01#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router01(config)#interface s0/0 Router01(config-if)#clock rate 64000 Router01(config-if)#ip address 172.17.0.1 255.255.0.0 Router01(config-if)#no shutdown Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router. Hostname and IP address configuration in Router02 Connect to Router02 console and use the following IOS commands to configure host name as Router02. Router>enable Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname Router02 Router02(config)# http://blog.router-switch.com/
  • 3. Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router02 and configure IP address as 172.18.0.1/16. Router02>enable Router02#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router02(config)#interface fa0/0 Router02(config-if)#ip address 172.18.0.1 255.255.0.0 Router02(config-if)#no shutdown Use the following IOS commands to open the serial interface S0/0 configuration mode on Router02 and configure IP addressas 172.17.0.2/16. Router02>enable Router02#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router02(config)#interface s0/0 Router02(config-if)#ip address 172.17.0.2 255.255.0.0 Router02(config-if)#no shutdown Use the following IOS commands to open the serial interface S0/1 configuration mode on Router02 and configure IP addressas 172.19.0.1/16. You have to set a clock rate also using the "clock rate" command on S0/1 interface, since this is the DCE side. Router02>enable Router02#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router02(config)#interface s0/1 Router02(config-if)#clock rate 64000 Router02(config-if)#ip address 172.19.0.1 255.255.0.0 Router02(config-if)#no shutdown Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router. Hostname and IP address configuration in Router03 Connect to Router03 console and use the following IOS commands to configure host name as Router03. Router>enable Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname Router03 Router03(config)# Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router03 and configure IP address as 172.20.0.1/16. Router03>enable http://blog.router-switch.com/
  • 4. Router03#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router03(config)#interface fa0/0 Router03(config-if)#ip address 172.20.0.1 255.255.0.0 Router03(config-if)#no shutdown Use the following IOS commands to open the serial interface S0/1 configuration mode on Router03 and configure IP addressas 172.19.0.2/16. Router03>enable Router03#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router03(config)#interface s0/1 Router03(config-if)#ip address 172.19.0.2 255.255.0.0 Router03(config-if)#no shutdown Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router. Routing Information Protocol Version 2 (RIPv2) configuration in Router01 Connect to Router01 console and use the following IOS commands to configure Routing Information Protocol Version 2 (RIPv2) in Router01. Please refer the beginning of this lesson to view the Routing Information Protocol Version 2 (RIPv2) configuration IOS commands. Using the IOS "network" command, as shown below, we specify only the directly connected networks of this router. Router01>enable Router01#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router01(config)#router rip Router01(config-router)#version 2 Router01(config-router)#network 172.16.0.0 Router01(config-router)#network 172.17.0.0 Router01(config-router)#exit Router01(config)#exit Router01# Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router. Routing Information Protocol Version 2 (RIPv2) configuration in Router02 Connect to Router02 console and use the following IOS commands to configure Routing Information Protocol Version 2 (RIPv2) in Router02. Please refer the beginning of this lesson to view the Routing Information Protocol Version 2 (RIPv2) http://blog.router-switch.com/
  • 5. configurationIOS commands. Using the IOS "network" command, as shown below, we specify only the directly connected networks of this router. Router02>enable Router02#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router02(config)#router rip Router02(config-router)#version 2 Router02(config-router)#network 172.17.0.0 Router02(config-router)#network 172.18.0.0 Router02(config-router)#network 172.19.0.0 Router02(config-router)#exit Router02(config)#exit Router02# Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router. Routing Information Protocol Version 2 (RIPv2) configuration in Router03 Connect to Router03 console and use the following IOS commands to configure Routing Information Protocol Version 2 (RIPv2) in Router03. Please refer the beginning of this lesson to view the Routing Information Protocol Version 2 (RIPv2) configurationIOS commands. Using the IOS "network" command, as shown below, we specify only the directly connected networks of this router. Router03>enable Router03#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router03(config)#router rip Router03(config-router)#version 2 Router03(config-router)#network 172.19.0.0 Router03(config-router)#network 172.20.0.0 Router03(config-router)#exit Router03(config)#exit Router03# Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router. How to View the Routing Table in Router01 After the network is converged after the initial configuration and Routing Information Protocol Version 2 (RIPv2) configuration, we can use the "show http://blog.router-switch.com/
  • 6. ip route" to view the routing table in Router01, as shown below. Router01>enable Router01#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set C 172.16.0.0/16 is directly connected, FastEthernet0/0 C 172.17.0.0/16 is directly connected, Serial0/0 R 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0 R 172.19.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0 R 172.20.0.0/16 [120/2] via 172.17.0.2, 00:00:22, Serial0/0 The "R" character at the beginning of a line in routing table shows that it is a route discovered by Routing Information Protocol Version 2 (RIPv2) and "C" character shows that it is a directly connected network. How to View the Routing Table in Router02 When the network is converged after the initial configuration and Routing Information Protocol Version 2 (RIPv2) configuration, we can use the "show ip route" to view the routing table in Router02, as shown below. Router02>enable Router02#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set R 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:07, Serial0/0 C 172.17.0.0/16 is directly connected, Serial0/0 C 172.18.0.0/16 is directly connected, FastEthernet0/0 C 172.19.0.0/16 is directly connected, Serial0/1 R 172.20.0.0/16 [120/1] via 172.19.0.2, 00:00:20, Serial0/1 The "R" character at the beginning of a line in routing table shows that it is a route discovered by Routing Information Protocol Version 2 (RIPv2) and "C" character shows that it is a directly connected network. http://blog.router-switch.com/
  • 7. How to View the Routing Table in Router03 When the network is converged after the initial configuration and Routing Information Protocol Version 2 (RIPv2) configuration, we can use the "show ip route" to view the routing table in Router03, as shown below. Router03>enable Router03#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set R 172.16.0.0/16 [120/2] via 172.19.0.1, 00:00:02, Serial0/1 R 172.17.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1 R 172.18.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1 C 172.19.0.0/16 is directly connected, Serial0/1 C 172.20.0.0/16 is directly connected, FastEthernet0/0 The "R" character at the beginning of a line in routing table shows that it is a route discovered by Routing Information Protocol Version 2 (RIPv2) and "C" character shows that it is a directly connected network. Verify the Connectivity between Networks Using the Ping Command To verify the Routing Information Protocol Version 2 (RIPv2) routes and the connectivity between networks, run the ping command from Host01 (IP address: 172.16.0.10/16) to Host03 (IP address: 172.20.0.10/16). C:>ping 172.20.0.10 Pinging 172.20.0.10 with 32 bytes of data: Reply from 172.20.0.10: bytes=32 time=172ms TTL=125 Reply from 172.20.0.10: bytes=32 time=188ms TTL=125 Reply from 172.20.0.10: bytes=32 time=157ms TTL=125 Reply from 172.20.0.10: bytes=32 time=188ms TTL=125 Ping statistics for 172.20.0.10: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximate round trip times in milli-seconds: Minimum = 157ms, Maximum = 188ms, Average = 176ms The ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Routing Information Protocol Version 2 (RIPv2) is configured well in three routers and there is network connectivity between different networks. More Related Routing Protocol Tips: http://blog.router-switch.com/
  • 8. How to Configure IGRP (Interior Gateway Routing Protocol)? http://blog.router-switch.com/