Microsoft Excel 
Je teste donc je SI()
Pré-requis 
Informer 
Microsoft Excel 
SI() 
RECHERCHEV() 
Août 2014 
00:20
Un besoin trivial 
J’ai des données 
Je souhaite les grouper dans des catégories 
Je saisie la catégorie 
Une formule affi...
Des SI() imbriqués 
=SI($D11="Publication";"COM_01"; 
SI($D11="Veille";"TCH_01"; 
SI($D11="Construction agence";"CST_01"; ...
Limitations 
Modifier un libellé ou un code 
? 
Modifier la formule 
Rajouter une catégorie 
? 
Impossible 
Limite 
= 
Niv...
Une meilleure solution 
Étape 1 
Créer un tableau de correspondance 
Catégorie 
Code
Utiliser la RECHERCHEV() 
=RECHERCHEV($D11; 
'Categorie-projet'!$C$11:$D$23; 
2; 
FAUX) 
Étape 2
Avantages 
Formule plus concise 
Ajouter ou modifier un code 
?
Merci qui ! 
Pompe-au-net.fr
Prochain SlideShare
Chargement dans…5
×

Comparer les fonctions si et recherchev dans la construction de feuilles de calculs

214 vues

Publié le

Nous faisons souvent la confusion sur le rôle de la fonction SI() de Microsoft Excel.
Elle ne sert nullement à retrouver une valeur.

Publié dans : Logiciels
0 commentaire
0 j’aime
Statistiques
Remarques
  • Soyez le premier à commenter

  • Soyez le premier à aimer ceci

Aucun téléchargement
Vues
Nombre de vues
214
Sur SlideShare
0
Issues des intégrations
0
Intégrations
44
Actions
Partages
0
Téléchargements
2
Commentaires
0
J’aime
0
Intégrations 0
Aucune incorporation

Aucune remarque pour cette diapositive

Comparer les fonctions si et recherchev dans la construction de feuilles de calculs

  1. 1. Microsoft Excel Je teste donc je SI()
  2. 2. Pré-requis Informer Microsoft Excel SI() RECHERCHEV() Août 2014 00:20
  3. 3. Un besoin trivial J’ai des données Je souhaite les grouper dans des catégories Je saisie la catégorie Une formule affiche le code de la catégorie
  4. 4. Des SI() imbriqués =SI($D11="Publication";"COM_01"; SI($D11="Veille";"TCH_01"; SI($D11="Construction agence";"CST_01"; SI($D11="Publicité";"COM_02"; SI($D11="Construction extension";"CST_02"; SI($D11="Construction site";"COM_03"; SI($D11="Recherche";"TCH_02";0)))))))
  5. 5. Limitations Modifier un libellé ou un code ? Modifier la formule Rajouter une catégorie ? Impossible Limite = Niveaux d’imbrication 7
  6. 6. Une meilleure solution Étape 1 Créer un tableau de correspondance Catégorie Code
  7. 7. Utiliser la RECHERCHEV() =RECHERCHEV($D11; 'Categorie-projet'!$C$11:$D$23; 2; FAUX) Étape 2
  8. 8. Avantages Formule plus concise Ajouter ou modifier un code ?
  9. 9. Merci qui ! Pompe-au-net.fr

×