Like virgin

569 vues

Publié le

Insérer des lignes dans un tableau Excel n'est pas toujours aisée.
Petit tour d'horizon des solutions disponibles.

Publié dans : Formation
0 commentaire
0 j’aime
Statistiques
Remarques
  • Soyez le premier à commenter

  • Soyez le premier à aimer ceci

Aucun téléchargement
Vues
Nombre de vues
569
Sur SlideShare
0
Issues des intégrations
0
Intégrations
242
Actions
Partages
0
Téléchargements
4
Commentaires
0
J’aime
0
Intégrations 0
Aucune incorporation

Aucune remarque pour cette diapositive

Like virgin

  1. 1. Microsoft Excel Like a virgin
  2. 2. Pré-requis Informer Microsoft Excel Mise en forme Insertion ligne - colonne Somme() Calculs simples Décembre 2014 00:10
  3. 3. Insérer des données Peut vite devenir… L’enfer !
  4. 4. Situation fréquente Où insérer ?
  5. 5. En haut Inepte !!!!
  6. 6. Insérer dans la plage Une solution sans effets pervers majeurs Pour débutants !
  7. 7. Mise en forme conservée Pour débutants !
  8. 8. Formules mises à jour Pour débutants !
  9. 9. Pas naturel Habitude ancestrale À la fin
  10. 10. Dans le futur Automatiser l’ajout ? Insérer en fin !
  11. 11. Insérer à la fin Catastrophe annoncée Ce que fait la majorité des utilisateurs Fatal Error
  12. 12. Mises en forme à refaire Catastrophe annoncée
  13. 13. Formules ne suivent pas Catastrophe annoncée
  14. 14. Les solutions 1. 2. 3. 4. Manuel Macro-commandes Formules délirantes Mettre sous forme de tableau
  15. 15. Manuelle 1. 1.2 2. Erreurs en cascades prévisibles Oubli mise à jour adresses formules Temps perdu – énervement assuré
  16. 16. Macro-commandes With .Range(.Range("A" & Nl), .Range("G" & Nl)) .Borders(xlDiagonalDown).LineStyle = xlNone .Borders(xlDiagonalUp).LineStyle = xlNone With .Borders(xlEdgeLeft) .LineStyle = xlContinuous .Weight = xlThick .ColorIndex = xlAutomatic End With With .Borders(xlEdgeTop) .LineStyle = xlContinuous .Weight = xlThick .ColorIndex = xlAutomatic End With With .Borders(xlEdgeBottom) .LineStyle = xlContinuous .Weight = xlThick .ColorIndex = xlAutomatic End With With .Borders(xlEdgeRight) .LineStyle = xlContinuous .Weight = xlThick .ColorIndex = xlAutomatic End With .Borders(xlInsideVertical).LineStyle = xlNone .Borders(xlInsideHorizontal).LineStyle = xlNone End With
  17. 17. Formule délirante {=SI(ESTERREUR(INDEX($B$3:$B$7;PETITE.VALEUR(SI(EQUIV($B$3:$B$7;$B$3:$B$7;0)=LIGNE(INDIRE CT("1:"&LIGNES($B$3:$B$7)));EQUIV(B3:B7;B3:B7;0);"");LIGNE(INDIRECT("1:"&LIGNES($ B$3:$B$7))))));"";INDEX($B$3:$B$7;PETITE.VALEUR(SI(EQUIV($B$3:$B$7;$B$3:$B$7;0)=LIGNE(IND IRECT("1:"&LIGNES($B$3:$B$7)));EQUIV(B3:B7;B3:B7;0);"");LIGNE(INDIRECT("1:"&LIGNE S($B$3:$B$7))))))}
  18. 18. Préparer des lignes d’avance Combien ? Trop – Pas assez ? Pour débutants !
  19. 19. Justifier le nombre de lignes Pour débutants !
  20. 20. Au moins ça marche Pour débutants !
  21. 21. S’il en manque ? Où insérer ?
  22. 22. Dans le futur Automatiser l’ajout ? Insérer en fin !
  23. 23. Mettre sous forme de tableau Pas qu’une simple mise en forme Face cachée
  24. 24. Mise en forme peu souple
  25. 25. Total collé aux données C’est moyen !
  26. 26. Changer d’habitudes =[@[Nb.]]*[@PV] =[@HT]*1,2 '=Tableau1[[#Cette ligne];[NbHeures]]*Tableau1[[#Cette ligne];[CoutHoraire]]*Tableau1[[#Cette ligne];[Coefficient]] =RECHERCHEV([@[Code
  27. 27. Le meilleur des deux mondes Mises à jour automatique + Insérer à la fin Ligne d’insertion en fin du tableau = Pour tous !
  28. 28. Ajouter une ligne d’insertion Formule() Pour tous !
  29. 29. Mettre en oeuvre 1. 1.1 2. 2.1 2.2 Ni une formule qui n’affiche rien Ligne formatée comme le reste du tableau Sauf bordure du bas comme le tour du tableau Ligne totalement vierge Pas même un espace dans une cellule
  30. 30. Utiliser Sélectionner toujours cette ligne vierge dans 1. 2. 3. 4. Etc. Les adresses de formules Mises en forme conditionnelles Validation de données Nom de cellules Sélection de plages
  31. 31. Insérer au niveau de la ligne Pour tous !
  32. 32. Toujours dans le tableau Pour tous !
  33. 33. Mise en forme conservée Pour tous !
  34. 34. Like a Virgin ! Pour tous !
  35. 35. Merci qui ! pompe-au-net.fr

×