SlideShare a Scribd company logo
1 of 30
Router Configuration




              Engineering Workshops
Cisco Router Configuration

• Rule #1: What Would v4 do?
  – Enable routing
    • ipv6 unicast-routing
  – Configure Interfaces
    • ipv6 address
  – Configure Routing Protocols




                             Engineering Workshops
Cisco Configs
• LAN Interface
interface Ethernet0/0
 ip address 192.168.1.254 255.255.255.0
 ipv6 address 2001:468:123:1::2/64




                           Engineering Workshops
Cisco Configs
• Tunnel Interface
interface Tunnel1
 description IPv6 to Abilene
 no ip address
 no ip redirects
 no ip proxy-arp
 ipv6 address 3FFE:3700:FF:105::2/64
 tunnel source ATM2/0.1
 tunnel destination 192.168.193.14
 tunnel mode ipv6ip



                           Engineering Workshops
Cisco Configs
• ATM PVC
interface ATM2/0.3 point-to-point
 description My GigaPoP
 no ip redirects
 no ip proxy-arp
 pvc MyGigaPoP 3/66
   ubr 155000
   encapsulation aal5snap
 !
 ipv6 address 2001:468:FF:555::1/64


                           Engineering Workshops
Cisco Configs
• IGP - most sites will use RIPng for now, but IS-
  IS is also available. OSPFv3 is on the way. . .
ipv6 router rip ipsix
 redistribute connected
interface Ethernet1/0
 ipv6 rip ipsix enable
 ipv6 rip ipsix default-information orig
• Static
ipv6 route <prefix> <nexthop>


                               Engineering Workshops
Cisco Configs
• BGP - added to your existing IPv4 BGP config
router bgp 64555
 bgp router-id 192.168.2.1
 neighbor Abilene-v6 peer-group
 neighbor Abilene-v6 remote-as 11537




                             Engineering Workshops
Cisco Configs
• BGP continued. . .
address-family ipv6 unicast
 neighbor Abilene-v6 activate
 neighbor Abilene-v6 soft-reconfiguration in
 neighbor Abilene-v6 prefix-list to-Abilene-
  v6 out
 neighbor 2001:468:555:200::6 peer-group
  Abilene-v6
 network 2001:468:4ff::/48
 aggregate-address 2001:468:4ff::/48
  summary-only
 exit-address-family

                           Engineering Workshops
Cisco Configs
• BGP continued. . .
ipv6 route 2001:468:4ff::/48 Null0
!
ipv6 prefix-list to-Abilene-v6 seq 10 permit
  2001:468:4ff::/48




                           Engineering Workshops
Cisco Configs
• Securing Console Access
ipv6 access-list V6VTY permit
   2001:468:4ff::/48 any
. . .
!
line vty 0 4
  ipv6 access-class V6VTY in




                           Engineering Workshops
Cisco Show Commands

•   show bgp
•   show bgp summary
•   show ipv6 bgp neigh <addr> routes
•   show ipv6 bgp neigh <addr> advertised
•   show ipv6 route
•   show ipv6 interface
•   show ipv6 neighbors


                               Engineering Workshops
The Cisco Show


show ipv6 interface      ! show all v6 address etc.
show bgp sum ! show summary of neighbors’ BGP state
show bgp     ! show all v6 BGP-learned routes
show bgp neigh [addr] routes ! what he’s sending
show bgp neigh [addr] advertised ! what you’re sending
show ipv6 route          ! show all v6 routes




                                   Engineering Workshops
Juniper Router Configuration

• Rule #1: What Would v4 do?
  – Enable routing - already there. . .
  – Configure Interfaces
     • family inet6 address
  – Configure Routing Protocols and RIBs




                                Engineering Workshops
Juniper Configs
• Interface (physical)
interfaces {
     fe-0/1/0 {
          unit 0 {
               family inet6 {
                     address 2001:468:123::1/64;
               }
          }
     }
}

                               Engineering Workshops
Juniper Configs
• Interface (tunnel)
interfaces {
    ip-0/3/0 {
         unit 0 {
               tunnel {
                     source 192.168.2.2;
                     destination 192.168.45.2;
               }
               family inet6 {
                     mtu 1514;
                     address 2001:468:123::1/64;
               }
         }


                                     Engineering Workshops
Juniper Configs
• Router Advertisement - not enabled by default
protocols {
    router-advertisement {
         interface fe-0/3/0.0 {
             prefix 2001:468:123::/64;
         }
    }
}




                                         Engineering Workshops
Juniper Configs
• Routing setup
routing-options {
    interface-routes {
         rib-group {
              inet6 ifrg6;
         }
    rib inet6.0 {
         aggregate {
              route 2001:468:4ff::/48;
         }
    }



                                   Engineering Workshops
Juniper Configs
• Routing setup continued. . .
    rib-groups {
         ifrg6 {
              import-rib [ inet6.0 inet6.2 ];
         }
    }
    router-id 192.168.2.1
}




                                  Engineering Workshops
Juniper Configs
• IGP - RIPng and IS-IS are both available
protocols {
    ripng {
         group local {
             export redist-direct;
             neighbor fe-0/1/0.0;
         }
    }
}
policy-options {
    policy-statement redist-direct {
         from protocol direct;
         then accept;
    }
}

                                             Engineering Workshops
Juniper Configs
• BGP
protocols {
    bgp {
        group Abilene-v6 {
            type external;
            family inet6 {
                unicast;
            }
            export to-Abilene-v6;
            peer-as 11537;
            neighbor 2001:468:555:200::6;
        }
    }
}



                                     Engineering Workshops
Juniper Configs
• BGP continued. . .
policy-options {
    policy-statement to-Abilene-v6 {
        term accept-aggregate {
             from {
                   route-filter 2001:468:4ff::/48 exact;
             }
             then accept;
        }
        term reject {
             then reject;
        }
    }
}



                                       Engineering Workshops
Juniper Show Commands

•   show bgp summary
•   show route advert bgp <addr>
•   show route rece bgp <addr>
•   show route table inet6.0 (terse)
•   show interfaces
•   show ipv6 neighbors



                                 Engineering Workshops
FreeBSD
/etc/rc.conf additions:
     # 'zebra' route daemon already started …
     # router_enable="YES"
     # router="/usr/local/sbin/zebractl"
     # router_flags="start"

     ipv6_enable="YES"
     ipv6_network_interfaces="auto"
     ipv6_gateway_enable="YES"
     ipv6_ifconfig_xl0="2001:388:1c10:2::1 prefixlen 64"
     ipv6_ifconfig_lo0="2001:388:1c10:ff::1 prefixlen 64"

     # Enable the sending of route advertisments ..
     rtadvd_enable="YES"
     rtadvd_interfaces="xl0"




                                                            Engineering Workshops
FreeBSD BGP
/usr/local/etc/zebra/bgpd.conf
     hostname bgpd.darwin
     password XXXXXXXX
     enable password XXXXXXXX
     log file bgpd.log
     log stdout

     router bgp 65200
      no bgp default ipv4-unicast
      neighbor 2001:388:1c00:1::1 remote-as 65100
      neighbor 2001:388:1c00:1::1 description to Cairns

      address-family ipv6
       network 2001:388:1c10::/44
       network 2001:388:1c10:1::/64
       aggregate-address 2001:0388:1c10::/44
       redistribute connected
       neighbor 2001:388:1c00:1::1 activate ! Cairns




                                                          Engineering Workshops
FreeBSD Router Advert
/usr/local/etc/radvd.conf
     interface xl0
     {
        AdvSendAdvert on;
        MinRtrAdvInterval 3;
        MaxRtrAdvInterval 10;
        AdvHomeAgentFlag off;
        prefix 2001:388:1c10:2::/64
        {
         AdvOnLink on;
         AdvAutonomous on;
         AdvRouterAddr off;
         AdvPreferredLifetime 120;
         AdvValidLifetime 300;
        };
     };




                                      Engineering Workshops
RedHat 7.3
For a host:
/etc/sysconfig/network, add:
  NETWORKING_IPV6=yes
Run the command:
  service network restart




                               Engineering Workshops
RedHat 7.3
/etc/sysconfig/network, add:
  NETWORKING_IPV6=yes
  IPV6FORWARDING=yes
/etc/sysconfig/network-scripts/ifcfg-eth0
  IPV6INIT=yes
  IPV6ADDR=2001:388:1c01:3::1/64

  IPV6ADDR_SECONDARIES=… …




                                Engineering Workshops
RedHat BGP
/etc/zebra/bgpd.conf
hostname bgpd.bourke
password XXXXXXXXXX
enable password XXXXXXXXXX
log stdout
log file /var/log/zebra/bgpd.log
!
router bgp 65400
  no bgp default ipv4-unicast
  neighbor 2001:388:1c00:5::1 remote-as 65500
  neighbor 2001:388:1c00:5::1 description to Cairns

 address-family ipv6
  network 2001:388:1c01::/48
  aggregate-address 2001:388:1c01::/48
  redistribute connected
  neighbor 2001:388:1c00:5::1 activate




                                                      Engineering Workshops
RedHat Router Advert
/etc/radvd.conf
     interface eth0 {
        AdvSendAdvert on;
        MinRtrAdvInterval 3;
        MaxRtrAdvInterval 10;
        AdvHomeAgentFlag off;
        prefix 2001:388:1c01:3::/64 {
        AdvOnLink on;
        AdvAutonomous on;
        AdvRouterAddr on;
        };
     };



                                        Engineering Workshops
RedHat, reboot
chkconfig radvd on
chkconfig zebra on
chkconfig bgpd on
/etc/init.d/radvd start
/etc/init.d/zebra start
/etc/init.d/bgpd start




                           Engineering Workshops

More Related Content

What's hot

Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview3Anetwork com
 
6th floorsharingsession ep 1 - networking - arp v 1.0
6th floorsharingsession ep 1 - networking - arp v 1.06th floorsharingsession ep 1 - networking - arp v 1.0
6th floorsharingsession ep 1 - networking - arp v 1.0A Achyar Nur
 
Cisco CCNA IPV6 Static Configuration
Cisco CCNA  IPV6 Static ConfigurationCisco CCNA  IPV6 Static Configuration
Cisco CCNA IPV6 Static ConfigurationHamed Moghaddam
 
Cisco CCNA EIGRP IPV6 Configuration
Cisco CCNA EIGRP IPV6 ConfigurationCisco CCNA EIGRP IPV6 Configuration
Cisco CCNA EIGRP IPV6 ConfigurationHamed Moghaddam
 
Cisco CCNA- How to Configure Multi-Layer Switch
Cisco CCNA- How to Configure Multi-Layer SwitchCisco CCNA- How to Configure Multi-Layer Switch
Cisco CCNA- How to Configure Multi-Layer SwitchHamed Moghaddam
 
Juniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route ConfigurationJuniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route ConfigurationHamed Moghaddam
 
Introduction to Network Performance Measurement with Cisco IOS IP Service Lev...
Introduction to Network Performance Measurement with Cisco IOS IP Service Lev...Introduction to Network Performance Measurement with Cisco IOS IP Service Lev...
Introduction to Network Performance Measurement with Cisco IOS IP Service Lev...Cisco Canada
 
Ipv6 test plan for opnfv poc v2.2 spirent-vctlab
Ipv6 test plan for opnfv poc v2.2 spirent-vctlabIpv6 test plan for opnfv poc v2.2 spirent-vctlab
Ipv6 test plan for opnfv poc v2.2 spirent-vctlabIben Rodriguez
 
Day 18 2 serial point to-point encapsulation
Day 18 2  serial point to-point encapsulationDay 18 2  serial point to-point encapsulation
Day 18 2 serial point to-point encapsulationCYBERINTELLIGENTS
 
Ccn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_studentCcn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_studentAngel Clavel
 
Juniper JNCIA – Juniper RIP and OSPF Route Configuration
Juniper JNCIA – Juniper RIP and OSPF Route ConfigurationJuniper JNCIA – Juniper RIP and OSPF Route Configuration
Juniper JNCIA – Juniper RIP and OSPF Route ConfigurationHamed Moghaddam
 
Cisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL ConfigurationCisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL ConfigurationHamed Moghaddam
 
Networking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP ConfigurationNetworking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP Configuration3Anetwork com
 
Upgrade Your Broadcast System to PCIe Gen2
Upgrade Your Broadcast System to PCIe Gen2Upgrade Your Broadcast System to PCIe Gen2
Upgrade Your Broadcast System to PCIe Gen2Altera Corporation
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsAlejandro Marin
 
Simulation and Performance Analysis of AODV using NS 2.34 by Ashok Panwar
Simulation and Performance Analysis of AODV using NS 2.34 by Ashok PanwarSimulation and Performance Analysis of AODV using NS 2.34 by Ashok Panwar
Simulation and Performance Analysis of AODV using NS 2.34 by Ashok PanwarAshok Panwar
 

What's hot (20)

Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview
 
6th floorsharingsession ep 1 - networking - arp v 1.0
6th floorsharingsession ep 1 - networking - arp v 1.06th floorsharingsession ep 1 - networking - arp v 1.0
6th floorsharingsession ep 1 - networking - arp v 1.0
 
Cisco CCNA IPV6 Static Configuration
Cisco CCNA  IPV6 Static ConfigurationCisco CCNA  IPV6 Static Configuration
Cisco CCNA IPV6 Static Configuration
 
96x1 poeers2550t
96x1 poeers2550t96x1 poeers2550t
96x1 poeers2550t
 
Cisco CCNA EIGRP IPV6 Configuration
Cisco CCNA EIGRP IPV6 ConfigurationCisco CCNA EIGRP IPV6 Configuration
Cisco CCNA EIGRP IPV6 Configuration
 
Cisco CCNA- How to Configure Multi-Layer Switch
Cisco CCNA- How to Configure Multi-Layer SwitchCisco CCNA- How to Configure Multi-Layer Switch
Cisco CCNA- How to Configure Multi-Layer Switch
 
Ipv6
Ipv6Ipv6
Ipv6
 
Juniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route ConfigurationJuniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route Configuration
 
IPv6 ACL
IPv6 ACLIPv6 ACL
IPv6 ACL
 
Introduction to Network Performance Measurement with Cisco IOS IP Service Lev...
Introduction to Network Performance Measurement with Cisco IOS IP Service Lev...Introduction to Network Performance Measurement with Cisco IOS IP Service Lev...
Introduction to Network Performance Measurement with Cisco IOS IP Service Lev...
 
Ipv6 test plan for opnfv poc v2.2 spirent-vctlab
Ipv6 test plan for opnfv poc v2.2 spirent-vctlabIpv6 test plan for opnfv poc v2.2 spirent-vctlab
Ipv6 test plan for opnfv poc v2.2 spirent-vctlab
 
Day 18 2 serial point to-point encapsulation
Day 18 2  serial point to-point encapsulationDay 18 2  serial point to-point encapsulation
Day 18 2 serial point to-point encapsulation
 
Ccn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_studentCcn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_student
 
Juniper JNCIA – Juniper RIP and OSPF Route Configuration
Juniper JNCIA – Juniper RIP and OSPF Route ConfigurationJuniper JNCIA – Juniper RIP and OSPF Route Configuration
Juniper JNCIA – Juniper RIP and OSPF Route Configuration
 
Cisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL ConfigurationCisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL Configuration
 
Router commands
Router commandsRouter commands
Router commands
 
Networking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP ConfigurationNetworking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP Configuration
 
Upgrade Your Broadcast System to PCIe Gen2
Upgrade Your Broadcast System to PCIe Gen2Upgrade Your Broadcast System to PCIe Gen2
Upgrade Your Broadcast System to PCIe Gen2
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheets
 
Simulation and Performance Analysis of AODV using NS 2.34 by Ashok Panwar
Simulation and Performance Analysis of AODV using NS 2.34 by Ashok PanwarSimulation and Performance Analysis of AODV using NS 2.34 by Ashok Panwar
Simulation and Performance Analysis of AODV using NS 2.34 by Ashok Panwar
 

Viewers also liked

Weather and climate journal
Weather and climate journalWeather and climate journal
Weather and climate journalA-gon22
 
Router configuration
Router configurationRouter configuration
Router configuration97148881557
 
Initial Configuration of Router
Initial Configuration of RouterInitial Configuration of Router
Initial Configuration of RouterKishore Kumar
 
Organs Immune System 1
Organs Immune System 1Organs Immune System 1
Organs Immune System 11395872
 
Backup and restore router configuration
Backup and restore router configurationBackup and restore router configuration
Backup and restore router configurationVasilis Nikitaras
 
Router configuration
Router configurationRouter configuration
Router configuration97148881557
 
Basic router configuration
Basic router configurationBasic router configuration
Basic router configurationSourabh Badve
 
CCNA Router Startup and Configuration
CCNA Router Startup and ConfigurationCCNA Router Startup and Configuration
CCNA Router Startup and ConfigurationDsunte Wilson
 
10 Tips for WeChat
10 Tips for WeChat10 Tips for WeChat
10 Tips for WeChatChris Baker
 
Benefits of drinking water
Benefits of drinking waterBenefits of drinking water
Benefits of drinking waterEason Chan
 
20 Ideas for your Website Homepage Content
20 Ideas for your Website Homepage Content20 Ideas for your Website Homepage Content
20 Ideas for your Website Homepage ContentBarry Feldman
 

Viewers also liked (14)

Weather and climate journal
Weather and climate journalWeather and climate journal
Weather and climate journal
 
Rei0410
Rei0410Rei0410
Rei0410
 
520scg basic
520scg basic520scg basic
520scg basic
 
Web 2.0
Web 2.0Web 2.0
Web 2.0
 
Router configuration
Router configurationRouter configuration
Router configuration
 
Initial Configuration of Router
Initial Configuration of RouterInitial Configuration of Router
Initial Configuration of Router
 
Organs Immune System 1
Organs Immune System 1Organs Immune System 1
Organs Immune System 1
 
Backup and restore router configuration
Backup and restore router configurationBackup and restore router configuration
Backup and restore router configuration
 
Router configuration
Router configurationRouter configuration
Router configuration
 
Basic router configuration
Basic router configurationBasic router configuration
Basic router configuration
 
CCNA Router Startup and Configuration
CCNA Router Startup and ConfigurationCCNA Router Startup and Configuration
CCNA Router Startup and Configuration
 
10 Tips for WeChat
10 Tips for WeChat10 Tips for WeChat
10 Tips for WeChat
 
Benefits of drinking water
Benefits of drinking waterBenefits of drinking water
Benefits of drinking water
 
20 Ideas for your Website Homepage Content
20 Ideas for your Website Homepage Content20 Ideas for your Website Homepage Content
20 Ideas for your Website Homepage Content
 

Similar to 03 router-configuration

Getting started with IPv6
Getting started with IPv6Getting started with IPv6
Getting started with IPv6Private
 
Implementing an IPv6 Enabled Environment for a Public Cloud Tenant
Implementing an IPv6 Enabled Environment for a Public Cloud TenantImplementing an IPv6 Enabled Environment for a Public Cloud Tenant
Implementing an IPv6 Enabled Environment for a Public Cloud TenantShixiong Shang
 
IDNIC OPM 2023: IPv6 deployment planning and security considerations
IDNIC OPM 2023: IPv6 deployment planning and security considerationsIDNIC OPM 2023: IPv6 deployment planning and security considerations
IDNIC OPM 2023: IPv6 deployment planning and security considerationsAPNIC
 
Cisco labs practical5
Cisco labs practical5Cisco labs practical5
Cisco labs practical5Tai Lam
 
SRWE_Module_15 (1).pptx
SRWE_Module_15 (1).pptxSRWE_Module_15 (1).pptx
SRWE_Module_15 (1).pptxYohaWaid
 
Deploying IPv6 in OpenStack Environments
Deploying IPv6 in OpenStack EnvironmentsDeploying IPv6 in OpenStack Environments
Deploying IPv6 in OpenStack EnvironmentsShannon McFarland
 
AutoIP -A mechanism for IPv6 migration and IPv4 sunsetting by Shishio Tsuchiy...
AutoIP -A mechanism for IPv6 migration and IPv4 sunsetting by Shishio Tsuchiy...AutoIP -A mechanism for IPv6 migration and IPv4 sunsetting by Shishio Tsuchiy...
AutoIP -A mechanism for IPv6 migration and IPv4 sunsetting by Shishio Tsuchiy...APNIC
 
KVM Security Groups Under the Hood - Wido den Hollander - Your.Online
KVM Security Groups Under the Hood - Wido den Hollander - Your.OnlineKVM Security Groups Under the Hood - Wido den Hollander - Your.Online
KVM Security Groups Under the Hood - Wido den Hollander - Your.OnlineShapeBlue
 
CodiLime Tech Talk - Adam Kułagowski: IPv6 - introduction
CodiLime Tech Talk - Adam Kułagowski: IPv6 - introductionCodiLime Tech Talk - Adam Kułagowski: IPv6 - introduction
CodiLime Tech Talk - Adam Kułagowski: IPv6 - introductionCodiLime
 
Whitepaper: Network transitioning from IPv4 to IPv6 Document - Happiest Minds
Whitepaper: Network transitioning from IPv4 to IPv6 Document - Happiest MindsWhitepaper: Network transitioning from IPv4 to IPv6 Document - Happiest Minds
Whitepaper: Network transitioning from IPv4 to IPv6 Document - Happiest MindsHappiest Minds Technologies
 
Hands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesHands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesCisco Canada
 
BIRD Routing Daemon
BIRD Routing DaemonBIRD Routing Daemon
BIRD Routing DaemonAPNIC
 

Similar to 03 router-configuration (20)

Getting started with IPv6
Getting started with IPv6Getting started with IPv6
Getting started with IPv6
 
Implementing an IPv6 Enabled Environment for a Public Cloud Tenant
Implementing an IPv6 Enabled Environment for a Public Cloud TenantImplementing an IPv6 Enabled Environment for a Public Cloud Tenant
Implementing an IPv6 Enabled Environment for a Public Cloud Tenant
 
7 slaac-rick graziani
7 slaac-rick graziani7 slaac-rick graziani
7 slaac-rick graziani
 
Day 11 eigrp
Day 11 eigrpDay 11 eigrp
Day 11 eigrp
 
IDNIC OPM 2023: IPv6 deployment planning and security considerations
IDNIC OPM 2023: IPv6 deployment planning and security considerationsIDNIC OPM 2023: IPv6 deployment planning and security considerations
IDNIC OPM 2023: IPv6 deployment planning and security considerations
 
Cisco labs practical5
Cisco labs practical5Cisco labs practical5
Cisco labs practical5
 
SRWE_Module_15 (1).pptx
SRWE_Module_15 (1).pptxSRWE_Module_15 (1).pptx
SRWE_Module_15 (1).pptx
 
Deploying IPv6 in OpenStack Environments
Deploying IPv6 in OpenStack EnvironmentsDeploying IPv6 in OpenStack Environments
Deploying IPv6 in OpenStack Environments
 
AutoIP -A mechanism for IPv6 migration and IPv4 sunsetting by Shishio Tsuchiy...
AutoIP -A mechanism for IPv6 migration and IPv4 sunsetting by Shishio Tsuchiy...AutoIP -A mechanism for IPv6 migration and IPv4 sunsetting by Shishio Tsuchiy...
AutoIP -A mechanism for IPv6 migration and IPv4 sunsetting by Shishio Tsuchiy...
 
KVM Security Groups Under the Hood - Wido den Hollander - Your.Online
KVM Security Groups Under the Hood - Wido den Hollander - Your.OnlineKVM Security Groups Under the Hood - Wido den Hollander - Your.Online
KVM Security Groups Under the Hood - Wido den Hollander - Your.Online
 
IPV6 IPv6 Routing Lab By Rob Hamm
IPV6 IPv6 Routing Lab  By Rob HammIPV6 IPv6 Routing Lab  By Rob Hamm
IPV6 IPv6 Routing Lab By Rob Hamm
 
CodiLime Tech Talk - Adam Kułagowski: IPv6 - introduction
CodiLime Tech Talk - Adam Kułagowski: IPv6 - introductionCodiLime Tech Talk - Adam Kułagowski: IPv6 - introduction
CodiLime Tech Talk - Adam Kułagowski: IPv6 - introduction
 
Whitepaper: Network transitioning from IPv4 to IPv6 Document - Happiest Minds
Whitepaper: Network transitioning from IPv4 to IPv6 Document - Happiest MindsWhitepaper: Network transitioning from IPv4 to IPv6 Document - Happiest Minds
Whitepaper: Network transitioning from IPv4 to IPv6 Document - Happiest Minds
 
Hands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesHands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and Services
 
BIRD Routing Daemon
BIRD Routing DaemonBIRD Routing Daemon
BIRD Routing Daemon
 
Eigrp authentication
Eigrp authenticationEigrp authentication
Eigrp authentication
 
Testing PPT
Testing PPTTesting PPT
Testing PPT
 
Networking Lab Report
Networking Lab ReportNetworking Lab Report
Networking Lab Report
 
Network Security Best Practice (BCP38 & 140)
Network Security Best Practice (BCP38 & 140) Network Security Best Practice (BCP38 & 140)
Network Security Best Practice (BCP38 & 140)
 
CCNA part 5 routing
CCNA part 5 routingCCNA part 5 routing
CCNA part 5 routing
 

More from 97148881557

Wisp mode aprouter
Wisp mode aprouterWisp mode aprouter
Wisp mode aprouter97148881557
 
Wireless router setupmanual
Wireless router setupmanualWireless router setupmanual
Wireless router setupmanual97148881557
 
Simply bb-customer-router-setup(1)
Simply bb-customer-router-setup(1)Simply bb-customer-router-setup(1)
Simply bb-customer-router-setup(1)97148881557
 
Simply bb-customer-router-setup
Simply bb-customer-router-setupSimply bb-customer-router-setup
Simply bb-customer-router-setup97148881557
 
Router configuration(1)
Router configuration(1)Router configuration(1)
Router configuration(1)97148881557
 
Netgear wnr834 b_v2
Netgear wnr834 b_v2Netgear wnr834 b_v2
Netgear wnr834 b_v297148881557
 
Mcitp server administrator
Mcitp server administratorMcitp server administrator
Mcitp server administrator97148881557
 
Introduction to-cisco-routers
Introduction to-cisco-routersIntroduction to-cisco-routers
Introduction to-cisco-routers97148881557
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config97148881557
 
D link router_setup_example
D link router_setup_exampleD link router_setup_example
D link router_setup_example97148881557
 
Ccna2 mod3-configuring a-router
Ccna2 mod3-configuring a-routerCcna2 mod3-configuring a-router
Ccna2 mod3-configuring a-router97148881557
 

More from 97148881557 (18)

Wisp mode aprouter
Wisp mode aprouterWisp mode aprouter
Wisp mode aprouter
 
Wireless router setupmanual
Wireless router setupmanualWireless router setupmanual
Wireless router setupmanual
 
Simply bb-customer-router-setup(1)
Simply bb-customer-router-setup(1)Simply bb-customer-router-setup(1)
Simply bb-customer-router-setup(1)
 
Simply bb-customer-router-setup
Simply bb-customer-router-setupSimply bb-customer-router-setup
Simply bb-customer-router-setup
 
Rtr config
Rtr configRtr config
Rtr config
 
Router configuration(1)
Router configuration(1)Router configuration(1)
Router configuration(1)
 
Routconf
RoutconfRoutconf
Routconf
 
Netgear wnr834 b_v2
Netgear wnr834 b_v2Netgear wnr834 b_v2
Netgear wnr834 b_v2
 
Mcitp server administrator
Mcitp server administratorMcitp server administrator
Mcitp server administrator
 
Introduction to-cisco-routers
Introduction to-cisco-routersIntroduction to-cisco-routers
Introduction to-cisco-routers
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
D link router_setup_example
D link router_setup_exampleD link router_setup_example
D link router_setup_example
 
Ciscointro
CiscointroCiscointro
Ciscointro
 
Cisco how-to
Cisco how-toCisco how-to
Cisco how-to
 
Cisco config
Cisco configCisco config
Cisco config
 
Ccna2 mod3-configuring a-router
Ccna2 mod3-configuring a-routerCcna2 mod3-configuring a-router
Ccna2 mod3-configuring a-router
 
C4 040 r-02(1)
C4 040 r-02(1)C4 040 r-02(1)
C4 040 r-02(1)
 
C4 040 r-02
C4 040 r-02C4 040 r-02
C4 040 r-02
 

03 router-configuration

  • 1. Router Configuration Engineering Workshops
  • 2. Cisco Router Configuration • Rule #1: What Would v4 do? – Enable routing • ipv6 unicast-routing – Configure Interfaces • ipv6 address – Configure Routing Protocols Engineering Workshops
  • 3. Cisco Configs • LAN Interface interface Ethernet0/0 ip address 192.168.1.254 255.255.255.0 ipv6 address 2001:468:123:1::2/64 Engineering Workshops
  • 4. Cisco Configs • Tunnel Interface interface Tunnel1 description IPv6 to Abilene no ip address no ip redirects no ip proxy-arp ipv6 address 3FFE:3700:FF:105::2/64 tunnel source ATM2/0.1 tunnel destination 192.168.193.14 tunnel mode ipv6ip Engineering Workshops
  • 5. Cisco Configs • ATM PVC interface ATM2/0.3 point-to-point description My GigaPoP no ip redirects no ip proxy-arp pvc MyGigaPoP 3/66 ubr 155000 encapsulation aal5snap ! ipv6 address 2001:468:FF:555::1/64 Engineering Workshops
  • 6. Cisco Configs • IGP - most sites will use RIPng for now, but IS- IS is also available. OSPFv3 is on the way. . . ipv6 router rip ipsix redistribute connected interface Ethernet1/0 ipv6 rip ipsix enable ipv6 rip ipsix default-information orig • Static ipv6 route <prefix> <nexthop> Engineering Workshops
  • 7. Cisco Configs • BGP - added to your existing IPv4 BGP config router bgp 64555 bgp router-id 192.168.2.1 neighbor Abilene-v6 peer-group neighbor Abilene-v6 remote-as 11537 Engineering Workshops
  • 8. Cisco Configs • BGP continued. . . address-family ipv6 unicast neighbor Abilene-v6 activate neighbor Abilene-v6 soft-reconfiguration in neighbor Abilene-v6 prefix-list to-Abilene- v6 out neighbor 2001:468:555:200::6 peer-group Abilene-v6 network 2001:468:4ff::/48 aggregate-address 2001:468:4ff::/48 summary-only exit-address-family Engineering Workshops
  • 9. Cisco Configs • BGP continued. . . ipv6 route 2001:468:4ff::/48 Null0 ! ipv6 prefix-list to-Abilene-v6 seq 10 permit 2001:468:4ff::/48 Engineering Workshops
  • 10. Cisco Configs • Securing Console Access ipv6 access-list V6VTY permit 2001:468:4ff::/48 any . . . ! line vty 0 4 ipv6 access-class V6VTY in Engineering Workshops
  • 11. Cisco Show Commands • show bgp • show bgp summary • show ipv6 bgp neigh <addr> routes • show ipv6 bgp neigh <addr> advertised • show ipv6 route • show ipv6 interface • show ipv6 neighbors Engineering Workshops
  • 12. The Cisco Show show ipv6 interface ! show all v6 address etc. show bgp sum ! show summary of neighbors’ BGP state show bgp ! show all v6 BGP-learned routes show bgp neigh [addr] routes ! what he’s sending show bgp neigh [addr] advertised ! what you’re sending show ipv6 route ! show all v6 routes Engineering Workshops
  • 13. Juniper Router Configuration • Rule #1: What Would v4 do? – Enable routing - already there. . . – Configure Interfaces • family inet6 address – Configure Routing Protocols and RIBs Engineering Workshops
  • 14. Juniper Configs • Interface (physical) interfaces { fe-0/1/0 { unit 0 { family inet6 { address 2001:468:123::1/64; } } } } Engineering Workshops
  • 15. Juniper Configs • Interface (tunnel) interfaces { ip-0/3/0 { unit 0 { tunnel { source 192.168.2.2; destination 192.168.45.2; } family inet6 { mtu 1514; address 2001:468:123::1/64; } } Engineering Workshops
  • 16. Juniper Configs • Router Advertisement - not enabled by default protocols { router-advertisement { interface fe-0/3/0.0 { prefix 2001:468:123::/64; } } } Engineering Workshops
  • 17. Juniper Configs • Routing setup routing-options { interface-routes { rib-group { inet6 ifrg6; } rib inet6.0 { aggregate { route 2001:468:4ff::/48; } } Engineering Workshops
  • 18. Juniper Configs • Routing setup continued. . . rib-groups { ifrg6 { import-rib [ inet6.0 inet6.2 ]; } } router-id 192.168.2.1 } Engineering Workshops
  • 19. Juniper Configs • IGP - RIPng and IS-IS are both available protocols { ripng { group local { export redist-direct; neighbor fe-0/1/0.0; } } } policy-options { policy-statement redist-direct { from protocol direct; then accept; } } Engineering Workshops
  • 20. Juniper Configs • BGP protocols { bgp { group Abilene-v6 { type external; family inet6 { unicast; } export to-Abilene-v6; peer-as 11537; neighbor 2001:468:555:200::6; } } } Engineering Workshops
  • 21. Juniper Configs • BGP continued. . . policy-options { policy-statement to-Abilene-v6 { term accept-aggregate { from { route-filter 2001:468:4ff::/48 exact; } then accept; } term reject { then reject; } } } Engineering Workshops
  • 22. Juniper Show Commands • show bgp summary • show route advert bgp <addr> • show route rece bgp <addr> • show route table inet6.0 (terse) • show interfaces • show ipv6 neighbors Engineering Workshops
  • 23. FreeBSD /etc/rc.conf additions: # 'zebra' route daemon already started … # router_enable="YES" # router="/usr/local/sbin/zebractl" # router_flags="start" ipv6_enable="YES" ipv6_network_interfaces="auto" ipv6_gateway_enable="YES" ipv6_ifconfig_xl0="2001:388:1c10:2::1 prefixlen 64" ipv6_ifconfig_lo0="2001:388:1c10:ff::1 prefixlen 64" # Enable the sending of route advertisments .. rtadvd_enable="YES" rtadvd_interfaces="xl0" Engineering Workshops
  • 24. FreeBSD BGP /usr/local/etc/zebra/bgpd.conf hostname bgpd.darwin password XXXXXXXX enable password XXXXXXXX log file bgpd.log log stdout router bgp 65200 no bgp default ipv4-unicast neighbor 2001:388:1c00:1::1 remote-as 65100 neighbor 2001:388:1c00:1::1 description to Cairns address-family ipv6 network 2001:388:1c10::/44 network 2001:388:1c10:1::/64 aggregate-address 2001:0388:1c10::/44 redistribute connected neighbor 2001:388:1c00:1::1 activate ! Cairns Engineering Workshops
  • 25. FreeBSD Router Advert /usr/local/etc/radvd.conf interface xl0 { AdvSendAdvert on; MinRtrAdvInterval 3; MaxRtrAdvInterval 10; AdvHomeAgentFlag off; prefix 2001:388:1c10:2::/64 { AdvOnLink on; AdvAutonomous on; AdvRouterAddr off; AdvPreferredLifetime 120; AdvValidLifetime 300; }; }; Engineering Workshops
  • 26. RedHat 7.3 For a host: /etc/sysconfig/network, add: NETWORKING_IPV6=yes Run the command: service network restart Engineering Workshops
  • 27. RedHat 7.3 /etc/sysconfig/network, add: NETWORKING_IPV6=yes IPV6FORWARDING=yes /etc/sysconfig/network-scripts/ifcfg-eth0 IPV6INIT=yes IPV6ADDR=2001:388:1c01:3::1/64 IPV6ADDR_SECONDARIES=… … Engineering Workshops
  • 28. RedHat BGP /etc/zebra/bgpd.conf hostname bgpd.bourke password XXXXXXXXXX enable password XXXXXXXXXX log stdout log file /var/log/zebra/bgpd.log ! router bgp 65400 no bgp default ipv4-unicast neighbor 2001:388:1c00:5::1 remote-as 65500 neighbor 2001:388:1c00:5::1 description to Cairns address-family ipv6 network 2001:388:1c01::/48 aggregate-address 2001:388:1c01::/48 redistribute connected neighbor 2001:388:1c00:5::1 activate Engineering Workshops
  • 29. RedHat Router Advert /etc/radvd.conf interface eth0 { AdvSendAdvert on; MinRtrAdvInterval 3; MaxRtrAdvInterval 10; AdvHomeAgentFlag off; prefix 2001:388:1c01:3::/64 { AdvOnLink on; AdvAutonomous on; AdvRouterAddr on; }; }; Engineering Workshops
  • 30. RedHat, reboot chkconfig radvd on chkconfig zebra on chkconfig bgpd on /etc/init.d/radvd start /etc/init.d/zebra start /etc/init.d/bgpd start Engineering Workshops

Editor's Notes

  1. Common problem is that students add the “/64” onto the end of the neighbor’s IPv6 address, causing an error message. The neighbors IPv6 address should not include the subnet size.
  2. BGP will not advertise a network unless it has a route to that explicit network, hence you need to configure a static route to the network super-block before BGP will advertise that super-block to its neighbors.
  3. Note that Null0 does not go into the core router