SlideShare une entreprise Scribd logo

vpn-site-a-site-avec-des-routeurs-cisco

configuration vpn site a site

1  sur  15
Télécharger pour lire hors ligne
VPN site à site avec des routeurs CISCO
juin. 28




                                                                                SOMMAIRE

       Introduction ............................................................................................................................................................ 2

       1.      Présentation Générale et Principe de la solution propose ............................................................................ 2

       1.1.        Présentation du réseau utilisé ................................................................................................................... 2

       1.2.        Schéma Idéalisé ......................................................................................................................................... 3

       1.3.        Schéma réel – Principe de mise en place ................................................................................................... 3

       2.      Configuration du premier routeur.................................................................................................................. 4

       2.1.        Mise en place du Tunnel ............................................................................................................................ 5

       2.2.        Cryptage du tunnel .................................................................................................................................... 6

       2.3.        Routage entre les 2 sites ............................................................................................................................ 8

       2.4.        Sécurité du routeur .................................................................................................................................... 8

       3.      Configuration du deuxième routeur ............................................................................................................... 9

       4.      Vérifier le bon fonctionnement du VPN ....................................................................................................... 12

       Conclusion ............................................................................................................................................................. 15




       Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007

                                                                                                                                                                                     1
VPN site à site avec des routeurs CISCO
juin. 28




       INTRODUCTION



       Avec la généralisation du dégroupage et de l'Adsl 2+, il est possible d'accéder à très bas coût
       à des connexions internet proposant des débits montants relativement honnêtes (1mb/s).
       Grâce à ces débits il devient tout a fait envisageable à de petites PME/PMI possédant
       plusieurs sites, d'interconnecter les réseaux via un VPN. Cette solution est d'ailleurs de plus
       en plus plébiscitée par les entreprises, principalement grâce à son coût très faible, et les
       débits « élevés », surtout vis à vis de solutions vieillissantes telles que RNIS (Numéris).



              1. PRESENTATION GENERALE ET PRINCIPE DE LA SOLUTION PROPOSE



              1.1.   PRÉSENTATION DU RÉSEAU UTILISÉ

       Pour la suite de l'article, nous utiliserons le réseau WAN ci-dessous, constitué de 2 sites
       distants, possédant chacun :

              un routeur Cisco, avec un IOS supportant les fonctions de cryptage (avec de
              préférence les modules d'accélération de cryptage matériel pour les « anciennes »
              séries)
              une connexion Internet (avec ip fixe)




       Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007

                                                                                                         2
VPN site à site avec des routeurs CISCO
juin. 28




       Site 1 : 172.16.1.0/24

              Interface/Ip locale du routeur : FastEthernet 0 / 172.16.1.254
              Interface/Ip internet du routeur : Ethernet 0 / 82.1.1.1

       Site 2 : 172.16.2.0/24

              Interface/Ip locale du routeur : Ethernet 0 / 172.16.2.254
              Interface/Ip internet du routeur : Ethernet 1 / 82.2.2.2



              1.2.   SCHÉMA IDÉALISÉ

       Le but du VPN est de faire en sorte que les 2 sites communiquent exactement comme s'ils
       étaient directement reliés entre eux, de manière à ce que les 2 réseaux puissent êtres
       directement routés (et non passer par du NAT).




       La liaison directe entre les 2 routeurs (172.16.254.0/30) symbolise le lien que l'on souhaite
       créer avec le VPN.



              1.3.   SCHEMA REEL – PRINCIPE DE MISE EN PLACE

       Dans la réalité il est évidement hors de question de connecter directement les 2 routeurs,
       puisque le but premier du VPN est justement de se passer d'une Ligne Spécialisée.

       Ce lien sera donc créé grâce à un tunnel crypté, qui permettra au 2 sites de communiquer
       entre eux de manière sécurisée. Pour cela, on créera des interfaces virtuelles, permettant de
       symboliser les 2 extrémités de ce tunnel.

       Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007

                                                                                                       3
VPN site à site avec des routeurs CISCO
juin. 28




       La mise en place du VPN se fera en 3 phases:

              Mise en place d'un Tunnel (GRE) entre les 2 sites (définition des interfaces virtuelles)
              Cryptage de ce tunnel
              Mise en place du routage entre les 2 Réseaux locaux.



              2. CONFIGURATION DU PREMIER ROUTEUR

       Soit la configuration standard suivante, permettant l'accès à internet (web) pour le Site 1 :

       ip subnet-zéro

       !

       interface FastEthernet0

       ip address 172.16.1.254 255.255.255.0

       ip nat inside

       !

       interface Ethernet0

       ip address 82.1.1.1 255.255.255.0

       ip access-group netin in

       ip access-group netout out


       Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007

                                                                                                         4
VPN site à site avec des routeurs CISCO
juin. 28


       ip nat outside

       !

       ip classless

       ip route 0.0.0.0 0.0.0.0 Ethernet0 82.1.1.254

       !

       ip nat inside source list natlist interface Ethernet0 overload

       !

       ip access-list extended netin

       permit tcp any host 82.1.1.1 established

       permit udp any eq domain host 82.1.1.1

       permit tcp any eq www host 82.1.1.1

       permit tcp any eq 443 host 82.1.1.1

       !

       ip access-list extended netout

       permit udp host 82.1.1.1 any eq domain

       permit tcp host 82.1.1.1 any eq www

       permit tcp host 82.1.1.1 any eq 443

       !

       ip access-list extended natlist

       permit ip 172.16.1.0 0.0.0.255 any



               2.1.     MISE EN PLACE DU TUNNEL

       Pour mettre en place le tunnel, créez l'interface virtuelle, puis configurez-la en spécifiant :

               son adresse ip (ici 10.16.254.1)
               à quelle interface physique elle est rattachée


       Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007

                                                                                                         5
VPN site à site avec des routeurs CISCO
juin. 28


              vers quelle ip (internet) pointe l'autre bout du tunnel



       Note: toutes commandes suivantes se font en mode de configuration global.

       site1 (config)#interface tunnel 2

       site1 (config-if)# ip address 10.16.254.1 255.255.255.252

       site1 (config-if)# tunnel source Ethernet0

       site1 (config-if)# tunnel destination 82.2.2.2



           2.2.       CRYPTAGE DU TUNNEL

       Nous allons tout d'abord spécifier la manière d'authentification.

       Dans notre cas, nous utiliseront une clef pré partagé:

       Note: nous numéroterons cette méthode ‘‘2’’, puisque qu'il s'agira de la méthode utilisée
       pour authentifier le site 2.

       Note: l'option "lifetime" indique la durée de vie de l'authentification (en secondes).

       site1 (config) # crypto isakmp policy 2

       site1 (config-isakmp) # authentication pre-share

       site1(config-isakmp)# lifetime 3600



       Définition de clef pré-partagée (en spécifiant l'ip de l'hôte avec qui celle sera utilisée, c'est à
       dire l'ip internet du second routeur)

       site1(config)# crypto isakmp key ###MaClef### address 82.2.2.2



       Sélection de l'algorithme de cryptage (DES, 56bits). Nous appellerons cette méthode de
       cryptage "transfdes".




       Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007

                                                                                                             6

Recommandé

Sécurité Réseau à Base d'un Firewall Matériel (fortigate)
Sécurité Réseau à Base d'un Firewall Matériel (fortigate)Sécurité Réseau à Base d'un Firewall Matériel (fortigate)
Sécurité Réseau à Base d'un Firewall Matériel (fortigate)Sakka Mustapha
 
VPN - Virtual Private Network
VPN - Virtual Private NetworkVPN - Virtual Private Network
VPN - Virtual Private Networkjulienlfr
 
Etude et mise en place d’un VPN
Etude et mise en place d’un VPNEtude et mise en place d’un VPN
Etude et mise en place d’un VPNCharif Khrichfa
 
configuration vpn-ipsec-routeur
 configuration vpn-ipsec-routeur configuration vpn-ipsec-routeur
configuration vpn-ipsec-routeurJULIOR MIKALA
 

Contenu connexe

Tendances

Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : SécuritéAlphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : SécuritéAlphorm
 
Mise en place d'un vpn site à site avec pfsense
Mise en place d'un vpn site à site avec pfsenseMise en place d'un vpn site à site avec pfsense
Mise en place d'un vpn site à site avec pfsensePape Moussa SONKO
 
Mise en place de la solution d’authentification Radius sous réseau LAN câblé
Mise en place de la solution d’authentification Radius sous réseau LAN câbléMise en place de la solution d’authentification Radius sous réseau LAN câblé
Mise en place de la solution d’authentification Radius sous réseau LAN câbléCharif Khrichfa
 
Configuration et mise en œuvre d'un réseau WAN (World Area Network)
Configuration et mise en œuvre  d'un réseau  WAN (World Area Network)Configuration et mise en œuvre  d'un réseau  WAN (World Area Network)
Configuration et mise en œuvre d'un réseau WAN (World Area Network)Abderrahmane Benyoub
 
Présentation etherchannel
Présentation etherchannelPrésentation etherchannel
Présentation etherchannelLechoco Kado
 
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.xAlphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.xAlphorm
 
Alphorm.com Formation Certification NSE4 - Fortinet Fortigate Infrastructure 6.x
Alphorm.com Formation Certification NSE4 - Fortinet Fortigate Infrastructure 6.xAlphorm.com Formation Certification NSE4 - Fortinet Fortigate Infrastructure 6.x
Alphorm.com Formation Certification NSE4 - Fortinet Fortigate Infrastructure 6.xAlphorm
 
TD_complet_reseau__CISCO__Packet Tracer.pdf
TD_complet_reseau__CISCO__Packet Tracer.pdfTD_complet_reseau__CISCO__Packet Tracer.pdf
TD_complet_reseau__CISCO__Packet Tracer.pdfInes Ben Hassine
 

Tendances (20)

Cours syslog
Cours syslogCours syslog
Cours syslog
 
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : SécuritéAlphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
 
Rapport projet
Rapport projetRapport projet
Rapport projet
 
Les Vpn
Les VpnLes Vpn
Les Vpn
 
Mise en place d'un vpn site à site avec pfsense
Mise en place d'un vpn site à site avec pfsenseMise en place d'un vpn site à site avec pfsense
Mise en place d'un vpn site à site avec pfsense
 
Vpn
VpnVpn
Vpn
 
projet sur le vpn presentation
projet sur le vpn presentationprojet sur le vpn presentation
projet sur le vpn presentation
 
Mise en place de la solution d’authentification Radius sous réseau LAN câblé
Mise en place de la solution d’authentification Radius sous réseau LAN câbléMise en place de la solution d’authentification Radius sous réseau LAN câblé
Mise en place de la solution d’authentification Radius sous réseau LAN câblé
 
E4 pt act_7_5_1
E4 pt act_7_5_1E4 pt act_7_5_1
E4 pt act_7_5_1
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
 
Configuration et mise en œuvre d'un réseau WAN (World Area Network)
Configuration et mise en œuvre  d'un réseau  WAN (World Area Network)Configuration et mise en œuvre  d'un réseau  WAN (World Area Network)
Configuration et mise en œuvre d'un réseau WAN (World Area Network)
 
Commutation
CommutationCommutation
Commutation
 
cours DHCP IPv4 et IPv6
cours DHCP IPv4 et IPv6cours DHCP IPv4 et IPv6
cours DHCP IPv4 et IPv6
 
VPN: SSL vs IPSEC
VPN: SSL vs IPSECVPN: SSL vs IPSEC
VPN: SSL vs IPSEC
 
Présentation etherchannel
Présentation etherchannelPrésentation etherchannel
Présentation etherchannel
 
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.xAlphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
 
Mise en place d’un OpenVPN sous PfSense
Mise en place d’un OpenVPN sous PfSenseMise en place d’un OpenVPN sous PfSense
Mise en place d’un OpenVPN sous PfSense
 
Alphorm.com Formation Certification NSE4 - Fortinet Fortigate Infrastructure 6.x
Alphorm.com Formation Certification NSE4 - Fortinet Fortigate Infrastructure 6.xAlphorm.com Formation Certification NSE4 - Fortinet Fortigate Infrastructure 6.x
Alphorm.com Formation Certification NSE4 - Fortinet Fortigate Infrastructure 6.x
 
TD_complet_reseau__CISCO__Packet Tracer.pdf
TD_complet_reseau__CISCO__Packet Tracer.pdfTD_complet_reseau__CISCO__Packet Tracer.pdf
TD_complet_reseau__CISCO__Packet Tracer.pdf
 
Tp voip
Tp voipTp voip
Tp voip
 

En vedette

Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)EL AMRI El Hassan
 
Mise en place de deux réseaux LAN interconnectés par un réseau WAN
Mise en place de deux réseaux LAN interconnectés par un réseau WANMise en place de deux réseaux LAN interconnectés par un réseau WAN
Mise en place de deux réseaux LAN interconnectés par un réseau WANGhassen Chaieb
 
Résumé ccna 1chapitre 1 v5.0
Résumé ccna 1chapitre 1 v5.0Résumé ccna 1chapitre 1 v5.0
Résumé ccna 1chapitre 1 v5.0EL AMRI El Hassan
 
Travaux pratiques configuration du routage entre réseaux locaux virtuels
Travaux pratiques   configuration du routage entre réseaux locaux virtuelsTravaux pratiques   configuration du routage entre réseaux locaux virtuels
Travaux pratiques configuration du routage entre réseaux locaux virtuelsMohamed Keita
 
Lire les tables de routage
Lire les tables de routageLire les tables de routage
Lire les tables de routagebelhadj_rached
 
Vpn d’acces avec cisco asa 5500 et client
Vpn d’acces avec cisco asa 5500 et clientVpn d’acces avec cisco asa 5500 et client
Vpn d’acces avec cisco asa 5500 et clientManassé Achim kpaya
 
Rapport simo issam
Rapport simo issamRapport simo issam
Rapport simo issamsimomans
 
Initiation à la gestion de projet
Initiation à la gestion de projetInitiation à la gestion de projet
Initiation à la gestion de projetmahassine_med_amine
 
La virtualisation dans le Datacenter
La virtualisation dans le DatacenterLa virtualisation dans le Datacenter
La virtualisation dans le DatacenterParis, France
 
Gsm Protocoles & ProcéDures
Gsm   Protocoles & ProcéDuresGsm   Protocoles & ProcéDures
Gsm Protocoles & ProcéDuresAnouar Loukili
 
cours base de données
cours base de donnéescours base de données
cours base de donnéesYassine Badri
 
Tp routage inter vlan
Tp routage inter vlanTp routage inter vlan
Tp routage inter vlanChris Dogny
 
569036 bases-de-traitement-du-signal
569036 bases-de-traitement-du-signal569036 bases-de-traitement-du-signal
569036 bases-de-traitement-du-signalOussema Ben Khlifa
 
Codage de l'information
Codage de l'informationCodage de l'information
Codage de l'informationPeronnin Eric
 

En vedette (20)

Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
 
Mise en place de deux réseaux LAN interconnectés par un réseau WAN
Mise en place de deux réseaux LAN interconnectés par un réseau WANMise en place de deux réseaux LAN interconnectés par un réseau WAN
Mise en place de deux réseaux LAN interconnectés par un réseau WAN
 
Résumé vlsm et cidr
Résumé vlsm et cidrRésumé vlsm et cidr
Résumé vlsm et cidr
 
Résumé ccna 1chapitre 1 v5.0
Résumé ccna 1chapitre 1 v5.0Résumé ccna 1chapitre 1 v5.0
Résumé ccna 1chapitre 1 v5.0
 
Cisco ASA
Cisco ASACisco ASA
Cisco ASA
 
Travaux pratiques configuration du routage entre réseaux locaux virtuels
Travaux pratiques   configuration du routage entre réseaux locaux virtuelsTravaux pratiques   configuration du routage entre réseaux locaux virtuels
Travaux pratiques configuration du routage entre réseaux locaux virtuels
 
Lire les tables de routage
Lire les tables de routageLire les tables de routage
Lire les tables de routage
 
Vpn d’acces avec cisco asa 5500 et client
Vpn d’acces avec cisco asa 5500 et clientVpn d’acces avec cisco asa 5500 et client
Vpn d’acces avec cisco asa 5500 et client
 
Gestion de projet
Gestion de projetGestion de projet
Gestion de projet
 
Rapport simo issam
Rapport simo issamRapport simo issam
Rapport simo issam
 
Soutenance Finale
Soutenance FinaleSoutenance Finale
Soutenance Finale
 
Initiation à la gestion de projet
Initiation à la gestion de projetInitiation à la gestion de projet
Initiation à la gestion de projet
 
SQL Jean-Antoine Moreau
SQL  Jean-Antoine MoreauSQL  Jean-Antoine Moreau
SQL Jean-Antoine Moreau
 
La virtualisation dans le Datacenter
La virtualisation dans le DatacenterLa virtualisation dans le Datacenter
La virtualisation dans le Datacenter
 
Carte mentale protocole sip
Carte mentale protocole sipCarte mentale protocole sip
Carte mentale protocole sip
 
Gsm Protocoles & ProcéDures
Gsm   Protocoles & ProcéDuresGsm   Protocoles & ProcéDures
Gsm Protocoles & ProcéDures
 
cours base de données
cours base de donnéescours base de données
cours base de données
 
Tp routage inter vlan
Tp routage inter vlanTp routage inter vlan
Tp routage inter vlan
 
569036 bases-de-traitement-du-signal
569036 bases-de-traitement-du-signal569036 bases-de-traitement-du-signal
569036 bases-de-traitement-du-signal
 
Codage de l'information
Codage de l'informationCodage de l'information
Codage de l'information
 

Similaire à vpn-site-a-site-avec-des-routeurs-cisco

Configuration d'un VP IPSEC CISCO
Configuration d'un VP IPSEC CISCOConfiguration d'un VP IPSEC CISCO
Configuration d'un VP IPSEC CISCOsaqrjareh
 
VPN site-to-site.pdf
VPN site-to-site.pdfVPN site-to-site.pdf
VPN site-to-site.pdfgorguindiaye
 
Presentation DMZ - GUERITEY
Presentation DMZ - GUERITEYPresentation DMZ - GUERITEY
Presentation DMZ - GUERITEYSbastienGuritey
 
Chapter2_ScalingNetworks.pdf
Chapter2_ScalingNetworks.pdfChapter2_ScalingNetworks.pdf
Chapter2_ScalingNetworks.pdfBARKAAMINEAHAMAT
 
Cisco et-le-simulateur-packet-tracer
Cisco et-le-simulateur-packet-tracerCisco et-le-simulateur-packet-tracer
Cisco et-le-simulateur-packet-tracerMed Ali Bhs
 
resume-theorique-m201-v2-0-6308e052ede7e (1).pdf
resume-theorique-m201-v2-0-6308e052ede7e (1).pdfresume-theorique-m201-v2-0-6308e052ede7e (1).pdf
resume-theorique-m201-v2-0-6308e052ede7e (1).pdfFootballLovers9
 
we config - procédure configuration rapide réseau Ethernet
we config - procédure configuration rapide réseau Ethernetwe config - procédure configuration rapide réseau Ethernet
we config - procédure configuration rapide réseau EthernetOlivier Bughin
 
Socket tcp ip client server on langace c
Socket tcp ip client server on langace c Socket tcp ip client server on langace c
Socket tcp ip client server on langace c mouad Lousimi
 
Case Cloud-Windows -ver 41a
Case Cloud-Windows -ver 41aCase Cloud-Windows -ver 41a
Case Cloud-Windows -ver 41aJulien Genon
 
resume-theorique-m201-v1-0-62f6e7977fea0.pdf
resume-theorique-m201-v1-0-62f6e7977fea0.pdfresume-theorique-m201-v1-0-62f6e7977fea0.pdf
resume-theorique-m201-v1-0-62f6e7977fea0.pdfMarshalElMaghribi
 
Deep Dive: Virtual Private Cloud
Deep Dive: Virtual Private CloudDeep Dive: Virtual Private Cloud
Deep Dive: Virtual Private CloudJulien SIMON
 
Reseaux Avancés Tunnel_Niveaux347.pdf
Reseaux Avancés Tunnel_Niveaux347.pdfReseaux Avancés Tunnel_Niveaux347.pdf
Reseaux Avancés Tunnel_Niveaux347.pdfSergeAKUE
 

Similaire à vpn-site-a-site-avec-des-routeurs-cisco (20)

Configuration d'un VP IPSEC CISCO
Configuration d'un VP IPSEC CISCOConfiguration d'un VP IPSEC CISCO
Configuration d'un VP IPSEC CISCO
 
VPN site-to-site.pdf
VPN site-to-site.pdfVPN site-to-site.pdf
VPN site-to-site.pdf
 
Presentation DMZ - GUERITEY
Presentation DMZ - GUERITEYPresentation DMZ - GUERITEY
Presentation DMZ - GUERITEY
 
Chapter2_ScalingNetworks.pdf
Chapter2_ScalingNetworks.pdfChapter2_ScalingNetworks.pdf
Chapter2_ScalingNetworks.pdf
 
Pfsense
PfsensePfsense
Pfsense
 
Ccna 2-module-2-v4
Ccna 2-module-2-v4Ccna 2-module-2-v4
Ccna 2-module-2-v4
 
Cisco et-le-simulateur-packet-tracer
Cisco et-le-simulateur-packet-tracerCisco et-le-simulateur-packet-tracer
Cisco et-le-simulateur-packet-tracer
 
resume-theorique-m201-v2-0-6308e052ede7e (1).pdf
resume-theorique-m201-v2-0-6308e052ede7e (1).pdfresume-theorique-m201-v2-0-6308e052ede7e (1).pdf
resume-theorique-m201-v2-0-6308e052ede7e (1).pdf
 
we config - procédure configuration rapide réseau Ethernet
we config - procédure configuration rapide réseau Ethernetwe config - procédure configuration rapide réseau Ethernet
we config - procédure configuration rapide réseau Ethernet
 
Socket tcp ip client server on langace c
Socket tcp ip client server on langace c Socket tcp ip client server on langace c
Socket tcp ip client server on langace c
 
Redondance
RedondanceRedondance
Redondance
 
Case Cloud-Windows -ver 41a
Case Cloud-Windows -ver 41aCase Cloud-Windows -ver 41a
Case Cloud-Windows -ver 41a
 
Adsl cisco
Adsl ciscoAdsl cisco
Adsl cisco
 
resume-theorique-m201-v1-0-62f6e7977fea0.pdf
resume-theorique-m201-v1-0-62f6e7977fea0.pdfresume-theorique-m201-v1-0-62f6e7977fea0.pdf
resume-theorique-m201-v1-0-62f6e7977fea0.pdf
 
Tuto vpn
Tuto vpnTuto vpn
Tuto vpn
 
Bah mamadou hady
Bah mamadou hadyBah mamadou hady
Bah mamadou hady
 
Deep Dive: Virtual Private Cloud
Deep Dive: Virtual Private CloudDeep Dive: Virtual Private Cloud
Deep Dive: Virtual Private Cloud
 
ccna1-3.pdf
ccna1-3.pdfccna1-3.pdf
ccna1-3.pdf
 
WeConfig boucle FRNT
WeConfig boucle FRNTWeConfig boucle FRNT
WeConfig boucle FRNT
 
Reseaux Avancés Tunnel_Niveaux347.pdf
Reseaux Avancés Tunnel_Niveaux347.pdfReseaux Avancés Tunnel_Niveaux347.pdf
Reseaux Avancés Tunnel_Niveaux347.pdf
 

vpn-site-a-site-avec-des-routeurs-cisco

  • 1. VPN site à site avec des routeurs CISCO juin. 28 SOMMAIRE Introduction ............................................................................................................................................................ 2 1. Présentation Générale et Principe de la solution propose ............................................................................ 2 1.1. Présentation du réseau utilisé ................................................................................................................... 2 1.2. Schéma Idéalisé ......................................................................................................................................... 3 1.3. Schéma réel – Principe de mise en place ................................................................................................... 3 2. Configuration du premier routeur.................................................................................................................. 4 2.1. Mise en place du Tunnel ............................................................................................................................ 5 2.2. Cryptage du tunnel .................................................................................................................................... 6 2.3. Routage entre les 2 sites ............................................................................................................................ 8 2.4. Sécurité du routeur .................................................................................................................................... 8 3. Configuration du deuxième routeur ............................................................................................................... 9 4. Vérifier le bon fonctionnement du VPN ....................................................................................................... 12 Conclusion ............................................................................................................................................................. 15 Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 1
  • 2. VPN site à site avec des routeurs CISCO juin. 28 INTRODUCTION Avec la généralisation du dégroupage et de l'Adsl 2+, il est possible d'accéder à très bas coût à des connexions internet proposant des débits montants relativement honnêtes (1mb/s). Grâce à ces débits il devient tout a fait envisageable à de petites PME/PMI possédant plusieurs sites, d'interconnecter les réseaux via un VPN. Cette solution est d'ailleurs de plus en plus plébiscitée par les entreprises, principalement grâce à son coût très faible, et les débits « élevés », surtout vis à vis de solutions vieillissantes telles que RNIS (Numéris). 1. PRESENTATION GENERALE ET PRINCIPE DE LA SOLUTION PROPOSE 1.1. PRÉSENTATION DU RÉSEAU UTILISÉ Pour la suite de l'article, nous utiliserons le réseau WAN ci-dessous, constitué de 2 sites distants, possédant chacun : un routeur Cisco, avec un IOS supportant les fonctions de cryptage (avec de préférence les modules d'accélération de cryptage matériel pour les « anciennes » séries) une connexion Internet (avec ip fixe) Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 2
  • 3. VPN site à site avec des routeurs CISCO juin. 28 Site 1 : 172.16.1.0/24 Interface/Ip locale du routeur : FastEthernet 0 / 172.16.1.254 Interface/Ip internet du routeur : Ethernet 0 / 82.1.1.1 Site 2 : 172.16.2.0/24 Interface/Ip locale du routeur : Ethernet 0 / 172.16.2.254 Interface/Ip internet du routeur : Ethernet 1 / 82.2.2.2 1.2. SCHÉMA IDÉALISÉ Le but du VPN est de faire en sorte que les 2 sites communiquent exactement comme s'ils étaient directement reliés entre eux, de manière à ce que les 2 réseaux puissent êtres directement routés (et non passer par du NAT). La liaison directe entre les 2 routeurs (172.16.254.0/30) symbolise le lien que l'on souhaite créer avec le VPN. 1.3. SCHEMA REEL – PRINCIPE DE MISE EN PLACE Dans la réalité il est évidement hors de question de connecter directement les 2 routeurs, puisque le but premier du VPN est justement de se passer d'une Ligne Spécialisée. Ce lien sera donc créé grâce à un tunnel crypté, qui permettra au 2 sites de communiquer entre eux de manière sécurisée. Pour cela, on créera des interfaces virtuelles, permettant de symboliser les 2 extrémités de ce tunnel. Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 3
  • 4. VPN site à site avec des routeurs CISCO juin. 28 La mise en place du VPN se fera en 3 phases: Mise en place d'un Tunnel (GRE) entre les 2 sites (définition des interfaces virtuelles) Cryptage de ce tunnel Mise en place du routage entre les 2 Réseaux locaux. 2. CONFIGURATION DU PREMIER ROUTEUR Soit la configuration standard suivante, permettant l'accès à internet (web) pour le Site 1 : ip subnet-zéro ! interface FastEthernet0 ip address 172.16.1.254 255.255.255.0 ip nat inside ! interface Ethernet0 ip address 82.1.1.1 255.255.255.0 ip access-group netin in ip access-group netout out Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 4
  • 5. VPN site à site avec des routeurs CISCO juin. 28 ip nat outside ! ip classless ip route 0.0.0.0 0.0.0.0 Ethernet0 82.1.1.254 ! ip nat inside source list natlist interface Ethernet0 overload ! ip access-list extended netin permit tcp any host 82.1.1.1 established permit udp any eq domain host 82.1.1.1 permit tcp any eq www host 82.1.1.1 permit tcp any eq 443 host 82.1.1.1 ! ip access-list extended netout permit udp host 82.1.1.1 any eq domain permit tcp host 82.1.1.1 any eq www permit tcp host 82.1.1.1 any eq 443 ! ip access-list extended natlist permit ip 172.16.1.0 0.0.0.255 any 2.1. MISE EN PLACE DU TUNNEL Pour mettre en place le tunnel, créez l'interface virtuelle, puis configurez-la en spécifiant : son adresse ip (ici 10.16.254.1) à quelle interface physique elle est rattachée Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 5
  • 6. VPN site à site avec des routeurs CISCO juin. 28 vers quelle ip (internet) pointe l'autre bout du tunnel Note: toutes commandes suivantes se font en mode de configuration global. site1 (config)#interface tunnel 2 site1 (config-if)# ip address 10.16.254.1 255.255.255.252 site1 (config-if)# tunnel source Ethernet0 site1 (config-if)# tunnel destination 82.2.2.2 2.2. CRYPTAGE DU TUNNEL Nous allons tout d'abord spécifier la manière d'authentification. Dans notre cas, nous utiliseront une clef pré partagé: Note: nous numéroterons cette méthode ‘‘2’’, puisque qu'il s'agira de la méthode utilisée pour authentifier le site 2. Note: l'option "lifetime" indique la durée de vie de l'authentification (en secondes). site1 (config) # crypto isakmp policy 2 site1 (config-isakmp) # authentication pre-share site1(config-isakmp)# lifetime 3600 Définition de clef pré-partagée (en spécifiant l'ip de l'hôte avec qui celle sera utilisée, c'est à dire l'ip internet du second routeur) site1(config)# crypto isakmp key ###MaClef### address 82.2.2.2 Sélection de l'algorithme de cryptage (DES, 56bits). Nous appellerons cette méthode de cryptage "transfdes". Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 6
  • 7. VPN site à site avec des routeurs CISCO juin. 28 Note: selon la puissance et les possibilités du routeur il est préférable de prendre des algorithmes de cryptage plus conséquents, tels de 3DES (esp-3des, 168bits) ou AES (esp- aes). site1 (config)# crypto ipsec transform-set transfdes esp-des Nous allons maintenant créer une Access List qui va sélectionner le trafic à crypter. Le tunnel IP encapsulant déjà tout le trafic dans des trames GRE, il suffit juste de sélectionner le trafic GRE entre les 2 routeurs. Nous appellerons cette Access List "cryptolist": site1(config)# ip access-list extended cryptolist site1(config-ext-nacl)# permit gre host 82.1.1.1 host 82.2.2.2 Nous allons maintenant regrouper toutes ces informations dans une "carte de cryptage", que nous appellerons "cryptvpn". Note: les lignes "set security-association lifetime" définissent la durée de vie d'une session cryptée. site1(config)# crypto map cryptvpn 2 ipsec-isakmp site1(config-crypto-map)# set peer 82.2.2.2 site1(config-crypto-map)# set security-association lifetime kilobytes 102400 site1(config-crypto-map)# set security-association lifetime seconds 600 site1(config-crypto-map)# set transform-set transfdes site1(config-crypto-map)# match address cryptolist Il ne reste plus qu'a appliquer cette "carte" sur l'interface internet du routeur : site1(config)# interface Ethernet0 site1(config-if)# crypto map cryptvpn Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 7
  • 8. VPN site à site avec des routeurs CISCO juin. 28 2.3. ROUTAGE ENTRE LES 2 SITES ATTENTION !!! NAT et ROUTAGE peuvent ne pas faire bon ménage lorsqu'ils sont tout deux appliqués sur le même routeur, alors que l’on n’y prenne pas garde. IL est donc impératif de rejeter le trafic destiné au VPN dans les règles du NAT. Nous devrons donc insérer une règle rejetant ce trafic avant celle déjà existante, nous l'insérerons donc en 5° position (les autres règles commençant en standard à 10) site1(config)# ip access-list extended natlist site1(config-ext-nacl)# 5 deny ip 172.16.1.0 0.0.0.255 172.16.2.0 0.0.0.255 Au final, l'Access List ressemblera à : site1#sh access-lists natlist Extended IP access list natlist 5 deny ip 172.16.1.0 0.0.0.255 172.16.2.0 0.0.0.255 (5790 matches) 10 permit ip 172.16.1.0 0.0.0.255 any (97034 matches) Afin que le routage puisse être effectué correctement, il est essentiel de rajouter une route statique vers le réseau distant. On notera au passage que l'on indique bien l'ip virtuelle du tunnel pour le second routeur, et non l'ip internet. site1(config)# ip route 172.16.2.0 255.255.255.0 Tunnel2 10.16.254.2 2.4. SÉCURITÉ DU ROUTEUR Si comme dans cet exemple, vous filtrez le trafic sur votre interface internet (Ce qui est vivement recommandé), il est essentiel de laisser passer les paquets d'authentification et le tunnel lui même. Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 8
  • 9. VPN site à site avec des routeurs CISCO juin. 28 On notera au passage qu'à ce stade, on ne permet pas du tout le protocole GRE, puisque celui-ci vas être entièrement encapsulé dans les trames cryptées (ESP). site1(config)# ip access-list extended netin site1(config-ext-nacl)# permit udp host 82.2.2.2 eq isakmp host 82.1.1.1 eq isakmp site1(config-ext-nacl)# permit esp host 82.2.2.2 host 82.1.1.1 site1(config)# ip access-list extended netout site1(config-ext-nacl)# permit udp host 82.1.1.1 eq isakmp host 82.2.2.2 eq isakmp site1(config-ext-nacl)# permit esp host 82.1.1.1 host 82.2.2.2 3. CONFIGURATION DU DEUXIEME ROUTEUR La configuration étant strictement la même sur le deuxième routeur (sauf bien sur les adresses sources et de destination), voici donc la configuration complète pour le deuxième routeur : ip subnet-zero ! crypto isakmp policy 1 authentication pre-share lifetime 3600 crypto isakmp key ###MaClef### address 82.1.1.1 ! crypto ipsec transform-set transfdes esp-des ! crypto map cryptvpn 1 ipsec-isakmp Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 9
  • 10. VPN site à site avec des routeurs CISCO juin. 28 set peer 82.1.1.1 set security-association lifetime kilobytes 102400 set security-association lifetime seconds 600 set transform-set transfdes match address cryptolist ! interface Tunnel1 ip address 10.16.254.2 255.255.255.252 tunnel source Ethernet1 tunnel destination 82.1.1.1 ! interface Ethernet0 ip address 172.16.2.254 255.255.255.0 ip nat inside ! interface Ethernet1 ip address 82.2.2.2 255.255.255.0 ip access-group netin in ip access-group netout out ip nat outside crypto map cryptvpn ! ip default-gateway 82.2.2.254 ip classless ip route 0.0.0.0 0.0.0.0 Ethernet1 82.2.2.254 Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 10
  • 11. VPN site à site avec des routeurs CISCO juin. 28 ip route 172.16.1.0 255.255.255.0 Tunnel1 10.16.254.1 ! ip nat inside source list listnat interface Ethernet1 overload ! ip access-list extended cryptolist permit gre host 82.2.2.2 host 82.1.1.1 ! ip access-list extended netin permit tcp any host 82.2.2.2 established permit udp any eq domain host 82.2.2.2 permit tcp any eq www host 82.2.2.2 permit tcp any eq 443 host 82.2.2.2 permit udp host 82.1.1.1 eq isakmp host 82.2.2.2 eq isakmp permit esp host 82.1.1.1 host 82.2.2.2 ! ip access-list extended netout permit udp host 82.2.2.2 any eq domain permit tcp host 82.2.2.2 any eq www permit tcp host 82.2.2.2 any eq 443 permit udp host 82.2.2.2 eq isakmp host 82.1.1.1 eq isakmp permit esp host 82.2.2.2 host 82.1.1.1 ! ip access-list extended listnat deny ip 172.16.2.0 0.0.0.255 172.16.1.0 0.0.0.255 permit ip 172.16.2.0 0.0.0.255 any Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 11
  • 12. VPN site à site avec des routeurs CISCO juin. 28 4. VERIFIER LE BON FONCTIONNEMENT DU VPN Afin de vérifier le bon fonctionnement du VPN, plusieurs commandes sont à votre disposition : En mode privilégié : Show crypto engine connections active : vous permet de voir les connexions cryptées actives: site1#sh crypto engine connections active ID Interface IP-Address State Algorithm Encrypt Decrypt 2002 Ethernet0 82.1.1.1 set DES 527 0 2005 Ethernet0 82.1.1.1 set DES 0 490 show crypto ipsec transform-set : vous permet de voir les différents types d'encodage actifs. site1#sh crypto ipsec transform-set Transform set transfdes: { esp-des } will negotiate = {Tunnel,}, show crypto ipsec transform-set : fourni une version plus détaillé que les 2 commandes citées plus haut. site1#sh crypto ipsec sa interface: Ethernet0 (...) inbound esp sas: spi: 0x4A65829E(1248166558) transform: esp-des , Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 12
  • 13. VPN site à site avec des routeurs CISCO juin. 28 in use settings ={Tunnel, } conn id: 2005, flow_id: C1700_EM:5, crypto map: cryptvpn sa timing: remaining key lifetime (k/sec): (99130/563) IV size: 8 bytes replay detection support: N Status: ACTIVE outbound esp sas: spi: 0x3481731A(880898842) transform: esp-des , in use settings ={Tunnel, } conn id: 2002, flow_id: C1700_EM:2, crypto map: cryptvpn sa timing: remaining key lifetime (k/sec): (99129/556) IV size: 8 bytes replay detection support: N Status: ACTIVE show ip route : vous permet de vérifier les routes. site1#sh ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 13
  • 14. VPN site à site avec des routeurs CISCO juin. 28 o - ODR, P - periodic downloaded static route Gateway of last resort is 82.1.1.254 to network 0.0.0.0 172.16.0.0/24 is subnetted, 3 subnets S 172.16.2.0 [1/0] via 10.16.254.2, Tunnel2 C 172.16.1.0 is directly connected, FastEthernet0 82.0.0.0/24 is subnetted, 1 subnets C 82.1.1.0 is directly connected, Ethernet0 10.0.0.0/30 is subnetted, 1 subnets C 10.16.2.0 is directly connected, Tunnel2 S* 0.0.0.0/0 [1/0] via 82.1.1.254, Ethernet0 show ip access-lists : vous permet de vérifier le fonctionnement des différents Access Lists. site1#sh ip access-lists Extended IP access list cryptolist 10 permit gre host 82.1.1.1 host 82.2.2.2 Extended IP access list netin 10 permit tcp any host 82.1.1.1 established 20 permit udp any eq domain host 82.1.1.1 (xxx matches) 30 permit tcp any eq www host 82.1.1.1 (xxx matches) 40 permit tcp any eq 443 host 82.1.1.1 (xxx matches) 50 permit udp host 82.2.2.2 eq isakmp host 82.1.1.1 eq isakmp (18 matches) 60 permit esp host 82.2.2.2 host 82.1.1.1 (573 matches) Extended IP access list netout 10 permit udp host 82.1.1.1 any eq domain (xxx matches) Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 14
  • 15. VPN site à site avec des routeurs CISCO juin. 28 20 permit tcp host 82.1.1.1 any eq www (xxx matches) 30 permit tcp host 82.1.1.1 any eq 443 (xxx matches) 40 permit udp host 82.1.1.1 eq isakmp host 82.2.2.2 eq isakmp (16 matches) 50 permit esp host 82.1.1.1 host 82.2.2.2 (461 matches) Extended IP access list natlist 5 deny ip 172.16.1.0 0.0.0.255 172.16.2.0 0.0.0.255 (461 matches) 10 permit ip 172.16.1.0 0.0.0.255 any (xxx matches) CONCLUSION Grâce aux connexions internet d'aujourd'hui, la solution VPN est plus que viable, et permet à des entreprises de taille relativement petites d'accéder à des fonctionnalités avancées. La mise en place du VPN demande de la rigueur, car il s'agit en fait de la combinaison de 3 technologies (cryptage, routage, firewalling). Si l’on n’y prête pas attention, on peut rapidement laisser de grosses failles de sécurités. Antonio ROSSETTI Elève-Ingénieur - Supinfo Alsace - Promotion SUPINFO 2007 15