SlideShare une entreprise Scribd logo
1  sur  7
Télécharger pour lire hors ligne
El Hassan EL AMRI – Frame Relay
1El Hassan EL AMRI
Frame Relay
I. Introduction
rame Relay est un protocole de réseau étendu (WAN) qui intervient dans les couches physique
et liaison de données du modèle de référence OSI. Bien que de nouveaux services tels que le
haut débit et le métro Ethernet ont réduit les besoins Frame Relay dans de nombreux endroits,
ce type de connexion reste une option viable dans de nombreux endroits partout dans le monde. Frame
Relay est une solution économique de communication entre plusieurs sites distants, qui utilise un seul
circuit d'accès entre chaque site et le fournisseur.
II. Présentation de Frame Relay
Les lignes louées offrent une capacité dédiée permanente. Elles sont très largement utilisées pour la
création de WAN. Elles représentent le choix traditionnel en matière de connexion, mais présentent un
certain nombre d'inconvénients. Un de ces inconvénients et que les clients payent pour des lignes
louées de capacité fixe. Cependant, le trafic WAN est souvent variable et une partie de cette capacité
n'est pas utilisée. Par ailleurs, chaque point d'extrémité requiert une interface physique séparée sur le
routeur, ce qui augmente les coûts d'équipements. Toute modification de la ligne louée nécessite
généralement une intervention sur site du personnel de l'opérateur.
Frame Relay est un protocole de réseau étendu (WAN) qui intervient dans les couches physique et
liaison de données du modèle de référence OSI. À l'inverse des lignes louées, Frame Relay ne
nécessite qu'un seul circuit d'accès au fournisseur Frame Relay pour communiquer avec les autres sites
connectés au même fournisseur. La capacité entre deux sites peut varier.
II.1 Avantages de la technologie WAN Frame Relay
Avec l'arrivée de services haut débit tels que le DSL, le modem câble, le WAN Ethernet (service
Ethernet point à point sur fibre optique), le VPN et le MPLS, Frame Relay a perdu de son intérêt
comme solution d'accès au WAN. Cependant, la solution Frame Relay est toujours utilisée pour la
connexion WAN dans certains endroits du monde.
 Plus la distance couverte par une ligne spécialisée est importante, plus le service est
coûteux.
 Les réseaux à commutation de paquets fournissent un multiplexage de nombreuses
données à travers un seul lien de communication.
 Si 2 sites distants veulent communiquer via Frame Relay, ils ont donc juste à constituer un
circuit entre ces sites, à travers le réseau Frame Relay.
III. Fonctionnement de la technologie Frame Relay
III. 1 Circuits virtuels (VC)
Au sein du nuage Frame Relay, la connexion entre deux sites se fait par l'intermédiaire de
circuits virtuels qui peuvent être établis en dur par le fournisseur, Les circuits virtuels offrent un
chemin pour la communication bidirectionnelle d'un périphérique à un autre. Les circuits virtuels
sont identifiés par les DLCI.
Les circuits virtuels peuvent s'établir de deux manières :
F
Campus des Réseaux Informatiques et Télécommunications
El Hassan EL AMRI – Frame Relay
2El Hassan EL AMRI
Circuits virtuels commutés (SVC, Switched Virtual circuits) : établis de façon dynamique
par l'envoi de messages de signal au réseau (CALL SETUP, DATA TRANSFER, IDLE, CALL
TERMINATION).
Circuits virtuels permanents (PVC, Permanent Virtual Circuits) : préconfigurés par
l'opérateur, une fois mis en place, ils ne fonctionnent qu'en mode DATA TRANSFER ou IDLE.
Notez que dans certaines publications, les circuits virtuels permanents sont appelés circuits
virtuels privés.
Remarque : les circuits virtuels permanents sont plus souvent utilisés que les circuits
virtuels commutés.
III.2 DLCI
Un indicateur DLCI identifie un circuit virtuel sur un équipement situé à une extrémité. Au-delà
de la liaison, ce DLCI n'a aucune signification. Deux périphériques connectés par un circuit
virtuel peuvent utiliser une valeur DLCI différente pour faire référence à la même connexion.
IV. Encapsulation Frame Relay
Tout d'abord, Frame Relay accepte le paquet d'un protocole de couche réseau, par exemple IPv4.
Il ajoute ensuite un champ d'adresse qui contient le DLCI et une somme de contrôle. Des champs
d'indicateur sont ajoutés pour indiquer le début et la fin de la trame. Ces champs marquent le début
et la fin de la trame et sont toujours les mêmes. Ces indicateurs sont représentés soit en
hexadécimal par 7E, soit en binaire par 01111110. Une fois le paquet encapsulé, Frame Relay
passe la trame à la couche physique qui assure le transport.
Le routeur d'équipement d'abonné encapsule chaque paquet de couche 3 dans un en-tête et un
code de fin Frame Relay avant de l'envoyer sur le circuit virtuel. L'en-tête et le code de fin sont
définis par la spécification Link Access Procedure for Frame Relay (LAPF) Bearer Services, UIT
Q.922-A. Comme illustré à la Figure 2, l'en-tête Frame Relay header (champ d'adresse) contient
les éléments suivants :
DLCI : le DLCI 10 bits est un des champs les plus importants de l'en-tête Frame Relay. Cette valeur
représente la connexion virtuelle entre l'équipement ETTD et le commutateur. Chaque connexion
virtuelle multiplexée sur le canal physique est représentée par un DLCI unique. Les identificateurs
DLCI n'ont qu'une signification locale. En d'autres termes, ils ne sont uniques que sur le canal
physique sur lequel ils résident. Les équipements situés à l'autre extrémité d'une connexion peuvent
donc faire référence à la même connexion virtuelle par des identificateurs DLCI différents.
C/R : bit qui suit l'octet DLCI significatif dans le champ d'adresse. Le bit C/R n'est pas actuellement
défini.
EA (Extended Address) : si la valeur du champ EA est 1, l'octet actuel est considéré comme le
dernier octet DLCI. Toutes les mises en œuvre actuelles du protocole Frame Relay utilisent
cependant un DLCI de 2 octets, ce qui permet une extension des adresses DLCI dans le futur. Le
huitième bit de chaque octet du champ d'adresse sert à indiquer une adresse étendue.
Contrôle d'encombrement : composé de trois bits de notification d'encombrement Frame Relay.
Ces trois bits sont appelés FECN (Forward Explicit Congestion Notification), BECN (Backward
Explicit Congestion Notification) et DE (Discard Eligible).
El Hassan EL AMRI – Frame Relay
3El Hassan EL AMRI
V. Topologies Frame Relay
Frame-relay supporte multiple topologies :
1) Full-mesh (Topologie à maillage global)
2) Partial-mesh (Topologie à maillage partiel)
3) Hub and Spoke (Topologie en étoile)
VI. Mappage des adresses Frame Relay
VI.1 ARP inverse
Un des outils principaux de Frame Relay est le protocole ARP inverse (Address Resolution
Protocol). Alors que le protocole ARP traduit les adresses IPv4 de couche 3 en adresses MAC de
couche 2, le protocole ARP inverse effectue l'opération inverse. Les adresses IPv4 de couche 3
correspondantes doivent être disponibles avant l'utilisation des circuits virtuels.
Remarque : Frame Relay pour IPv6 utilise le protocole IND (Inverse Neighbor Discovery) pour
obtenir une adresse IPv6 de couche 3 de la part d'un DLCI de couche 2.
El Hassan EL AMRI – Frame Relay
4El Hassan EL AMRI
VI.2 Mappage dynamique
Le mappage dynamique des adresses s'appuie sur le protocole ARP inverse pour convertir
l'adresse de couche réseau IPv4 du tronçon suivant en valeur DLCI locale. Le routeur Frame Relay
envoie des demandes d'ARP inverse sur son circuit virtuel permanent pour détecter l'adresse de
protocole du périphérique distant connecté au réseau Frame Relay. Le routeur utilise les réponses
obtenues pour compléter une table de mappage d'adresse en DLCI sur le routeur Frame Relay ou
sur le serveur d'accès. Le routeur établit et entretient cette table de mappage qui contient toutes les
demandes d'ARP inverse résolues, y compris les entrées de mappage statique et dynamique.
VI.3 Mappage statique Frame Relay
L'utilisateur peut choisir d'ignorer le mappage ARP inverse dynamique en indiquant un mappage
statique pour l'adresse de protocole du tronçon suivant au DLCI local. Le mappage statique
fonctionne de façon similaire au protocole ARP inverse en associant une adresse de protocole du
tronçon suivant à un DLCI Frame Relay local. Vous ne pouvez pas utiliser le protocole ARP inverse
et une instruction de mappage pour le même DLCI et le même protocole.
Un exemple d'utilisation de mappage d'adresse statique est une situation dans laquelle le routeur à
l'autre extrémité du réseau Frame Relay ne prend pas en charge le protocole ARP inverse
dynamique pour un protocole réseau particulier. Afin d'assurer la connectivité, un mappage statique
est né. La LMI est un mécanisme de maintien de connexion qui fournit des informations d'état sur
les connexions Frame Relay entre le routeur (ETTD) et le commutateur Frame Relay (DCE). Environ
toutes les 10 secondes, le périphérique final interroge le réseau pour obtenir soit une simple
séquence de réponses, soit des informations sur l'état des canaux. cessaire pour finaliser la
conversion de l'adresse de couche réseau distante en DLCI local.
VI.4 Interface de gestion locale (LMI)
La LMI est un mécanisme de maintien de connexion qui fournit des informations d'état sur les
connexions Frame Relay entre le routeur (ETTD) et le commutateur Frame Relay (DCE). Environ
toutes les 10 secondes, le périphérique final interroge le réseau pour obtenir soit une simple
séquence de réponses, soit des informations sur l'état des canaux.
Les fonctions principales de l'interface LMI sont les suivantes :
 Déterminer la fonctionnalité des divers circuits virtuels permanents connus du routeur
 Transmettre des paquets de messages de veille pour s'assurer que le circuit PVC reste
ouvert et ne se ferme pas pour cause d'inactivité
 Indiquer au routeur les circuits PVC disponibles
Le routeur peut faire appel à trois types d'interface LMI : ansi, cisco et q933a.
VII. Concepts avancés du protocole Frame Relay
Débit d'accès : fait référence à la vitesse du port. Du point de vue du client, le fournisseur de
services propose une connexion série ou une liaison d'accès au réseau Frame Relay via une ligne
louée. Le débit d'accès est le débit auquel vos circuits d'accès se connectent au réseau Frame
Relay. Il peut être de 56 kbit/s, 1,544 Mbit/s (T1) ou une fraction de T1 (multiple de 56 kbit/s ou 64
kbit/s). Le débit d'accès est mesuré sur le commutateur Frame Relay. Il n'est pas possible d'envoyer
des données à un débit supérieur au débit d'accès.
El Hassan EL AMRI – Frame Relay
5El Hassan EL AMRI
Débit de données garanti (CIR, Committed Information Rate) : les clients négocient les débits
de données garantis avec le fournisseur de services pour chaque circuit virtuel permanent. Le débit
de données garanti est la quantité de données que le réseau reçoit du circuit d'accès. Le fournisseur
de services garantit que le client peut envoyer des données au débit de données garanti. Toutes
les trames reçues au débit de données garanti ou en dessous sont acceptées.
Les rafales : permettent aux périphériques qui ont par moment besoin de plus de bande passante
d'en emprunter gratuitement auprès d'autres périphériques qui ne l'utilisent pas. Un périphérique
peut transmettre en rafale jusqu'au débit d'accès et être certain que les données seront transmises.
La durée d'une transmission en rafale doit être de trois ou quatre secondes au maximum.
Il existe plusieurs termes pour décrire les débits de rafales, dont Bc (Committed Burst Size) et Be
(Excess Burst Size).
Configuration Frame-Relay
Configuration Frame-Relay
R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#no shutdown
1
Interface physique – Inverse-arp activé
R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#frame-relay map ip 192.168.0.2 200 broadcast
R1(config-if)#frame-relay map ip 192.168.0.3 300 broadcast
R1(config-if)#no shutdown
Interface physique – Inverse-arp désactivé
R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial 0/0.1 multipoint
R1(config-subif)#frame-relay interface-dlci 200
R1(config-subif)#frame-relay interface-dlci 300
R1(config-subif)#ip address 192.168.0.1 255.255.255.0
Subinterface multipoint – Inverse-arp activé
R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial 0/0.1 multipoint
R1(config-subif)#no frame-relay inverse-arp
R1(config-subif)#ip address 192.168.0.1 255.255.255.0
R1(config-subif)#frame-relay map ip 192.168.0.2 200 broadcast
R1(config-subif)#frame-relay map ip 192.168.0.3 300 broadcast
Subinterface multipoint – Inverse-arp désactivé
http://www.ciscomadesimple.be
Configuration Frame-Relay 2
R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial 0/0.200 point-to-point
R1(config-subif)#ip address 192.168.0.1 255.255.255.252
R1(config-subif)#exit
R1(config)#interface Serial 0/0.300 point-to-point
R1(config-subif)#ip address 192.168.0.5 255.255.255.252
R1(config-subif)#exit
Subinterface point-to-point – Inverse-arp activé
R1>enable
R1#configure terminal
R1(config)#interface Serial 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial 0/0.200 point-to-point
R1(config-subif)#no frame-relay inverse-arp
R1(config-subif)#frame-relay interface-dlci 200
R1(config-subif)#ip address 192.168.0.1 255.255.255.252
R1(config-subif)#exit
R1(config)#interface Serial 0/0.300 point-to-point
R1(config-subif)#no frame-relay inverse-arp
R1(config-subif)#frame-relay interface-dlci 300
R1(config-subif)#ip address 192.168.0.5 255.255.255.252
R1(config-subif)#exit
Subinterface point-to-point – Inverse-arp désactivé
http://www.ciscomadesimple.be

Contenu connexe

Tendances

204081791-Protocole-Frame-Relay.pptx
204081791-Protocole-Frame-Relay.pptx204081791-Protocole-Frame-Relay.pptx
204081791-Protocole-Frame-Relay.pptxFatimazogr
 
Introduction_Reseau.ppt
Introduction_Reseau.pptIntroduction_Reseau.ppt
Introduction_Reseau.pptAmalHadri2
 
cours NAT (traduction d'adresse réseau)
cours NAT (traduction d'adresse réseau)cours NAT (traduction d'adresse réseau)
cours NAT (traduction d'adresse réseau)EL AMRI El Hassan
 
Equipements d'interconnexion
Equipements d'interconnexionEquipements d'interconnexion
Equipements d'interconnexionInes Kechiche
 
Concepts et configuration de base de la commutation
Concepts et configuration de base de la commutationConcepts et configuration de base de la commutation
Concepts et configuration de base de la commutationEL AMRI El Hassan
 
(équipements réseau)
(équipements réseau)(équipements réseau)
(équipements réseau)Anouar Abtoy
 
cours le routage statique (ipv4 et ipv6)
cours le routage statique (ipv4 et ipv6)cours le routage statique (ipv4 et ipv6)
cours le routage statique (ipv4 et ipv6)EL AMRI El Hassan
 
Introduction aux réseaux informatiques
Introduction aux réseaux informatiquesIntroduction aux réseaux informatiques
Introduction aux réseaux informatiquessarah Benmerzouk
 
LTE Presentation [French]
LTE Presentation [French] LTE Presentation [French]
LTE Presentation [French] Assia Mounir
 
Présentation etherchannel
Présentation etherchannelPrésentation etherchannel
Présentation etherchannelLechoco Kado
 

Tendances (20)

Cours syslog
Cours syslogCours syslog
Cours syslog
 
MPLS-TE
MPLS-TEMPLS-TE
MPLS-TE
 
Tp voip
Tp voipTp voip
Tp voip
 
204081791-Protocole-Frame-Relay.pptx
204081791-Protocole-Frame-Relay.pptx204081791-Protocole-Frame-Relay.pptx
204081791-Protocole-Frame-Relay.pptx
 
Cours eigrp i pv4 et ipv6
Cours eigrp i pv4 et ipv6Cours eigrp i pv4 et ipv6
Cours eigrp i pv4 et ipv6
 
Introduction_Reseau.ppt
Introduction_Reseau.pptIntroduction_Reseau.ppt
Introduction_Reseau.ppt
 
Résumé vlsm et cidr
Résumé vlsm et cidrRésumé vlsm et cidr
Résumé vlsm et cidr
 
cours NAT (traduction d'adresse réseau)
cours NAT (traduction d'adresse réseau)cours NAT (traduction d'adresse réseau)
cours NAT (traduction d'adresse réseau)
 
Equipements d'interconnexion
Equipements d'interconnexionEquipements d'interconnexion
Equipements d'interconnexion
 
Concepts et configuration de base de la commutation
Concepts et configuration de base de la commutationConcepts et configuration de base de la commutation
Concepts et configuration de base de la commutation
 
(équipements réseau)
(équipements réseau)(équipements réseau)
(équipements réseau)
 
Virtuals LAN
Virtuals LANVirtuals LAN
Virtuals LAN
 
cours le routage statique (ipv4 et ipv6)
cours le routage statique (ipv4 et ipv6)cours le routage statique (ipv4 et ipv6)
cours le routage statique (ipv4 et ipv6)
 
Introduction aux réseaux informatiques
Introduction aux réseaux informatiquesIntroduction aux réseaux informatiques
Introduction aux réseaux informatiques
 
cours ospf
cours ospf cours ospf
cours ospf
 
Présentation UMTS
Présentation UMTSPrésentation UMTS
Présentation UMTS
 
LTE Presentation [French]
LTE Presentation [French] LTE Presentation [French]
LTE Presentation [French]
 
Ccnp securite vpn
Ccnp securite vpnCcnp securite vpn
Ccnp securite vpn
 
Présentation etherchannel
Présentation etherchannelPrésentation etherchannel
Présentation etherchannel
 
Cours etherchannel
Cours etherchannelCours etherchannel
Cours etherchannel
 

En vedette

Réseaux locaux sans fil wlan
Réseaux locaux sans fil  wlanRéseaux locaux sans fil  wlan
Réseaux locaux sans fil wlanEL AMRI El Hassan
 
CCNA 1 Routing and Switching v5.0 Chapter 2
CCNA 1 Routing and Switching v5.0 Chapter 2CCNA 1 Routing and Switching v5.0 Chapter 2
CCNA 1 Routing and Switching v5.0 Chapter 2Nil Menon
 
Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)EL AMRI El Hassan
 
Résumé ccna 1chapitre 1 v5.0
Résumé ccna 1chapitre 1 v5.0Résumé ccna 1chapitre 1 v5.0
Résumé ccna 1chapitre 1 v5.0EL AMRI El Hassan
 
La livraison, un levier pour créer la préférence client.
La livraison, un levier pour créer la préférence client. La livraison, un levier pour créer la préférence client.
La livraison, un levier pour créer la préférence client. eshopexpo
 
Ccna 4 configuration-de_frame_ relay_hub_and_spoke
Ccna 4 configuration-de_frame_ relay_hub_and_spokeCcna 4 configuration-de_frame_ relay_hub_and_spoke
Ccna 4 configuration-de_frame_ relay_hub_and_spokeTouré Kunda
 
Redondance de routeur (hsrp, vrrp, glbp)
Redondance de routeur (hsrp, vrrp, glbp)Redondance de routeur (hsrp, vrrp, glbp)
Redondance de routeur (hsrp, vrrp, glbp)EL AMRI El Hassan
 
Alphorm.com Support de la formation Mac OS X Server 10.11 El Capitan les fonc...
Alphorm.com Support de la formation Mac OS X Server 10.11 El Capitan les fonc...Alphorm.com Support de la formation Mac OS X Server 10.11 El Capitan les fonc...
Alphorm.com Support de la formation Mac OS X Server 10.11 El Capitan les fonc...Alphorm
 
alphorm.com - Formation Windows 8.1 - Utilisateur
alphorm.com - Formation Windows 8.1 - Utilisateuralphorm.com - Formation Windows 8.1 - Utilisateur
alphorm.com - Formation Windows 8.1 - UtilisateurAlphorm
 
Support de la formation Inventor 2017 : perfectionnement
Support de la formation Inventor 2017 : perfectionnementSupport de la formation Inventor 2017 : perfectionnement
Support de la formation Inventor 2017 : perfectionnementAlphorm
 
Alphorm.com Formation OS X 10.11 Client El Capitan , avancé
Alphorm.com Formation OS X 10.11 Client El Capitan , avancéAlphorm.com Formation OS X 10.11 Client El Capitan , avancé
Alphorm.com Formation OS X 10.11 Client El Capitan , avancéAlphorm
 
Alphorm.com Formation OS X 10.11 Server El Capitan, Les fondamentaux
Alphorm.com Formation OS X 10.11 Server El Capitan, Les fondamentauxAlphorm.com Formation OS X 10.11 Server El Capitan, Les fondamentaux
Alphorm.com Formation OS X 10.11 Server El Capitan, Les fondamentauxAlphorm
 
Alphorm.com Formation SketchUp 2016 et Artlantis 6 - Atelier architectural
Alphorm.com Formation SketchUp 2016 et Artlantis 6 - Atelier architecturalAlphorm.com Formation SketchUp 2016 et Artlantis 6 - Atelier architectural
Alphorm.com Formation SketchUp 2016 et Artlantis 6 - Atelier architecturalAlphorm
 
Alphorm.com support de la formation Git avancé
Alphorm.com support de la formation Git avancé Alphorm.com support de la formation Git avancé
Alphorm.com support de la formation Git avancé Alphorm
 
Alphorm.com Support de la Formation Stormshield Administration
Alphorm.com Support de la Formation Stormshield AdministrationAlphorm.com Support de la Formation Stormshield Administration
Alphorm.com Support de la Formation Stormshield AdministrationAlphorm
 
Alphorm.com support de la formation ms azure pour les développeurs
Alphorm.com support de la formation ms azure pour les développeursAlphorm.com support de la formation ms azure pour les développeurs
Alphorm.com support de la formation ms azure pour les développeursAlphorm
 
Alphorm.com Support de la Formation MDT 2013 Update 2 : Maîtrisez le déploiem...
Alphorm.com Support de la Formation MDT 2013 Update 2 : Maîtrisez le déploiem...Alphorm.com Support de la Formation MDT 2013 Update 2 : Maîtrisez le déploiem...
Alphorm.com Support de la Formation MDT 2013 Update 2 : Maîtrisez le déploiem...Alphorm
 
Alphorm.com Formation Microsoft ATA 2016 : Installation et Configuration
Alphorm.com Formation Microsoft ATA 2016 : Installation et ConfigurationAlphorm.com Formation Microsoft ATA 2016 : Installation et Configuration
Alphorm.com Formation Microsoft ATA 2016 : Installation et ConfigurationAlphorm
 

En vedette (20)

Réseaux locaux sans fil wlan
Réseaux locaux sans fil  wlanRéseaux locaux sans fil  wlan
Réseaux locaux sans fil wlan
 
Cours SNMP
Cours SNMPCours SNMP
Cours SNMP
 
Cours VTP
Cours VTPCours VTP
Cours VTP
 
CCNA 1 Routing and Switching v5.0 Chapter 2
CCNA 1 Routing and Switching v5.0 Chapter 2CCNA 1 Routing and Switching v5.0 Chapter 2
CCNA 1 Routing and Switching v5.0 Chapter 2
 
Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
 
Résumé ccna 1chapitre 1 v5.0
Résumé ccna 1chapitre 1 v5.0Résumé ccna 1chapitre 1 v5.0
Résumé ccna 1chapitre 1 v5.0
 
La livraison, un levier pour créer la préférence client.
La livraison, un levier pour créer la préférence client. La livraison, un levier pour créer la préférence client.
La livraison, un levier pour créer la préférence client.
 
Ccna 4 configuration-de_frame_ relay_hub_and_spoke
Ccna 4 configuration-de_frame_ relay_hub_and_spokeCcna 4 configuration-de_frame_ relay_hub_and_spoke
Ccna 4 configuration-de_frame_ relay_hub_and_spoke
 
Redondance de routeur (hsrp, vrrp, glbp)
Redondance de routeur (hsrp, vrrp, glbp)Redondance de routeur (hsrp, vrrp, glbp)
Redondance de routeur (hsrp, vrrp, glbp)
 
Alphorm.com Support de la formation Mac OS X Server 10.11 El Capitan les fonc...
Alphorm.com Support de la formation Mac OS X Server 10.11 El Capitan les fonc...Alphorm.com Support de la formation Mac OS X Server 10.11 El Capitan les fonc...
Alphorm.com Support de la formation Mac OS X Server 10.11 El Capitan les fonc...
 
alphorm.com - Formation Windows 8.1 - Utilisateur
alphorm.com - Formation Windows 8.1 - Utilisateuralphorm.com - Formation Windows 8.1 - Utilisateur
alphorm.com - Formation Windows 8.1 - Utilisateur
 
Support de la formation Inventor 2017 : perfectionnement
Support de la formation Inventor 2017 : perfectionnementSupport de la formation Inventor 2017 : perfectionnement
Support de la formation Inventor 2017 : perfectionnement
 
Alphorm.com Formation OS X 10.11 Client El Capitan , avancé
Alphorm.com Formation OS X 10.11 Client El Capitan , avancéAlphorm.com Formation OS X 10.11 Client El Capitan , avancé
Alphorm.com Formation OS X 10.11 Client El Capitan , avancé
 
Alphorm.com Formation OS X 10.11 Server El Capitan, Les fondamentaux
Alphorm.com Formation OS X 10.11 Server El Capitan, Les fondamentauxAlphorm.com Formation OS X 10.11 Server El Capitan, Les fondamentaux
Alphorm.com Formation OS X 10.11 Server El Capitan, Les fondamentaux
 
Alphorm.com Formation SketchUp 2016 et Artlantis 6 - Atelier architectural
Alphorm.com Formation SketchUp 2016 et Artlantis 6 - Atelier architecturalAlphorm.com Formation SketchUp 2016 et Artlantis 6 - Atelier architectural
Alphorm.com Formation SketchUp 2016 et Artlantis 6 - Atelier architectural
 
Alphorm.com support de la formation Git avancé
Alphorm.com support de la formation Git avancé Alphorm.com support de la formation Git avancé
Alphorm.com support de la formation Git avancé
 
Alphorm.com Support de la Formation Stormshield Administration
Alphorm.com Support de la Formation Stormshield AdministrationAlphorm.com Support de la Formation Stormshield Administration
Alphorm.com Support de la Formation Stormshield Administration
 
Alphorm.com support de la formation ms azure pour les développeurs
Alphorm.com support de la formation ms azure pour les développeursAlphorm.com support de la formation ms azure pour les développeurs
Alphorm.com support de la formation ms azure pour les développeurs
 
Alphorm.com Support de la Formation MDT 2013 Update 2 : Maîtrisez le déploiem...
Alphorm.com Support de la Formation MDT 2013 Update 2 : Maîtrisez le déploiem...Alphorm.com Support de la Formation MDT 2013 Update 2 : Maîtrisez le déploiem...
Alphorm.com Support de la Formation MDT 2013 Update 2 : Maîtrisez le déploiem...
 
Alphorm.com Formation Microsoft ATA 2016 : Installation et Configuration
Alphorm.com Formation Microsoft ATA 2016 : Installation et ConfigurationAlphorm.com Formation Microsoft ATA 2016 : Installation et Configuration
Alphorm.com Formation Microsoft ATA 2016 : Installation et Configuration
 

Similaire à Cours frame relay

un pdf bien detaillé a propos du frame relay
un pdf bien detaillé a propos du frame relayun pdf bien detaillé a propos du frame relay
un pdf bien detaillé a propos du frame relayOthmane88
 
ccna 4 frame relay exposée.docx
ccna 4 frame relay exposée.docxccna 4 frame relay exposée.docx
ccna 4 frame relay exposée.docxAlexLissom
 
1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routageSimo Qb
 
Reseau Ad hoc - Bachar Haydar
Reseau Ad hoc - Bachar HaydarReseau Ad hoc - Bachar Haydar
Reseau Ad hoc - Bachar HaydarBashar Haidar
 
Commutation-Ethernet.pptx
Commutation-Ethernet.pptxCommutation-Ethernet.pptx
Commutation-Ethernet.pptxbochramiinfo
 
res_mobiles_ch4.pdf
res_mobiles_ch4.pdfres_mobiles_ch4.pdf
res_mobiles_ch4.pdfkohay75604
 
Chapitre 6 - Protocoles TCP/IP, UDP/IP
Chapitre 6  - Protocoles TCP/IP, UDP/IPChapitre 6  - Protocoles TCP/IP, UDP/IP
Chapitre 6 - Protocoles TCP/IP, UDP/IPTarik Zakaria Benmerar
 
Architecture réseaux
Architecture réseauxArchitecture réseaux
Architecture réseauxSaifEJJILALI
 
Priorité des flux
Priorité des fluxPriorité des flux
Priorité des fluxbuffy14
 
Fiche projet réseau local d'une entreprise moderne
Fiche projet réseau local d'une entreprise moderne Fiche projet réseau local d'une entreprise moderne
Fiche projet réseau local d'une entreprise moderne Mohamed Boubaya
 

Similaire à Cours frame relay (20)

un pdf bien detaillé a propos du frame relay
un pdf bien detaillé a propos du frame relayun pdf bien detaillé a propos du frame relay
un pdf bien detaillé a propos du frame relay
 
ccna 4 frame relay exposée.docx
ccna 4 frame relay exposée.docxccna 4 frame relay exposée.docx
ccna 4 frame relay exposée.docx
 
Examen1
Examen1Examen1
Examen1
 
1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage
 
Chapitre 2.pdf
Chapitre 2.pdfChapitre 2.pdf
Chapitre 2.pdf
 
Reseau Ad hoc - Bachar Haydar
Reseau Ad hoc - Bachar HaydarReseau Ad hoc - Bachar Haydar
Reseau Ad hoc - Bachar Haydar
 
Media
MediaMedia
Media
 
Smi5 cours partie2
Smi5 cours partie2Smi5 cours partie2
Smi5 cours partie2
 
Commutation-Ethernet.pptx
Commutation-Ethernet.pptxCommutation-Ethernet.pptx
Commutation-Ethernet.pptx
 
Cours reseaux lan
Cours reseaux lanCours reseaux lan
Cours reseaux lan
 
Chap5 wan
Chap5 wanChap5 wan
Chap5 wan
 
res_mobiles_ch4.pdf
res_mobiles_ch4.pdfres_mobiles_ch4.pdf
res_mobiles_ch4.pdf
 
Chapitre 6 - Protocoles TCP/IP, UDP/IP
Chapitre 6  - Protocoles TCP/IP, UDP/IPChapitre 6  - Protocoles TCP/IP, UDP/IP
Chapitre 6 - Protocoles TCP/IP, UDP/IP
 
Normes IEEE
Normes IEEENormes IEEE
Normes IEEE
 
Architecture réseaux
Architecture réseauxArchitecture réseaux
Architecture réseaux
 
Priorité des flux
Priorité des fluxPriorité des flux
Priorité des flux
 
4G.pdf
4G.pdf4G.pdf
4G.pdf
 
Routing in 6lowpan (in French)
Routing in 6lowpan (in French) Routing in 6lowpan (in French)
Routing in 6lowpan (in French)
 
Fiche projet réseau local d'une entreprise moderne
Fiche projet réseau local d'une entreprise moderne Fiche projet réseau local d'une entreprise moderne
Fiche projet réseau local d'une entreprise moderne
 
Chapitre 4 - couche liaison
Chapitre 4 - couche liaisonChapitre 4 - couche liaison
Chapitre 4 - couche liaison
 

Plus de EL AMRI El Hassan

Plus de EL AMRI El Hassan (8)

Cours Vlan
Cours VlanCours Vlan
Cours Vlan
 
Cours les technologies WAN
Cours les technologies WANCours les technologies WAN
Cours les technologies WAN
 
Cours routage inter-vlan
Cours routage inter-vlanCours routage inter-vlan
Cours routage inter-vlan
 
cours DHCP IPv4 et IPv6
cours DHCP IPv4 et IPv6cours DHCP IPv4 et IPv6
cours DHCP IPv4 et IPv6
 
Cours routage dynamique (ri pv1,ripv2,ripng)
Cours routage dynamique (ri pv1,ripv2,ripng) Cours routage dynamique (ri pv1,ripv2,ripng)
Cours routage dynamique (ri pv1,ripv2,ripng)
 
lettre commercial
lettre commercial lettre commercial
lettre commercial
 
Fonction commercial d’entreprise
Fonction commercial d’entrepriseFonction commercial d’entreprise
Fonction commercial d’entreprise
 
Maintenance du système Linux
Maintenance du système LinuxMaintenance du système Linux
Maintenance du système Linux
 

Cours frame relay

  • 1. El Hassan EL AMRI – Frame Relay 1El Hassan EL AMRI Frame Relay I. Introduction rame Relay est un protocole de réseau étendu (WAN) qui intervient dans les couches physique et liaison de données du modèle de référence OSI. Bien que de nouveaux services tels que le haut débit et le métro Ethernet ont réduit les besoins Frame Relay dans de nombreux endroits, ce type de connexion reste une option viable dans de nombreux endroits partout dans le monde. Frame Relay est une solution économique de communication entre plusieurs sites distants, qui utilise un seul circuit d'accès entre chaque site et le fournisseur. II. Présentation de Frame Relay Les lignes louées offrent une capacité dédiée permanente. Elles sont très largement utilisées pour la création de WAN. Elles représentent le choix traditionnel en matière de connexion, mais présentent un certain nombre d'inconvénients. Un de ces inconvénients et que les clients payent pour des lignes louées de capacité fixe. Cependant, le trafic WAN est souvent variable et une partie de cette capacité n'est pas utilisée. Par ailleurs, chaque point d'extrémité requiert une interface physique séparée sur le routeur, ce qui augmente les coûts d'équipements. Toute modification de la ligne louée nécessite généralement une intervention sur site du personnel de l'opérateur. Frame Relay est un protocole de réseau étendu (WAN) qui intervient dans les couches physique et liaison de données du modèle de référence OSI. À l'inverse des lignes louées, Frame Relay ne nécessite qu'un seul circuit d'accès au fournisseur Frame Relay pour communiquer avec les autres sites connectés au même fournisseur. La capacité entre deux sites peut varier. II.1 Avantages de la technologie WAN Frame Relay Avec l'arrivée de services haut débit tels que le DSL, le modem câble, le WAN Ethernet (service Ethernet point à point sur fibre optique), le VPN et le MPLS, Frame Relay a perdu de son intérêt comme solution d'accès au WAN. Cependant, la solution Frame Relay est toujours utilisée pour la connexion WAN dans certains endroits du monde.  Plus la distance couverte par une ligne spécialisée est importante, plus le service est coûteux.  Les réseaux à commutation de paquets fournissent un multiplexage de nombreuses données à travers un seul lien de communication.  Si 2 sites distants veulent communiquer via Frame Relay, ils ont donc juste à constituer un circuit entre ces sites, à travers le réseau Frame Relay. III. Fonctionnement de la technologie Frame Relay III. 1 Circuits virtuels (VC) Au sein du nuage Frame Relay, la connexion entre deux sites se fait par l'intermédiaire de circuits virtuels qui peuvent être établis en dur par le fournisseur, Les circuits virtuels offrent un chemin pour la communication bidirectionnelle d'un périphérique à un autre. Les circuits virtuels sont identifiés par les DLCI. Les circuits virtuels peuvent s'établir de deux manières : F Campus des Réseaux Informatiques et Télécommunications
  • 2. El Hassan EL AMRI – Frame Relay 2El Hassan EL AMRI Circuits virtuels commutés (SVC, Switched Virtual circuits) : établis de façon dynamique par l'envoi de messages de signal au réseau (CALL SETUP, DATA TRANSFER, IDLE, CALL TERMINATION). Circuits virtuels permanents (PVC, Permanent Virtual Circuits) : préconfigurés par l'opérateur, une fois mis en place, ils ne fonctionnent qu'en mode DATA TRANSFER ou IDLE. Notez que dans certaines publications, les circuits virtuels permanents sont appelés circuits virtuels privés. Remarque : les circuits virtuels permanents sont plus souvent utilisés que les circuits virtuels commutés. III.2 DLCI Un indicateur DLCI identifie un circuit virtuel sur un équipement situé à une extrémité. Au-delà de la liaison, ce DLCI n'a aucune signification. Deux périphériques connectés par un circuit virtuel peuvent utiliser une valeur DLCI différente pour faire référence à la même connexion. IV. Encapsulation Frame Relay Tout d'abord, Frame Relay accepte le paquet d'un protocole de couche réseau, par exemple IPv4. Il ajoute ensuite un champ d'adresse qui contient le DLCI et une somme de contrôle. Des champs d'indicateur sont ajoutés pour indiquer le début et la fin de la trame. Ces champs marquent le début et la fin de la trame et sont toujours les mêmes. Ces indicateurs sont représentés soit en hexadécimal par 7E, soit en binaire par 01111110. Une fois le paquet encapsulé, Frame Relay passe la trame à la couche physique qui assure le transport. Le routeur d'équipement d'abonné encapsule chaque paquet de couche 3 dans un en-tête et un code de fin Frame Relay avant de l'envoyer sur le circuit virtuel. L'en-tête et le code de fin sont définis par la spécification Link Access Procedure for Frame Relay (LAPF) Bearer Services, UIT Q.922-A. Comme illustré à la Figure 2, l'en-tête Frame Relay header (champ d'adresse) contient les éléments suivants : DLCI : le DLCI 10 bits est un des champs les plus importants de l'en-tête Frame Relay. Cette valeur représente la connexion virtuelle entre l'équipement ETTD et le commutateur. Chaque connexion virtuelle multiplexée sur le canal physique est représentée par un DLCI unique. Les identificateurs DLCI n'ont qu'une signification locale. En d'autres termes, ils ne sont uniques que sur le canal physique sur lequel ils résident. Les équipements situés à l'autre extrémité d'une connexion peuvent donc faire référence à la même connexion virtuelle par des identificateurs DLCI différents. C/R : bit qui suit l'octet DLCI significatif dans le champ d'adresse. Le bit C/R n'est pas actuellement défini. EA (Extended Address) : si la valeur du champ EA est 1, l'octet actuel est considéré comme le dernier octet DLCI. Toutes les mises en œuvre actuelles du protocole Frame Relay utilisent cependant un DLCI de 2 octets, ce qui permet une extension des adresses DLCI dans le futur. Le huitième bit de chaque octet du champ d'adresse sert à indiquer une adresse étendue. Contrôle d'encombrement : composé de trois bits de notification d'encombrement Frame Relay. Ces trois bits sont appelés FECN (Forward Explicit Congestion Notification), BECN (Backward Explicit Congestion Notification) et DE (Discard Eligible).
  • 3. El Hassan EL AMRI – Frame Relay 3El Hassan EL AMRI V. Topologies Frame Relay Frame-relay supporte multiple topologies : 1) Full-mesh (Topologie à maillage global) 2) Partial-mesh (Topologie à maillage partiel) 3) Hub and Spoke (Topologie en étoile) VI. Mappage des adresses Frame Relay VI.1 ARP inverse Un des outils principaux de Frame Relay est le protocole ARP inverse (Address Resolution Protocol). Alors que le protocole ARP traduit les adresses IPv4 de couche 3 en adresses MAC de couche 2, le protocole ARP inverse effectue l'opération inverse. Les adresses IPv4 de couche 3 correspondantes doivent être disponibles avant l'utilisation des circuits virtuels. Remarque : Frame Relay pour IPv6 utilise le protocole IND (Inverse Neighbor Discovery) pour obtenir une adresse IPv6 de couche 3 de la part d'un DLCI de couche 2.
  • 4. El Hassan EL AMRI – Frame Relay 4El Hassan EL AMRI VI.2 Mappage dynamique Le mappage dynamique des adresses s'appuie sur le protocole ARP inverse pour convertir l'adresse de couche réseau IPv4 du tronçon suivant en valeur DLCI locale. Le routeur Frame Relay envoie des demandes d'ARP inverse sur son circuit virtuel permanent pour détecter l'adresse de protocole du périphérique distant connecté au réseau Frame Relay. Le routeur utilise les réponses obtenues pour compléter une table de mappage d'adresse en DLCI sur le routeur Frame Relay ou sur le serveur d'accès. Le routeur établit et entretient cette table de mappage qui contient toutes les demandes d'ARP inverse résolues, y compris les entrées de mappage statique et dynamique. VI.3 Mappage statique Frame Relay L'utilisateur peut choisir d'ignorer le mappage ARP inverse dynamique en indiquant un mappage statique pour l'adresse de protocole du tronçon suivant au DLCI local. Le mappage statique fonctionne de façon similaire au protocole ARP inverse en associant une adresse de protocole du tronçon suivant à un DLCI Frame Relay local. Vous ne pouvez pas utiliser le protocole ARP inverse et une instruction de mappage pour le même DLCI et le même protocole. Un exemple d'utilisation de mappage d'adresse statique est une situation dans laquelle le routeur à l'autre extrémité du réseau Frame Relay ne prend pas en charge le protocole ARP inverse dynamique pour un protocole réseau particulier. Afin d'assurer la connectivité, un mappage statique est né. La LMI est un mécanisme de maintien de connexion qui fournit des informations d'état sur les connexions Frame Relay entre le routeur (ETTD) et le commutateur Frame Relay (DCE). Environ toutes les 10 secondes, le périphérique final interroge le réseau pour obtenir soit une simple séquence de réponses, soit des informations sur l'état des canaux. cessaire pour finaliser la conversion de l'adresse de couche réseau distante en DLCI local. VI.4 Interface de gestion locale (LMI) La LMI est un mécanisme de maintien de connexion qui fournit des informations d'état sur les connexions Frame Relay entre le routeur (ETTD) et le commutateur Frame Relay (DCE). Environ toutes les 10 secondes, le périphérique final interroge le réseau pour obtenir soit une simple séquence de réponses, soit des informations sur l'état des canaux. Les fonctions principales de l'interface LMI sont les suivantes :  Déterminer la fonctionnalité des divers circuits virtuels permanents connus du routeur  Transmettre des paquets de messages de veille pour s'assurer que le circuit PVC reste ouvert et ne se ferme pas pour cause d'inactivité  Indiquer au routeur les circuits PVC disponibles Le routeur peut faire appel à trois types d'interface LMI : ansi, cisco et q933a. VII. Concepts avancés du protocole Frame Relay Débit d'accès : fait référence à la vitesse du port. Du point de vue du client, le fournisseur de services propose une connexion série ou une liaison d'accès au réseau Frame Relay via une ligne louée. Le débit d'accès est le débit auquel vos circuits d'accès se connectent au réseau Frame Relay. Il peut être de 56 kbit/s, 1,544 Mbit/s (T1) ou une fraction de T1 (multiple de 56 kbit/s ou 64 kbit/s). Le débit d'accès est mesuré sur le commutateur Frame Relay. Il n'est pas possible d'envoyer des données à un débit supérieur au débit d'accès.
  • 5. El Hassan EL AMRI – Frame Relay 5El Hassan EL AMRI Débit de données garanti (CIR, Committed Information Rate) : les clients négocient les débits de données garantis avec le fournisseur de services pour chaque circuit virtuel permanent. Le débit de données garanti est la quantité de données que le réseau reçoit du circuit d'accès. Le fournisseur de services garantit que le client peut envoyer des données au débit de données garanti. Toutes les trames reçues au débit de données garanti ou en dessous sont acceptées. Les rafales : permettent aux périphériques qui ont par moment besoin de plus de bande passante d'en emprunter gratuitement auprès d'autres périphériques qui ne l'utilisent pas. Un périphérique peut transmettre en rafale jusqu'au débit d'accès et être certain que les données seront transmises. La durée d'une transmission en rafale doit être de trois ou quatre secondes au maximum. Il existe plusieurs termes pour décrire les débits de rafales, dont Bc (Committed Burst Size) et Be (Excess Burst Size). Configuration Frame-Relay
  • 6. Configuration Frame-Relay R1>enable R1#configure terminal R1(config)#interface Serial 0/0 R1(config-if)#encapsulation frame-relay R1(config-if)#ip address 192.168.0.1 255.255.255.0 R1(config-if)#no shutdown 1 Interface physique – Inverse-arp activé R1>enable R1#configure terminal R1(config)#interface Serial 0/0 R1(config-if)#encapsulation frame-relay R1(config-if)#no frame-relay inverse-arp R1(config-if)#ip address 192.168.0.1 255.255.255.0 R1(config-if)#frame-relay map ip 192.168.0.2 200 broadcast R1(config-if)#frame-relay map ip 192.168.0.3 300 broadcast R1(config-if)#no shutdown Interface physique – Inverse-arp désactivé R1>enable R1#configure terminal R1(config)#interface Serial 0/0 R1(config-if)#encapsulation frame-relay R1(config-if)#no shutdown R1(config-if)#exit R1(config)#interface Serial 0/0.1 multipoint R1(config-subif)#frame-relay interface-dlci 200 R1(config-subif)#frame-relay interface-dlci 300 R1(config-subif)#ip address 192.168.0.1 255.255.255.0 Subinterface multipoint – Inverse-arp activé R1>enable R1#configure terminal R1(config)#interface Serial 0/0 R1(config-if)#encapsulation frame-relay R1(config-if)#no frame-relay inverse-arp R1(config-if)#no shutdown R1(config-if)#exit R1(config)#interface Serial 0/0.1 multipoint R1(config-subif)#no frame-relay inverse-arp R1(config-subif)#ip address 192.168.0.1 255.255.255.0 R1(config-subif)#frame-relay map ip 192.168.0.2 200 broadcast R1(config-subif)#frame-relay map ip 192.168.0.3 300 broadcast Subinterface multipoint – Inverse-arp désactivé http://www.ciscomadesimple.be
  • 7. Configuration Frame-Relay 2 R1>enable R1#configure terminal R1(config)#interface Serial 0/0 R1(config-if)#encapsulation frame-relay R1(config-if)#no shutdown R1(config-if)#exit R1(config)#interface Serial 0/0.200 point-to-point R1(config-subif)#ip address 192.168.0.1 255.255.255.252 R1(config-subif)#exit R1(config)#interface Serial 0/0.300 point-to-point R1(config-subif)#ip address 192.168.0.5 255.255.255.252 R1(config-subif)#exit Subinterface point-to-point – Inverse-arp activé R1>enable R1#configure terminal R1(config)#interface Serial 0/0 R1(config-if)#encapsulation frame-relay R1(config-if)#no frame-relay inverse-arp R1(config-if)#no shutdown R1(config-if)#exit R1(config)#interface Serial 0/0.200 point-to-point R1(config-subif)#no frame-relay inverse-arp R1(config-subif)#frame-relay interface-dlci 200 R1(config-subif)#ip address 192.168.0.1 255.255.255.252 R1(config-subif)#exit R1(config)#interface Serial 0/0.300 point-to-point R1(config-subif)#no frame-relay inverse-arp R1(config-subif)#frame-relay interface-dlci 300 R1(config-subif)#ip address 192.168.0.5 255.255.255.252 R1(config-subif)#exit Subinterface point-to-point – Inverse-arp désactivé http://www.ciscomadesimple.be