SlideShare une entreprise Scribd logo
1
Introduction à BGP
BOUZID AymenBOUZID Aymen
bbouzidaymen@gmail.comouzidaymen@gmail.com
aymenbouzid@blogspot.comaymenbouzid@blogspot.com
Last updated 28 May 2014
2
Border Gateway Protocol
 Un protocol de routage utilisé pour l’échange
information de routage entre plusieurs réseaux
 Protocol de routage externe (EGP)
 Décrit dans le RFC4271
 RFC4276 donne un rapport d’implementation BGP
 RFC4277 descrit les experiences operationelles BGP
 Le système autonome est fondamental dans le
fonctionnement de BGP
 Il est utilisé pour identifier de façon unique les réseaux
ayant la même politique de routage.
3
BGP
 Path Vector Protocol
 Des mises à jour incrémentales
 Plusieurs options pour appliquer une
politique de routage
 Classless Inter Domain Routing (CIDR)
 Largement utilisé sur les Backbones
Internet.
 Système Autonome
4
Path Vector Protocol
 BGP est un protocole de routage basé sur
les vecteurs de chemin (path vector) (voir
RFC 1322)
 Un vecteur de chemin défini une route comme
une association entre une destination et les
attributs du chemin vers cette destination.
12.6.126.0/24 207.126.96.43 1021 0 6461 7018 6337 11268 i12.6.126.0/24 207.126.96.43 1021 0 6461 7018 6337 11268 i
AS PathAS Path
5
Path Vector Protocol
AS6461
AS7018
AS6337
AS11268
AS500
AS600
6
Definitions
 Transit – Transporter du traffic à travers le
réseau d’un opérateur.
 Peering – échange d’information de routage
et de trafic.
 Default – Destination par défaut lorsqu’il n’y
a pas de routes spécifiques dans la table de
routage
Default Free Zone
7
Zone de routage constituée de
routeurs ayant des routes explicites
des réseaux d’Internet et donc n’ont
pas besoin de route par défaut
NB: Different pour les IPS liés à un
upstream
Example de Peering et Transit
8
provider A
provider F
provider B
A et B ont un accord de peering gratuit,
mais requierent un transit avec C et D
pour communiquer avec E et F
IXP-West IXP-East
provider E
Backbone
Provider D
Backbone
Provider C
peering
peering
transit
transit
peering
9
AS 100
Autonomous System (AS)
 Ensemble de réseaux ayant la même politique
de routage
 Un seul protocole de routage
 En general sous la responsabilité d’une seule
autorité d’administration
 Identifié par un ASN unique de 32-bit
Autonomous System Number
(ASN)
 Deux plages
0-65535 (original 16-bit range)
65536-4294967295(32-bit range – RFC6793)
 Usage:
0 and 65535 (reserved)
1-64495 (public Internet)
64496-64511 (documentation – RFC5398)
64512-65534 (private use only)
23456 (represent 32-bit range in 16-bit world)
65536-65551 (documentation – RFC5398)
65552-4199999999(public Internet)
4200000000-4294967295 (private use only)
 La representation 32-bit décrite dans le RFC5396
 Explique “asplain” (traditional format) comme notation standard
10
Autonomous System Number (ASN)
 Les ASNs sont attribués par les registres
regionaux ( RIR)
 Ils sont aussi utilisés par les ISP affiliés à des
RIR.
 Actuellement plus de 63487 16-bit ASN asignés
par les RIRs
 Environ 44500 visibles sur Internet
 Environ 1500 restent pas attribués
 Chaque RIR a aussi recu un bloque de 32-bit
ASNs
 Sur 4800 ASN asignés, environ 3700 sont visibles sur
Internet
 See www.iana.org/assignments/as-numbers
11
Configuration de BGP ( Cisco IOS )
 Cette commande active BGP in Cisco IOS:
router bgp 100
 Pour ASNs > 65535, l’ASN peut etre configuré
soit en format decimal simple ou avec des points:
router bgp 131076
ou
router bgp 2.4
 L’IOS affiche l’ASN en format decimal par default
 Le format decimal avec des points est optionel :
router bgp 2.4
bgp asnotation dot
12
13
AS 100 AS 101
AS 102
EE
BB DD
AA CC
Peering
Les bases de BGP
 TCP – port 179
 Path vector protocol
 Mise à jour incrémentale
 “Internal” et “External” BGP
14
AS 100 AS 101
AS 102
DMZ
Network
AA
BB
CC
DD
EE
 Une DMZ est un lien ou un réseau partagé par plusieurs
AS
Zone de Demarcation (DMZ)
15
Fonctionnement général
 BGP apprend plusieurs chemins via les
routeurs “peers” qui communiquent via
internal et external BGP.
 Le meilleur chemin est installé dans la
table de routage (RIB)
 Les meilleurs chemins sont exportés vers
les routeurs voisins supportant “external
BGP”
 La politique de routage est appliquées en
infuençant la selection du meilleur chemin.
Création de la table de Forwarding
 BGP “in” fonctionnement
 Recois les informations chemin du “peers”
 Resultat de la selection des chemins est insérré dans la
table BGP.
 “best path” est taggué
 BGP “out” fonctionnement
 announce les informations des “meilleurs routes” aux
peers
 Les meilleures routes sont installées dans la table
de routage (RIB)
 Les meilleurs routes sont installées dans la table
de forwarding (FIB):
 Les prefixes et longueur de préfixe sont uniques
 Plus petite “Distance administrative”
16
17
Création de la table de Forwarding
BGP in
process
BGP
table
BGP out
process
accepted
discarded
bgp
peer
routing
table
in
out
best paths
everything
forwarding
table
eBGP & iBGP
 BGP utilise en interne (iBGP) en externe
(eBGP)
 iBGP pour le transport
 Quelques/Tous les préfixes Internet à travers
le backbone de l’ISP
 Préfixe des clients des ISP
 eBGP utilisé
 Exchanger les prefixes avec les autres AS
 Implemente la politique de routage
18
19
BGP/IGP modèle d’utilisée par les
ISP
 representation
IGP
iBGP
IGP
iBGP
IGP
iBGP
IGP
iBGP
eBGP eBGP eBGP
AS1 AS2 AS3 AS4
20
AS 100 AS 101
CC
AA
BB
BGP Externe Peering (eBGP)
 Entre des homologues BGP dans différents
AS
 Les homologues doivent directement
connectés
 Ne Jamais utiliser un IGP entre deux peers
eBGP
21
Configurer BGP Externe
Router A dans AS100
interface ethernet 5/0
ip address 102.102.10.2 255.255.255.240
!
router bgp 100
network 100.100.8.0 mask 255.255.252.0
neighbor 102.102.10.1 remote-as 101
neighbor 102.102.10.1 prefix-list RouterC in
neighbor 102.102.10.1 prefix-list RouterC out
!
ip address on
ethernet interface
ip address of Router
C ethernet interface
Local ASN
Remote ASN
Inbound and
outbound filters
22
Configurer BGP Externe
Router C in AS101
interface ethernet 1/0/0
ip address 102.102.10.1 255.255.255.240
!
router bgp 101
network 100.100.64.0 mask 255.255.248.0
neighbor 102.102.10.2 remote-as 100
neighbor 102.102.10.2 prefix-list RouterA in
neighbor 102.102.10.2 prefix-list RouterA out
!
ip address on
ethernet interface
ip address of Router
A ethernet interface
Local ASN
Remote ASN
Inbound and
outbound filters
Multi-Protocol BGP pour IPv6 –
RFC2545
 Extensions spécifiques IPv6
 Adresses “Scoped”: Next-hop contient une
adresse globale IPv6 et/ou dans certain cas
une adresse “link-local”
 Le NEXT_HOP et NLRI sont définis comme les
adresses et préfixe IPv6
 Address Family Information (AFI) = 2 (IPv6)
 Sub-AFI = 1 (NLRI est utilisé pour l’unicast)
 Sub-AFI = 2 (NLRI est utilisé pour verifier l’adresse
multicast )
 Sub-AFI = 3 (NLRI est utilisé pour verifier l’adresse
unicast et multicast )
 Sub-AFI = 4 (label) 23
Session MP-BGP
24
Router1#
interface Ethernet0
ipv6 address 2001:db8:2:1::f/64
!
router bgp 65001
bgp router-id 10.10.10.1
no bgp default ipv4-unicast
neighbor 2001:db8:2:1::1 remote-as 65002
address-family ipv6
neighbor 2001:db8:2:1::1 activate
neighbor 2001:db8:2:1::1 prefix-list bgp65002in in
neighbor 2001:db8:2:1::1 prefix-list bgp65002out out
exit-address-family
AS 65001 AS 65002
Router2Router1
2001:db8:2:1::f 2001:db8:2:1::1
Internal BGP (iBGP)
 Homologues BGP dans le même AS
 Ne requierent pas une connectivité directe
 IGP utilisé pour faire communiquer les
homologues BGP
 Homologues iBGP doivent être en “full
meshed” :
 Les routes apparaissent comme étant
connectés
 Diffuse les préfixes appris de l’extérieur
d’autres AS
 Ne diffuse pas les préfixes appris des autres
routeurs homologues IBGP 25
26
AS 100
AA
DD
CC
BB
BGP interne Peering (iBGP)
 Topologie indépendante
 Tous les homologues IBGP dans un AS doivent
communiquer entre eux.
27
Interfaces Loopback et “peering”
 Communique avec l’interface loop-back
 interface Loop-back est toujours UP – ever!
 Pour eviter que la session iBGP depende de
l’état d’une seule interface
AS 100
AA
BB
CC
28
Configuration de BGP interne
Router A dans AS100
interface loopback 0
ip address 105.3.7.1 255.255.255.255
!
router bgp 100
network 100.100.1.0
neighbor 105.3.7.2 remote-as 100
neighbor 105.3.7.2 update-source loopback0
neighbor 105.3.7.3 remote-as 100
neighbor 105.3.7.3 update-source loopback0
!
adresse ip sur
loopback interface
Adresse IP du Routeur B
loopback interface
ASN Local
ASN Local
29
Configuring Internal BGP
Router B dans AS100
interface loopback 0
ip address 105.3.7.2 255.255.255.255
!
router bgp 100
network 100.100.1.0
neighbor 105.3.7.1 remote-as 100
neighbor 105.3.7.1 update-source loopback0
neighbor 105.3.7.3 remote-as 100
neighbor 105.3.7.3 update-source loopback0
!
Adresse IP sur
l’interface loopback
ip address of Router
A loopback interface
ASN Local
ASN Local
30
Insertion de prefixes dans BGP
 Deux methodes pour inserrer un préfixe
dans BGPs
 redistribute static
 network command
31
Inserting prefixes into BGP –
redistribute static
 Exemple de configuration:
router bgp 100
redistribute static
ip route 102.10.32.0 255.255.254.0 serial0
 La route statique doit exister pour que la
commande fonctionne
 Force la valeur “origin” à “incomplete”
 Utiliser avec prudence!
32
Insertion de prefixes dans BGP –
redistribute static
 Utiliser avec beaucoup de prudence !
 redistribute <routing-protocol> indique
que toutes les routes du <routing-protocol>
sera transfer
 Pas evolutif Will not scale if uncontrolled
 A eviter si possible
 redistribute doit être utilisé conjointement
avec des “route-maps” avec beaucoup de
controle
33
Insertion des prefixes dans BGP –
network command
 Exemple de configuration
router bgp 100
network 102.10.32.0 mask 255.255.254.0
ip route 102.10.32.0 255.255.254.0 serial0
 Une route correspondante dans la table de
route est nécessaire pour que le préfixe
soit annoncé par BGP.
 Force l’attribute origin à “IGP”
34
Configuration Aggregation
 Trois methodes pour configurer les
aggregation de route :
 redistribute static
 aggregate-address
 network command
35
Configuration d’Aggregation
 Exemple de configuration :
router bgp 100
redistribute static
ip route 102.10.0.0 255.255.0.0 null0 250
 Route statique vers “null0” is called a pull
up route
 Packets only sent here if there is no more
specific match in the routing table
 Distance of 250 ensures this is last resort static
 Care required – see previously!
36
Configuration Aggregation–
Commande “Network”
 Exemple de configuration
router bgp 100
network 102.10.0.0 mask 255.255.0.0
ip route 102.10.0.0 255.255.0.0 null0 250
 Une route correspondante doit exister
dans la table de routage pour que le
réseau soit annoncé
 Methode recommandée pour générer des
route aggrégée
Configuration Aggregation–
Commande “aggregate-address”
 Exemple de configuration:
router bgp 100
network 102.10.32.0 mask 255.255.252.0
aggregate-address 102.10.0.0 255.255.0.0 [summary-only]
 L’existence d’un préfixe plus specifique dans la table
BGP est nécessaire pour que la route aggrégée soit
annoncée
 L’option “summary-only”
 Assure que seule la route aggrégée est annoncée si un
préfixe plus spécifique existe dans la table de routage
38
Resumé
BGP neighbour status
Router6>sh ip bgp sum
BGP router identifier 10.0.15.246, local AS number 10
BGP table version is 16, main routing table version 16
7 network entries using 819 bytes of memory
14 path entries using 728 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1795 total bytes of memory
BGP activity 7/0 prefixes, 14/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.15.241 4 10 9 8 16 0 0 00:04:47 2
10.0.15.242 4 10 6 5 16 0 0 00:01:43 2
10.0.15.243 4 10 9 8 16 0 0 00:04:49 2
...
BGP Version Updates sent
and received
Updates waiting
39
Resumé
Table BGP
Router6>sh ip bgp
BGP table version is 16, local router ID is 10.0.15.246
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
*>i 10.0.0.0/26 10.0.15.241 0 100 0 i
*>i 10.0.0.64/26 10.0.15.242 0 100 0 i
*>i 10.0.0.128/26 10.0.15.243 0 100 0 i
*>i 10.0.0.192/26 10.0.15.244 0 100 0 i
*>i 10.0.1.0/26 10.0.15.245 0 100 0 i
*> 10.0.1.64/26 0.0.0.0 0 32768 i
*>i 10.0.1.128/26 10.0.15.247 0 100 0 i
*>i 10.0.1.192/26 10.0.15.248 0 100 0 i
*>i 10.0.2.0/26 10.0.15.249 0 100 0 i
*>i 10.0.2.64/26 10.0.15.250 0 100 0 i
...
40
Resumé
 BGP4 – path vector protocol
 iBGP versus eBGP
 Design iBGP stable – peer with loopbacks
 Announce des prefixes & aggregates
41
Introduction à BGP
AFNOG 2014AFNOG 2014

Contenu connexe

Tendances

EIGRP - Fonctionnement de l'EIGRP
EIGRP - Fonctionnement de l'EIGRPEIGRP - Fonctionnement de l'EIGRP
EIGRP - Fonctionnement de l'EIGRPmdyabi
 
CCNP Route - OSPF
CCNP Route - OSPFCCNP Route - OSPF
CCNP Route - OSPFmdyabi
 
EIGRP - Configuration
EIGRP - ConfigurationEIGRP - Configuration
EIGRP - Configurationmdyabi
 
EIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relayEIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relaymdyabi
 
EIGRP - Mesures de l’EIGRP
EIGRP - Mesures de l’EIGRPEIGRP - Mesures de l’EIGRP
EIGRP - Mesures de l’EIGRPmdyabi
 
1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routageSimo Qb
 
Comment paramétrer une connexion adsl sur un modem
Comment paramétrer une connexion adsl sur un modemComment paramétrer une connexion adsl sur un modem
Comment paramétrer une connexion adsl sur un modemCONNECT Tunisia
 
Configuration et mise en œuvre d'un réseau WAN (World Area Network)
Configuration et mise en œuvre  d'un réseau  WAN (World Area Network)Configuration et mise en œuvre  d'un réseau  WAN (World Area Network)
Configuration et mise en œuvre d'un réseau WAN (World Area Network)Abderrahmane Benyoub
 

Tendances (20)

cours ospf
cours ospf cours ospf
cours ospf
 
Weos routage dynamique OSPF
Weos routage dynamique OSPFWeos routage dynamique OSPF
Weos routage dynamique OSPF
 
Le protocole stp
Le protocole stpLe protocole stp
Le protocole stp
 
EIGRP - Fonctionnement de l'EIGRP
EIGRP - Fonctionnement de l'EIGRPEIGRP - Fonctionnement de l'EIGRP
EIGRP - Fonctionnement de l'EIGRP
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
 
CCNP Route - OSPF
CCNP Route - OSPFCCNP Route - OSPF
CCNP Route - OSPF
 
EIGRP - Configuration
EIGRP - ConfigurationEIGRP - Configuration
EIGRP - Configuration
 
Ccna4
Ccna4Ccna4
Ccna4
 
Routage
RoutageRoutage
Routage
 
Cours eigrp i pv4 et ipv6
Cours eigrp i pv4 et ipv6Cours eigrp i pv4 et ipv6
Cours eigrp i pv4 et ipv6
 
Cours frame relay
Cours frame relayCours frame relay
Cours frame relay
 
Cours VTP
Cours VTPCours VTP
Cours VTP
 
EIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relayEIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relay
 
EIGRP - Mesures de l’EIGRP
EIGRP - Mesures de l’EIGRPEIGRP - Mesures de l’EIGRP
EIGRP - Mesures de l’EIGRP
 
MPLS
MPLSMPLS
MPLS
 
1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage
 
Services IP
Services IPServices IP
Services IP
 
Comment paramétrer une connexion adsl sur un modem
Comment paramétrer une connexion adsl sur un modemComment paramétrer une connexion adsl sur un modem
Comment paramétrer une connexion adsl sur un modem
 
Configuration et mise en œuvre d'un réseau WAN (World Area Network)
Configuration et mise en œuvre  d'un réseau  WAN (World Area Network)Configuration et mise en œuvre  d'un réseau  WAN (World Area Network)
Configuration et mise en œuvre d'un réseau WAN (World Area Network)
 
Spanning-Tree
Spanning-TreeSpanning-Tree
Spanning-Tree
 

En vedette

Routage Ipv6 _fr_2015
Routage Ipv6 _fr_2015Routage Ipv6 _fr_2015
Routage Ipv6 _fr_2015Aymen Bouzid
 
Mécanismes de transition ipv6
Mécanismes de transition ipv6Mécanismes de transition ipv6
Mécanismes de transition ipv6Aymen Bouzid
 
Tendances et évolution des réseaux Wireless LAN
Tendances et évolution des réseaux Wireless LANTendances et évolution des réseaux Wireless LAN
Tendances et évolution des réseaux Wireless LANAymen Bouzid
 
Voix et téléphonie sur IP- Convergence voix et données
Voix et téléphonie sur IP- Convergence voix et données Voix et téléphonie sur IP- Convergence voix et données
Voix et téléphonie sur IP- Convergence voix et données Aymen Bouzid
 
La technologie xDSL
La technologie xDSLLa technologie xDSL
La technologie xDSLAymen Bouzid
 
Webinar-Linux Networking is Awesome
Webinar-Linux Networking is AwesomeWebinar-Linux Networking is Awesome
Webinar-Linux Networking is AwesomeCumulus Networks
 
Carte Mentale Réseaux privés virtuels MPLS-VPN-IP
Carte Mentale Réseaux privés virtuels MPLS-VPN-IPCarte Mentale Réseaux privés virtuels MPLS-VPN-IP
Carte Mentale Réseaux privés virtuels MPLS-VPN-IPDr, Noureddine IDBOUFKER
 
CCIE R&S V5 Changes
CCIE R&S V5 ChangesCCIE R&S V5 Changes
CCIE R&S V5 ChangesJohn Berry
 
Cisco -Ccie rs quick_review_kit
Cisco -Ccie rs quick_review_kitCisco -Ccie rs quick_review_kit
Cisco -Ccie rs quick_review_kitStoyan Stoyanov
 
Carte mentale projet de fin d'études (pfe)
Carte mentale projet de fin d'études (pfe)Carte mentale projet de fin d'études (pfe)
Carte mentale projet de fin d'études (pfe)Dr, Noureddine IDBOUFKER
 
Myanmar IP Data Network
Myanmar IP Data NetworkMyanmar IP Data Network
Myanmar IP Data NetworkAPNIC
 

En vedette (20)

Routage Ipv6 _fr_2015
Routage Ipv6 _fr_2015Routage Ipv6 _fr_2015
Routage Ipv6 _fr_2015
 
Mécanismes de transition ipv6
Mécanismes de transition ipv6Mécanismes de transition ipv6
Mécanismes de transition ipv6
 
Tendances et évolution des réseaux Wireless LAN
Tendances et évolution des réseaux Wireless LANTendances et évolution des réseaux Wireless LAN
Tendances et évolution des réseaux Wireless LAN
 
Voix et téléphonie sur IP- Convergence voix et données
Voix et téléphonie sur IP- Convergence voix et données Voix et téléphonie sur IP- Convergence voix et données
Voix et téléphonie sur IP- Convergence voix et données
 
La technologie xDSL
La technologie xDSLLa technologie xDSL
La technologie xDSL
 
MPLS Presentation
MPLS PresentationMPLS Presentation
MPLS Presentation
 
IPv6 Les Bases
IPv6 Les BasesIPv6 Les Bases
IPv6 Les Bases
 
MPLS-TE
MPLS-TEMPLS-TE
MPLS-TE
 
Is is
Is isIs is
Is is
 
Ospf
OspfOspf
Ospf
 
Carte mentale transport Voix sur ip
Carte mentale transport Voix sur ipCarte mentale transport Voix sur ip
Carte mentale transport Voix sur ip
 
Carte mentale du cours h323, V2
Carte mentale du cours h323, V2Carte mentale du cours h323, V2
Carte mentale du cours h323, V2
 
Webinar-Linux Networking is Awesome
Webinar-Linux Networking is AwesomeWebinar-Linux Networking is Awesome
Webinar-Linux Networking is Awesome
 
Carte mentale protocole sip
Carte mentale protocole sipCarte mentale protocole sip
Carte mentale protocole sip
 
Carte mentale MPLS
Carte mentale MPLSCarte mentale MPLS
Carte mentale MPLS
 
Carte Mentale Réseaux privés virtuels MPLS-VPN-IP
Carte Mentale Réseaux privés virtuels MPLS-VPN-IPCarte Mentale Réseaux privés virtuels MPLS-VPN-IP
Carte Mentale Réseaux privés virtuels MPLS-VPN-IP
 
CCIE R&S V5 Changes
CCIE R&S V5 ChangesCCIE R&S V5 Changes
CCIE R&S V5 Changes
 
Cisco -Ccie rs quick_review_kit
Cisco -Ccie rs quick_review_kitCisco -Ccie rs quick_review_kit
Cisco -Ccie rs quick_review_kit
 
Carte mentale projet de fin d'études (pfe)
Carte mentale projet de fin d'études (pfe)Carte mentale projet de fin d'études (pfe)
Carte mentale projet de fin d'études (pfe)
 
Myanmar IP Data Network
Myanmar IP Data NetworkMyanmar IP Data Network
Myanmar IP Data Network
 

Similaire à Fr introbgp-sif

Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : RoutingAlphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : RoutingAlphorm
 
Alphorm.com Formation Cisco BGP: Mise en œuvre routeurs Cisco
Alphorm.com Formation Cisco BGP: Mise en œuvre routeurs CiscoAlphorm.com Formation Cisco BGP: Mise en œuvre routeurs Cisco
Alphorm.com Formation Cisco BGP: Mise en œuvre routeurs CiscoAlphorm
 
Configuration ospf
Configuration ospfConfiguration ospf
Configuration ospfJoeongala
 
laboratoire formation ccna cisco materiel .ppt
laboratoire formation ccna cisco materiel .pptlaboratoire formation ccna cisco materiel .ppt
laboratoire formation ccna cisco materiel .pptprofsn
 
Composants routeur cisco et différent mode de Configuration
Composants routeur cisco et différent mode de ConfigurationComposants routeur cisco et différent mode de Configuration
Composants routeur cisco et différent mode de ConfigurationZakariaBouzzitMadrid
 
Bgp formation-configurer-bgp-sur-des-routeurs-cisco
Bgp formation-configurer-bgp-sur-des-routeurs-ciscoBgp formation-configurer-bgp-sur-des-routeurs-cisco
Bgp formation-configurer-bgp-sur-des-routeurs-ciscoCERTyou Formation
 
notions de routage IP
notions de routage IPnotions de routage IP
notions de routage IPmohamednacim
 
ENSA_Module_1.pptx
ENSA_Module_1.pptxENSA_Module_1.pptx
ENSA_Module_1.pptxAyaGharby
 
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : ServicesAlphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : ServicesAlphorm
 

Similaire à Fr introbgp-sif (20)

Ccna 2-module-2-v4
Ccna 2-module-2-v4Ccna 2-module-2-v4
Ccna 2-module-2-v4
 
1301000.ppt
1301000.ppt1301000.ppt
1301000.ppt
 
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : RoutingAlphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
 
Carte mentale bgp
Carte mentale bgpCarte mentale bgp
Carte mentale bgp
 
Alphorm.com Formation Cisco BGP: Mise en œuvre routeurs Cisco
Alphorm.com Formation Cisco BGP: Mise en œuvre routeurs CiscoAlphorm.com Formation Cisco BGP: Mise en œuvre routeurs Cisco
Alphorm.com Formation Cisco BGP: Mise en œuvre routeurs Cisco
 
Configuration de-base-d
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
 
1485606887355.pdf
1485606887355.pdf1485606887355.pdf
1485606887355.pdf
 
1485606887426.pdf
1485606887426.pdf1485606887426.pdf
1485606887426.pdf
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
Configuration ospf
Configuration ospfConfiguration ospf
Configuration ospf
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
CCNA 3.pdf
CCNA 3.pdfCCNA 3.pdf
CCNA 3.pdf
 
laboratoire formation ccna cisco materiel .ppt
laboratoire formation ccna cisco materiel .pptlaboratoire formation ccna cisco materiel .ppt
laboratoire formation ccna cisco materiel .ppt
 
Composants routeur cisco et différent mode de Configuration
Composants routeur cisco et différent mode de ConfigurationComposants routeur cisco et différent mode de Configuration
Composants routeur cisco et différent mode de Configuration
 
Bgp formation-configurer-bgp-sur-des-routeurs-cisco
Bgp formation-configurer-bgp-sur-des-routeurs-ciscoBgp formation-configurer-bgp-sur-des-routeurs-cisco
Bgp formation-configurer-bgp-sur-des-routeurs-cisco
 
notions de routage IP
notions de routage IPnotions de routage IP
notions de routage IP
 
ENSA_Module_1.pptx
ENSA_Module_1.pptxENSA_Module_1.pptx
ENSA_Module_1.pptx
 
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : ServicesAlphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
 

Fr introbgp-sif

  • 1. 1 Introduction à BGP BOUZID AymenBOUZID Aymen bbouzidaymen@gmail.comouzidaymen@gmail.com aymenbouzid@blogspot.comaymenbouzid@blogspot.com Last updated 28 May 2014
  • 2. 2 Border Gateway Protocol  Un protocol de routage utilisé pour l’échange information de routage entre plusieurs réseaux  Protocol de routage externe (EGP)  Décrit dans le RFC4271  RFC4276 donne un rapport d’implementation BGP  RFC4277 descrit les experiences operationelles BGP  Le système autonome est fondamental dans le fonctionnement de BGP  Il est utilisé pour identifier de façon unique les réseaux ayant la même politique de routage.
  • 3. 3 BGP  Path Vector Protocol  Des mises à jour incrémentales  Plusieurs options pour appliquer une politique de routage  Classless Inter Domain Routing (CIDR)  Largement utilisé sur les Backbones Internet.  Système Autonome
  • 4. 4 Path Vector Protocol  BGP est un protocole de routage basé sur les vecteurs de chemin (path vector) (voir RFC 1322)  Un vecteur de chemin défini une route comme une association entre une destination et les attributs du chemin vers cette destination. 12.6.126.0/24 207.126.96.43 1021 0 6461 7018 6337 11268 i12.6.126.0/24 207.126.96.43 1021 0 6461 7018 6337 11268 i AS PathAS Path
  • 6. 6 Definitions  Transit – Transporter du traffic à travers le réseau d’un opérateur.  Peering – échange d’information de routage et de trafic.  Default – Destination par défaut lorsqu’il n’y a pas de routes spécifiques dans la table de routage
  • 7. Default Free Zone 7 Zone de routage constituée de routeurs ayant des routes explicites des réseaux d’Internet et donc n’ont pas besoin de route par défaut NB: Different pour les IPS liés à un upstream
  • 8. Example de Peering et Transit 8 provider A provider F provider B A et B ont un accord de peering gratuit, mais requierent un transit avec C et D pour communiquer avec E et F IXP-West IXP-East provider E Backbone Provider D Backbone Provider C peering peering transit transit peering
  • 9. 9 AS 100 Autonomous System (AS)  Ensemble de réseaux ayant la même politique de routage  Un seul protocole de routage  En general sous la responsabilité d’une seule autorité d’administration  Identifié par un ASN unique de 32-bit
  • 10. Autonomous System Number (ASN)  Deux plages 0-65535 (original 16-bit range) 65536-4294967295(32-bit range – RFC6793)  Usage: 0 and 65535 (reserved) 1-64495 (public Internet) 64496-64511 (documentation – RFC5398) 64512-65534 (private use only) 23456 (represent 32-bit range in 16-bit world) 65536-65551 (documentation – RFC5398) 65552-4199999999(public Internet) 4200000000-4294967295 (private use only)  La representation 32-bit décrite dans le RFC5396  Explique “asplain” (traditional format) comme notation standard 10
  • 11. Autonomous System Number (ASN)  Les ASNs sont attribués par les registres regionaux ( RIR)  Ils sont aussi utilisés par les ISP affiliés à des RIR.  Actuellement plus de 63487 16-bit ASN asignés par les RIRs  Environ 44500 visibles sur Internet  Environ 1500 restent pas attribués  Chaque RIR a aussi recu un bloque de 32-bit ASNs  Sur 4800 ASN asignés, environ 3700 sont visibles sur Internet  See www.iana.org/assignments/as-numbers 11
  • 12. Configuration de BGP ( Cisco IOS )  Cette commande active BGP in Cisco IOS: router bgp 100  Pour ASNs > 65535, l’ASN peut etre configuré soit en format decimal simple ou avec des points: router bgp 131076 ou router bgp 2.4  L’IOS affiche l’ASN en format decimal par default  Le format decimal avec des points est optionel : router bgp 2.4 bgp asnotation dot 12
  • 13. 13 AS 100 AS 101 AS 102 EE BB DD AA CC Peering Les bases de BGP  TCP – port 179  Path vector protocol  Mise à jour incrémentale  “Internal” et “External” BGP
  • 14. 14 AS 100 AS 101 AS 102 DMZ Network AA BB CC DD EE  Une DMZ est un lien ou un réseau partagé par plusieurs AS Zone de Demarcation (DMZ)
  • 15. 15 Fonctionnement général  BGP apprend plusieurs chemins via les routeurs “peers” qui communiquent via internal et external BGP.  Le meilleur chemin est installé dans la table de routage (RIB)  Les meilleurs chemins sont exportés vers les routeurs voisins supportant “external BGP”  La politique de routage est appliquées en infuençant la selection du meilleur chemin.
  • 16. Création de la table de Forwarding  BGP “in” fonctionnement  Recois les informations chemin du “peers”  Resultat de la selection des chemins est insérré dans la table BGP.  “best path” est taggué  BGP “out” fonctionnement  announce les informations des “meilleurs routes” aux peers  Les meilleures routes sont installées dans la table de routage (RIB)  Les meilleurs routes sont installées dans la table de forwarding (FIB):  Les prefixes et longueur de préfixe sont uniques  Plus petite “Distance administrative” 16
  • 17. 17 Création de la table de Forwarding BGP in process BGP table BGP out process accepted discarded bgp peer routing table in out best paths everything forwarding table
  • 18. eBGP & iBGP  BGP utilise en interne (iBGP) en externe (eBGP)  iBGP pour le transport  Quelques/Tous les préfixes Internet à travers le backbone de l’ISP  Préfixe des clients des ISP  eBGP utilisé  Exchanger les prefixes avec les autres AS  Implemente la politique de routage 18
  • 19. 19 BGP/IGP modèle d’utilisée par les ISP  representation IGP iBGP IGP iBGP IGP iBGP IGP iBGP eBGP eBGP eBGP AS1 AS2 AS3 AS4
  • 20. 20 AS 100 AS 101 CC AA BB BGP Externe Peering (eBGP)  Entre des homologues BGP dans différents AS  Les homologues doivent directement connectés  Ne Jamais utiliser un IGP entre deux peers eBGP
  • 21. 21 Configurer BGP Externe Router A dans AS100 interface ethernet 5/0 ip address 102.102.10.2 255.255.255.240 ! router bgp 100 network 100.100.8.0 mask 255.255.252.0 neighbor 102.102.10.1 remote-as 101 neighbor 102.102.10.1 prefix-list RouterC in neighbor 102.102.10.1 prefix-list RouterC out ! ip address on ethernet interface ip address of Router C ethernet interface Local ASN Remote ASN Inbound and outbound filters
  • 22. 22 Configurer BGP Externe Router C in AS101 interface ethernet 1/0/0 ip address 102.102.10.1 255.255.255.240 ! router bgp 101 network 100.100.64.0 mask 255.255.248.0 neighbor 102.102.10.2 remote-as 100 neighbor 102.102.10.2 prefix-list RouterA in neighbor 102.102.10.2 prefix-list RouterA out ! ip address on ethernet interface ip address of Router A ethernet interface Local ASN Remote ASN Inbound and outbound filters
  • 23. Multi-Protocol BGP pour IPv6 – RFC2545  Extensions spécifiques IPv6  Adresses “Scoped”: Next-hop contient une adresse globale IPv6 et/ou dans certain cas une adresse “link-local”  Le NEXT_HOP et NLRI sont définis comme les adresses et préfixe IPv6  Address Family Information (AFI) = 2 (IPv6)  Sub-AFI = 1 (NLRI est utilisé pour l’unicast)  Sub-AFI = 2 (NLRI est utilisé pour verifier l’adresse multicast )  Sub-AFI = 3 (NLRI est utilisé pour verifier l’adresse unicast et multicast )  Sub-AFI = 4 (label) 23
  • 24. Session MP-BGP 24 Router1# interface Ethernet0 ipv6 address 2001:db8:2:1::f/64 ! router bgp 65001 bgp router-id 10.10.10.1 no bgp default ipv4-unicast neighbor 2001:db8:2:1::1 remote-as 65002 address-family ipv6 neighbor 2001:db8:2:1::1 activate neighbor 2001:db8:2:1::1 prefix-list bgp65002in in neighbor 2001:db8:2:1::1 prefix-list bgp65002out out exit-address-family AS 65001 AS 65002 Router2Router1 2001:db8:2:1::f 2001:db8:2:1::1
  • 25. Internal BGP (iBGP)  Homologues BGP dans le même AS  Ne requierent pas une connectivité directe  IGP utilisé pour faire communiquer les homologues BGP  Homologues iBGP doivent être en “full meshed” :  Les routes apparaissent comme étant connectés  Diffuse les préfixes appris de l’extérieur d’autres AS  Ne diffuse pas les préfixes appris des autres routeurs homologues IBGP 25
  • 26. 26 AS 100 AA DD CC BB BGP interne Peering (iBGP)  Topologie indépendante  Tous les homologues IBGP dans un AS doivent communiquer entre eux.
  • 27. 27 Interfaces Loopback et “peering”  Communique avec l’interface loop-back  interface Loop-back est toujours UP – ever!  Pour eviter que la session iBGP depende de l’état d’une seule interface AS 100 AA BB CC
  • 28. 28 Configuration de BGP interne Router A dans AS100 interface loopback 0 ip address 105.3.7.1 255.255.255.255 ! router bgp 100 network 100.100.1.0 neighbor 105.3.7.2 remote-as 100 neighbor 105.3.7.2 update-source loopback0 neighbor 105.3.7.3 remote-as 100 neighbor 105.3.7.3 update-source loopback0 ! adresse ip sur loopback interface Adresse IP du Routeur B loopback interface ASN Local ASN Local
  • 29. 29 Configuring Internal BGP Router B dans AS100 interface loopback 0 ip address 105.3.7.2 255.255.255.255 ! router bgp 100 network 100.100.1.0 neighbor 105.3.7.1 remote-as 100 neighbor 105.3.7.1 update-source loopback0 neighbor 105.3.7.3 remote-as 100 neighbor 105.3.7.3 update-source loopback0 ! Adresse IP sur l’interface loopback ip address of Router A loopback interface ASN Local ASN Local
  • 30. 30 Insertion de prefixes dans BGP  Deux methodes pour inserrer un préfixe dans BGPs  redistribute static  network command
  • 31. 31 Inserting prefixes into BGP – redistribute static  Exemple de configuration: router bgp 100 redistribute static ip route 102.10.32.0 255.255.254.0 serial0  La route statique doit exister pour que la commande fonctionne  Force la valeur “origin” à “incomplete”  Utiliser avec prudence!
  • 32. 32 Insertion de prefixes dans BGP – redistribute static  Utiliser avec beaucoup de prudence !  redistribute <routing-protocol> indique que toutes les routes du <routing-protocol> sera transfer  Pas evolutif Will not scale if uncontrolled  A eviter si possible  redistribute doit être utilisé conjointement avec des “route-maps” avec beaucoup de controle
  • 33. 33 Insertion des prefixes dans BGP – network command  Exemple de configuration router bgp 100 network 102.10.32.0 mask 255.255.254.0 ip route 102.10.32.0 255.255.254.0 serial0  Une route correspondante dans la table de route est nécessaire pour que le préfixe soit annoncé par BGP.  Force l’attribute origin à “IGP”
  • 34. 34 Configuration Aggregation  Trois methodes pour configurer les aggregation de route :  redistribute static  aggregate-address  network command
  • 35. 35 Configuration d’Aggregation  Exemple de configuration : router bgp 100 redistribute static ip route 102.10.0.0 255.255.0.0 null0 250  Route statique vers “null0” is called a pull up route  Packets only sent here if there is no more specific match in the routing table  Distance of 250 ensures this is last resort static  Care required – see previously!
  • 36. 36 Configuration Aggregation– Commande “Network”  Exemple de configuration router bgp 100 network 102.10.0.0 mask 255.255.0.0 ip route 102.10.0.0 255.255.0.0 null0 250  Une route correspondante doit exister dans la table de routage pour que le réseau soit annoncé  Methode recommandée pour générer des route aggrégée
  • 37. Configuration Aggregation– Commande “aggregate-address”  Exemple de configuration: router bgp 100 network 102.10.32.0 mask 255.255.252.0 aggregate-address 102.10.0.0 255.255.0.0 [summary-only]  L’existence d’un préfixe plus specifique dans la table BGP est nécessaire pour que la route aggrégée soit annoncée  L’option “summary-only”  Assure que seule la route aggrégée est annoncée si un préfixe plus spécifique existe dans la table de routage
  • 38. 38 Resumé BGP neighbour status Router6>sh ip bgp sum BGP router identifier 10.0.15.246, local AS number 10 BGP table version is 16, main routing table version 16 7 network entries using 819 bytes of memory 14 path entries using 728 bytes of memory 2/1 BGP path/bestpath attribute entries using 248 bytes of memory 0 BGP route-map cache entries using 0 bytes of memory 0 BGP filter-list cache entries using 0 bytes of memory BGP using 1795 total bytes of memory BGP activity 7/0 prefixes, 14/0 paths, scan interval 60 secs Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd 10.0.15.241 4 10 9 8 16 0 0 00:04:47 2 10.0.15.242 4 10 6 5 16 0 0 00:01:43 2 10.0.15.243 4 10 9 8 16 0 0 00:04:49 2 ... BGP Version Updates sent and received Updates waiting
  • 39. 39 Resumé Table BGP Router6>sh ip bgp BGP table version is 16, local router ID is 10.0.15.246 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, x best-external, a additional-path, c RIB-compressed, Origin codes: i - IGP, e - EGP, ? - incomplete RPKI validation codes: V valid, I invalid, N Not found Network Next Hop Metric LocPrf Weight Path *>i 10.0.0.0/26 10.0.15.241 0 100 0 i *>i 10.0.0.64/26 10.0.15.242 0 100 0 i *>i 10.0.0.128/26 10.0.15.243 0 100 0 i *>i 10.0.0.192/26 10.0.15.244 0 100 0 i *>i 10.0.1.0/26 10.0.15.245 0 100 0 i *> 10.0.1.64/26 0.0.0.0 0 32768 i *>i 10.0.1.128/26 10.0.15.247 0 100 0 i *>i 10.0.1.192/26 10.0.15.248 0 100 0 i *>i 10.0.2.0/26 10.0.15.249 0 100 0 i *>i 10.0.2.64/26 10.0.15.250 0 100 0 i ...
  • 40. 40 Resumé  BGP4 – path vector protocol  iBGP versus eBGP  Design iBGP stable – peer with loopbacks  Announce des prefixes & aggregates