Ce diaporama a bien été signalé.
Nous utilisons votre profil LinkedIn et vos données d’activité pour vous proposer des publicités personnalisées et pertinentes. Vous pouvez changer vos préférences de publicités à tout moment.
Arreglos en
Pseudocódigo
Emerson E. Garay Gómez
www.youtube.com/emergaray
http://www.slideshare.net/emergar
200 300 45 89 ...
Definición: Arreglos
 Un arreglo en programación de
computadores, es una colección o
conjunto de variables del mismo tipo...
Clasificación de los arreglos según
las dimensiones
 Unidimensionales: son los llamados vectores, se
referencia con un so...
Representación de los arreglos 1
 Ejemplos de Vectores:
◦ Que permita almacenar 5 nombres:
◦ Para contener 10 notas estud...
Representación de los arreglos 2
 Ejemplos de Matrices:
◦ Una matriz(3x3) para guardar el estado de un
juego del triqui.
...
Definición de arreglos
 Definición y creación de Vectores:
 <Tipo Dato> <Nombre Vector> [n]; //Definición y Creación
 D...
Recorrer arreglos 1
 Recorrer un vector:
◦ La posiciones de un vector se referencia desde el índice 1
hasta el n.
 Para ...
Recorrer arreglos 2
 Recorrer una matriz:
Para f=1 Hasta n Con Paso 1 Hacer
Para c=1 Hasta m Con Paso 1 Hacer
//Acciones ...
Enlaces WEB
 Mi canal de videos en YouTube:
 www.youtube.com/emergaray
http://www.slideshare.net/emergar
Prochain SlideShare
Chargement dans…5
×

Arreglos en pseudocodigo 01

  • Identifiez-vous pour voir les commentaires

Arreglos en pseudocodigo 01

  1. 1. Arreglos en Pseudocódigo Emerson E. Garay Gómez www.youtube.com/emergaray http://www.slideshare.net/emergar 200 300 45 89 598 2015 A B C D E F
  2. 2. Definición: Arreglos  Un arreglo en programación de computadores, es una colección o conjunto de variables del mismo tipo(sea un tipo dado por el lenguaje o del tipo creado por el usuario) que se pueden referenciar bajo un mismo nombre y un índice. Es decir, son posiciones de memoria continuas que se consultan o modifican a través de un identificador y un índice que indica la posición. http://www.slideshare.net/emergar
  3. 3. Clasificación de los arreglos según las dimensiones  Unidimensionales: son los llamados vectores, se referencia con un solo índice. Y no es mas que un caso particular de una matriz, es decir, un vector es una matriz con una sola fila y una o mas columnas.  Bidimensionales: son las llamadas matrices que tienen dos índices, uno para la fila y otro para la columna. Son usados generalmente para llevar los estados de un juego(ajedrez, triqui, damas, …).  Multidimensionales: Son los que poseen mas de dos dimensiones. http://www.slideshare.net/emergar
  4. 4. Representación de los arreglos 1  Ejemplos de Vectores: ◦ Que permita almacenar 5 nombres: ◦ Para contener 10 notas estudiantiles: ◦ Que permita guardar los meses del año: ◦ Los números de cedulas de 4 personas: Adriana Josep María Susan Wilmer 5.0 3.8 4.5 2.9 3.5 4.1 4.0 3.6 4.2 2.5 Ene Feb Mar Abr May Jun Jul Ago Sep Oct Nov Dic 92.123.456 1.102.123.456 64.859.689 24.989.200 http://www.slideshare.net/emergar
  5. 5. Representación de los arreglos 2  Ejemplos de Matrices: ◦ Una matriz(3x3) para guardar el estado de un juego del triqui. ◦ Una matriz(5x5) para guardar el estado de un juego de bingo X O X O X O X O O B I N G O http://www.slideshare.net/emergar
  6. 6. Definición de arreglos  Definición y creación de Vectores:  <Tipo Dato> <Nombre Vector> [n]; //Definición y Creación  Donde n es un numero entero positivo. ◦ Ejemplos: ◦ Cadena nombres[5] ◦ Real notas[10] ◦ Cadena meses[12]  Definición y creación de matrices: ◦ <Tipo Dato> <Nombre Matriz> [Filas][Columnas] //Definición y Creación ◦ Donde Filas y Columnas son números enteros positivos. ◦ Ejemplos: ◦ Carácter triqui[3][3] ◦ Entero bingo[5][5] http://www.slideshare.net/emergar
  7. 7. Recorrer arreglos 1  Recorrer un vector: ◦ La posiciones de un vector se referencia desde el índice 1 hasta el n.  Para k=1 Hasta n Con Paso 1 Hacer ◦ //Acciones con el elemento sub-k del vector  FinPara  //Leer 5 nombres desde el teclado y almacenarlos:  Entero n=5  Cadena v[n]  Para k=1 Hasta n Con Paso 1 Hacer ◦ Escribir “Digite la cadena # ”, k ◦ Leer v[k]  FinPara http://www.slideshare.net/emergar
  8. 8. Recorrer arreglos 2  Recorrer una matriz: Para f=1 Hasta n Con Paso 1 Hacer Para c=1 Hasta m Con Paso 1 Hacer //Acciones con el elemento sub-f, sub-c FinPara FinPara  //Leer las 3 notas 10 estudiantes y almacenarlas: Entero f, c, n = 10, m = 3 Real notas[n][m]; Para f=1 Hasta n Con Paso 1 Hacer Escribir “Estudiante # ”, f Para c=1 Hasta m Con Paso 1 Hacer Escribir “Digite la nota # ”, c Leer notas[f][c] FinPara FinPara http://www.slideshare.net/emergar
  9. 9. Enlaces WEB  Mi canal de videos en YouTube:  www.youtube.com/emergaray http://www.slideshare.net/emergar

×