Successfully reported this slideshow.
EXCEL
LES FONCTIONS MATHÉMATIQUES
AIT ELMOUDEN Zakariyaa
mouden.zakariyaa@outlook.com
1
LES FORMULES EXCEL
2
LES FORMULES
 Définition : Une formule est une instruction
permettant de remplir le contenu d’une cellule
automatiquement...
LES FORMULES
 Exemple :
4
 Dans ce cas la formule représente une opération
de multiplication entre deux cellules : Quant...
LES FORMULES
 Il est possible d’écrire la formule directement dans
la cellule ou utiliser la zone spécifiée aux formules
...
LES FORMULES
 Il est possible d’écrire la formule directement dans
le cellule ou utiliser la zone spécifiée aux formules
...
RÉFÉRENCE RELATIVE OU ABSOLUE
 Dans l’exemple précédent, lorsqu’on glisse la
poignée de le cellule qui contient la formul...
RÉFÉRENCE RELATIVE OU ABSOLUE
 Dans le prochain exemple, on veut calculer le prix
*TTC d’un article, basé sur son prix *H...
RÉFÉRENCE RELATIVE OU ABSOLUE
 Si on utilise la cellule TVA (C7) comme référence
relative, le résultat sera :
9
 On rema...
RÉFÉRENCE RELATIVE OU ABSOLUE
 Le problème se pose quand la référence de la cellule
C7 sera incrémentée dans les autres l...
RÉFÉRENCE RELATIVE OU ABSOLUE
 La cellule C7 sera gardée pour toutes les lignes, ce
qui donne par la suite des valeurs co...
12
LES FONCTIONS EXCEL
LES FONCTIONS
 Une fonction Excel est un code prédéfinie par le
logiciel, permettant d’exécuter une requête sur les
donné...
LES FONCTIONS (SYNTAXE)
 Syntaxe
Une fonctions Excel s’écrit en manière générale
sous la forme suivante :
Nom_fonction(pa...
LES FONCTIONS (SYNTAXE)
 Liste des paramètres : ou liste des arguments
Sont les entrés de la fonctions, les paramètres so...
LES FONCTIONS (LES PARAMÈTRES)
 Une fonction peut avoir un ou plusieurs paramètres,
comme elle ne peut avoir aucun paramè...
LES FONCTIONS (LA SURCHARGE)
 Ils existent des fonctions qui ont besoin d’un
nombre spécifié des arguments sinon elles
re...
LES FONCTIONS MATHÉMATIQUES
 SOMME
Cette fonction réalise la somme des paramètres
numériques.
 Exemples
18
 SOMME(A1;D1...
LES FONCTIONS MATHÉMATIQUES
 SOMME
Cette fonction réalise la somme des paramètres
numériques.
 Exemples
19
 SOMME(A1;D1...
LES FONCTIONS MATHÉMATIQUES
 ABS
Retourne la valeur absolue d’un nombre
 ENT
Retourne la valeur entière d’un nombre
 AL...
LES FONCTIONS MATHÉMATIQUES
 Exemples
 La fonction qui permet de retourner un nombre
aléatoire entre 0 et 100 ?
 La fon...
LES FONCTIONS MATHÉMATIQUES
 Exemples
 La fonction qui permet de retourner un nombre
aléatoire entre 0 et 100 ?
ALEA()*1...
LES FONCTIONS MATHÉMATIQUES
 ALEA.ENTRE.BORNES
Cette fonction prend deux paramètre min et max, et
retourne un nombre enti...
LES FONCTIONS MATHÉMATIQUES
 ARRONDI
Prend deux paramètres, le 1er paramètre pour la
cellule, le 2ème paramètre est un no...
LES FONCTIONS MATHÉMATIQUES
 ARRONDI
Prend deux paramètres, le 1er paramètre pour la
cellule, le 2ème paramètre est un no...
LES FONCTIONS MATHÉMATIQUES
 ARRONDI.SUP
Même syntaxe que la fonction ARRONDI; et
résultat équivalent à celui de ARRONDI....
LES FONCTIONS MATHÉMATIQUES
 PI
Retourne la valeur de : 3,141592654
 SIGNE
Retourne le signe d’un nombre réel (1 pour un...
LES FONCTIONS MATHÉMATIQUES
 Remarque
Les fonctions mathématiques exigent de mettre
en paramètre des cellules numériques,...
LES FONCTIONS MATHÉMATIQUES
 Exercice
29
 Donner la formule qui permet de calculer à partir de A1 les
autres colonnes de...
LES FONCTIONS MATHÉMATIQUES
 Solution
30
 Donner la formule qui permet de calculer à partir de A1 les
autres colonnes de...
LES FONCTIONS MATHÉMATIQUES
 SOMME.SI
Réaliser la somme d’une plage de cellules si une
condition est satisfaite pour une ...
LES FONCTIONS MATHÉMATIQUES
 Exercice
32
 Calculer en D8 la somme des points des acteurs
nés à Casablanca
LES FONCTIONS MATHÉMATIQUES
 Solution
33
 Calculer en D8 la somme des points des acteurs
nés à Casablanca :
SOMME.SI(C1:...
LES FONCTIONS MATHÉMATIQUES
 SOMME.SI.ENS
Réaliser la somme d’une plage de cellules avec un
ensemble de conditions sur de...
LES FONCTIONS MATHÉMATIQUES
 Exercice
35
 Calculer en D8 la somme des points des joueurs
marocains (MAR) qui ont une val...
LES FONCTIONS MATHÉMATIQUES
 Solution
36
 Calculer en D8 la somme des points des joueurs
marocains (MAR) qui ont une val...
LES FONCTIONS MATHÉMATIQUES
 La combinaison de SOMME et SOMME.SI
Sert à faire une somme avec deux conditions ou
plus sur ...
LES FONCTIONS MATHÉMATIQUES
 Exemple
38
C8 = SOMME.SI(C:C;{"=ALG";"=MAR"};E:E) 165 ; 243
D8 = SOMME.SI(C:C;{"=MAR";"=ALG"...
LES FONCTIONS MATHÉMATIQUES
 Exercice
39
1) Calculer la somme des points des joueurs marocains
qui jouent au Bayern et qu...
LES FONCTIONS MATHÉMATIQUES
 Solution
1) = SOMME.SI.ENS( E2:E9;
C2:C9; "MAR";
D2:D9; "BAY";
E2:E9; ">80")
2) = SOMME.SI(E...
LES FONCTIONS MATHÉMATIQUES
 SOMMEPRODUIT
Multiplie toutes les valeurs de deux ou plusieurs matrices
entrées, et après ad...
LES FONCTIONS MATHÉMATIQUES
 Exemple
42
SOMMEPRODUIT(A2:B4;C2:D4)
= 1* 5 + 3 * 7 + 2 * 6 + 4 *8 + 0 * 9 + 1 * 4
= 74
 On...
Fin
43
Prochain SlideShare
Chargement dans…5
×

Excel : Les fonctions mathématiques

737 vues

Publié le

Les fonctions mathématique dans Excel

Publié dans : Ingénierie
  • Soyez le premier à commenter

Excel : Les fonctions mathématiques

  1. 1. EXCEL LES FONCTIONS MATHÉMATIQUES AIT ELMOUDEN Zakariyaa mouden.zakariyaa@outlook.com 1
  2. 2. LES FORMULES EXCEL 2
  3. 3. LES FORMULES  Définition : Une formule est une instruction permettant de remplir le contenu d’une cellule automatiquement, à base des opérations arithmétiques ou des fonctions qui prennent en paramètres les données d’autres cellules.  Toute formule Excel doit commencée pas le signe =  Les symboles des opérations arithmétique :  * pour la multiplication  + et – pour l’addition et la soustraction  / pour la division ( la division par zéro déclenche un erreur de type #DIV/0! ) 3
  4. 4. LES FORMULES  Exemple : 4  Dans ce cas la formule représente une opération de multiplication entre deux cellules : Quantité (C2) et Prix Unitaire en (D2), et après nous glissons la poignée de la cellule E2 sur l’ensemble des cellules qui souhaitent effectuer le même calcul.
  5. 5. LES FORMULES  Il est possible d’écrire la formule directement dans la cellule ou utiliser la zone spécifiée aux formules et fonctions Excel : 5  Une formules peut regroupée plusieurs cellules et plusieurs opérations arithmétiques, on respectant les priorités.  Exemple : =3+C2*(E2-D2)/10 Le résultat de cette formule sera combien si on utilise les données du tableau précédent? (C2 = 5, D2 = 1 200 et E2 = 6 000)
  6. 6. LES FORMULES  Il est possible d’écrire la formule directement dans le cellule ou utiliser la zone spécifiée aux formules et fonctions Excel : 6  Une formules peut regroupée plusieurs cellules et plusieurs opérations arithmétiques, on respectant les priorités.  Exemple : =3+C2*(E2-D2)/10 Le résultat de cette formule sera combien si on utilise les données du tableau précédent? Solution : 2 403,00
  7. 7. RÉFÉRENCE RELATIVE OU ABSOLUE  Dans l’exemple précédent, lorsqu’on glisse la poignée de le cellule qui contient la formule, les indices des lignes s’incrémentent pour mettre à jour les paramètres de la formule à ce qui correspond à la ligne courante. C2 * D2 C3 * D3 C4 * D4 .. Ci * Di  On parle ici d’une référence relative. 7
  8. 8. RÉFÉRENCE RELATIVE OU ABSOLUE  Dans le prochain exemple, on veut calculer le prix *TTC d’un article, basé sur son prix *HT et le montant de la *TVA. 8 • *TTC : Toute Taxe Comprise • *HT : Hors Taxes • *TVA : Taxe sur la Valeur Ajoutée
  9. 9. RÉFÉRENCE RELATIVE OU ABSOLUE  Si on utilise la cellule TVA (C7) comme référence relative, le résultat sera : 9  On remarque que le montant TTC et égale au montant HT ce qui est faux ( vrai : HT < TTC )  Sauf dans la cellule D2 le résultat sera correcte. Prix TTC = 12,00 MAD Pourquoi ?
  10. 10. RÉFÉRENCE RELATIVE OU ABSOLUE  Le problème se pose quand la référence de la cellule C7 sera incrémentée dans les autres ligne, alors TVA passe de C7 à C8 dans la 2eme ligne, et à C9 dans la 3ème, … Alors que ces cellules sont réellement vides ! La formule remplace les montants du TVA vides par des zéros, ce qui donne un : prix TTC = prix HT  La solution est de figer la cellule C7, pour qu’elle ne s’incrémente pas en passant d’une ligne à une autre.  Pour figer une cellule on utilise l’opérateur $ Exemple : $C$7 10
  11. 11. RÉFÉRENCE RELATIVE OU ABSOLUE  La cellule C7 sera gardée pour toutes les lignes, ce qui donne par la suite des valeurs correctes pour le champs Prix TTC: 11  On parle ici d’une référence absolue
  12. 12. 12 LES FONCTIONS EXCEL
  13. 13. LES FONCTIONS  Une fonction Excel est un code prédéfinie par le logiciel, permettant d’exécuter une requête sur les données des cellules.  Par exemple la formule =D1+D2+D3+D4 peut être remplacer par la fonction =SOMME(D1;D2;D3;D4) ou aussi =SOMME(D1:D4)  La même chose pour la fonction MOYENNE() qui rassemble les deux opérations somme des éléments et la division par le nombre d’éléments.  On peut dire alors que les fonctions facilite la gestion et la manipulation des données sous Excel. 13
  14. 14. LES FONCTIONS (SYNTAXE)  Syntaxe Une fonctions Excel s’écrit en manière générale sous la forme suivante : Nom_fonction(paramètre1;[paramètre2];[paramètre3]; ….) Liste des paramètres  Nom_fonction : le nom de la fonction Excel. L’onglet formules contient un groupe nommé «Bibliothèque des fonctions» qui regroupe plus de 300 fonctions Excel selon leurs types (texte, maths, logique, … ). 14
  15. 15. LES FONCTIONS (SYNTAXE)  Liste des paramètres : ou liste des arguments Sont les entrés de la fonctions, les paramètres sont séparés par un point virgule ‘;’ ou par deux points ‘:’ dans le cas d’une plage de cellules.  Exemples : =SOMME(D1;D2;D3) Le nom de la fonction est ‘SOMME’ et les paramètres sont : « D1, D2 et D3 ». =MOYENNE(D1:D10) Dans ce cas les paramètres représente une plage de cellules : « D1, D2, ……. , D9 et D10 », cette fonction permet d’effectuer la moyenne de l’ensemble des paramètres. 15
  16. 16. LES FONCTIONS (LES PARAMÈTRES)  Une fonction peut avoir un ou plusieurs paramètres, comme elle ne peut avoir aucun paramètre.  Comme par exemple le cas de la fonction AUJOURDHUI() qui affiche la date actuelle, cette fonction n’a pas besoin de paramètres. Remarque : Dans le cas où la fonction AUJOURDHUI() retourne des ‘ ###..’ il suffit d’élargir la cellule. 16
  17. 17. LES FONCTIONS (LA SURCHARGE)  Ils existent des fonctions qui ont besoin d’un nombre spécifié des arguments sinon elles retournent un erreur, comme le cas de la fonction ABS(cellule) qui retourne la valeur absolue de la cellule entrée comme paramètre, alors on ne peut pas utiliser cette fonction avec plus d’un paramètre ou sans paramètre.  Mais il existe aussi des fonctions qui peuvent utiliser un nombre varié des paramètres, comme le cas de les fonctions SOMME et MOYENNE qu’on a déjà traiter. On parle d’un surcharge de la fonction 17
  18. 18. LES FONCTIONS MATHÉMATIQUES  SOMME Cette fonction réalise la somme des paramètres numériques.  Exemples 18  SOMME(A1;D1) = ?  SOMME(A1:F1) = ?  SOMME(A2:F2) = ?  SOMME(E1:E3) = ?
  19. 19. LES FONCTIONS MATHÉMATIQUES  SOMME Cette fonction réalise la somme des paramètres numériques.  Exemples 19  SOMME(A1;D1) = 4  SOMME(A1:F1) = 16  SOMME(A2:F2) = 88,4  SOMME(E1:E3) = 23
  20. 20. LES FONCTIONS MATHÉMATIQUES  ABS Retourne la valeur absolue d’un nombre  ENT Retourne la valeur entière d’un nombre  ALEA Retourne un nombre aléatoire (différent à chaque calcul) dans l’intérvale [0,1[ 20
  21. 21. LES FONCTIONS MATHÉMATIQUES  Exemples  La fonction qui permet de retourner un nombre aléatoire entre 0 et 100 ?  La fonction qui permet de retourner un nombre entier aléatoire entre 0 et 100 ?  La fonction qui permet de retourner un symbole décimal (entre 0 et 9) ? 21
  22. 22. LES FONCTIONS MATHÉMATIQUES  Exemples  La fonction qui permet de retourner un nombre aléatoire entre 0 et 100 ? ALEA()*100+1  La fonction qui permet de retourner un nombre entier aléatoire entre 0 et 100 ? ENT(ALEA()*100+1)  La fonction qui permet de retourner symbole décimal (entre 0 et 9) ? ENT(ALEA()*10) 22
  23. 23. LES FONCTIONS MATHÉMATIQUES  ALEA.ENTRE.BORNES Cette fonction prend deux paramètre min et max, et retourne un nombre entier aléatoire entre les deux nombres min et max (l’interval [min, max]).  Exemple Pour un pourcentage il suffit d’écrire : ALEA.ENTRE.BORNES(0;100) 23
  24. 24. LES FONCTIONS MATHÉMATIQUES  ARRONDI Prend deux paramètres, le 1er paramètre pour la cellule, le 2ème paramètre est un nombre entier n, le résultat sera le contenu de la cellule avec n chiffres après la virgule.  Exemple : Soit les cellules A1=11,1447 et A2 = 23,955 ARRONDI(A1;1) = ? ARRONDI(A1;3) = ? ARRONDI(A2;0) = ? ARRONDI(A2;2) = ? 24
  25. 25. LES FONCTIONS MATHÉMATIQUES  ARRONDI Prend deux paramètres, le 1er paramètre pour la cellule, le 2ème paramètre est un nombre entier n, le résultat sera le contenu de la cellule avec n chiffres après la virgule.  Exemple : Soit les cellules A1=11,1447 et A2 = 23,955 ARRONDI(A1;1) = 11,1 ARRONDI(A1;3) = 11,145 ARRONDI(A2;0) = 24 ARRONDI(A2;2) = 23,96 25
  26. 26. LES FONCTIONS MATHÉMATIQUES  ARRONDI.SUP Même syntaxe que la fonction ARRONDI; et résultat équivalent à celui de ARRONDI.  ARRONDO.INF Même syntaxe que la fonction ARRONDI; elle arrondis le contenu de la cellule avec le nombre spécifié après la virgule, en ignorant le reste des chiffres.  Exemple : Si A1=11,1899999 ARRONDI.INF(A1;2) = 11,18 26
  27. 27. LES FONCTIONS MATHÉMATIQUES  PI Retourne la valeur de : 3,141592654  SIGNE Retourne le signe d’un nombre réel (1 pour un nombre positif, -1 pour un nombre négatif et 0 pour nul)  RACINE Retourne le racine carré de la valeur de la cellule.  PUISSANCE Prend deux paramètres; la cellule qui contient un nombre réel N et la puissance q, et retourne la valeur de Nq. 27
  28. 28. LES FONCTIONS MATHÉMATIQUES  Remarque Les fonctions mathématiques exigent de mettre en paramètre des cellules numériques, sinon retournent un erreur de type #VALEUR! Sauf la fonction SOMME qui remplace toute cellule sous format non numérique par un zéro. 28
  29. 29. LES FONCTIONS MATHÉMATIQUES  Exercice 29  Donner la formule qui permet de calculer à partir de A1 les autres colonnes de la 1ere ligne, sachant que la valeur de chaque colonnes égale à la valeur de la colonne à gauche + 1.333  Donner la formule qui permet de calculer dans la 2eme ligne la racine carré de la valeur en haut, avec deux chiffres après la virgule  Donner la formule qui permet de calculer dans la 3eme ligne les valeur entières de la 1ere ligne en puissance des valeurs entières de leurs racines
  30. 30. LES FONCTIONS MATHÉMATIQUES  Solution 30  Donner la formule qui permet de calculer à partir de A1 les autres colonnes de la 1ere ligne, sachant que la valeur de chaque colonnes égale à la valeur de la colonne à gauche + 1.333 =A1+1.333  Donner la formule qui permet de calculer dans la 2eme ligne la racine carré de la valeur en haut, avec deux chiffres après la virgule =ARRONDI(RACINE(A1);2)  Donner la formule qui permet de calculer dans la 3eme ligne les valeur entières de la 1ere ligne en puissance des valeurs entières de leurs racines =PUISSANCE(ENT(A1);ENT(A2))
  31. 31. LES FONCTIONS MATHÉMATIQUES  SOMME.SI Réaliser la somme d’une plage de cellules si une condition est satisfaite pour une autre plage de cellules (somme conditionnelle)  Syntaxe SOMME.SI(plage_cellules; ’’critère’’ ; plage_cellules_à_sommer)  Exemple SOMME.SI(B1:B9; ‘’=0’’ ; D1:D9) Calcule la somme des colonnes D1 à D9, mais seulement ceux qui ont une colonne B avec une valeur égale à 0. 31
  32. 32. LES FONCTIONS MATHÉMATIQUES  Exercice 32  Calculer en D8 la somme des points des acteurs nés à Casablanca
  33. 33. LES FONCTIONS MATHÉMATIQUES  Solution 33  Calculer en D8 la somme des points des acteurs nés à Casablanca : SOMME.SI(C1:C6 ; ’’=Casablanca’’ ; D1:D6) SOMME.SI(C:C ; ’’Casablanca’’ ; D:D)
  34. 34. LES FONCTIONS MATHÉMATIQUES  SOMME.SI.ENS Réaliser la somme d’une plage de cellules avec un ensemble de conditions sur deux ou plusieurs champs différents.  Syntaxe SOMME.SI.ENS ( Plage_cellules_somme ; Plage_cellules_critère_1; ’’critère_1’’ ; Plage_cellules_critère_2; ’’critère_2’’ ; …………… Plage_cellules_critère_n; ’’critère_n’’ ) 34
  35. 35. LES FONCTIONS MATHÉMATIQUES  Exercice 35  Calculer en D8 la somme des points des joueurs marocains (MAR) qui ont une valeur de ‘points’ supérieure ou égale à 80
  36. 36. LES FONCTIONS MATHÉMATIQUES  Solution 36  Calculer en D8 la somme des points des joueurs marocains (MAR) qui ont une valeur de ‘points’ supérieure ou égale à 80 SOMME.SI.ENS(E2:E7;C2:C7;"MAR";E2:E7;">=80") Ou d’une manière générale SOMME.SI.ENS(E:E;C:C;"MAR";E:E;">=80")
  37. 37. LES FONCTIONS MATHÉMATIQUES  La combinaison de SOMME et SOMME.SI Sert à faire une somme avec deux conditions ou plus sur la même colonne  Syntaxe SOMME(SOMME.SI( plage_cellules; {’’critère_1’’; ’’critère_2’’;……; ’’critère_n’’}; Plage_cellules_somme)) ; Joue le rôle d’un OU/OR 37
  38. 38. LES FONCTIONS MATHÉMATIQUES  Exemple 38 C8 = SOMME.SI(C:C;{"=ALG";"=MAR"};E:E) 165 ; 243 D8 = SOMME.SI(C:C;{"=MAR";"=ALG"};E:E) 243 ; 165 E8 = SOMME(SOMME.SI(C:C;{"MAR";"ALG"};E:E)) N.B: Si on n’utilise pas la fonction SOMME, le résultat affiché concerne seulement la première critère et le reste sera ignoré, comme vous remarquez sur C8 et D8.
  39. 39. LES FONCTIONS MATHÉMATIQUES  Exercice 39 1) Calculer la somme des points des joueurs marocains qui jouent au Bayern et qui ont une somme des points supérieure à 80. 2) Calculer la somme des points des joueurs qui ont la valeur du champs ‘points’ comprise entre 80 et 85.
  40. 40. LES FONCTIONS MATHÉMATIQUES  Solution 1) = SOMME.SI.ENS( E2:E9; C2:C9; "MAR"; D2:D9; "BAY"; E2:E9; ">80") 2) = SOMME.SI(E2:E9;"<=85"; E2:E9) -SOMME.SI(E2:E9;"<80"; E2:E9) Ou =SOMME.SI.ENS(E2:E9; E2:E9;">=80"; E2:E9;"<=85") 40
  41. 41. LES FONCTIONS MATHÉMATIQUES  SOMMEPRODUIT Multiplie toutes les valeurs de deux ou plusieurs matrices entrées, et après additionne les produits  Syntaxe SOMMEPRODUIT( matrice_1; [matrice_2] ; …. [matrice_n] )  matrice_1 est un paramètres obligatoire, les autres sont facultatifs.  Les matrices doivent avoir la même dimension, sinon erreur de type #VALEUR! 41
  42. 42. LES FONCTIONS MATHÉMATIQUES  Exemple 42 SOMMEPRODUIT(A2:B4;C2:D4) = 1* 5 + 3 * 7 + 2 * 6 + 4 *8 + 0 * 9 + 1 * 4 = 74  On va voir une autre utilisation de cette fonction dans les fonctions statistiques.
  43. 43. Fin 43

×