SlideShare une entreprise Scribd logo
1  sur  22
Configuring a Router
Router user interface




• The Cisco IOS software uses a command-line interface
    (CLI) as the traditional console environment.
•   This environment is accessible through several methods:
     – Console
     – AUX port (modem)
     – Telnet
Establishing a HyperTerminal session

                                                               Router


             Console port
                                                          Terminal or a
                                                          PC with
      Rollover cable
                                                          terminal
                                                          emulation
                                                          software

                     Com1 or Com2 serial port


Take the following steps to connect a terminal to the console port on the router:
• Connect the terminal using the RJ-45 to RJ-45 rollover cable and an RJ-45 to
   DB-9 or RJ-45 to DB-25 adapter.
• Configure the terminal or PC terminal emulation software for 9600 baud, 8 data
   bits, no parity, 1 stop bit, and no flow control.
Establishing a HyperTerminal session




                                  =

• Important: A console connection is not the same as a
  network connection!
Logging into the router




• Two commands can be used to set a password used to access privileged
    EXEC mode: enable password and enable secret
•   The following are specific modes that can also be accessed from the global
    configuration mode:
     – Interface
     – Subinterface
     – Line
     – Router
     – Route-map
CLI command modes




Router>enable
                                   The command Exit
Router#configure terminal
                                   will take you up one
Router(config)# interface fa 0/0
Router(config-if)#                 level
Configuring a router name




 Router#config t
 Router(config)#hostname Tokyo
 Tokyo(config)#
Configuring a serial interface




Configuring an IP Address on an interface…
Router(config)#interface serial 0/0
Router(config-if)#ip address <ip address> <netmask>
show ip interface command

Router# show ip interface brief

Interface    IP-Address       OK?   Method     Status                   Protocol
Ethernet0    131.108.1.11     YES   manual     up                       up
Serial0      198.135.2.49     YES   manual     administratively down    down


      What is wrong here? The administrator has either done a
      “shutdown” on the interface or has forgotten to do a “no shutdown”.



• A serial interface will not show “up” and “up” unless both
    ends are properly configured (mostly) and the no shutdown
    command is used.
•   If one router’s configuration looks okay, check the other
    router’s configuration.
Configuring a serial interface
           Lab                    DCE        DTE



    Real world



• On serial links that are directly interconnected, as in a lab environment,
     one side must be considered a DCE and provide a clocking signal.
•    The clock is enabled and speed is specified with the clock rate
     command.


Router(config)#interface serial 0/0
Router(config-if)#clock rate 56000 (on DCE end Only)
Router(config-if)#no shutdown
Configuring an Ethernet Interface
Configuring a Dynamic Routing Protocol:
Configuring RIPv1


First, RIP is enabled on each router.

From global configuration you will enter the command (the
  default is RIPv1):
Router(config)#router rip

Second, Once you are in the Router RIP configuration sub-
  mode, all you need to do is enter the classful network
  address for each directly connected network, using the
  network command.
Router(config-router)#network directly-
  connected-classful-network-address
Example
                            First, we Configure the interfaces on
                               each router

                            SanJose2
                            hostname SanJose2
                            interface ethernet 0
                               ip add 192.168.1.1 255.255.255.0
                            interface serial 0
                               ip add 192.168.2.1 255.255.255.0

                            SanJose1
                            hostname SanJose1
                            interface ethernet 0
                               ip add 192.168.3.1 255.255.255.0
                            interface serial 0
                               ip add 192.168.2.2 255.255.255.0
                                clockrate 64000
                            interface serial 1
                               ip add 192.168.4.2 255.255.255.0
                                clockrate 64000


When done configuring the   Baypointe
                            hostname Baypointe
interfaces use the          interface ethernet 0
                               ip add 192.168.5.1 255.255.255.0
command: show ip            interface serial 0

interface brief                ip add 192.168.4.1 255.255.255.0
Second, we configure RIPv1

Here are the commands for each router:

SanJose2#configure terminal
Enter configuration commands, one per line.   End with CNTL/Z.
SanJose2(config)#router rip
SanJose2(config-router)#network 192.168.1.0
SanJose2(config-router)#network 192.168.2.0

Baypointe#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Baypointe(config)#router rip
Baypointe(config-router)#network 192.168.4.0
Baypointe(config-router)#network 192.168.5.0

SanJose1#configure terminal
Enter configuration commands, one per line.   End with CNTL/Z.
SanJose1(config)#router rip
SanJose1(config-router)#network 192.168.2.0
SanJose1(config-router)#network 192.168.3.0
SanJose1(config-router)#network 192.168.4.0
Third, We check on the routing table for each
router

SanJose2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M -
   mobile, B - BGP
        <omitted>
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, *
   - candidate default
        U - per-user static route, o - ODR
Gateway of last resort is not set

R    192.168.4.0/24   [120/1] via 192.168.2.2, 00:00:10,
   Serial0
R    192.168.5.0/24   [120/2] via 192.168.2.2, 00:00:10,
   Serial0
C    192.168.1.0/24   is directly connected, Ethernet0
C    192.168.2.0/24   is directly connected, Serial0
R    192.168.3.0/24   [120/1] via 192.168.2.2, 00:00:10,
   Serial0
SanJose2#
Third, We check on the routing table for each
  router

SanJose1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M
    - mobile, B - BGP
       <omitted>
Gateway of last resort is not set
C    192.168.4.0/24 is directly connected, Serial1
R    192.168.5.0/24 [120/1] via 192.168.4.1, 00:00:12,
    Serial1
R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:10,
    Serial0
C    192.168.2.0/24 is directly connected, Serial0
C    192.168.3.0/24 is directly connected, Ethernet0
Third, We check on the routing table for each
    router

Baypointe#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M -
   mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF
   inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external
   type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2, E
   - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
   candidate default
        U - per-user static route, o - ODR
Gateway of last resort is not set

C     192.168.4.0/24   is directly   connected, Serial0
C     192.168.5.0/24   is directly   connected, Ethernet0
R     192.168.1.0/24   [120/2] via   192.168.4.2, 00:00:23, Serial0
R     192.168.2.0/24   [120/1] via   192.168.4.2, 00:00:23, Serial0
R     192.168.3.0/24   [120/1] via   192.168.4.2, 00:00:23, Serial0
copy running-config startup-config


                       During bootup



         running-config
                             RAM
                                                     startup-config
Router# copy running-config startup-config



 • Changes to the router are automatically put in the running-config file.
 • If the router loses power or reboots, everything in RAM is lost including the running-
     config file.
 •   To make sure the changes to the router’s configuration remain saved, you must copy
     the running-config from RAM into the startup-config into NVRAM:

 Router# copy         running-config           startup-config
copy running-config startup-config
Router# copy running-config startup-config
 Or
Router# copy running startup
 OR
Router# copy run start
 OR
Any usage of the command or parameters, so that they are still uniquely recognizable .

WARNING
• Using an incorrect configuration file name could overwrite the router’s IOS in flash, as the router believes
   you are trying to copy a blank file into flash.

Router#copy running-config start-up
                         **** NOTICE ****       Incorrect file name!
Flash load helper v1.0
This process will accept the copy options and then terminate
the current system image to use the ROM based image for the copy.
Routing functionality will not be available during that time.
If you are logged in via telnet, this connection will terminate.
Users with console access can see the results of the copy operation.
                         ---- ******** ----
Proceed? [confirm]^C
%Copy cancelled by user request.
Router#
                                  Press <control> C
Examining the show commands (typed from
Privileged Mode)
• Show ip interface Brief: Shows the
    status of the interfaces along with their IP
    Addresses
•   show startup-configuration –
    Displays the saved configuration located in
    NVRAM
•   show running-configuration –
    Displays the configuration currently running
    in RAM
How to Reset The Router

1. Router> enable
2. Router# erase start (Press enter to confirm): This step
     erases the configuration file
3.   Router# Reload : This step soft-boots the router
4.   After the router reloads, the following question will show:
     “Would you like to enter the setup mode”, Please answer
     “no” to that question.
5.   The router should now take you to user mode: Router>


Note: If asked for a password, use the password system in
   the next slide
Router Passwords Used in the Cisco Lab
Will not be used for the VoIP Labs
Privilege Password     cisco




Console password       conpass




VTY 0 4 password       vtypass




Auxiliary              auxpass

Contenu connexe

Tendances

Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorial
IT Tech
 
How to configure Default Routing
How to configure Default RoutingHow to configure Default Routing
How to configure Default Routing
tcpipguru
 
Ciso 4 ospf
Ciso 4 ospfCiso 4 ospf
Ciso 4 ospf
myciokas
 
Cisco labs practical4
Cisco labs practical4Cisco labs practical4
Cisco labs practical4
Tai Lam
 

Tendances (18)

Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorial
 
Cisco switch commands cheat sheet
Cisco switch commands cheat sheetCisco switch commands cheat sheet
Cisco switch commands cheat sheet
 
Router commands
Router commandsRouter commands
Router commands
 
Day 5.3 configuration of router
Day 5.3 configuration of routerDay 5.3 configuration of router
Day 5.3 configuration of router
 
Initial Configuration of Router
Initial Configuration of RouterInitial Configuration of Router
Initial Configuration of Router
 
test
testtest
test
 
Modes of router
Modes of routerModes of router
Modes of router
 
How to configure Default Routing
How to configure Default RoutingHow to configure Default Routing
How to configure Default Routing
 
Ciso ospf
Ciso ospfCiso ospf
Ciso ospf
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 Minutes
 
Ccna command
Ccna commandCcna command
Ccna command
 
Ciso 4 ospf
Ciso 4 ospfCiso 4 ospf
Ciso 4 ospf
 
Dynamic routing OSPF 1
Dynamic routing OSPF 1Dynamic routing OSPF 1
Dynamic routing OSPF 1
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
 
Wan Interface Configuration
Wan Interface ConfigurationWan Interface Configuration
Wan Interface Configuration
 
Day 5.3 routercomponents
Day 5.3 routercomponentsDay 5.3 routercomponents
Day 5.3 routercomponents
 
Cisco labs practical4
Cisco labs practical4Cisco labs practical4
Cisco labs practical4
 

En vedette (6)

Svcc Groovy Testing
Svcc Groovy TestingSvcc Groovy Testing
Svcc Groovy Testing
 
A dança da água
A dança da águaA dança da água
A dança da água
 
Svcc Building Rich Applications with Groovy's SwingBuilder
Svcc Building Rich Applications with Groovy's SwingBuilderSvcc Building Rich Applications with Groovy's SwingBuilder
Svcc Building Rich Applications with Groovy's SwingBuilder
 
Svcc Java2D And Groovy
Svcc Java2D And GroovySvcc Java2D And Groovy
Svcc Java2D And Groovy
 
Keeping the peace
Keeping the peaceKeeping the peace
Keeping the peace
 
phone de copia de seguridad
phone de copia de seguridadphone de copia de seguridad
phone de copia de seguridad
 

Similaire à Intro to router_config

CCNA at a glance
CCNA at a glanceCCNA at a glance
CCNA at a glance
Vikas Raut
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer)
Arz Sy
 
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Abhilash Kuniyil
 
How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)
IT Tech
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
Kishore Kumar
 

Similaire à Intro to router_config (20)

Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)
 
Routing information protocol & rip configuration
Routing information protocol & rip configurationRouting information protocol & rip configuration
Routing information protocol & rip configuration
 
CCNA at a glance
CCNA at a glanceCCNA at a glance
CCNA at a glance
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer)
 
General lab documentation~cisco router configuration
General lab documentation~cisco router configurationGeneral lab documentation~cisco router configuration
General lab documentation~cisco router configuration
 
Labmannual
LabmannualLabmannual
Labmannual
 
Cisco config
Cisco configCisco config
Cisco config
 
Cisco config
Cisco configCisco config
Cisco config
 
Cisco config
Cisco configCisco config
Cisco config
 
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
 
CCNA_LAB_MANUAL_part1.pptx
CCNA_LAB_MANUAL_part1.pptxCCNA_LAB_MANUAL_part1.pptx
CCNA_LAB_MANUAL_part1.pptx
 
managing your network environment
managing your network environmentmanaging your network environment
managing your network environment
 
How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)
 
Static Routing
Static RoutingStatic Routing
Static Routing
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands list
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configuration
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
 
Ccna 4 Final 4 Version 4.0 Answers
Ccna 4 Final 4 Version 4.0 AnswersCcna 4 Final 4 Version 4.0 Answers
Ccna 4 Final 4 Version 4.0 Answers
 

Plus de 97148881557

03 router-configuration
03 router-configuration03 router-configuration
03 router-configuration
97148881557
 
Wisp mode aprouter
Wisp mode aprouterWisp mode aprouter
Wisp mode aprouter
97148881557
 
Wireless router setupmanual
Wireless router setupmanualWireless router setupmanual
Wireless router setupmanual
97148881557
 
Simply bb-customer-router-setup(1)
Simply bb-customer-router-setup(1)Simply bb-customer-router-setup(1)
Simply bb-customer-router-setup(1)
97148881557
 
Simply bb-customer-router-setup
Simply bb-customer-router-setupSimply bb-customer-router-setup
Simply bb-customer-router-setup
97148881557
 
Router configuration(1)
Router configuration(1)Router configuration(1)
Router configuration(1)
97148881557
 
Router configuration
Router configurationRouter configuration
Router configuration
97148881557
 
Netgear wnr834 b_v2
Netgear wnr834 b_v2Netgear wnr834 b_v2
Netgear wnr834 b_v2
97148881557
 
Mcitp server administrator
Mcitp server administratorMcitp server administrator
Mcitp server administrator
97148881557
 
Introduction to-cisco-routers
Introduction to-cisco-routersIntroduction to-cisco-routers
Introduction to-cisco-routers
97148881557
 
D link router_setup_example
D link router_setup_exampleD link router_setup_example
D link router_setup_example
97148881557
 

Plus de 97148881557 (18)

03 router-configuration
03 router-configuration03 router-configuration
03 router-configuration
 
Wisp mode aprouter
Wisp mode aprouterWisp mode aprouter
Wisp mode aprouter
 
Wireless router setupmanual
Wireless router setupmanualWireless router setupmanual
Wireless router setupmanual
 
Simply bb-customer-router-setup(1)
Simply bb-customer-router-setup(1)Simply bb-customer-router-setup(1)
Simply bb-customer-router-setup(1)
 
Simply bb-customer-router-setup
Simply bb-customer-router-setupSimply bb-customer-router-setup
Simply bb-customer-router-setup
 
Rtr config
Rtr configRtr config
Rtr config
 
Router configuration(1)
Router configuration(1)Router configuration(1)
Router configuration(1)
 
Router configuration
Router configurationRouter configuration
Router configuration
 
Routconf
RoutconfRoutconf
Routconf
 
Netgear wnr834 b_v2
Netgear wnr834 b_v2Netgear wnr834 b_v2
Netgear wnr834 b_v2
 
Mcitp server administrator
Mcitp server administratorMcitp server administrator
Mcitp server administrator
 
Introduction to-cisco-routers
Introduction to-cisco-routersIntroduction to-cisco-routers
Introduction to-cisco-routers
 
D link router_setup_example
D link router_setup_exampleD link router_setup_example
D link router_setup_example
 
Ciscointro
CiscointroCiscointro
Ciscointro
 
Cisco how-to
Cisco how-toCisco how-to
Cisco how-to
 
C4 040 r-02(1)
C4 040 r-02(1)C4 040 r-02(1)
C4 040 r-02(1)
 
C4 040 r-02
C4 040 r-02C4 040 r-02
C4 040 r-02
 
520scg basic
520scg basic520scg basic
520scg basic
 

Intro to router_config

  • 2. Router user interface • The Cisco IOS software uses a command-line interface (CLI) as the traditional console environment. • This environment is accessible through several methods: – Console – AUX port (modem) – Telnet
  • 3. Establishing a HyperTerminal session Router Console port Terminal or a PC with Rollover cable terminal emulation software Com1 or Com2 serial port Take the following steps to connect a terminal to the console port on the router: • Connect the terminal using the RJ-45 to RJ-45 rollover cable and an RJ-45 to DB-9 or RJ-45 to DB-25 adapter. • Configure the terminal or PC terminal emulation software for 9600 baud, 8 data bits, no parity, 1 stop bit, and no flow control.
  • 4. Establishing a HyperTerminal session = • Important: A console connection is not the same as a network connection!
  • 5. Logging into the router • Two commands can be used to set a password used to access privileged EXEC mode: enable password and enable secret • The following are specific modes that can also be accessed from the global configuration mode: – Interface – Subinterface – Line – Router – Route-map
  • 6. CLI command modes Router>enable The command Exit Router#configure terminal will take you up one Router(config)# interface fa 0/0 Router(config-if)# level
  • 7. Configuring a router name Router#config t Router(config)#hostname Tokyo Tokyo(config)#
  • 8. Configuring a serial interface Configuring an IP Address on an interface… Router(config)#interface serial 0/0 Router(config-if)#ip address <ip address> <netmask>
  • 9. show ip interface command Router# show ip interface brief Interface IP-Address OK? Method Status Protocol Ethernet0 131.108.1.11 YES manual up up Serial0 198.135.2.49 YES manual administratively down down What is wrong here? The administrator has either done a “shutdown” on the interface or has forgotten to do a “no shutdown”. • A serial interface will not show “up” and “up” unless both ends are properly configured (mostly) and the no shutdown command is used. • If one router’s configuration looks okay, check the other router’s configuration.
  • 10. Configuring a serial interface Lab DCE DTE Real world • On serial links that are directly interconnected, as in a lab environment, one side must be considered a DCE and provide a clocking signal. • The clock is enabled and speed is specified with the clock rate command. Router(config)#interface serial 0/0 Router(config-if)#clock rate 56000 (on DCE end Only) Router(config-if)#no shutdown
  • 12. Configuring a Dynamic Routing Protocol: Configuring RIPv1 First, RIP is enabled on each router. From global configuration you will enter the command (the default is RIPv1): Router(config)#router rip Second, Once you are in the Router RIP configuration sub- mode, all you need to do is enter the classful network address for each directly connected network, using the network command. Router(config-router)#network directly- connected-classful-network-address
  • 13. Example First, we Configure the interfaces on each router SanJose2 hostname SanJose2 interface ethernet 0 ip add 192.168.1.1 255.255.255.0 interface serial 0 ip add 192.168.2.1 255.255.255.0 SanJose1 hostname SanJose1 interface ethernet 0 ip add 192.168.3.1 255.255.255.0 interface serial 0 ip add 192.168.2.2 255.255.255.0 clockrate 64000 interface serial 1 ip add 192.168.4.2 255.255.255.0 clockrate 64000 When done configuring the Baypointe hostname Baypointe interfaces use the interface ethernet 0 ip add 192.168.5.1 255.255.255.0 command: show ip interface serial 0 interface brief ip add 192.168.4.1 255.255.255.0
  • 14. Second, we configure RIPv1 Here are the commands for each router: SanJose2#configure terminal Enter configuration commands, one per line. End with CNTL/Z. SanJose2(config)#router rip SanJose2(config-router)#network 192.168.1.0 SanJose2(config-router)#network 192.168.2.0 Baypointe#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Baypointe(config)#router rip Baypointe(config-router)#network 192.168.4.0 Baypointe(config-router)#network 192.168.5.0 SanJose1#configure terminal Enter configuration commands, one per line. End with CNTL/Z. SanJose1(config)#router rip SanJose1(config-router)#network 192.168.2.0 SanJose1(config-router)#network 192.168.3.0 SanJose1(config-router)#network 192.168.4.0
  • 15. Third, We check on the routing table for each router SanJose2#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP <omitted> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default U - per-user static route, o - ODR Gateway of last resort is not set R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:10, Serial0 R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:10, Serial0 C 192.168.1.0/24 is directly connected, Ethernet0 C 192.168.2.0/24 is directly connected, Serial0 R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:10, Serial0 SanJose2#
  • 16. Third, We check on the routing table for each router SanJose1#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP <omitted> Gateway of last resort is not set C 192.168.4.0/24 is directly connected, Serial1 R 192.168.5.0/24 [120/1] via 192.168.4.1, 00:00:12, Serial1 R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:10, Serial0 C 192.168.2.0/24 is directly connected, Serial0 C 192.168.3.0/24 is directly connected, Ethernet0
  • 17. Third, We check on the routing table for each router Baypointe#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default U - per-user static route, o - ODR Gateway of last resort is not set C 192.168.4.0/24 is directly connected, Serial0 C 192.168.5.0/24 is directly connected, Ethernet0 R 192.168.1.0/24 [120/2] via 192.168.4.2, 00:00:23, Serial0 R 192.168.2.0/24 [120/1] via 192.168.4.2, 00:00:23, Serial0 R 192.168.3.0/24 [120/1] via 192.168.4.2, 00:00:23, Serial0
  • 18. copy running-config startup-config During bootup running-config RAM startup-config Router# copy running-config startup-config • Changes to the router are automatically put in the running-config file. • If the router loses power or reboots, everything in RAM is lost including the running- config file. • To make sure the changes to the router’s configuration remain saved, you must copy the running-config from RAM into the startup-config into NVRAM: Router# copy running-config startup-config
  • 19. copy running-config startup-config Router# copy running-config startup-config Or Router# copy running startup OR Router# copy run start OR Any usage of the command or parameters, so that they are still uniquely recognizable . WARNING • Using an incorrect configuration file name could overwrite the router’s IOS in flash, as the router believes you are trying to copy a blank file into flash. Router#copy running-config start-up **** NOTICE **** Incorrect file name! Flash load helper v1.0 This process will accept the copy options and then terminate the current system image to use the ROM based image for the copy. Routing functionality will not be available during that time. If you are logged in via telnet, this connection will terminate. Users with console access can see the results of the copy operation. ---- ******** ---- Proceed? [confirm]^C %Copy cancelled by user request. Router# Press <control> C
  • 20. Examining the show commands (typed from Privileged Mode) • Show ip interface Brief: Shows the status of the interfaces along with their IP Addresses • show startup-configuration – Displays the saved configuration located in NVRAM • show running-configuration – Displays the configuration currently running in RAM
  • 21. How to Reset The Router 1. Router> enable 2. Router# erase start (Press enter to confirm): This step erases the configuration file 3. Router# Reload : This step soft-boots the router 4. After the router reloads, the following question will show: “Would you like to enter the setup mode”, Please answer “no” to that question. 5. The router should now take you to user mode: Router> Note: If asked for a password, use the password system in the next slide
  • 22. Router Passwords Used in the Cisco Lab Will not be used for the VoIP Labs Privilege Password cisco Console password conpass VTY 0 4 password vtypass Auxiliary auxpass