SlideShare une entreprise Scribd logo
1  sur  6
Configuration Example 10: Controlling Route Redistribution Based on Tag
Values

In Figure 14-4, Router B is learning six routes via EIGRP. The EIGRP routes are redistributed into OSPF with the
classful routes assigned a tag of 2 and the classless routes a tag of 1. Router A is redistributing the OSPF external routes
into RIP-2. The policy is to redistribute only the classless routes into RIP-2. This can be accomplished using a route map
and an IP access list. Because the external routes have been tagged, a route map can be used that redistributes only routes
with a tag value equal to 1. Configure the routers as shown in the listing that follows the figure. Initially, all OSPF routes
will be redistributed into RIP-2 on Router A.

Figure 14-4 A Route Map Can Be Used to Control Route Redistribution Based on the Tag Value

Router A
interface Loopback0
  ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
  bandwidth 64
  ip address 10.1.1.9 255.255.255.252
  no ip mroute-cache
!
interface Serial0/1
  bandwidth 64
  ip address 10.1.1.1 255.255.255.252
  clockrate 64000
!
router ospf 1
  network 10.1.1.0 0.0.0.3 area 0
!
router rip
  version 2
  redistribute ospf 1 metric 1
  passive-interface Serial0/1
  network 10.0.0.0
  no auto-summary




  Router B
  interface Loopback0
   ip address 2.2.2.2 255.255.255.255
  !
  interface Serial0
   bandwidth 64
   ip address 10.1.1.2 255.255.255.252
   no ip directed-broadcast
  !
  interface Serial1
   bandwidth 64
ip address 10.1.1.5 255.255.255.252
 clockrate 64000
!
!
router eigrp 1
 network 10.0.0.0
!
router ospf 1
 redistribute eigrp 1 subnets route-map set-tags
 network 10.1.1.0 0.0.0.3 area 0
!
access-list 1 permit 6.0.0.0 0.15.255.255
access-list 1 permit 146.6.0.0 0.0.15.255
access-list 1 permit 206.6.6.0 0.0.0.15
access-list 1 permit 10.1.1.4 0.0.0.3
route-map set-tags permit 10
 match ip address 1
 set tag 1
!
route-map set-tags permit 20
 set tag 2




Router C
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
 ip address 5.5.5.5 255.0.0.0
!
interface Loopback2
 ip address 6.6.6.6 255.240.0.0
!
interface Loopback3
 ip address 145.5.5.5 255.255.0.0
!
interface Loopback4
 ip address 146.6.6.6 255.255.240.0
!
interface Loopback5
 ip address 205.5.5.5 255.255.255.0
!
interface Loopback6
 ip address 206.6.6.6 255.255.255.240
!
interface Serial0
 bandwidth 64
 ip address 10.1.1.6 255.255.255.252
 no ip directed-broadcast
!
router eigrp 1
 network 5.0.0.0
 network 6.0.0.0
 network 10.0.0.0
 network 145.5.0.0
 network 146.6.0.0
 network 205.5.5.0
 network 206.6.6.0
 no auto-summary


Router D
interface Serial0/1
 ip address 10.1.1.10 255.255.255.252
 clockrate 64000
!
router rip
 version 2
network 10.0.0.0
Verify that Router D is receiving the redistributed OSPF routes from Router A.




 rtrD#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
 BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
 default
       U - per-user static route, o - ODR
 Gateway of last resort is not set
 R    205.5.5.0/24 [120/1] via 10.1.1.9, 00:00:01, Serial0/1
      206.6.6.0/28 is subnetted, 1 subnets
 R       206.6.6.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
 R    5.0.0.0/8 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      6.0.0.0/12 is subnetted, 1 subnets
 R       6.0.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      172.16.0.0/24 is subnetted, 1 subnets
 R       172.16.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
 R    145.5.0.0/16 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      10.0.0.0/30 is subnetted, 3 subnets
 C       10.1.1.8 is directly connected, Serial0/1
 R       10.1.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
 R       10.1.1.4 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      146.6.0.0/20 is subnetted, 1 subnets
R 146.6.0.0 [120/1] via 10.1.1.9, 00:00:05, Serial0/1
Modify the configuration on Router A so that only OSPF routes with a tag value of 1 get redistributed into
RIP.



 Router A
 router rip
   version 2
   redistribute ospf 1 metric 1 route-map check-tags
   passive-interface Serial0/1
   network 10.0.0.0
   no auto-summary
 !
 route-map check-tags permit 10
match tag 1



Verification

Verify that the only OSPF routes redistributed into RIP on Router A are those routes with a tag value of 1.

 rtrD#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
 BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
 default
       U - per-user static route, o - ODR
 Gateway of last resort is not set
      206.6.6.0/28 is subnetted, 1 subnets
 R       206.6.6.0 [120/1] via 10.1.1.9, 00:00:01, Serial0/1
      6.0.0.0/12 is subnetted, 1 subnets
 R       6.0.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      10.0.0.0/30 is subnetted, 3 subnets
 C       10.1.1.8 is directly connected, Serial0/1
 R       10.1.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
 R       10.1.1.4 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      146.6.0.0/20 is subnetted, 1 subnets
R 146.6.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1

Contenu connexe

Dernier

#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024BookNet Canada
 
A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)Gabriella Davis
 
Breaking the Kubernetes Kill Chain: Host Path Mount
Breaking the Kubernetes Kill Chain: Host Path MountBreaking the Kubernetes Kill Chain: Host Path Mount
Breaking the Kubernetes Kill Chain: Host Path MountPuma Security, LLC
 
Handwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsHandwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsMaria Levchenko
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerThousandEyes
 
[2024]Digital Global Overview Report 2024 Meltwater.pdf
[2024]Digital Global Overview Report 2024 Meltwater.pdf[2024]Digital Global Overview Report 2024 Meltwater.pdf
[2024]Digital Global Overview Report 2024 Meltwater.pdfhans926745
 
Raspberry Pi 5: Challenges and Solutions in Bringing up an OpenGL/Vulkan Driv...
Raspberry Pi 5: Challenges and Solutions in Bringing up an OpenGL/Vulkan Driv...Raspberry Pi 5: Challenges and Solutions in Bringing up an OpenGL/Vulkan Driv...
Raspberry Pi 5: Challenges and Solutions in Bringing up an OpenGL/Vulkan Driv...Igalia
 
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 3652toLead Limited
 
Kalyanpur ) Call Girls in Lucknow Finest Escorts Service 🍸 8923113531 🎰 Avail...
Kalyanpur ) Call Girls in Lucknow Finest Escorts Service 🍸 8923113531 🎰 Avail...Kalyanpur ) Call Girls in Lucknow Finest Escorts Service 🍸 8923113531 🎰 Avail...
Kalyanpur ) Call Girls in Lucknow Finest Escorts Service 🍸 8923113531 🎰 Avail...gurkirankumar98700
 
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptxHampshireHUG
 
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...Miguel Araújo
 
FULL ENJOY 🔝 8264348440 🔝 Call Girls in Diplomatic Enclave | Delhi
FULL ENJOY 🔝 8264348440 🔝 Call Girls in Diplomatic Enclave | DelhiFULL ENJOY 🔝 8264348440 🔝 Call Girls in Diplomatic Enclave | Delhi
FULL ENJOY 🔝 8264348440 🔝 Call Girls in Diplomatic Enclave | Delhisoniya singh
 
Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)Allon Mureinik
 
08448380779 Call Girls In Greater Kailash - I Women Seeking Men
08448380779 Call Girls In Greater Kailash - I Women Seeking Men08448380779 Call Girls In Greater Kailash - I Women Seeking Men
08448380779 Call Girls In Greater Kailash - I Women Seeking MenDelhi Call girls
 
Data Cloud, More than a CDP by Matt Robison
Data Cloud, More than a CDP by Matt RobisonData Cloud, More than a CDP by Matt Robison
Data Cloud, More than a CDP by Matt RobisonAnna Loughnan Colquhoun
 
08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking MenDelhi Call girls
 
WhatsApp 9892124323 ✓Call Girls In Kalyan ( Mumbai ) secure service
WhatsApp 9892124323 ✓Call Girls In Kalyan ( Mumbai ) secure serviceWhatsApp 9892124323 ✓Call Girls In Kalyan ( Mumbai ) secure service
WhatsApp 9892124323 ✓Call Girls In Kalyan ( Mumbai ) secure servicePooja Nehwal
 
A Call to Action for Generative AI in 2024
A Call to Action for Generative AI in 2024A Call to Action for Generative AI in 2024
A Call to Action for Generative AI in 2024Results
 
Enhancing Worker Digital Experience: A Hands-on Workshop for Partners
Enhancing Worker Digital Experience: A Hands-on Workshop for PartnersEnhancing Worker Digital Experience: A Hands-on Workshop for Partners
Enhancing Worker Digital Experience: A Hands-on Workshop for PartnersThousandEyes
 
How to convert PDF to text with Nanonets
How to convert PDF to text with NanonetsHow to convert PDF to text with Nanonets
How to convert PDF to text with Nanonetsnaman860154
 

Dernier (20)

#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
 
A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)
 
Breaking the Kubernetes Kill Chain: Host Path Mount
Breaking the Kubernetes Kill Chain: Host Path MountBreaking the Kubernetes Kill Chain: Host Path Mount
Breaking the Kubernetes Kill Chain: Host Path Mount
 
Handwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsHandwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed texts
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected Worker
 
[2024]Digital Global Overview Report 2024 Meltwater.pdf
[2024]Digital Global Overview Report 2024 Meltwater.pdf[2024]Digital Global Overview Report 2024 Meltwater.pdf
[2024]Digital Global Overview Report 2024 Meltwater.pdf
 
Raspberry Pi 5: Challenges and Solutions in Bringing up an OpenGL/Vulkan Driv...
Raspberry Pi 5: Challenges and Solutions in Bringing up an OpenGL/Vulkan Driv...Raspberry Pi 5: Challenges and Solutions in Bringing up an OpenGL/Vulkan Driv...
Raspberry Pi 5: Challenges and Solutions in Bringing up an OpenGL/Vulkan Driv...
 
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
 
Kalyanpur ) Call Girls in Lucknow Finest Escorts Service 🍸 8923113531 🎰 Avail...
Kalyanpur ) Call Girls in Lucknow Finest Escorts Service 🍸 8923113531 🎰 Avail...Kalyanpur ) Call Girls in Lucknow Finest Escorts Service 🍸 8923113531 🎰 Avail...
Kalyanpur ) Call Girls in Lucknow Finest Escorts Service 🍸 8923113531 🎰 Avail...
 
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
 
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
 
FULL ENJOY 🔝 8264348440 🔝 Call Girls in Diplomatic Enclave | Delhi
FULL ENJOY 🔝 8264348440 🔝 Call Girls in Diplomatic Enclave | DelhiFULL ENJOY 🔝 8264348440 🔝 Call Girls in Diplomatic Enclave | Delhi
FULL ENJOY 🔝 8264348440 🔝 Call Girls in Diplomatic Enclave | Delhi
 
Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)
 
08448380779 Call Girls In Greater Kailash - I Women Seeking Men
08448380779 Call Girls In Greater Kailash - I Women Seeking Men08448380779 Call Girls In Greater Kailash - I Women Seeking Men
08448380779 Call Girls In Greater Kailash - I Women Seeking Men
 
Data Cloud, More than a CDP by Matt Robison
Data Cloud, More than a CDP by Matt RobisonData Cloud, More than a CDP by Matt Robison
Data Cloud, More than a CDP by Matt Robison
 
08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men
 
WhatsApp 9892124323 ✓Call Girls In Kalyan ( Mumbai ) secure service
WhatsApp 9892124323 ✓Call Girls In Kalyan ( Mumbai ) secure serviceWhatsApp 9892124323 ✓Call Girls In Kalyan ( Mumbai ) secure service
WhatsApp 9892124323 ✓Call Girls In Kalyan ( Mumbai ) secure service
 
A Call to Action for Generative AI in 2024
A Call to Action for Generative AI in 2024A Call to Action for Generative AI in 2024
A Call to Action for Generative AI in 2024
 
Enhancing Worker Digital Experience: A Hands-on Workshop for Partners
Enhancing Worker Digital Experience: A Hands-on Workshop for PartnersEnhancing Worker Digital Experience: A Hands-on Workshop for Partners
Enhancing Worker Digital Experience: A Hands-on Workshop for Partners
 
How to convert PDF to text with Nanonets
How to convert PDF to text with NanonetsHow to convert PDF to text with Nanonets
How to convert PDF to text with Nanonets
 

En vedette

PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024Neil Kimberley
 
Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)contently
 
How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024Albert Qian
 
Social Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie InsightsSocial Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie InsightsKurio // The Social Media Age(ncy)
 
Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024Search Engine Journal
 
5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summary5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summarySpeakerHub
 
ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd Clark Boyd
 
Getting into the tech field. what next
Getting into the tech field. what next Getting into the tech field. what next
Getting into the tech field. what next Tessa Mero
 
Google's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search IntentGoogle's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search IntentLily Ray
 
Time Management & Productivity - Best Practices
Time Management & Productivity -  Best PracticesTime Management & Productivity -  Best Practices
Time Management & Productivity - Best PracticesVit Horky
 
The six step guide to practical project management
The six step guide to practical project managementThe six step guide to practical project management
The six step guide to practical project managementMindGenius
 
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...RachelPearson36
 
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...Applitools
 
12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at Work12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at WorkGetSmarter
 
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...DevGAMM Conference
 
Barbie - Brand Strategy Presentation
Barbie - Brand Strategy PresentationBarbie - Brand Strategy Presentation
Barbie - Brand Strategy PresentationErica Santiago
 

En vedette (20)

PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024
 
Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)
 
How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024
 
Social Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie InsightsSocial Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie Insights
 
Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024
 
5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summary5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summary
 
ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd
 
Getting into the tech field. what next
Getting into the tech field. what next Getting into the tech field. what next
Getting into the tech field. what next
 
Google's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search IntentGoogle's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search Intent
 
How to have difficult conversations
How to have difficult conversations How to have difficult conversations
How to have difficult conversations
 
Introduction to Data Science
Introduction to Data ScienceIntroduction to Data Science
Introduction to Data Science
 
Time Management & Productivity - Best Practices
Time Management & Productivity -  Best PracticesTime Management & Productivity -  Best Practices
Time Management & Productivity - Best Practices
 
The six step guide to practical project management
The six step guide to practical project managementThe six step guide to practical project management
The six step guide to practical project management
 
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
 
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
 
12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at Work12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at Work
 
ChatGPT webinar slides
ChatGPT webinar slidesChatGPT webinar slides
ChatGPT webinar slides
 
More than Just Lines on a Map: Best Practices for U.S Bike Routes
More than Just Lines on a Map: Best Practices for U.S Bike RoutesMore than Just Lines on a Map: Best Practices for U.S Bike Routes
More than Just Lines on a Map: Best Practices for U.S Bike Routes
 
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
 
Barbie - Brand Strategy Presentation
Barbie - Brand Strategy PresentationBarbie - Brand Strategy Presentation
Barbie - Brand Strategy Presentation
 

Cisco Ospf Route Redistribution

  • 1. Configuration Example 10: Controlling Route Redistribution Based on Tag Values In Figure 14-4, Router B is learning six routes via EIGRP. The EIGRP routes are redistributed into OSPF with the classful routes assigned a tag of 2 and the classless routes a tag of 1. Router A is redistributing the OSPF external routes into RIP-2. The policy is to redistribute only the classless routes into RIP-2. This can be accomplished using a route map and an IP access list. Because the external routes have been tagged, a route map can be used that redistributes only routes with a tag value equal to 1. Configure the routers as shown in the listing that follows the figure. Initially, all OSPF routes will be redistributed into RIP-2 on Router A. Figure 14-4 A Route Map Can Be Used to Control Route Redistribution Based on the Tag Value Router A interface Loopback0 ip address 1.1.1.1 255.255.255.255 ! interface Serial0/0 bandwidth 64 ip address 10.1.1.9 255.255.255.252 no ip mroute-cache ! interface Serial0/1 bandwidth 64 ip address 10.1.1.1 255.255.255.252 clockrate 64000 ! router ospf 1 network 10.1.1.0 0.0.0.3 area 0 ! router rip version 2 redistribute ospf 1 metric 1 passive-interface Serial0/1 network 10.0.0.0 no auto-summary Router B interface Loopback0 ip address 2.2.2.2 255.255.255.255 ! interface Serial0 bandwidth 64 ip address 10.1.1.2 255.255.255.252 no ip directed-broadcast ! interface Serial1 bandwidth 64
  • 2. ip address 10.1.1.5 255.255.255.252 clockrate 64000 ! ! router eigrp 1 network 10.0.0.0 ! router ospf 1 redistribute eigrp 1 subnets route-map set-tags network 10.1.1.0 0.0.0.3 area 0 ! access-list 1 permit 6.0.0.0 0.15.255.255 access-list 1 permit 146.6.0.0 0.0.15.255 access-list 1 permit 206.6.6.0 0.0.0.15 access-list 1 permit 10.1.1.4 0.0.0.3 route-map set-tags permit 10 match ip address 1 set tag 1 ! route-map set-tags permit 20 set tag 2 Router C interface Loopback0 ip address 3.3.3.3 255.255.255.255 ! interface Loopback1 ip address 5.5.5.5 255.0.0.0 ! interface Loopback2 ip address 6.6.6.6 255.240.0.0 ! interface Loopback3 ip address 145.5.5.5 255.255.0.0
  • 3. ! interface Loopback4 ip address 146.6.6.6 255.255.240.0 ! interface Loopback5 ip address 205.5.5.5 255.255.255.0 ! interface Loopback6 ip address 206.6.6.6 255.255.255.240 ! interface Serial0 bandwidth 64 ip address 10.1.1.6 255.255.255.252 no ip directed-broadcast ! router eigrp 1 network 5.0.0.0 network 6.0.0.0 network 10.0.0.0 network 145.5.0.0 network 146.6.0.0 network 205.5.5.0 network 206.6.6.0 no auto-summary Router D interface Serial0/1 ip address 10.1.1.10 255.255.255.252 clockrate 64000 ! router rip version 2 network 10.0.0.0
  • 4. Verify that Router D is receiving the redistributed OSPF routes from Router A. rtrD#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default U - per-user static route, o - ODR Gateway of last resort is not set R 205.5.5.0/24 [120/1] via 10.1.1.9, 00:00:01, Serial0/1 206.6.6.0/28 is subnetted, 1 subnets R 206.6.6.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 R 5.0.0.0/8 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 6.0.0.0/12 is subnetted, 1 subnets R 6.0.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 172.16.0.0/24 is subnetted, 1 subnets R 172.16.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 R 145.5.0.0/16 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 10.0.0.0/30 is subnetted, 3 subnets C 10.1.1.8 is directly connected, Serial0/1 R 10.1.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 R 10.1.1.4 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 146.6.0.0/20 is subnetted, 1 subnets R 146.6.0.0 [120/1] via 10.1.1.9, 00:00:05, Serial0/1
  • 5. Modify the configuration on Router A so that only OSPF routes with a tag value of 1 get redistributed into RIP. Router A router rip version 2 redistribute ospf 1 metric 1 route-map check-tags passive-interface Serial0/1 network 10.0.0.0 no auto-summary ! route-map check-tags permit 10 match tag 1 Verification Verify that the only OSPF routes redistributed into RIP on Router A are those routes with a tag value of 1. rtrD#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default U - per-user static route, o - ODR Gateway of last resort is not set 206.6.6.0/28 is subnetted, 1 subnets R 206.6.6.0 [120/1] via 10.1.1.9, 00:00:01, Serial0/1 6.0.0.0/12 is subnetted, 1 subnets R 6.0.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 10.0.0.0/30 is subnetted, 3 subnets C 10.1.1.8 is directly connected, Serial0/1 R 10.1.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 R 10.1.1.4 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 146.6.0.0/20 is subnetted, 1 subnets
  • 6. R 146.6.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1