Microsoft Excel 
Les lignes, colonne vertébrale
Pré-requis 
Informer 
Microsoft Excel 
Si() 
EstNa() 
Validation de données 
#NA 
Juillet 2014 
00:20 
RechercheV() 
Liste...
Exemples de données dupliquées 
J’ai une personne 
Je veux stocker 
•Le prénom des enfants 
•Ses divers numéros de télépho...
Les données en colonnes ou lignes ? 
Comment présenter l’information ? 
Faire une colonne par prénom ou numéro ? 
Mettre c...
Un exemple de travail 
Un soucis ! 
•Un projet 
•Référencé par plusieurs codes 
Résolution ! 
•Unifier les codes 
•Un nouv...
Tableau en colonne 
L'utilisateur dispache en 3 colonnes les codes (les codes ont été modifiés sur 3 phases). 
Nous avons ...
Fonctionnement du système 
Saisir ancien code 
Formules de recherche
Principe de recherche 
Rechercher ancien code 
1° colonne 
Trouvé 
Afficher le nouveau code et le service 
Introuvable 
Re...
Trouver la bonne colonne 
=RECHERCHEV(Saisie;$E$7:$I$12;5;FAUX) 
=RECHERCHEV(Saisie;$G$7:$I$12;3;FAUX) 
Pour chaque code 
...
Formules complètes 
Nouveau code 
•=SI(ESTNA(RECHERCHEV(Saisie;$C$7:$I$12;7;FAUX)); SI(ESTNA(RECHERCHEV(Saisie;$E$7:$I$12;...
Discuter du modèle 
Formule indigeste ! 
Quid ! Liste de choix saisie ancien code ? 
Nous n’avons pas une telle liste ! 
C...
Tableau en ligne 
Se débarrasser des informations inutiles. 
Tableau plus compact.
Une recherche simplifiée 
Nouveau code 
•=RECHERCHEV(Saisie;$C$7:$E$12;3;FAUX) 
Service 
•=RECHERCHEV(Saisie;$C$7:$E$12;2;...
Avantages constatés 
Liste de choix saisie ancien code ? 
Possible, nous avons une telle liste ! 
Code ? 
DEP_XX 
La formu...
Merci qui ! 
Pompe-au-net.fr
Prochain SlideShare
Chargement dans…5
×

Travailler en lignes ou colonnes avec Microsoft Excel ?

452 vues

Publié le

Souvent nous devons dupliquer des l'information – plusieurs numéros de téléphone, plusieurs enfants, etc.).
Quelle est la structure de tableau la plus efficace ?

Publié dans : Logiciels
0 commentaire
0 j’aime
Statistiques
Remarques
  • Soyez le premier à commenter

  • Soyez le premier à aimer ceci

Aucun téléchargement
Vues
Nombre de vues
452
Sur SlideShare
0
Issues des intégrations
0
Intégrations
84
Actions
Partages
0
Téléchargements
6
Commentaires
0
J’aime
0
Intégrations 0
Aucune incorporation

Aucune remarque pour cette diapositive

Travailler en lignes ou colonnes avec Microsoft Excel ?

  1. 1. Microsoft Excel Les lignes, colonne vertébrale
  2. 2. Pré-requis Informer Microsoft Excel Si() EstNa() Validation de données #NA Juillet 2014 00:20 RechercheV() Listes de choix
  3. 3. Exemples de données dupliquées J’ai une personne Je veux stocker •Le prénom des enfants •Ses divers numéros de téléphones
  4. 4. Les données en colonnes ou lignes ? Comment présenter l’information ? Faire une colonne par prénom ou numéro ? Mettre ces données en ligne ?
  5. 5. Un exemple de travail Un soucis ! •Un projet •Référencé par plusieurs codes Résolution ! •Unifier les codes •Un nouveau code remplace les anciens Besoin ! •Saisir un ancien code •Le système affiche •Le nouveau code •Le service à l’origine du code
  6. 6. Tableau en colonne L'utilisateur dispache en 3 colonnes les codes (les codes ont été modifiés sur 3 phases). Nous avons besoin du service à l’origine de la modification. À aucun moment nous n’avons besoin •Connaître la phase où le code a été modifié. •Savoir s'il a été ou non modifié sur une phase précise.
  7. 7. Fonctionnement du système Saisir ancien code Formules de recherche
  8. 8. Principe de recherche Rechercher ancien code 1° colonne Trouvé Afficher le nouveau code et le service Introuvable Rechercher ancien code 2° colonne 1 2 3 Valeur cherchée Résultat Trouvé Introuvable Rechercher ancien code 3° colonne
  9. 9. Trouver la bonne colonne =RECHERCHEV(Saisie;$E$7:$I$12;5;FAUX) =RECHERCHEV(Saisie;$G$7:$I$12;3;FAUX) Pour chaque code •Le tableau de recherche se décale de 2 colonnes * * Même principe pour le service.
  10. 10. Formules complètes Nouveau code •=SI(ESTNA(RECHERCHEV(Saisie;$C$7:$I$12;7;FAUX)); SI(ESTNA(RECHERCHEV(Saisie;$E$7:$I$12;5;FAUX)); SI(ESTNA(RECHERCHEV(Saisie;$G$7:$I$12;3;FAUX)); ""; RECHERCHEV(Saisie;$G$7:$I$12;3;FAUX));RECHERCHEV(Saisie;$E$7:$I$12;5;FAUX)); RECHERCHEV(Saisie;$C$7:$I$12;7;FAUX)) Service •=SI(ESTNA(RECHERCHEV(Saisie;$C$7:$I$12;2;FAUX)); SI(ESTNA(RECHERCHEV(Saisie;$E$7:$I$12;2;FAUX)) SI(ESTNA(RECHERCHEV(Saisie;$G$7:$I$12;2;FAUX));""; RECHERCHEV(Saisie;$G$7:$I$12;2;FAUX));RECHERCHEV(Saisie;$E$7:$I$12;2;FAUX)); RECHERCHEV(Saisie;$C$7:$I$12;2;FAUX))
  11. 11. Discuter du modèle Formule indigeste ! Quid ! Liste de choix saisie ancien code ? Nous n’avons pas une telle liste ! Code ? DEP_XX La formule doit être modifiée ? Penser à le faire sur les 3 colonnes ! Besoin de statistiques sur une information ? Référencer plusieurs colonnes pour calculer ! Besoin d’une autre information ? Dispatcher l’information sur 3 colonnes ! Les coordonnées des colonnes de recherche changent Retoucher les formules
  12. 12. Tableau en ligne Se débarrasser des informations inutiles. Tableau plus compact.
  13. 13. Une recherche simplifiée Nouveau code •=RECHERCHEV(Saisie;$C$7:$E$12;3;FAUX) Service •=RECHERCHEV(Saisie;$C$7:$E$12;2;FAUX
  14. 14. Avantages constatés Liste de choix saisie ancien code ? Possible, nous avons une telle liste ! Code ? DEP_XX La formule doit être modifiée ? À faire pour une seule colonne ! Besoin d’une autre information ? Une seule colonne à manipuler ! Formule largement amaigrie ! Plus besoin de tester plusieurs colonnes ! Besoin de statistiques sur une information ? Référencer une seule colonne pour calculer !
  15. 15. Merci qui ! Pompe-au-net.fr

×