SlideShare une entreprise Scribd logo
1  sur  16
Télécharger pour lire hors ligne
CCNA All Commands
Page 1 of 16
CCNA Routing & Switching Commands
IP ROUTING
To view IP routing tables created on a Cisco router.
#sh ip route
Static Routing- Routers are manually configured for networks that are not directly connected,
to be able to route to all networks via the next-hop interface.
Example- Let 192.168.30.0/24 be the IP of a network not directly connected Let 192.168.20.2 be
the next hop interface
(config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2
To remove static route
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2
Default Routing- Used on stub networks only to send packets with remote destination network
not in the routing table to the next hop router
Assume IP 192.168.40.1 is not in routing table
first remove static route
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.40.1
(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1
CCNA All Commands
Page 2 of 16
RIP-A distance vector routing protocol that passes complete routing table contents to
neighbouring routers
Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces
and 192.168.30.0 be non-directly connected
first delete all static routes
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2
(config)#router rip
(config-router)#192.168.10.0
(config-router)#192.168.20.0
(config-router)#^z
Verifying RIP
1.Sh ip route
2.debug ip
Holding Down RIP Propagation-To stop RIP update sending but allow its receipt -say for s0/0
with ip 192.168.10.0
(config)#router rip
(config-router)#network 192.168.10.0
(config-router)#passive-interface serial 0/0
CCNA All Commands
Page 3 of 16
IGRP-Also a distance routing protocol
Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces
with autonomous system number of 10 and 192.168.30.0 be non-directly connected
#router igrp 10
(config-router)#network 192.168.10.0
(config-router)#network 192.168.20.0
(config-router)#^z
Verifying IGRP
sh ip route
Displays routed protocols and their interfaces
sh protocols
Displays routing protocols configured
sh ip protocols
Displays summary of IGRP routing information running on the network
debug igrp events
Displays messages request from neighbour routers
debug igrp transactions
Turning off all possible
debugging #un all
CCNA All Commands
Page 4 of 16
EIGRP-Uses classless routing which is subnet mask information sent with routing protocol
updates.
Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces
with autonomous system number of 20 and 192.168.30.0 be non-directly connected
1. #router eigrp 20
2. (config-router)#network 192.168.10.0
3. (config-router)#network 192.168.20.0
4. (config-router)#^z
To stop EIGRP from working on an interface-no sending no receipt
(config)#router eigrp 20
(config-router)#passive-interface serial 0/0
To enable EIGRP on discontiguos networks(two different subnetworks of classfull network
connected by another different classful subnetwork)
Example- Let 172.16.0.0 & 10.0.0.0 be directly connected to a router to another remote
subnetwork of 192.168.10.0, then to enable EIGRP, we use
1. (config)#router eigrp 100
2. (config-router)#network 172.16.0.0
3. (config-router)#network 10.0.0.0
4. (config-router)#no auto-summary
N.B-The no auto-summary command sholuld be enabled in routers that encloses such networks.
Verifying EIGRP
sh ip route- Shows entire routing table
sh ip route eigrp- Shows only EIGRP entries in the routing table
ip eigrp neighbours- Shows all EIGRP neighbours
ip eigrp topology- Shows entries in the EIGRP topology table
CCNA All Commands
Page 5 of 16
OSPF- A link-state routing protocol
Example- Let 10.0.0.0 be the network directly connected to the router upon which OSPF is to be
enabled; with ospf ID of 1 and area o
1. (config)#router ospf 1
2. (config-router)#network 10.0.0.0 0.255.255.255 area0
Loopback Interface- They are configured to be used as the routers RID to advertise the routes
and elect DR and BDR.
Example- Let the loopback iinterface be configured on interface with ip 172.16.10.1
(config)#int loopback 0
(config-if)#ip address 172.16.10.1 255.255.255.0
(config-if)#no shut
(config-if)#^z
Verifying OSPF Configuration
Used to display all OSPF information
sho ip ospf
indicates the number of links and neighboring router ID
sho ip ospf database
Displays all OSPF interface related info
sho ip ospf interface
Summarizes OSPF info about neighbours
sho ip ospf neighbour
Overview of all present running protocols
sho ip protocols
CCNA All Commands
Page 6 of 16
Verifying Loopback and RID
To verify loopback address
sho running-config
Verifies the new RID of each router
sho ip ospf database
Verifies the new RID of each router
sho ip ospf interface
Initial configuration of a 1900 Switch with ip 172.16.10.16
>en
#config t
(config)#enable password level 1 kennifeh
(config)#enable password level 15 kennifeh 1
(config)#enable secret kennifeh 2 (when enabled no need 4 enable password)
(config)#hostname kenn 1900
(config)#ip address 172.16.10.16 255.255.255.0
(config)#ip default-gateway 172.16.10.1 (config)#int f0/1
(config-if)#description Finance_vlan (No space for 1900)
(config-if)#int f0/26
(config-if)#description Trunk_to_Biulding
(config-if)#exit
CCNA All Commands
Page 7 of 16
Initail Configuration of 2950 Switch with ip 172.16.10.17 255.255.255.0
>en
#config t(config)#hostame kenn2950
(config)#enable password kenn
(config)#enable password kenn1 (enable and enable secret password must be different)
(config)#line vty 0 15
(config-line)#login
(config-line)#password telnet
(config-line)#line con 0
(config-line)#login
(config-line)#password console
(config-line)#exit
(config)#int vlan 1
(config-if)#ip address 172.16.10.17 255.255.255.0
(config-if)#no shut
(config-if)#int f0/1
(config-if)#description sales printer(with space)
(config-if)#int f0/12
(config-if)description connection to backbone
(config-if)#exit
(config)#ip default-gateway 172.16.10.1
(config)
Erasing Switching Configuration 1900
#delete nvram yes
Erasing Switching Configuration 2950
#erase startup-config Enter
CCNA All Commands
Page 8 of 16
Configuring VLANS 1900
>en #config t
(config)#vlan 2 name Cisco
(config)#vlan 3 name Microsoft
(config)#vlan 4 name Comptia
(config)#exit
Verify with command
sh run
Configuring for 2950
>en
#vlan database
(vlan)#vlan 2 name Cisco
(vlan)#vlan 3 name Microsoft
(vlan)#vlan 4 name Comptia (vlan)#apply
(vlan)#^c
Verify with command sh vlan brief
Assigning Switch Ports To Vlan-1900
(config)#int e0/2
(config-if)#vlan-membership static 2
(config-if)#int e0/3
(config-if)#vlan-membership static 3
(config-if)#exit
Verify with
sh vlan
CCNA All Commands
Page 9 of 16
Assigning Switch Ports To Vlan-2950
(config)#int f0/2
(config-if)#switchport access vlan 2
(config-if)#int f0/3
(config-t)#switchport access vlan 3
(config-if)#int f0/4
(config-if)#switchport access vlan 4
(config-if)#verify with sh vlan brief
Configuring Trunks ports
(config)#int f0/26
(config-if)#trunk on
Configuring Trunk Ports for 2950
(config)#int f0/12
(config-if)#switchport mode trunk
(config-if)#^z
To disable Trunk use
switchport mode access
To verify Trunking use
sh running config
CCNA All Commands
Page 10 of 16
Configuring Inter-vlan Routing for 1900 connecting to 2600
(config)#int f0/0.1
(config-if)#encapsulation isl vlan (d number)
Configuring Inter-vlan Routing for 2950 connecting to 2600
(config)#int f0/0.1
(config-if)#encapsulation dot1q vlan (d number)
Configuring VTP for 1900
(config)#vtp server
(config)vtp domain kenn
(config)#vtp password kenn
Configuring VTP for 2950
(config)#vtp mode server
(config)#vtp domain routersim
(config)#^z
Verify with
sh vtp status
CCNA All Commands
Page 11 of 16
Checking the Current Configuration Register Values
Show version or show ver
Changing Configuration Register
(config)#config-register 0x101 (d default is 0x2102) (config)#^z
Recovering Passwords
Interrupt the Router Boot Sequene
ctrl+Break key (windows wont perform break key, only 95/98)
Changing the configuration register -for 2600 series router
rammon>confreg 0x2142
for 2500 - type 0 after a break and enter the command o/r 0x2142
Reloading the Router and Entering Privilged mode - for 2600 - type reset
Viewing and changing the configuration - copy run start
Resetting the configuration Register and Reloading the Router - config t
Backing up and restoring the Cisco ios
verifying flash memory - Ensuring flash memory has enough
room router#sh flash
Backing-up the ciso ios
first verify server connectivity by-
Router#ping 192.168.0.120
then; router#copy flash tftp
CCNA All Commands
Page 12 of 16
Restoring or upgrading the cisco router
ios router#copy tftp flash
[confirm][ENTER]
?[ENTER]
Backing up and Restoring the Cisco configuration
Backing up the cisco router configuration
copy runing config tftp
Verifying the current configuration
sh run
copying the current cofiguration to NVRAM
copy run start
copying the current configuration to a TFTP server
copy run TFTP
Restoring the Cisco Router Configuration
copy TFTP run
Erasing the configuration
erase startup-config
CCNA All Commands
Page 13 of 16
Getting CDP timers and Holdtime
information Router#config t
Router(config)#cdp timer 90
Router(config)#cdp holdtime 240
Router(config)#^z
To turn-off CDP Completely
no cdp run
Gathering Neighbour information
kenn2509#sh cdp nei
delivers information about directly connected devices or
kenn2509#sh cdp neighbour detail
Also sh cdp entry
Gathering Interface Traffic Information
kenn2509#sh cdp traffic
Gathering port and Interface
information kenn2509#sh cdp interface
To turn off cdp on a router,
use no cdp enable
then ^z
CCNA All Commands
Page 14 of 16
Using Telnet
kenn2509#telnet 172.16.10.2
Telnetting into multiple devices
simultaneously kenn2509#telnet 172.16.10.2
then, 2501B>{cntl+shift+6, then x}
Checking Telnet connections
kenn2509#sh sessions - connections from your router to remote
Checking Telnet users
kenn2509#sh user
Closing Telnet sessions
1900switch>exit OR
kenn2509#disconnect1 (num of active networks)
CCNA All Commands
Page 15 of 16
Resolving Hostname
kenn2509#config t
kenn2509(config)#ip host 2501B 172.16.10.2
kenn2509(config)#ip host 1900switch 192.168.0.148
kenn2509(config)#^z
To remove a hostname from a table, use
RouterA(config)#no ip host routerB
Using DNS to resolve names
#config t
(config)#ip domain-lookup (usually turned on by default)
(config)#ip name-server 192.168.0.70 (ip of an assumed DNS set)
(config)#ip domain-name kenn.com (Appends the domain name to a host)
(config)#^z
Check Network Connectivity use ping command
#ping kenn2509
Using Traceroute command
#trace 2501B
CCNA All Commands
Page 16 of 16
Access Lists
Creating a Standard Access Lists (1-99 or 1,300-1,999)
(config)#access-list 10 deny 172.16.30.2 (using the ip as a test)
Controlling vty(Telnet) sessions
(config)#access-list 50 permit 172.16.30.2
(config)#line vty 0 4
(config-line)#access-class 50 in
Creating Extended Access-lists (100 to 199) OR (2000 to 2699)
(config)#access-list 110 deny tcp any host 172.16.30.2 eq 23 log
(config)#access-list 110 permit ip any any
(config)#int f0/0
(config-if)#ip access-group 110 in
(config-if)#ipaccess-group 110 out

Contenu connexe

Tendances

Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)DH Da Lat
 
CCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPTCCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPTNishant Goel
 
CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01Irsandi Hasan
 
Cisco ACL
Cisco ACLCisco ACL
Cisco ACLfaust0
 
Ccna ppt1
Ccna ppt1Ccna ppt1
Ccna ppt1AIRTEL
 
Encor chapter 1_packet forwarding
Encor chapter 1_packet forwardingEncor chapter 1_packet forwarding
Encor chapter 1_packet forwardingmerhatsidikmelke
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And AnswersCCNAResources
 
CCNA 2 Routing and Switching v5.0 Chapter 8
CCNA 2 Routing and Switching v5.0 Chapter 8CCNA 2 Routing and Switching v5.0 Chapter 8
CCNA 2 Routing and Switching v5.0 Chapter 8Nil Menon
 
CCNA Routing Protocols
CCNA Routing ProtocolsCCNA Routing Protocols
CCNA Routing ProtocolsDsunte Wilson
 
CCNA v6.0 ITN - Chapter 02
CCNA v6.0 ITN - Chapter 02CCNA v6.0 ITN - Chapter 02
CCNA v6.0 ITN - Chapter 02Irsandi Hasan
 
CCNA 2 Routing and Switching v5.0 Chapter 11
CCNA 2 Routing and Switching v5.0 Chapter 11CCNA 2 Routing and Switching v5.0 Chapter 11
CCNA 2 Routing and Switching v5.0 Chapter 11Nil Menon
 
CCNA 2 Routing and Switching v5.0 Chapter 9
CCNA 2 Routing and Switching v5.0 Chapter 9CCNA 2 Routing and Switching v5.0 Chapter 9
CCNA 2 Routing and Switching v5.0 Chapter 9Nil Menon
 
Cisco router-commands
Cisco router-commandsCisco router-commands
Cisco router-commandsRobin Rohit
 
6.5.1.3 packet tracer layer 2 vlan security instructor
6.5.1.3 packet tracer   layer 2 vlan security instructor6.5.1.3 packet tracer   layer 2 vlan security instructor
6.5.1.3 packet tracer layer 2 vlan security instructorSalem Trabelsi
 

Tendances (20)

CCNA IP Addressing
CCNA IP AddressingCCNA IP Addressing
CCNA IP Addressing
 
OSPF
OSPF OSPF
OSPF
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
 
CCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPTCCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPT
 
CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01
 
Cisco ACL
Cisco ACLCisco ACL
Cisco ACL
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
 
Ccna ppt1
Ccna ppt1Ccna ppt1
Ccna ppt1
 
Encor chapter 1_packet forwarding
Encor chapter 1_packet forwardingEncor chapter 1_packet forwarding
Encor chapter 1_packet forwarding
 
CCNA Lab Guide
CCNA Lab GuideCCNA Lab Guide
CCNA Lab Guide
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And Answers
 
ccna networking ppt
ccna networking pptccna networking ppt
ccna networking ppt
 
CCNA 2 Routing and Switching v5.0 Chapter 8
CCNA 2 Routing and Switching v5.0 Chapter 8CCNA 2 Routing and Switching v5.0 Chapter 8
CCNA 2 Routing and Switching v5.0 Chapter 8
 
CCNA Routing Protocols
CCNA Routing ProtocolsCCNA Routing Protocols
CCNA Routing Protocols
 
Dynamic routing protocols (CCNA)
Dynamic routing protocols (CCNA)Dynamic routing protocols (CCNA)
Dynamic routing protocols (CCNA)
 
CCNA v6.0 ITN - Chapter 02
CCNA v6.0 ITN - Chapter 02CCNA v6.0 ITN - Chapter 02
CCNA v6.0 ITN - Chapter 02
 
CCNA 2 Routing and Switching v5.0 Chapter 11
CCNA 2 Routing and Switching v5.0 Chapter 11CCNA 2 Routing and Switching v5.0 Chapter 11
CCNA 2 Routing and Switching v5.0 Chapter 11
 
CCNA 2 Routing and Switching v5.0 Chapter 9
CCNA 2 Routing and Switching v5.0 Chapter 9CCNA 2 Routing and Switching v5.0 Chapter 9
CCNA 2 Routing and Switching v5.0 Chapter 9
 
Cisco router-commands
Cisco router-commandsCisco router-commands
Cisco router-commands
 
6.5.1.3 packet tracer layer 2 vlan security instructor
6.5.1.3 packet tracer   layer 2 vlan security instructor6.5.1.3 packet tracer   layer 2 vlan security instructor
6.5.1.3 packet tracer layer 2 vlan security instructor
 

En vedette

Switch configuration (command)
Switch configuration (command)Switch configuration (command)
Switch configuration (command)Muhammad Ibrahim
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer) Arz Sy
 
Step by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet TracerStep by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet TracerSorath Asnani
 
Routers and Routing Configuration
Routers and Routing ConfigurationRouters and Routing Configuration
Routers and Routing Configurationyasir1122
 
Router configuration in packet tracer
Router configuration in packet  tracerRouter configuration in packet  tracer
Router configuration in packet tracerAnabia Anabia
 
Increase internet speed by 20%
Increase internet speed by 20%Increase internet speed by 20%
Increase internet speed by 20%usamaali213
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorialIT Tech
 
37 en-1-especificaciones
37 en-1-especificaciones37 en-1-especificaciones
37 en-1-especificacionesIVAN GAVILAN
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic ConfigurationProf. Erwin Globio
 

En vedette (14)

Switch configuration (command)
Switch configuration (command)Switch configuration (command)
Switch configuration (command)
 
Ccna full
Ccna fullCcna full
Ccna full
 
Router commands
Router commandsRouter commands
Router commands
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer)
 
Step by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet TracerStep by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet Tracer
 
Routers and Routing Configuration
Routers and Routing ConfigurationRouters and Routing Configuration
Routers and Routing Configuration
 
Router configuration in packet tracer
Router configuration in packet  tracerRouter configuration in packet  tracer
Router configuration in packet tracer
 
Ccna concepts
Ccna conceptsCcna concepts
Ccna concepts
 
Increase internet speed by 20%
Increase internet speed by 20%Increase internet speed by 20%
Increase internet speed by 20%
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorial
 
37 en-1-especificaciones
37 en-1-especificaciones37 en-1-especificaciones
37 en-1-especificaciones
 
CCNA CheatSheet
CCNA CheatSheetCCNA CheatSheet
CCNA CheatSheet
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic Configuration
 
Ccna notes
Ccna notesCcna notes
Ccna notes
 

Similaire à CCNA - Routing & Switching Commands

Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands listactsupport .com
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2MAFANTIRI SELLO
 
Routing information protocol & rip configuration
Routing information protocol & rip configurationRouting information protocol & rip configuration
Routing information protocol & rip configuration3Anetwork com
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)IT Tech
 
How to configure frame realy
How to configure frame realyHow to configure frame realy
How to configure frame realyNetProtocol Xpert
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame RelayTharindu Sankalpa
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheetGuntaka Reddy
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheetEZREIG OMAR
 
VRF Configuration
VRF ConfigurationVRF Configuration
VRF ConfigurationNetwax Lab
 
Ciso 4 ospf
Ciso 4 ospfCiso 4 ospf
Ciso 4 ospfmyciokas
 

Similaire à CCNA - Routing & Switching Commands (20)

Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01
 
Ccna command
Ccna commandCcna command
Ccna command
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commands   Ccna commands
Ccna commands
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands list
 
Networking Lab Report
Networking Lab ReportNetworking Lab Report
Networking Lab Report
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2
 
Routing information protocol & rip configuration
Routing information protocol & rip configurationRouting information protocol & rip configuration
Routing information protocol & rip configuration
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)
 
How to configure frame realy
How to configure frame realyHow to configure frame realy
How to configure frame realy
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame Relay
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
VRF Configuration
VRF ConfigurationVRF Configuration
VRF Configuration
 
Ciso 4 ospf
Ciso 4 ospfCiso 4 ospf
Ciso 4 ospf
 
Ccna command
Ccna commandCcna command
Ccna command
 

Plus de Eng. Emad Al-Atoum

Plus de Eng. Emad Al-Atoum (12)

Mind Mapping
Mind MappingMind Mapping
Mind Mapping
 
How to Build Your Own Power Supply
How to Build Your Own Power SupplyHow to Build Your Own Power Supply
How to Build Your Own Power Supply
 
CCNA 200-120 Exam Quick Notes
CCNA 200-120 Exam Quick NotesCCNA 200-120 Exam Quick Notes
CCNA 200-120 Exam Quick Notes
 
Ccna 200-120 Exam Dumps
Ccna 200-120 Exam DumpsCcna 200-120 Exam Dumps
Ccna 200-120 Exam Dumps
 
CCNA 200-120 Exam Questions
CCNA 200-120 Exam QuestionsCCNA 200-120 Exam Questions
CCNA 200-120 Exam Questions
 
NAT- Network Address Translation
NAT- Network Address TranslationNAT- Network Address Translation
NAT- Network Address Translation
 
Fast and Easy Subnetting
Fast and Easy SubnettingFast and Easy Subnetting
Fast and Easy Subnetting
 
CISCO Exact Questions By: Konard
CISCO Exact Questions By: KonardCISCO Exact Questions By: Konard
CISCO Exact Questions By: Konard
 
CCNA Quick Notes
CCNA Quick NotesCCNA Quick Notes
CCNA Quick Notes
 
CCNA Dec, 2015 Questions
CCNA Dec, 2015 QuestionsCCNA Dec, 2015 Questions
CCNA Dec, 2015 Questions
 
50 Impossible Quotes
50 Impossible Quotes50 Impossible Quotes
50 Impossible Quotes
 
CCNA Exam Question
CCNA Exam QuestionCCNA Exam Question
CCNA Exam Question
 

Dernier

Accessible Digital Futures project (20/03/2024)
Accessible Digital Futures project (20/03/2024)Accessible Digital Futures project (20/03/2024)
Accessible Digital Futures project (20/03/2024)Jisc
 
Spellings Wk 3 English CAPS CARES Please Practise
Spellings Wk 3 English CAPS CARES Please PractiseSpellings Wk 3 English CAPS CARES Please Practise
Spellings Wk 3 English CAPS CARES Please PractiseAnaAcapella
 
Basic Civil Engineering first year Notes- Chapter 4 Building.pptx
Basic Civil Engineering first year Notes- Chapter 4 Building.pptxBasic Civil Engineering first year Notes- Chapter 4 Building.pptx
Basic Civil Engineering first year Notes- Chapter 4 Building.pptxDenish Jangid
 
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptxMaritesTamaniVerdade
 
Towards a code of practice for AI in AT.pptx
Towards a code of practice for AI in AT.pptxTowards a code of practice for AI in AT.pptx
Towards a code of practice for AI in AT.pptxJisc
 
Graduate Outcomes Presentation Slides - English
Graduate Outcomes Presentation Slides - EnglishGraduate Outcomes Presentation Slides - English
Graduate Outcomes Presentation Slides - Englishneillewis46
 
ICT role in 21st century education and it's challenges.
ICT role in 21st century education and it's challenges.ICT role in 21st century education and it's challenges.
ICT role in 21st century education and it's challenges.MaryamAhmad92
 
Holdier Curriculum Vitae (April 2024).pdf
Holdier Curriculum Vitae (April 2024).pdfHoldier Curriculum Vitae (April 2024).pdf
Holdier Curriculum Vitae (April 2024).pdfagholdier
 
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdfUGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdfNirmal Dwivedi
 
Jual Obat Aborsi Hongkong ( Asli No.1 ) 085657271886 Obat Penggugur Kandungan...
Jual Obat Aborsi Hongkong ( Asli No.1 ) 085657271886 Obat Penggugur Kandungan...Jual Obat Aborsi Hongkong ( Asli No.1 ) 085657271886 Obat Penggugur Kandungan...
Jual Obat Aborsi Hongkong ( Asli No.1 ) 085657271886 Obat Penggugur Kandungan...ZurliaSoop
 
Single or Multiple melodic lines structure
Single or Multiple melodic lines structureSingle or Multiple melodic lines structure
Single or Multiple melodic lines structuredhanjurrannsibayan2
 
General Principles of Intellectual Property: Concepts of Intellectual Proper...
General Principles of Intellectual Property: Concepts of Intellectual  Proper...General Principles of Intellectual Property: Concepts of Intellectual  Proper...
General Principles of Intellectual Property: Concepts of Intellectual Proper...Poonam Aher Patil
 
Application orientated numerical on hev.ppt
Application orientated numerical on hev.pptApplication orientated numerical on hev.ppt
Application orientated numerical on hev.pptRamjanShidvankar
 
This PowerPoint helps students to consider the concept of infinity.
This PowerPoint helps students to consider the concept of infinity.This PowerPoint helps students to consider the concept of infinity.
This PowerPoint helps students to consider the concept of infinity.christianmathematics
 
How to Give a Domain for a Field in Odoo 17
How to Give a Domain for a Field in Odoo 17How to Give a Domain for a Field in Odoo 17
How to Give a Domain for a Field in Odoo 17Celine George
 
Kodo Millet PPT made by Ghanshyam bairwa college of Agriculture kumher bhara...
Kodo Millet  PPT made by Ghanshyam bairwa college of Agriculture kumher bhara...Kodo Millet  PPT made by Ghanshyam bairwa college of Agriculture kumher bhara...
Kodo Millet PPT made by Ghanshyam bairwa college of Agriculture kumher bhara...pradhanghanshyam7136
 
The basics of sentences session 3pptx.pptx
The basics of sentences session 3pptx.pptxThe basics of sentences session 3pptx.pptx
The basics of sentences session 3pptx.pptxheathfieldcps1
 
1029 - Danh muc Sach Giao Khoa 10 . pdf
1029 -  Danh muc Sach Giao Khoa 10 . pdf1029 -  Danh muc Sach Giao Khoa 10 . pdf
1029 - Danh muc Sach Giao Khoa 10 . pdfQucHHunhnh
 

Dernier (20)

Accessible Digital Futures project (20/03/2024)
Accessible Digital Futures project (20/03/2024)Accessible Digital Futures project (20/03/2024)
Accessible Digital Futures project (20/03/2024)
 
Spellings Wk 3 English CAPS CARES Please Practise
Spellings Wk 3 English CAPS CARES Please PractiseSpellings Wk 3 English CAPS CARES Please Practise
Spellings Wk 3 English CAPS CARES Please Practise
 
Basic Civil Engineering first year Notes- Chapter 4 Building.pptx
Basic Civil Engineering first year Notes- Chapter 4 Building.pptxBasic Civil Engineering first year Notes- Chapter 4 Building.pptx
Basic Civil Engineering first year Notes- Chapter 4 Building.pptx
 
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
 
Towards a code of practice for AI in AT.pptx
Towards a code of practice for AI in AT.pptxTowards a code of practice for AI in AT.pptx
Towards a code of practice for AI in AT.pptx
 
Graduate Outcomes Presentation Slides - English
Graduate Outcomes Presentation Slides - EnglishGraduate Outcomes Presentation Slides - English
Graduate Outcomes Presentation Slides - English
 
ICT role in 21st century education and it's challenges.
ICT role in 21st century education and it's challenges.ICT role in 21st century education and it's challenges.
ICT role in 21st century education and it's challenges.
 
Holdier Curriculum Vitae (April 2024).pdf
Holdier Curriculum Vitae (April 2024).pdfHoldier Curriculum Vitae (April 2024).pdf
Holdier Curriculum Vitae (April 2024).pdf
 
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdfUGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
 
Jual Obat Aborsi Hongkong ( Asli No.1 ) 085657271886 Obat Penggugur Kandungan...
Jual Obat Aborsi Hongkong ( Asli No.1 ) 085657271886 Obat Penggugur Kandungan...Jual Obat Aborsi Hongkong ( Asli No.1 ) 085657271886 Obat Penggugur Kandungan...
Jual Obat Aborsi Hongkong ( Asli No.1 ) 085657271886 Obat Penggugur Kandungan...
 
Mehran University Newsletter Vol-X, Issue-I, 2024
Mehran University Newsletter Vol-X, Issue-I, 2024Mehran University Newsletter Vol-X, Issue-I, 2024
Mehran University Newsletter Vol-X, Issue-I, 2024
 
Single or Multiple melodic lines structure
Single or Multiple melodic lines structureSingle or Multiple melodic lines structure
Single or Multiple melodic lines structure
 
General Principles of Intellectual Property: Concepts of Intellectual Proper...
General Principles of Intellectual Property: Concepts of Intellectual  Proper...General Principles of Intellectual Property: Concepts of Intellectual  Proper...
General Principles of Intellectual Property: Concepts of Intellectual Proper...
 
Application orientated numerical on hev.ppt
Application orientated numerical on hev.pptApplication orientated numerical on hev.ppt
Application orientated numerical on hev.ppt
 
This PowerPoint helps students to consider the concept of infinity.
This PowerPoint helps students to consider the concept of infinity.This PowerPoint helps students to consider the concept of infinity.
This PowerPoint helps students to consider the concept of infinity.
 
How to Give a Domain for a Field in Odoo 17
How to Give a Domain for a Field in Odoo 17How to Give a Domain for a Field in Odoo 17
How to Give a Domain for a Field in Odoo 17
 
Kodo Millet PPT made by Ghanshyam bairwa college of Agriculture kumher bhara...
Kodo Millet  PPT made by Ghanshyam bairwa college of Agriculture kumher bhara...Kodo Millet  PPT made by Ghanshyam bairwa college of Agriculture kumher bhara...
Kodo Millet PPT made by Ghanshyam bairwa college of Agriculture kumher bhara...
 
Spatium Project Simulation student brief
Spatium Project Simulation student briefSpatium Project Simulation student brief
Spatium Project Simulation student brief
 
The basics of sentences session 3pptx.pptx
The basics of sentences session 3pptx.pptxThe basics of sentences session 3pptx.pptx
The basics of sentences session 3pptx.pptx
 
1029 - Danh muc Sach Giao Khoa 10 . pdf
1029 -  Danh muc Sach Giao Khoa 10 . pdf1029 -  Danh muc Sach Giao Khoa 10 . pdf
1029 - Danh muc Sach Giao Khoa 10 . pdf
 

CCNA - Routing & Switching Commands

  • 1. CCNA All Commands Page 1 of 16 CCNA Routing & Switching Commands IP ROUTING To view IP routing tables created on a Cisco router. #sh ip route Static Routing- Routers are manually configured for networks that are not directly connected, to be able to route to all networks via the next-hop interface. Example- Let 192.168.30.0/24 be the IP of a network not directly connected Let 192.168.20.2 be the next hop interface (config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2 To remove static route (config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2 Default Routing- Used on stub networks only to send packets with remote destination network not in the routing table to the next hop router Assume IP 192.168.40.1 is not in routing table first remove static route (config)#no ip route 192.168.30.0 255.255.255.0 192.168.40.1 (config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1
  • 2. CCNA All Commands Page 2 of 16 RIP-A distance vector routing protocol that passes complete routing table contents to neighbouring routers Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces and 192.168.30.0 be non-directly connected first delete all static routes (config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2 (config)#router rip (config-router)#192.168.10.0 (config-router)#192.168.20.0 (config-router)#^z Verifying RIP 1.Sh ip route 2.debug ip Holding Down RIP Propagation-To stop RIP update sending but allow its receipt -say for s0/0 with ip 192.168.10.0 (config)#router rip (config-router)#network 192.168.10.0 (config-router)#passive-interface serial 0/0
  • 3. CCNA All Commands Page 3 of 16 IGRP-Also a distance routing protocol Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces with autonomous system number of 10 and 192.168.30.0 be non-directly connected #router igrp 10 (config-router)#network 192.168.10.0 (config-router)#network 192.168.20.0 (config-router)#^z Verifying IGRP sh ip route Displays routed protocols and their interfaces sh protocols Displays routing protocols configured sh ip protocols Displays summary of IGRP routing information running on the network debug igrp events Displays messages request from neighbour routers debug igrp transactions Turning off all possible debugging #un all
  • 4. CCNA All Commands Page 4 of 16 EIGRP-Uses classless routing which is subnet mask information sent with routing protocol updates. Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces with autonomous system number of 20 and 192.168.30.0 be non-directly connected 1. #router eigrp 20 2. (config-router)#network 192.168.10.0 3. (config-router)#network 192.168.20.0 4. (config-router)#^z To stop EIGRP from working on an interface-no sending no receipt (config)#router eigrp 20 (config-router)#passive-interface serial 0/0 To enable EIGRP on discontiguos networks(two different subnetworks of classfull network connected by another different classful subnetwork) Example- Let 172.16.0.0 & 10.0.0.0 be directly connected to a router to another remote subnetwork of 192.168.10.0, then to enable EIGRP, we use 1. (config)#router eigrp 100 2. (config-router)#network 172.16.0.0 3. (config-router)#network 10.0.0.0 4. (config-router)#no auto-summary N.B-The no auto-summary command sholuld be enabled in routers that encloses such networks. Verifying EIGRP sh ip route- Shows entire routing table sh ip route eigrp- Shows only EIGRP entries in the routing table ip eigrp neighbours- Shows all EIGRP neighbours ip eigrp topology- Shows entries in the EIGRP topology table
  • 5. CCNA All Commands Page 5 of 16 OSPF- A link-state routing protocol Example- Let 10.0.0.0 be the network directly connected to the router upon which OSPF is to be enabled; with ospf ID of 1 and area o 1. (config)#router ospf 1 2. (config-router)#network 10.0.0.0 0.255.255.255 area0 Loopback Interface- They are configured to be used as the routers RID to advertise the routes and elect DR and BDR. Example- Let the loopback iinterface be configured on interface with ip 172.16.10.1 (config)#int loopback 0 (config-if)#ip address 172.16.10.1 255.255.255.0 (config-if)#no shut (config-if)#^z Verifying OSPF Configuration Used to display all OSPF information sho ip ospf indicates the number of links and neighboring router ID sho ip ospf database Displays all OSPF interface related info sho ip ospf interface Summarizes OSPF info about neighbours sho ip ospf neighbour Overview of all present running protocols sho ip protocols
  • 6. CCNA All Commands Page 6 of 16 Verifying Loopback and RID To verify loopback address sho running-config Verifies the new RID of each router sho ip ospf database Verifies the new RID of each router sho ip ospf interface Initial configuration of a 1900 Switch with ip 172.16.10.16 >en #config t (config)#enable password level 1 kennifeh (config)#enable password level 15 kennifeh 1 (config)#enable secret kennifeh 2 (when enabled no need 4 enable password) (config)#hostname kenn 1900 (config)#ip address 172.16.10.16 255.255.255.0 (config)#ip default-gateway 172.16.10.1 (config)#int f0/1 (config-if)#description Finance_vlan (No space for 1900) (config-if)#int f0/26 (config-if)#description Trunk_to_Biulding (config-if)#exit
  • 7. CCNA All Commands Page 7 of 16 Initail Configuration of 2950 Switch with ip 172.16.10.17 255.255.255.0 >en #config t(config)#hostame kenn2950 (config)#enable password kenn (config)#enable password kenn1 (enable and enable secret password must be different) (config)#line vty 0 15 (config-line)#login (config-line)#password telnet (config-line)#line con 0 (config-line)#login (config-line)#password console (config-line)#exit (config)#int vlan 1 (config-if)#ip address 172.16.10.17 255.255.255.0 (config-if)#no shut (config-if)#int f0/1 (config-if)#description sales printer(with space) (config-if)#int f0/12 (config-if)description connection to backbone (config-if)#exit (config)#ip default-gateway 172.16.10.1 (config) Erasing Switching Configuration 1900 #delete nvram yes Erasing Switching Configuration 2950 #erase startup-config Enter
  • 8. CCNA All Commands Page 8 of 16 Configuring VLANS 1900 >en #config t (config)#vlan 2 name Cisco (config)#vlan 3 name Microsoft (config)#vlan 4 name Comptia (config)#exit Verify with command sh run Configuring for 2950 >en #vlan database (vlan)#vlan 2 name Cisco (vlan)#vlan 3 name Microsoft (vlan)#vlan 4 name Comptia (vlan)#apply (vlan)#^c Verify with command sh vlan brief Assigning Switch Ports To Vlan-1900 (config)#int e0/2 (config-if)#vlan-membership static 2 (config-if)#int e0/3 (config-if)#vlan-membership static 3 (config-if)#exit Verify with sh vlan
  • 9. CCNA All Commands Page 9 of 16 Assigning Switch Ports To Vlan-2950 (config)#int f0/2 (config-if)#switchport access vlan 2 (config-if)#int f0/3 (config-t)#switchport access vlan 3 (config-if)#int f0/4 (config-if)#switchport access vlan 4 (config-if)#verify with sh vlan brief Configuring Trunks ports (config)#int f0/26 (config-if)#trunk on Configuring Trunk Ports for 2950 (config)#int f0/12 (config-if)#switchport mode trunk (config-if)#^z To disable Trunk use switchport mode access To verify Trunking use sh running config
  • 10. CCNA All Commands Page 10 of 16 Configuring Inter-vlan Routing for 1900 connecting to 2600 (config)#int f0/0.1 (config-if)#encapsulation isl vlan (d number) Configuring Inter-vlan Routing for 2950 connecting to 2600 (config)#int f0/0.1 (config-if)#encapsulation dot1q vlan (d number) Configuring VTP for 1900 (config)#vtp server (config)vtp domain kenn (config)#vtp password kenn Configuring VTP for 2950 (config)#vtp mode server (config)#vtp domain routersim (config)#^z Verify with sh vtp status
  • 11. CCNA All Commands Page 11 of 16 Checking the Current Configuration Register Values Show version or show ver Changing Configuration Register (config)#config-register 0x101 (d default is 0x2102) (config)#^z Recovering Passwords Interrupt the Router Boot Sequene ctrl+Break key (windows wont perform break key, only 95/98) Changing the configuration register -for 2600 series router rammon>confreg 0x2142 for 2500 - type 0 after a break and enter the command o/r 0x2142 Reloading the Router and Entering Privilged mode - for 2600 - type reset Viewing and changing the configuration - copy run start Resetting the configuration Register and Reloading the Router - config t Backing up and restoring the Cisco ios verifying flash memory - Ensuring flash memory has enough room router#sh flash Backing-up the ciso ios first verify server connectivity by- Router#ping 192.168.0.120 then; router#copy flash tftp
  • 12. CCNA All Commands Page 12 of 16 Restoring or upgrading the cisco router ios router#copy tftp flash [confirm][ENTER] ?[ENTER] Backing up and Restoring the Cisco configuration Backing up the cisco router configuration copy runing config tftp Verifying the current configuration sh run copying the current cofiguration to NVRAM copy run start copying the current configuration to a TFTP server copy run TFTP Restoring the Cisco Router Configuration copy TFTP run Erasing the configuration erase startup-config
  • 13. CCNA All Commands Page 13 of 16 Getting CDP timers and Holdtime information Router#config t Router(config)#cdp timer 90 Router(config)#cdp holdtime 240 Router(config)#^z To turn-off CDP Completely no cdp run Gathering Neighbour information kenn2509#sh cdp nei delivers information about directly connected devices or kenn2509#sh cdp neighbour detail Also sh cdp entry Gathering Interface Traffic Information kenn2509#sh cdp traffic Gathering port and Interface information kenn2509#sh cdp interface To turn off cdp on a router, use no cdp enable then ^z
  • 14. CCNA All Commands Page 14 of 16 Using Telnet kenn2509#telnet 172.16.10.2 Telnetting into multiple devices simultaneously kenn2509#telnet 172.16.10.2 then, 2501B>{cntl+shift+6, then x} Checking Telnet connections kenn2509#sh sessions - connections from your router to remote Checking Telnet users kenn2509#sh user Closing Telnet sessions 1900switch>exit OR kenn2509#disconnect1 (num of active networks)
  • 15. CCNA All Commands Page 15 of 16 Resolving Hostname kenn2509#config t kenn2509(config)#ip host 2501B 172.16.10.2 kenn2509(config)#ip host 1900switch 192.168.0.148 kenn2509(config)#^z To remove a hostname from a table, use RouterA(config)#no ip host routerB Using DNS to resolve names #config t (config)#ip domain-lookup (usually turned on by default) (config)#ip name-server 192.168.0.70 (ip of an assumed DNS set) (config)#ip domain-name kenn.com (Appends the domain name to a host) (config)#^z Check Network Connectivity use ping command #ping kenn2509 Using Traceroute command #trace 2501B
  • 16. CCNA All Commands Page 16 of 16 Access Lists Creating a Standard Access Lists (1-99 or 1,300-1,999) (config)#access-list 10 deny 172.16.30.2 (using the ip as a test) Controlling vty(Telnet) sessions (config)#access-list 50 permit 172.16.30.2 (config)#line vty 0 4 (config-line)#access-class 50 in Creating Extended Access-lists (100 to 199) OR (2000 to 2699) (config)#access-list 110 deny tcp any host 172.16.30.2 eq 23 log (config)#access-list 110 permit ip any any (config)#int f0/0 (config-if)#ip access-group 110 in (config-if)#ipaccess-group 110 out