SlideShare une entreprise Scribd logo
1  sur  25
Télécharger pour lire hors ligne
2013

PROJET MPLS - VPN

DIA Coumba
TIANI Wilfried
INTRODUCTION
Contrairement à la pratique courante qui conseil de configurer le le BackBone MPLS
avant de revenir sur les routeurs clients, nous avons opté pour une approche qui nous permet
de faire les configurations d’une manière directe. Ce qui nous évite de revenir sur un routeur
une fois qu’on la configuré et aussi de nous permet de voir les adjacences au fur et à mesure
que l’on fait les configurations.
Ainsi pour réaliser notre projet, nous avons suivie les étapes suivantes :
-

Identification des VRF et de leurs propriétés
Configuration des routeurs CU
Configuration des routeurs P du BackBone (P ≠ PE)
Configuration des routeurs EDGE (PE)
Configuration et partage de la route par défaut

TOPOLOGIE
BESOINS DES CLIENTS
 Les sociétés BH, Monoprix et OneTech décident d’interconnecter leurs
sites à travers la technologie MPLS VPN
 La société BH veut avoir une architecture ‘’Hub and spoke’’, les agences
communiquent avec le site central mais n’ont pas une connexion entre
eux.
 Les sites de la société OneTech de même que les sites Monoprix
appartiennent au même VPN.
 Tous les sites des différentes sociétés veulent se connecter à internet.

IDENTIFICATION DES VRF ET DE LEURS PROPRIETES
A – Lister les VRF et leurs interdépendances
En suivant l’énonce on distingue plusieurs VRF qui sont :
-

Internet : INT
Monoprix_Branch : MB
Monoprix_HQ : MHQ
OneTech_Branch : OTB
OneTech_HQ : OTHQ
BH_HQ : BHHQ
BH_Branch_SFAX 1 : SFAX1
BH_Branch_SFAX 2 : SFAX2
Ces VRF ont les interdépendances suivantes :

MB

SFAX1

MHQ

INT

BHHQ

OTB

SFAX2
OTHQ

B – AFFECTATIONS DES Route-Target ET Route Distinguer

INT
RD 11:11
route-target export 11:11
route-target import 10:10
route-target import 19:56
route-target import 77:88

MB
RD 5:5
route-target export 19:56
route-target import 19:56
route-target import 11:11
OTHQ
RD 6:6
route-target export 19:56
route-target import 19:56
route-target import 11:11

SFAX1
RD 8:8
route-target export 77:88
route-target import 10:10
route-target import 11:11

SFAX2
RD 7:7
route-target export 77:88
route-target import 10:10
route-target import 11:11

BHHQ
RD 10:10
route-target export 10:10
route-target import 77:88
route-target import 11:11

MHQ
RD 1:1
route-target export 19:56
route-target import 19:56
route-target import 11:11
OTB
RD 9:9
route-target export 19:56
route-target import 19:56
route-target import 11:11

CONFIGURATION DES ROUTEURS CU
Elle se fait en deux parties que l’on répétera sur chaque routeur CU
-

Interfaces (Activation, Configuration des @IP)
Configuration de protocole de routage

Routeur « 1 » : Monoprix HQ


Interfaces

1#conf t
1(config)#int loo0
1(config-if) #ip add 1.1.1.1 255.255.255.0
1(config-if)#int f0/0
1(config-if) #no sh
1(config-if)#ip add 192.168.12.1 255.255.255.0
1(config-if)#exit



Protocole de routage

1(config)#router eigrp 100
1(config-router)#network 1.1.1.0 255.255.255.0
1(config-router)#net 192.168.12.0
1(config-router)#no auto-summary

i
Routeur « 10 » : BH HQ


Interfaces

10#conf t
10(config)#int loo0
10(config-if)#ip add 10.10.10.10 255.255.255.0
10(config-if)#int f0/0
10(config-if)#no sh
10(config-if)#ip add 192.168.102.10 255.255.255.0



Protocole de routage

10(config-if)#router os 4
10(config-router)#net 10.10.10.0 0.0.0.255 area 0
10(config-router)#net 192.168.102.0 0.0.0.255 area 0

Routeur « 9 » : OneTech_Branch


Interfaces

9#conf t
9(config)#int loo0
9(config-if)#ip add 9.9.9.9 255.255.255.0
9(config-if)#int f0/0
9(config-if)#no sh
9(config-if)#ip add 192.168.92.9 255.255.255.0


Protocole de routage

9(config-if)#router rip
9(config-router)#version 2
9(config-router)#network 9.9.9.0
9(config-router)#network 9.9.9.0
9(config-router)#net 192.168.92.0
9(config-router)#no auto-summary

Routeur « 8 » : SFAX 1


Interfaces

8#conf t
8(config)#int loopback 0
8(config-if)#ip add 8.8.8.8 255.255.255.0
8(config-if)#int f0/0
8(config-if)#no sh
8(config-if)#ip add 192.168.84.8 255.255.255.0
8(config-if)#exit



Protocole de routage

8(config)#router ospf 5
8(config-router)#network 8.8.8.0 0.0.0.255 ar 0
8(config-router)#net 192.168.84.0 0.0.0.255 ar 0
Routeur « 7 » : SFAX 2


Interfaces

7#conf t
7(config)#int loo0
7(config-if)#ip add
7(config-if)#ip add 7.7.7.7 255.255.255.0
7(config-if)#int f0/0
7(config-if)#no sh
7(config-if)#ip add 192.168.74.7 255.255.255.0



Protocole de routage

7(config-if)#router osp 2
7(config-router)#net 7.7.7.0 0.0.0.255 ar 0
7(config-router)#net 192.168.74.0 0.0.0.255 ar 0

Routeur « 6 » : OneTech_HQ


Interfaces

6#conf t
6(config)#int loo0
6(config-if)#ip add
6(config-if)#ip add 6.6.6.6 255.255.255.0
6(config-if)#int f0/0
6(config-if)#no sh
6(config-if)#ip add 192.168.64.6 255.255.255.0
6(config-router)#exit


Protocole de routage

6(config)#router rip
6(config-router)#ver 2
6(config-router)#net 6.6.6.0
6(config-router)#net 192.168.64.0
6(config-router)#no auto-summary

Routeur « 11 » : Internet


Interfaces

11#conf t
11(config)#int loo0
11(config-if)#ip add
11(config-if)#ip add 11.11.11.11 255.255.255.0
11(config-if)#int f0/0
11(config-if)#no sh
11(config-if)#ip add 192.168.114.11 255.255.255.0
11(config-if)#int f0/1
11(config-if)#no sh
11(config-if)#ip add 193.95.66.1 255.255.255.0



Protocole de routage

11(config-if)#router osp 3
11(config-router)#net 11.11.11.0 0.0.0.255 ar 0
11(config-router)#net 192.168.114.0 0.0.0.255 ar 0
Routeur « 5 » : Monoprix_Branch


Interfaces

5#conf t
5(config)#int loo0
5(config-if)#ip add 5.5.5.5 255.255.255.0
5(config-if)#int f0/0
5(config-if)#no sh
5(config-if)#ip add 192.168.54.5 255.255.255.0



Protocole de routage

5(config-if)#router eigr 100
5(config-router)#net 5.5.5.0 0.0.0.255
5(config-router)#net 192.168.54.0
5(config-router)#no auto-summary
CONFIGURATION DES ROUTEURS P DU BACKBONE
Ici nous n’avons qu’un seul routeur a configuré et nous le faisons en suivant les étapes
suivantes :

-

i
MPLS
 CEF
 Label
 Interfaces

ii

Routeur « 3 » : P


Interfaces

3#conf t
3(config)#int loo0
3(config-if)#ip add 3.3.3.3 255.255.255.0
3(config-if)#int f0/0
3(config-if)#no sh
3(config-if)#ip add 192.168.23.3 255.255.255.0
3(config-if)#int f0/1
3(config-if)#no sh
3(config-if)#ip add 192.168.43.3 255.255.255.0
3(config-if)#exit



Protocole de routage

3(config)#router ospf 1
3(config-router)#net 3.3.3.0 0.0.0.255 ar 0
3(config-router)#net 192.168.23.0 0.0.0.255 ar 0
3(config-router)#net 192.168.43.0 0.0.0.255 ar 0
3(config-router)#exit


MPLS

3(config)#ip cef

// Activation du Cisco Express Forwarding

3(config)#mpl label protocol ldp

// Activation du protocole d’échange de label LDP

3(config)#mpls ldp router-id loo0

// Choix de l’interface pour le LDP

3(config)#int f0/0
3(config-if)#mpls ip // Activation du MPLS sur l’interface F0/0
3(config-if)#int f0/1
3(config-if)#mpls ip
3(config-if)#int loo0
3(config-if)#ip ospf network point-to-point
CONFIGURATION DES ROUTEURS EDGE (PE)

Les routers PE se configurent en suivant les étapes
-

-

ii
VFR
 Création des VRF
 Affectation des VRF aux interfaces
 Configuration des protocoles de routage des VRF
BGP (MP-BGP)
Redistribution des routes

Routeur « 2 » : PE1


Interfaces

2#conf t
2(config)#int loo0
2(config-if)#ip add 2.2.2.2 255.255.255.0
2(config-if)#int f0/1
2(config-if)#no sh
2(config-if)#ip add 192.168.23.2 255.255.255.0



Protocole de routage

2(config-if)#router osp 1
2(config-router)#net 2.2.2.0 0.0.0.255 ar 0
2(config-router)#net 192.168.23.0 0.0.0.255 ar 0



MPLS
2(config-router)#exit
2(config)#ip cef // Activation du Cisco Express Forwarding
2(config)#mpls label protocol ldp // Activation du protocole de LDP pour l’echange de

labels
2(config)#mpls ldp router-id loo0 // Affectation de la boucle locale au protocole LDP
2(config)#int f0/1
2(config-if)#mpls ip // Activation du MPLS sur l’interface F0/1
2(config-if)#exit



VRF

// Création des VRF
2(config)# ip vrf BHHQ
2(config-vrf)# rd 10:10
2(config-vrf)#route-target export 10:10
2(config-vrf)# route-target import 77:88
2(config-vrf)# route-target import 11:11
2(config-vrf)# ip vrf MHQ
2(config-vrf)# rd 1:1
2(config-vrf)# route-target both 19:56
2(config-vrf)# route-target import 11:11
2(config-vrf)# ip vrf OTB
2(config-vrf)# route-target both 19:56
2(config-vrf)# route-target import 11:11
2(config-vrf)#exit

// Affectation desVRF aux interfaces adéquates
2(config)# interface FastEthernet0/0
2(config-if)# ip vrf forwarding MHQ
2(config-if)# ip address 192.168.12.2 255.255.255.0
2(config-if)# interface FastEthernet0/1
2(config-if)# ip vrf forwarding BHHQ
2(config-if)# ip address 192.168.102.2 255.255.255.0
2(config-if)# interface FastEthernet1/0
2(config-if)# ip vrf forwarding OTB
2(config-if)# ip address 192.168.92.2 255.255.255.0

// Protocoles de routage de chaques VRF
2(config-if)# router eigrp 100

// Protocole EIGRP

2(config-router)# address-family ipv4 vrf MHQ
2(config-router-af)# network 192.168.12.0
2(config-router-af)# no auto-summary
2(config-router-af)# autonomous-system 1
2(config-router-af)# router ospf 4 vrf BHHQ

// Protocole OSPF4

2(config-router)# network 192.168.102.0 0.0.0.255 area 0
2(config-router)# router rip // Protocole RIP V2
2(config-router)#version 2
2(config-router)#address-family ipv4 vrf OTB
2(config-router-af)#network 192.168.92.0
2(config-router-af)#no auto-summary



BGP (MP-BGP)

2(config-router)# router bgp 1 // Protocole BGP
2(config-router)# neighbor 4.4.4.4 remote-as 1
2(config-router)# neighbor 4.4.4.4 update-source Loopback0
2(config-router)# address-family vpnv4 // Activation du protocole MP-BGP
2(config-router-af)# neighbor 4.4.4.4 activate
2(config-router-af)# neighbor 4.4.4.4 send-community both


Redistribution des routes des VRF

// RIP & EIGRP & OSPF 4 dans BGP
2(config-router-af)# address-family ipv4 vrf OTB
2(config-router-af)# redistribute rip
2(config-router-af)# address-family ipv4 vrf MHQ
2(config-router-af)# redistribute eigrp 100
2(config-router-af)# address-family ipv4 vrf BHHQ
2(config-router-af)# redistribute ospf 4 vrf BHHQ
// BGP dans RIP
2(config-router)# router rip
2(config-router)#version 2
2(config-router)#address-family ipv4 vrf OTB
2(config-router-af)#redistribute bgp 1 metric transparent
// BGP dans OSPF4
2(config-router-af)# router ospf 4 vrf BHHQ
2(config-router)# redistribute bgp 1 subnets
// BGP dans EIGRP
2(config-if)# router eigrp 100
2(config-router)# address-family ipv4 vrf MHQ
2(config-router-af)# redistribute bgp 1 metric 64 1000 255 1 1500

Routeur « 4 » : PE2


Interfaces

4#conf t
4(config)#int loo0
4(config-if)# ip address 4.4.4.4 255.255.255.0
4(config-if)#int f0/0
4(config-if)#no sh
4(config-if)# ip address 192.168.43.4 255.255.255.0


Protocole de routage

4(config-if)#router osp 1
4(config-router)# network 4.4.4.0 0.0.0.255 area 0
4(config-router)# network 192.168.43.0 0.0.0.255 area 0



MPLS

4(config-router)#exit
4(config)#ip cef // Activation du Cisco Express Forwarding
4(config)#mpls label protocol ldp // Activation du protocole de LDP pour l’échange de

labels
4(config)#mpls ldp router-id loo0 // Affectation de la boucle locale au protocole LDP
4(config)#int f0/0
4(config-if)#mpls ip // Activation du MPLS sur l’interface F0/1
4(config-if)#exit



VRF

// Création des VRF
4(config)# ip vrf INT
4(config-vrf)# rd 11:11
4(config-vrf)#route-target export 11:11
4(config-vrf)# route-target import 77:88
4(config-vrf)# route-target import 10:10
4(config-vrf)# route-target import 19:56
4(config-vrf)# ip vrf MB
4(config-vrf)# rd 5:5
4(config-vrf)# route-target both 19:56
4(config-vrf)# route-target import 11:11
4(config-vrf)# ip vrf OTHQ
4(config-vrf)# route-target both 19:56
4(config-vrf)# route-target import 11:11
4(config-vrf)#exit
4(config)# ip vrf SFAX1
4(config-vrf)# rd 8:8
4(config-vrf)#route-target export 77:88
4(config-vrf)# route-target import 10:10
4(config-vrf)# route-target import 11:11
4(config)# ip vrf SFAX2
4(config-vrf)# rd 8:8
4(config-vrf)#route-target export 77:88
4(config-vrf)# route-target import 10:10
4(config-vrf)# route-target import 11:11
// Affectation desVRF aux interfaces adéquates
4(config)# interface FastEthernet0/1
4(config-if)# ip vrf forwarding MB
4(config-if)# ip address 192.168.54.4 255.255.255.0
4(config-if)# interface FastEthernet1/0
4(config-if)# ip vrf forwarding INT
4(config-if)# ip address 192.168.114.4 255.255.255.0
4(config-if)# interface FastEthernet2/0
4(config-if)# ip vrf forwarding OTHQ
4(config-if)# ip address 192.168.64.4 255.255.255.0
4(config-if)# interface FastEthernet3/0
4(config-if)# ip vrf forwarding SFAX2
4(config-if)# ip address 192.168.74.4 255.255.255.0
4(config-if)# interface FastEthernet4/0
4(config-if)# ip vrf forwarding SFAX1
4(config-if)# ip address 192.168.84.4 255.255.255.0
// Protocoles de routage de chaques VRF
4(config-if)# router eigrp 100

// Protocole EIGRP

4(config-router)# address-family ipv4 vrf MB
4(config-router-af)# network 192.168.54.0
4(config-router-af)# no auto-summary
4(config-router-af)# autonomous-system 1
4(config-router-af)# router ospf 3 vrf INT // Protocole OSPF3
4(config-router)# network 192.168.114.0 0.0.0.255 area 0
4(config-router)# router rip // Protocole RIP V2
4(config-router)#version 2
4(config-router)#address-family ipv4 vrf OTHQ
4(config-router-af)# network 192.168.64.0
4(config-router-af)#no auto-summary
4(config-router-af)# router ospf 2 vrf SFAX2

// Protocole OSPF2

4(config-router)# network 192.168.74.0 0.0.0.255 area 0
4(config-router-af)# router ospf 5 vrf SFAX1

// Protocole OSPF5

4(config-router)# network 192.168.84.0 0.0.0.255 area 0



BGP (MP-BGP)

4(config-router)# router bgp 1 // Protocole BGP
4(config-router)# neighbor 2.2.2.2 remote-as 1
4(config-router)# neighbor 2.2.2.2 update-source Loopback0
4(config-router)# address-family vpnv4 // Activation du protocole MP-BGP
4(config-router-af)# neighbor 2.2.2.2 activate
4(config-router-af)# neighbor 2.2.2.2 send-community both



Redistribution des routes des VRF

// RIP & EIGRP & OSPF 3,5,2 dans BGP
4(config-router-af)# address-family ipv4 vrf OTHQ
4(config-router-af)# redistribute rip
4(config-router-af)# address-family ipv4 vrf MB
4(config-router-af)# redistribute eigrp 100
4(config-router-af)# address-family ipv4 vrf SFAX1
4(config-router-af)# redistribute ospf 5 vrf SFAX1
4(config-router-af)# address-family ipv4 vrf SFAX2
4(config-router-af)# redistribute ospf 2 vrf SFAX2
4(config-router-af)# address-family ipv4 vrf INT
4(config-router-af)# redistribute ospf 3 vrf INT
// BGP dans RIP
4(config-router)# router rip
4(config-router)#version 2
4(config-router)#address-family ipv4 vrf OTHQ
4(config-router-af)#redistribute bgp 1 metric transparent
// BGP dans EIGRP
4(config-if)# router eigrp 100
4(config-router)# address-family ipv4 vrf MB
4(config-router-af)# redistribute bgp 1 metric 64 1000 255 1 1500
// BGP dans OSPF3
4(config-router-af)# router ospf 3 vrf INT
4(config-router)# redistribute bgp 1 subnets
// BGP dans OSPF5
4(config-router-af)# router ospf 5 vrf SFAX1
4(config-router)# redistribute bgp 1 subnets
// BGP dans OSPF2
4(config-router-af)# router ospf 2 vrf SFAX2
4(config-router)# redistribute bgp 1 subnets
CONFIGURATION ET PARTAGE DE LA ROUTE PAR
DEFAUT

Routeur « 11 » : Internet


Definition et redistribution de la route par défaut

11(config)#ip route 0.0.0.0 0.0.0.0 193.95.66.1

// Route par défaut

11(config)#router ospf 3
11(config-router)#default-information originate



// Redistribution

Configuration du NAT

11(config-router)#int f0/0

// Définition de l’interface d’entrée du NAT

11(config-if)#ip nat inside
11(config-router)#int f0/1

// Définition de l’interface de sortie du NAT

11(config-if)#ip nat outside
11(config)#access-list permit any // Création d’une ACL qu’on utilisera comme source

du NAT
11(config)#ip nat pool NAT 193.95.66.100 193.95.66.200 netmask 255.255.255.0 // Pool

d’@
11(config)# ip nat inside source list 1 pool NAT

// Activation du NAT

Routeur « 4 » : PE2


Redistribution de la route par defaut dans les VRF

4(config)# router bgp 1
4(config-router)# address-family ipv4 vrf INT
4(config-router-af)# redistribute ospf 3 vrf INT match internal external 1 external 2
4(config-router-af)# default-information originate
TEST FINAL
-Ping entre OneTech et Monoprix et leur accès à l’internet

-Ping entre SFAX1, SFAX2 et le noeud central BH et leur accès à l’internet
-Accès internet sur XP
On teste ainsi si au niveau de l’hôte XP( reliée à MonoprixHQ) nous avons accès à internet :
MPLS VPN

Contenu connexe

Tendances

Tendances (20)

MPLS-VPN
MPLS-VPNMPLS-VPN
MPLS-VPN
 
Mise en place des réseaux LAN interconnectés par un réseau WAN
Mise en place des réseaux LAN interconnectés par un réseau WANMise en place des réseaux LAN interconnectés par un réseau WAN
Mise en place des réseaux LAN interconnectés par un réseau WAN
 
Vpn site to site avec les équipements JUNIPER
Vpn site to site avec les équipements JUNIPERVpn site to site avec les équipements JUNIPER
Vpn site to site avec les équipements JUNIPER
 
Connexion point à point (ppp, hdlc)
Connexion point à point (ppp, hdlc)Connexion point à point (ppp, hdlc)
Connexion point à point (ppp, hdlc)
 
IPv6 Les Bases
IPv6 Les BasesIPv6 Les Bases
IPv6 Les Bases
 
Cours les technologies WAN
Cours les technologies WANCours les technologies WAN
Cours les technologies WAN
 
MPLS-TE
MPLS-TEMPLS-TE
MPLS-TE
 
Cours SNMP
Cours SNMPCours SNMP
Cours SNMP
 
projet sur le vpn presentation
projet sur le vpn presentationprojet sur le vpn presentation
projet sur le vpn presentation
 
Etude et mise en place d’un VPN
Etude et mise en place d’un VPNEtude et mise en place d’un VPN
Etude et mise en place d’un VPN
 
Mpls L3_vpn
Mpls L3_vpnMpls L3_vpn
Mpls L3_vpn
 
Atm
AtmAtm
Atm
 
La sécurité des réseaux sans fil
La sécurité des réseaux sans filLa sécurité des réseaux sans fil
La sécurité des réseaux sans fil
 
Rapport mise en place d'un sevrer VPN .
   Rapport mise en place d'un sevrer VPN .   Rapport mise en place d'un sevrer VPN .
Rapport mise en place d'un sevrer VPN .
 
Routage ospf
Routage ospfRoutage ospf
Routage ospf
 
Equipements d'interconnexion
Equipements d'interconnexionEquipements d'interconnexion
Equipements d'interconnexion
 
Cours eigrp i pv4 et ipv6
Cours eigrp i pv4 et ipv6Cours eigrp i pv4 et ipv6
Cours eigrp i pv4 et ipv6
 
GNS3, VoIP, ToIP
GNS3, VoIP, ToIPGNS3, VoIP, ToIP
GNS3, VoIP, ToIP
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
 
Cours Vlan
Cours VlanCours Vlan
Cours Vlan
 

En vedette

MPLS - Multiprotocol Label Switching
MPLS - Multiprotocol Label SwitchingMPLS - Multiprotocol Label Switching
MPLS - Multiprotocol Label SwitchingPeter R. Egli
 
Virtualisation
VirtualisationVirtualisation
VirtualisationTsubichi
 
Tutoriel : Apprendre à configurer et gérer un serveur Web sous Windows Server...
Tutoriel : Apprendre à configurer et gérer un serveur Web sous Windows Server...Tutoriel : Apprendre à configurer et gérer un serveur Web sous Windows Server...
Tutoriel : Apprendre à configurer et gérer un serveur Web sous Windows Server...Christophe Lauer
 
Carte Mentale Réseaux privés virtuels MPLS-VPN-IP
Carte Mentale Réseaux privés virtuels MPLS-VPN-IPCarte Mentale Réseaux privés virtuels MPLS-VPN-IP
Carte Mentale Réseaux privés virtuels MPLS-VPN-IPDr, Noureddine IDBOUFKER
 
CCIE R&S V5 Changes
CCIE R&S V5 ChangesCCIE R&S V5 Changes
CCIE R&S V5 ChangesJohn Berry
 
Cisco -Ccie rs quick_review_kit
Cisco -Ccie rs quick_review_kitCisco -Ccie rs quick_review_kit
Cisco -Ccie rs quick_review_kitStoyan Stoyanov
 
Carte mentale projet de fin d'études (pfe)
Carte mentale projet de fin d'études (pfe)Carte mentale projet de fin d'études (pfe)
Carte mentale projet de fin d'études (pfe)Dr, Noureddine IDBOUFKER
 
INFORMATIQUE DES GESTION : MERISE
INFORMATIQUE DES GESTION : MERISE INFORMATIQUE DES GESTION : MERISE
INFORMATIQUE DES GESTION : MERISE HINDOUSSATI
 
Telecharger Cours Systèmes d’exploitation windows: Administration Windows
Telecharger Cours Systèmes d’exploitation windows: Administration  WindowsTelecharger Cours Systèmes d’exploitation windows: Administration  Windows
Telecharger Cours Systèmes d’exploitation windows: Administration Windowswebreaker
 
Rapport stage IP-MSAN Tunisie télécom
Rapport stage IP-MSAN Tunisie télécomRapport stage IP-MSAN Tunisie télécom
Rapport stage IP-MSAN Tunisie télécomSiwar GUEMRI
 
Rapport Windows Serveur 2008 "Active Directory Management"
Rapport Windows Serveur 2008 "Active Directory Management"Rapport Windows Serveur 2008 "Active Directory Management"
Rapport Windows Serveur 2008 "Active Directory Management"Ayoub Rouzi
 

En vedette (20)

MPLS - Multiprotocol Label Switching
MPLS - Multiprotocol Label SwitchingMPLS - Multiprotocol Label Switching
MPLS - Multiprotocol Label Switching
 
MPLS: Multiprotocol Label Switching
MPLS: Multiprotocol Label SwitchingMPLS: Multiprotocol Label Switching
MPLS: Multiprotocol Label Switching
 
Virtualisation
VirtualisationVirtualisation
Virtualisation
 
Tutoriel : Apprendre à configurer et gérer un serveur Web sous Windows Server...
Tutoriel : Apprendre à configurer et gérer un serveur Web sous Windows Server...Tutoriel : Apprendre à configurer et gérer un serveur Web sous Windows Server...
Tutoriel : Apprendre à configurer et gérer un serveur Web sous Windows Server...
 
Rapport de stage
Rapport de stageRapport de stage
Rapport de stage
 
Carte mentale transport Voix sur ip
Carte mentale transport Voix sur ipCarte mentale transport Voix sur ip
Carte mentale transport Voix sur ip
 
Carte mentale du cours h323, V2
Carte mentale du cours h323, V2Carte mentale du cours h323, V2
Carte mentale du cours h323, V2
 
Carte mentale protocole sip
Carte mentale protocole sipCarte mentale protocole sip
Carte mentale protocole sip
 
Carte mentale MPLS
Carte mentale MPLSCarte mentale MPLS
Carte mentale MPLS
 
Carte Mentale Réseaux privés virtuels MPLS-VPN-IP
Carte Mentale Réseaux privés virtuels MPLS-VPN-IPCarte Mentale Réseaux privés virtuels MPLS-VPN-IP
Carte Mentale Réseaux privés virtuels MPLS-VPN-IP
 
CCIE R&S V5 Changes
CCIE R&S V5 ChangesCCIE R&S V5 Changes
CCIE R&S V5 Changes
 
Cisco -Ccie rs quick_review_kit
Cisco -Ccie rs quick_review_kitCisco -Ccie rs quick_review_kit
Cisco -Ccie rs quick_review_kit
 
Carte mentale projet de fin d'études (pfe)
Carte mentale projet de fin d'études (pfe)Carte mentale projet de fin d'études (pfe)
Carte mentale projet de fin d'études (pfe)
 
INFORMATIQUE DES GESTION : MERISE
INFORMATIQUE DES GESTION : MERISE INFORMATIQUE DES GESTION : MERISE
INFORMATIQUE DES GESTION : MERISE
 
Telecharger Cours Systèmes d’exploitation windows: Administration Windows
Telecharger Cours Systèmes d’exploitation windows: Administration  WindowsTelecharger Cours Systèmes d’exploitation windows: Administration  Windows
Telecharger Cours Systèmes d’exploitation windows: Administration Windows
 
MPLS ppt
MPLS pptMPLS ppt
MPLS ppt
 
Itil 2011 process map goldfish_fr_v1.0
Itil 2011 process map goldfish_fr_v1.0Itil 2011 process map goldfish_fr_v1.0
Itil 2011 process map goldfish_fr_v1.0
 
MPLS Presentation
MPLS PresentationMPLS Presentation
MPLS Presentation
 
Rapport stage IP-MSAN Tunisie télécom
Rapport stage IP-MSAN Tunisie télécomRapport stage IP-MSAN Tunisie télécom
Rapport stage IP-MSAN Tunisie télécom
 
Rapport Windows Serveur 2008 "Active Directory Management"
Rapport Windows Serveur 2008 "Active Directory Management"Rapport Windows Serveur 2008 "Active Directory Management"
Rapport Windows Serveur 2008 "Active Directory Management"
 

Similaire à MPLS VPN

commande 2.pdf
commande 2.pdfcommande 2.pdf
commande 2.pdfalirayss
 
EIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relayEIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relaymdyabi
 
Configuración de los router
Configuración de los routerConfiguración de los router
Configuración de los routerJESUS EMMANUEL
 
Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)EL AMRI El Hassan
 
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)SmartnSkilled
 
Alphorm.com Formation CCNP ENCOR 350-401 (5/8) : Architecture
Alphorm.com Formation CCNP ENCOR 350-401 (5/8) : ArchitectureAlphorm.com Formation CCNP ENCOR 350-401 (5/8) : Architecture
Alphorm.com Formation CCNP ENCOR 350-401 (5/8) : ArchitectureAlphorm
 
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : RoutingAlphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : RoutingAlphorm
 

Similaire à MPLS VPN (20)

Configuration de-base-d
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
commande 2.pdf
commande 2.pdfcommande 2.pdf
commande 2.pdf
 
EIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relayEIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relay
 
Astuces cisco
Astuces ciscoAstuces cisco
Astuces cisco
 
Tout atm
Tout atmTout atm
Tout atm
 
CCNA 3.pdf
CCNA 3.pdfCCNA 3.pdf
CCNA 3.pdf
 
Tuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-siteTuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-site
 
Ccna 2-module-2-v4
Ccna 2-module-2-v4Ccna 2-module-2-v4
Ccna 2-module-2-v4
 
Configuración de los router
Configuración de los routerConfiguración de los router
Configuración de los router
 
Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
 
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
 
Alphorm.com Formation CCNP ENCOR 350-401 (5/8) : Architecture
Alphorm.com Formation CCNP ENCOR 350-401 (5/8) : ArchitectureAlphorm.com Formation CCNP ENCOR 350-401 (5/8) : Architecture
Alphorm.com Formation CCNP ENCOR 350-401 (5/8) : Architecture
 
cisco_base.ppt
cisco_base.pptcisco_base.ppt
cisco_base.ppt
 
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : RoutingAlphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
 
Fr introbgp-sif
Fr introbgp-sifFr introbgp-sif
Fr introbgp-sif
 
Tp voip
Tp voipTp voip
Tp voip
 

Plus de Wilfried Tiani

Plus de Wilfried Tiani (8)

PUPPET AND ICINGA WEB
PUPPET AND ICINGA WEBPUPPET AND ICINGA WEB
PUPPET AND ICINGA WEB
 
Nconf et nsclient pour icinga
Nconf et nsclient pour icingaNconf et nsclient pour icinga
Nconf et nsclient pour icinga
 
Installation nconf
Installation nconfInstallation nconf
Installation nconf
 
Installer icinga
Installer icingaInstaller icinga
Installer icinga
 
Agent de supervision
Agent de supervisionAgent de supervision
Agent de supervision
 
PROJET JAVA BD MySQL
PROJET JAVA BD MySQLPROJET JAVA BD MySQL
PROJET JAVA BD MySQL
 
Cacti or pnp for Icinga Web
Cacti or pnp for Icinga WebCacti or pnp for Icinga Web
Cacti or pnp for Icinga Web
 
BlackBerry 10
BlackBerry 10BlackBerry 10
BlackBerry 10
 

Dernier

Calendrier de la semaine du 8 au 12 avril
Calendrier de la semaine du 8 au 12 avrilCalendrier de la semaine du 8 au 12 avril
Calendrier de la semaine du 8 au 12 avrilfrizzole
 
Bibdoc 2024 - Sobriete numerique en bibliotheque et centre de documentation.pdf
Bibdoc 2024 - Sobriete numerique en bibliotheque et centre de documentation.pdfBibdoc 2024 - Sobriete numerique en bibliotheque et centre de documentation.pdf
Bibdoc 2024 - Sobriete numerique en bibliotheque et centre de documentation.pdfAtelier Canopé 37 - Tours
 
Bibdoc 2024 - Les intelligences artificielles en bibliotheque.pdf
Bibdoc 2024 - Les intelligences artificielles en bibliotheque.pdfBibdoc 2024 - Les intelligences artificielles en bibliotheque.pdf
Bibdoc 2024 - Les intelligences artificielles en bibliotheque.pdfAtelier Canopé 37 - Tours
 
0234567778999876554345678898765566.15.ppt
0234567778999876554345678898765566.15.ppt0234567778999876554345678898765566.15.ppt
0234567778999876554345678898765566.15.pptessiben
 
La Base unique départementale - Quel bilan, au bout de 5 ans .pdf
La Base unique départementale - Quel bilan, au bout de 5 ans .pdfLa Base unique départementale - Quel bilan, au bout de 5 ans .pdf
La Base unique départementale - Quel bilan, au bout de 5 ans .pdfbdp12
 
Newsletter SPW Agriculture en province du Luxembourg du 10-04-24
Newsletter SPW Agriculture en province du Luxembourg du 10-04-24Newsletter SPW Agriculture en province du Luxembourg du 10-04-24
Newsletter SPW Agriculture en province du Luxembourg du 10-04-24BenotGeorges3
 
Aux origines de la sociologie : du XIXème au début XX ème siècle
Aux origines de la sociologie : du XIXème au début XX ème siècleAux origines de la sociologie : du XIXème au début XX ème siècle
Aux origines de la sociologie : du XIXème au début XX ème siècleAmar LAKEL, PhD
 
Chana Orloff.pptx Sculptrice franco-ukranienne
Chana Orloff.pptx Sculptrice franco-ukranienneChana Orloff.pptx Sculptrice franco-ukranienne
Chana Orloff.pptx Sculptrice franco-ukranienneTxaruka
 
M2i Webinar - CPF 2024 : une stratégie pour booster les performances RH
M2i Webinar - CPF 2024 : une stratégie pour booster les performances RHM2i Webinar - CPF 2024 : une stratégie pour booster les performances RH
M2i Webinar - CPF 2024 : une stratégie pour booster les performances RHM2i Formation
 
Copilot your everyday AI companion- OFFICE 365-
Copilot your everyday AI companion- OFFICE 365-Copilot your everyday AI companion- OFFICE 365-
Copilot your everyday AI companion- OFFICE 365-Majida Antonios, M.Ed.
 
L'Unité de Spiritualité Eudiste se joint à toute l'Église Universelle et en p...
L'Unité de Spiritualité Eudiste se joint à toute l'Église Universelle et en p...L'Unité de Spiritualité Eudiste se joint à toute l'Église Universelle et en p...
L'Unité de Spiritualité Eudiste se joint à toute l'Église Universelle et en p...Unidad de Espiritualidad Eudista
 

Dernier (12)

Calendrier de la semaine du 8 au 12 avril
Calendrier de la semaine du 8 au 12 avrilCalendrier de la semaine du 8 au 12 avril
Calendrier de la semaine du 8 au 12 avril
 
Bibdoc 2024 - Sobriete numerique en bibliotheque et centre de documentation.pdf
Bibdoc 2024 - Sobriete numerique en bibliotheque et centre de documentation.pdfBibdoc 2024 - Sobriete numerique en bibliotheque et centre de documentation.pdf
Bibdoc 2024 - Sobriete numerique en bibliotheque et centre de documentation.pdf
 
Bibdoc 2024 - Les intelligences artificielles en bibliotheque.pdf
Bibdoc 2024 - Les intelligences artificielles en bibliotheque.pdfBibdoc 2024 - Les intelligences artificielles en bibliotheque.pdf
Bibdoc 2024 - Les intelligences artificielles en bibliotheque.pdf
 
0234567778999876554345678898765566.15.ppt
0234567778999876554345678898765566.15.ppt0234567778999876554345678898765566.15.ppt
0234567778999876554345678898765566.15.ppt
 
La Base unique départementale - Quel bilan, au bout de 5 ans .pdf
La Base unique départementale - Quel bilan, au bout de 5 ans .pdfLa Base unique départementale - Quel bilan, au bout de 5 ans .pdf
La Base unique départementale - Quel bilan, au bout de 5 ans .pdf
 
Newsletter SPW Agriculture en province du Luxembourg du 10-04-24
Newsletter SPW Agriculture en province du Luxembourg du 10-04-24Newsletter SPW Agriculture en province du Luxembourg du 10-04-24
Newsletter SPW Agriculture en province du Luxembourg du 10-04-24
 
Aux origines de la sociologie : du XIXème au début XX ème siècle
Aux origines de la sociologie : du XIXème au début XX ème siècleAux origines de la sociologie : du XIXème au début XX ème siècle
Aux origines de la sociologie : du XIXème au début XX ème siècle
 
Chana Orloff.pptx Sculptrice franco-ukranienne
Chana Orloff.pptx Sculptrice franco-ukranienneChana Orloff.pptx Sculptrice franco-ukranienne
Chana Orloff.pptx Sculptrice franco-ukranienne
 
M2i Webinar - CPF 2024 : une stratégie pour booster les performances RH
M2i Webinar - CPF 2024 : une stratégie pour booster les performances RHM2i Webinar - CPF 2024 : une stratégie pour booster les performances RH
M2i Webinar - CPF 2024 : une stratégie pour booster les performances RH
 
Copilot your everyday AI companion- OFFICE 365-
Copilot your everyday AI companion- OFFICE 365-Copilot your everyday AI companion- OFFICE 365-
Copilot your everyday AI companion- OFFICE 365-
 
Bulletin des bibliotheques Burkina Faso mars 2024
Bulletin des bibliotheques Burkina Faso mars 2024Bulletin des bibliotheques Burkina Faso mars 2024
Bulletin des bibliotheques Burkina Faso mars 2024
 
L'Unité de Spiritualité Eudiste se joint à toute l'Église Universelle et en p...
L'Unité de Spiritualité Eudiste se joint à toute l'Église Universelle et en p...L'Unité de Spiritualité Eudiste se joint à toute l'Église Universelle et en p...
L'Unité de Spiritualité Eudiste se joint à toute l'Église Universelle et en p...
 

MPLS VPN

  • 1. 2013 PROJET MPLS - VPN DIA Coumba TIANI Wilfried
  • 2. INTRODUCTION Contrairement à la pratique courante qui conseil de configurer le le BackBone MPLS avant de revenir sur les routeurs clients, nous avons opté pour une approche qui nous permet de faire les configurations d’une manière directe. Ce qui nous évite de revenir sur un routeur une fois qu’on la configuré et aussi de nous permet de voir les adjacences au fur et à mesure que l’on fait les configurations. Ainsi pour réaliser notre projet, nous avons suivie les étapes suivantes : - Identification des VRF et de leurs propriétés Configuration des routeurs CU Configuration des routeurs P du BackBone (P ≠ PE) Configuration des routeurs EDGE (PE) Configuration et partage de la route par défaut TOPOLOGIE
  • 3. BESOINS DES CLIENTS  Les sociétés BH, Monoprix et OneTech décident d’interconnecter leurs sites à travers la technologie MPLS VPN  La société BH veut avoir une architecture ‘’Hub and spoke’’, les agences communiquent avec le site central mais n’ont pas une connexion entre eux.  Les sites de la société OneTech de même que les sites Monoprix appartiennent au même VPN.  Tous les sites des différentes sociétés veulent se connecter à internet. IDENTIFICATION DES VRF ET DE LEURS PROPRIETES A – Lister les VRF et leurs interdépendances En suivant l’énonce on distingue plusieurs VRF qui sont : - Internet : INT Monoprix_Branch : MB Monoprix_HQ : MHQ OneTech_Branch : OTB OneTech_HQ : OTHQ BH_HQ : BHHQ BH_Branch_SFAX 1 : SFAX1 BH_Branch_SFAX 2 : SFAX2
  • 4. Ces VRF ont les interdépendances suivantes : MB SFAX1 MHQ INT BHHQ OTB SFAX2 OTHQ B – AFFECTATIONS DES Route-Target ET Route Distinguer INT RD 11:11 route-target export 11:11 route-target import 10:10 route-target import 19:56 route-target import 77:88 MB RD 5:5 route-target export 19:56 route-target import 19:56 route-target import 11:11
  • 5. OTHQ RD 6:6 route-target export 19:56 route-target import 19:56 route-target import 11:11 SFAX1 RD 8:8 route-target export 77:88 route-target import 10:10 route-target import 11:11 SFAX2 RD 7:7 route-target export 77:88 route-target import 10:10 route-target import 11:11 BHHQ RD 10:10 route-target export 10:10 route-target import 77:88 route-target import 11:11 MHQ RD 1:1 route-target export 19:56 route-target import 19:56 route-target import 11:11
  • 6. OTB RD 9:9 route-target export 19:56 route-target import 19:56 route-target import 11:11 CONFIGURATION DES ROUTEURS CU Elle se fait en deux parties que l’on répétera sur chaque routeur CU - Interfaces (Activation, Configuration des @IP) Configuration de protocole de routage Routeur « 1 » : Monoprix HQ  Interfaces 1#conf t 1(config)#int loo0 1(config-if) #ip add 1.1.1.1 255.255.255.0 1(config-if)#int f0/0 1(config-if) #no sh 1(config-if)#ip add 192.168.12.1 255.255.255.0 1(config-if)#exit  Protocole de routage 1(config)#router eigrp 100 1(config-router)#network 1.1.1.0 255.255.255.0 1(config-router)#net 192.168.12.0 1(config-router)#no auto-summary i
  • 7. Routeur « 10 » : BH HQ  Interfaces 10#conf t 10(config)#int loo0 10(config-if)#ip add 10.10.10.10 255.255.255.0 10(config-if)#int f0/0 10(config-if)#no sh 10(config-if)#ip add 192.168.102.10 255.255.255.0  Protocole de routage 10(config-if)#router os 4 10(config-router)#net 10.10.10.0 0.0.0.255 area 0 10(config-router)#net 192.168.102.0 0.0.0.255 area 0 Routeur « 9 » : OneTech_Branch  Interfaces 9#conf t 9(config)#int loo0 9(config-if)#ip add 9.9.9.9 255.255.255.0 9(config-if)#int f0/0 9(config-if)#no sh 9(config-if)#ip add 192.168.92.9 255.255.255.0
  • 8.  Protocole de routage 9(config-if)#router rip 9(config-router)#version 2 9(config-router)#network 9.9.9.0 9(config-router)#network 9.9.9.0 9(config-router)#net 192.168.92.0 9(config-router)#no auto-summary Routeur « 8 » : SFAX 1  Interfaces 8#conf t 8(config)#int loopback 0 8(config-if)#ip add 8.8.8.8 255.255.255.0 8(config-if)#int f0/0 8(config-if)#no sh 8(config-if)#ip add 192.168.84.8 255.255.255.0 8(config-if)#exit  Protocole de routage 8(config)#router ospf 5 8(config-router)#network 8.8.8.0 0.0.0.255 ar 0 8(config-router)#net 192.168.84.0 0.0.0.255 ar 0
  • 9. Routeur « 7 » : SFAX 2  Interfaces 7#conf t 7(config)#int loo0 7(config-if)#ip add 7(config-if)#ip add 7.7.7.7 255.255.255.0 7(config-if)#int f0/0 7(config-if)#no sh 7(config-if)#ip add 192.168.74.7 255.255.255.0  Protocole de routage 7(config-if)#router osp 2 7(config-router)#net 7.7.7.0 0.0.0.255 ar 0 7(config-router)#net 192.168.74.0 0.0.0.255 ar 0 Routeur « 6 » : OneTech_HQ  Interfaces 6#conf t 6(config)#int loo0 6(config-if)#ip add 6(config-if)#ip add 6.6.6.6 255.255.255.0 6(config-if)#int f0/0 6(config-if)#no sh 6(config-if)#ip add 192.168.64.6 255.255.255.0 6(config-router)#exit
  • 10.  Protocole de routage 6(config)#router rip 6(config-router)#ver 2 6(config-router)#net 6.6.6.0 6(config-router)#net 192.168.64.0 6(config-router)#no auto-summary Routeur « 11 » : Internet  Interfaces 11#conf t 11(config)#int loo0 11(config-if)#ip add 11(config-if)#ip add 11.11.11.11 255.255.255.0 11(config-if)#int f0/0 11(config-if)#no sh 11(config-if)#ip add 192.168.114.11 255.255.255.0 11(config-if)#int f0/1 11(config-if)#no sh 11(config-if)#ip add 193.95.66.1 255.255.255.0  Protocole de routage 11(config-if)#router osp 3 11(config-router)#net 11.11.11.0 0.0.0.255 ar 0 11(config-router)#net 192.168.114.0 0.0.0.255 ar 0
  • 11. Routeur « 5 » : Monoprix_Branch  Interfaces 5#conf t 5(config)#int loo0 5(config-if)#ip add 5.5.5.5 255.255.255.0 5(config-if)#int f0/0 5(config-if)#no sh 5(config-if)#ip add 192.168.54.5 255.255.255.0  Protocole de routage 5(config-if)#router eigr 100 5(config-router)#net 5.5.5.0 0.0.0.255 5(config-router)#net 192.168.54.0 5(config-router)#no auto-summary
  • 12. CONFIGURATION DES ROUTEURS P DU BACKBONE Ici nous n’avons qu’un seul routeur a configuré et nous le faisons en suivant les étapes suivantes : - i MPLS  CEF  Label  Interfaces ii Routeur « 3 » : P  Interfaces 3#conf t 3(config)#int loo0 3(config-if)#ip add 3.3.3.3 255.255.255.0 3(config-if)#int f0/0 3(config-if)#no sh 3(config-if)#ip add 192.168.23.3 255.255.255.0 3(config-if)#int f0/1 3(config-if)#no sh 3(config-if)#ip add 192.168.43.3 255.255.255.0 3(config-if)#exit  Protocole de routage 3(config)#router ospf 1 3(config-router)#net 3.3.3.0 0.0.0.255 ar 0 3(config-router)#net 192.168.23.0 0.0.0.255 ar 0 3(config-router)#net 192.168.43.0 0.0.0.255 ar 0 3(config-router)#exit
  • 13.  MPLS 3(config)#ip cef // Activation du Cisco Express Forwarding 3(config)#mpl label protocol ldp // Activation du protocole d’échange de label LDP 3(config)#mpls ldp router-id loo0 // Choix de l’interface pour le LDP 3(config)#int f0/0 3(config-if)#mpls ip // Activation du MPLS sur l’interface F0/0 3(config-if)#int f0/1 3(config-if)#mpls ip 3(config-if)#int loo0 3(config-if)#ip ospf network point-to-point
  • 14. CONFIGURATION DES ROUTEURS EDGE (PE) Les routers PE se configurent en suivant les étapes - - ii VFR  Création des VRF  Affectation des VRF aux interfaces  Configuration des protocoles de routage des VRF BGP (MP-BGP) Redistribution des routes Routeur « 2 » : PE1  Interfaces 2#conf t 2(config)#int loo0 2(config-if)#ip add 2.2.2.2 255.255.255.0 2(config-if)#int f0/1 2(config-if)#no sh 2(config-if)#ip add 192.168.23.2 255.255.255.0  Protocole de routage 2(config-if)#router osp 1 2(config-router)#net 2.2.2.0 0.0.0.255 ar 0 2(config-router)#net 192.168.23.0 0.0.0.255 ar 0  MPLS
  • 15. 2(config-router)#exit 2(config)#ip cef // Activation du Cisco Express Forwarding 2(config)#mpls label protocol ldp // Activation du protocole de LDP pour l’echange de labels 2(config)#mpls ldp router-id loo0 // Affectation de la boucle locale au protocole LDP 2(config)#int f0/1 2(config-if)#mpls ip // Activation du MPLS sur l’interface F0/1 2(config-if)#exit  VRF // Création des VRF 2(config)# ip vrf BHHQ 2(config-vrf)# rd 10:10 2(config-vrf)#route-target export 10:10 2(config-vrf)# route-target import 77:88 2(config-vrf)# route-target import 11:11 2(config-vrf)# ip vrf MHQ 2(config-vrf)# rd 1:1 2(config-vrf)# route-target both 19:56 2(config-vrf)# route-target import 11:11 2(config-vrf)# ip vrf OTB 2(config-vrf)# route-target both 19:56 2(config-vrf)# route-target import 11:11 2(config-vrf)#exit // Affectation desVRF aux interfaces adéquates 2(config)# interface FastEthernet0/0 2(config-if)# ip vrf forwarding MHQ 2(config-if)# ip address 192.168.12.2 255.255.255.0 2(config-if)# interface FastEthernet0/1
  • 16. 2(config-if)# ip vrf forwarding BHHQ 2(config-if)# ip address 192.168.102.2 255.255.255.0 2(config-if)# interface FastEthernet1/0 2(config-if)# ip vrf forwarding OTB 2(config-if)# ip address 192.168.92.2 255.255.255.0 // Protocoles de routage de chaques VRF 2(config-if)# router eigrp 100 // Protocole EIGRP 2(config-router)# address-family ipv4 vrf MHQ 2(config-router-af)# network 192.168.12.0 2(config-router-af)# no auto-summary 2(config-router-af)# autonomous-system 1 2(config-router-af)# router ospf 4 vrf BHHQ // Protocole OSPF4 2(config-router)# network 192.168.102.0 0.0.0.255 area 0 2(config-router)# router rip // Protocole RIP V2 2(config-router)#version 2 2(config-router)#address-family ipv4 vrf OTB 2(config-router-af)#network 192.168.92.0 2(config-router-af)#no auto-summary  BGP (MP-BGP) 2(config-router)# router bgp 1 // Protocole BGP 2(config-router)# neighbor 4.4.4.4 remote-as 1 2(config-router)# neighbor 4.4.4.4 update-source Loopback0 2(config-router)# address-family vpnv4 // Activation du protocole MP-BGP 2(config-router-af)# neighbor 4.4.4.4 activate 2(config-router-af)# neighbor 4.4.4.4 send-community both
  • 17.  Redistribution des routes des VRF // RIP & EIGRP & OSPF 4 dans BGP 2(config-router-af)# address-family ipv4 vrf OTB 2(config-router-af)# redistribute rip 2(config-router-af)# address-family ipv4 vrf MHQ 2(config-router-af)# redistribute eigrp 100 2(config-router-af)# address-family ipv4 vrf BHHQ 2(config-router-af)# redistribute ospf 4 vrf BHHQ // BGP dans RIP 2(config-router)# router rip 2(config-router)#version 2 2(config-router)#address-family ipv4 vrf OTB 2(config-router-af)#redistribute bgp 1 metric transparent // BGP dans OSPF4 2(config-router-af)# router ospf 4 vrf BHHQ 2(config-router)# redistribute bgp 1 subnets // BGP dans EIGRP 2(config-if)# router eigrp 100 2(config-router)# address-family ipv4 vrf MHQ 2(config-router-af)# redistribute bgp 1 metric 64 1000 255 1 1500 Routeur « 4 » : PE2  Interfaces 4#conf t 4(config)#int loo0 4(config-if)# ip address 4.4.4.4 255.255.255.0 4(config-if)#int f0/0 4(config-if)#no sh 4(config-if)# ip address 192.168.43.4 255.255.255.0
  • 18.  Protocole de routage 4(config-if)#router osp 1 4(config-router)# network 4.4.4.0 0.0.0.255 area 0 4(config-router)# network 192.168.43.0 0.0.0.255 area 0  MPLS 4(config-router)#exit 4(config)#ip cef // Activation du Cisco Express Forwarding 4(config)#mpls label protocol ldp // Activation du protocole de LDP pour l’échange de labels 4(config)#mpls ldp router-id loo0 // Affectation de la boucle locale au protocole LDP 4(config)#int f0/0 4(config-if)#mpls ip // Activation du MPLS sur l’interface F0/1 4(config-if)#exit  VRF // Création des VRF 4(config)# ip vrf INT 4(config-vrf)# rd 11:11 4(config-vrf)#route-target export 11:11 4(config-vrf)# route-target import 77:88 4(config-vrf)# route-target import 10:10 4(config-vrf)# route-target import 19:56 4(config-vrf)# ip vrf MB 4(config-vrf)# rd 5:5 4(config-vrf)# route-target both 19:56 4(config-vrf)# route-target import 11:11 4(config-vrf)# ip vrf OTHQ 4(config-vrf)# route-target both 19:56 4(config-vrf)# route-target import 11:11
  • 19. 4(config-vrf)#exit 4(config)# ip vrf SFAX1 4(config-vrf)# rd 8:8 4(config-vrf)#route-target export 77:88 4(config-vrf)# route-target import 10:10 4(config-vrf)# route-target import 11:11 4(config)# ip vrf SFAX2 4(config-vrf)# rd 8:8 4(config-vrf)#route-target export 77:88 4(config-vrf)# route-target import 10:10 4(config-vrf)# route-target import 11:11 // Affectation desVRF aux interfaces adéquates 4(config)# interface FastEthernet0/1 4(config-if)# ip vrf forwarding MB 4(config-if)# ip address 192.168.54.4 255.255.255.0 4(config-if)# interface FastEthernet1/0 4(config-if)# ip vrf forwarding INT 4(config-if)# ip address 192.168.114.4 255.255.255.0 4(config-if)# interface FastEthernet2/0 4(config-if)# ip vrf forwarding OTHQ 4(config-if)# ip address 192.168.64.4 255.255.255.0 4(config-if)# interface FastEthernet3/0 4(config-if)# ip vrf forwarding SFAX2 4(config-if)# ip address 192.168.74.4 255.255.255.0 4(config-if)# interface FastEthernet4/0 4(config-if)# ip vrf forwarding SFAX1 4(config-if)# ip address 192.168.84.4 255.255.255.0 // Protocoles de routage de chaques VRF 4(config-if)# router eigrp 100 // Protocole EIGRP 4(config-router)# address-family ipv4 vrf MB
  • 20. 4(config-router-af)# network 192.168.54.0 4(config-router-af)# no auto-summary 4(config-router-af)# autonomous-system 1 4(config-router-af)# router ospf 3 vrf INT // Protocole OSPF3 4(config-router)# network 192.168.114.0 0.0.0.255 area 0 4(config-router)# router rip // Protocole RIP V2 4(config-router)#version 2 4(config-router)#address-family ipv4 vrf OTHQ 4(config-router-af)# network 192.168.64.0 4(config-router-af)#no auto-summary 4(config-router-af)# router ospf 2 vrf SFAX2 // Protocole OSPF2 4(config-router)# network 192.168.74.0 0.0.0.255 area 0 4(config-router-af)# router ospf 5 vrf SFAX1 // Protocole OSPF5 4(config-router)# network 192.168.84.0 0.0.0.255 area 0  BGP (MP-BGP) 4(config-router)# router bgp 1 // Protocole BGP 4(config-router)# neighbor 2.2.2.2 remote-as 1 4(config-router)# neighbor 2.2.2.2 update-source Loopback0 4(config-router)# address-family vpnv4 // Activation du protocole MP-BGP 4(config-router-af)# neighbor 2.2.2.2 activate 4(config-router-af)# neighbor 2.2.2.2 send-community both  Redistribution des routes des VRF // RIP & EIGRP & OSPF 3,5,2 dans BGP 4(config-router-af)# address-family ipv4 vrf OTHQ 4(config-router-af)# redistribute rip 4(config-router-af)# address-family ipv4 vrf MB 4(config-router-af)# redistribute eigrp 100
  • 21. 4(config-router-af)# address-family ipv4 vrf SFAX1 4(config-router-af)# redistribute ospf 5 vrf SFAX1 4(config-router-af)# address-family ipv4 vrf SFAX2 4(config-router-af)# redistribute ospf 2 vrf SFAX2 4(config-router-af)# address-family ipv4 vrf INT 4(config-router-af)# redistribute ospf 3 vrf INT // BGP dans RIP 4(config-router)# router rip 4(config-router)#version 2 4(config-router)#address-family ipv4 vrf OTHQ 4(config-router-af)#redistribute bgp 1 metric transparent // BGP dans EIGRP 4(config-if)# router eigrp 100 4(config-router)# address-family ipv4 vrf MB 4(config-router-af)# redistribute bgp 1 metric 64 1000 255 1 1500 // BGP dans OSPF3 4(config-router-af)# router ospf 3 vrf INT 4(config-router)# redistribute bgp 1 subnets // BGP dans OSPF5 4(config-router-af)# router ospf 5 vrf SFAX1 4(config-router)# redistribute bgp 1 subnets // BGP dans OSPF2 4(config-router-af)# router ospf 2 vrf SFAX2 4(config-router)# redistribute bgp 1 subnets
  • 22. CONFIGURATION ET PARTAGE DE LA ROUTE PAR DEFAUT Routeur « 11 » : Internet  Definition et redistribution de la route par défaut 11(config)#ip route 0.0.0.0 0.0.0.0 193.95.66.1 // Route par défaut 11(config)#router ospf 3 11(config-router)#default-information originate  // Redistribution Configuration du NAT 11(config-router)#int f0/0 // Définition de l’interface d’entrée du NAT 11(config-if)#ip nat inside 11(config-router)#int f0/1 // Définition de l’interface de sortie du NAT 11(config-if)#ip nat outside 11(config)#access-list permit any // Création d’une ACL qu’on utilisera comme source du NAT 11(config)#ip nat pool NAT 193.95.66.100 193.95.66.200 netmask 255.255.255.0 // Pool d’@ 11(config)# ip nat inside source list 1 pool NAT // Activation du NAT Routeur « 4 » : PE2  Redistribution de la route par defaut dans les VRF 4(config)# router bgp 1 4(config-router)# address-family ipv4 vrf INT 4(config-router-af)# redistribute ospf 3 vrf INT match internal external 1 external 2 4(config-router-af)# default-information originate
  • 23. TEST FINAL -Ping entre OneTech et Monoprix et leur accès à l’internet -Ping entre SFAX1, SFAX2 et le noeud central BH et leur accès à l’internet
  • 24. -Accès internet sur XP On teste ainsi si au niveau de l’hôte XP( reliée à MonoprixHQ) nous avons accès à internet :