SlideShare une entreprise Scribd logo
1  sur  23
Le protocole OSPF
Guérin Julien 2005-2006
Mézerette Marius GTR FI 2A
Plan
 Introduction
 Présentation du protocole OSPF
 Fonctionnement global
 Sous protocoles Hello, échange, Inondation
 L’algorithme SPF
 Notion de système autonome et de zone OSPF
 Configuration d’un réseau OSPF
 Présentation de la maquette
 Configuration des routeurs
 Mise en place de RIP
 Validation de fonctionnement & Tests
 Tests de connectivité
 Fonctionnement entre zones OSPF
 Cohabitation entre RIP et OSPF
 Conclusion
 Sources
Introduction
 OSPF pour Open Shortest Path First
 Protocole de routage à état de liens
 Conçu au sein de l’IETF (Internet Engineering Task
Force) à la fin des années 80
 But : Résoudre les principaux défauts du protocole RIP
 Temps de convergence
 Augmentation du nombre de routeurs
 Structure réseau d’interconnexions de taille plus importante
 Meilleure efficacité
 Contrôle sur la propagation des informations de routage
 Meilleure bande passante utile
Présentation du protocole OSPF
 Fonctionnement global
 Chaque routeur test le fonctionnement de ses
interconnexions avec les routeurs voisins
 Chaque routeur tiens à jour une base d’état de
lien
 Élection d’un routeur : « Designated Routeur »
(DR) et d’un BackupDR si le DR devient
indisponible, qui sera chargé de diffuser les
bases d’état de lien
 Grâce aux bases d’état de lien chaque routeur
calcul la route la moins « chère » pour
atteindre les différents réseaux
Présentation du protocole OSPF
 Sous protocoles Hello
 Message Hello envoyé périodiquement
pour confirmer l’état de ses liens
 Contient de nombreuses informations
telles que :
 Un identifiant
 La fréquence d’émission des messages Hello (10s)
 La durée au bout de laquelle un routeur ne répondant
pas sera considéré comme mort (40s)
 Le numéro de la zone à laquelle le routeur appartient
 La priorité du routeur
 @IP du DR et du BDR
Présentation du protocole OSPF
 Sous protocoles échange
 Suite d’un échange réussi de messages
Hello entre deux routeurs
 Échange de Messages « Link State
Advertisement » (LSA) contenant :
 @IP du routeur
 Coût de la liaison avec ses voisins
 Numéro de séquence
 Synchronisation des bases d’état de lien:
Statut « FULL »
 Chaque routeur exécute alors
l’algorithme SPF
Présentation du protocole OSPF
 Sous protocoles Inondation
 Utilisé lorsqu’un lien change d’état et
pour des échanges toutes les 30minutes
 Envoie des messages « Link State
Update » (LSU)
 Permet une mise à jour des tables de
routages rapides :
 Mise à jour des bases d’état de lien
 Nouvelle exécution de l’algorithme SPF
Présentation du protocole OSPF
 L’algorithme SPF
 Créé par Djikstra à la base pour calculer
le moyen le plus rapide pour atteindre
un point par l’intermédiaire de vecteur
dans un plan
 Utilisé pour calculer le chemin le plus
rapide pour atteindre un réseau :
 Un lien correspondant à un vecteur
 La longueur du vecteur correspondant à un
coût calculé selon le débit du lien : 10^8/
débit max (en bits/s)
Lien Ethernet : 10
Lien Série 56Kb/s : 1785
Présentation du protocole OSPF
 Notion de système autonome
 Le réseau internet est découpé en
systèmes autonomes
 Un système autonome est un réseau IP
de grande taille comportant un grand
nombre de routeur
 OSPF intervient au niveau du routage
Intra-domaine
Présentation du protocole OSPF
 Notion de zone OSPF
 Un réseau OSPF ne peut contenir plus de
50 routeurs -> nécessité de découper un
réseau en plusieurs zones OSPF
 Entre chaque zones OSPF on place un
ABR qui transmettra les bases d’état de
lien entre zones voisines
 Obligation d’avoir une zone « Backbone
» numéroté 0 qui assure le transfert des
tables de routages
 Les zones secondaires sont numérotés
de 1 à 4294996795
Configuration d’un réseau OSPF
 Présentation de la maquette
Configuration d’un réseau OSPF
 4 zones : zone backbone obligatoire
située au centre car elle relie les
autres zones entre-elles.  3 Cisco
2500
 Zones secondaires :
 Border Router : Cisco 2500
 Un routeur Cisco 2600 interne à la zone.
 Réseau terminal où une station est
branchée.
Configuration d’un réseau OSPF
 Configuration des BR :
 On active OSPF sur chacun d'eux
  Liste des réseau auxquels ils sont
rattachés
>Conf t
>router ospf <ID processus> // permet d'activer
OSPF avec un numéro associé, ici 1
>network <n° de réseau> <masque inversé>
area <n° de zone> // fourni la liste des réseaux
où le routeur est relié plus le numéro de zone
associé.
>network ... // autant de fois que de réseaux
reliés physiquement.
Configuration d’un réseau OSPF
 On procède de même pour les 2600
Exemple du Routeur R2600Haut :
router ospf 1
network 192.168.70.0 0.0.0.255 area 1 //zone 1, lien vers la zone 0
network 192.168.80.0 0.0.0.255 area 1 //zone 1, lien vers le réseau
Configuration d’un réseau OSPF
 Cohabitation RIP & OSPF
 Zone 1 en routage RIP
 Désactiver le routage OSPF
  « no router ospf 1 ».
 Activer RIP et déclarer les routes à
partager
Sur le R2600Haut :
router rip
network 192.168.70.0
network 192.168.80.0
Configuration d’un réseau OSPF
 Le BR doit faire la traduction des routes
RIP et OSPF :
router ospf 1
redistribute rip subnets //redistribution des routes
RIP en routes OPSF
router rip
redistribute ospf 1
network 192.168.70.0 //les routes apprises via OSPF
seront émises sur le numéro de réseau 192.168.70.0
default-metric 10 //la métrique par défaut des routes
exporté via OSPF sera de 10
Validation de fonctionnement &
Tests
 Tests de connectivité
 Vérification sur chaque routeur de l’état des
connections : « sh int »
 Pour vérifier l’accessibilité du routeur on effectue
un ping à partir de la station vers le routeur
Validation de fonctionnement &
Tests
 Tests spécifiques à OSPF :
 Sh IP OSPF
 Sh IP OSPF Interface : visualise les interfaces
configurées pour opsf
 Sh IP OSPF database : visualise les bases de
données des routeurs
 Sh IP OSPF database router : visualise les
informations échangées et interroge les bases de
données
Validation de fonctionnement &
Tests
 Fonctionnement entre zones OSPF 1
 On vérifie les tables de routages (exemple du
routeur 2600 n°22) :
Validation de fonctionnement &
Tests
 Fonctionnement entre zones OSPF 2
 On peut vérifier l’accessiblité des stations grâce a
des pings ou des traceroutes :
Validation de fonctionnement &
Tests
 Cohabitation entre RIP et OSPF 1
 On commence par vérifier les tables de routages
des routeurs de la zone OPSF (exemple du routeur
2600 n°22) et de celui de la zone RIP :
Validation de fonctionnement &
Tests
 Cohabitation entre RIP et OSPF 2
 Pour confirmer l’accessibilité de la station situé
dans la zone RIP à partir d’une zone OSPF on
réalise un ping d’une zone OSPF vers la zone RIP
et inversement :
Conclusion
 Ainsi OSPF tend à remplacer peu à peu le
protocole RIP premier protocole de routage
intra domaine.
 Les limites de RIP sont aujourd’hui
dépassées.
 Ceci grâce à son calcul du plus court
chemin à sa stabilité et à sa moindre
consommation de bande passante et son
amélioration du temps de convergence.
 Il reste néanmoins plus ‘difficile’ à
implémenter que RIP et demande plus de
ressources processeur aux routeurs.
 Mais comme RIP, OSPF reste limité au
routage intra-domaine

Contenu connexe

Similaire à 1301000.ppt

1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage
Simo Qb
 

Similaire à 1301000.ppt (20)

OSPF Presentation
OSPF PresentationOSPF Presentation
OSPF Presentation
 
Le protocole rip
Le protocole rip Le protocole rip
Le protocole rip
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
 
CCNA 3.pdf
CCNA 3.pdfCCNA 3.pdf
CCNA 3.pdf
 
Routage ospf
Routage ospfRoutage ospf
Routage ospf
 
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : RoutingAlphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
 
Chapitre 6 - Protocoles TCP/IP, UDP/IP
Chapitre 6  - Protocoles TCP/IP, UDP/IPChapitre 6  - Protocoles TCP/IP, UDP/IP
Chapitre 6 - Protocoles TCP/IP, UDP/IP
 
CMs-Reseaux.pdf
CMs-Reseaux.pdfCMs-Reseaux.pdf
CMs-Reseaux.pdf
 
Fr introbgp-sif
Fr introbgp-sifFr introbgp-sif
Fr introbgp-sif
 
Présentation Packet Radio et APRS par F4BHQ et F1IJP
Présentation Packet Radio et APRS par F4BHQ et F1IJPPrésentation Packet Radio et APRS par F4BHQ et F1IJP
Présentation Packet Radio et APRS par F4BHQ et F1IJP
 
Weos routage dynamique OSPF
Weos routage dynamique OSPFWeos routage dynamique OSPF
Weos routage dynamique OSPF
 
Rip-ng vs ospf-v3
Rip-ng vs ospf-v3Rip-ng vs ospf-v3
Rip-ng vs ospf-v3
 
Configuration de-base-d
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
 
Presentation 6lowpan
Presentation 6lowpanPresentation 6lowpan
Presentation 6lowpan
 
Redondance de routeur (hsrp, vrrp, glbp)
Redondance de routeur (hsrp, vrrp, glbp)Redondance de routeur (hsrp, vrrp, glbp)
Redondance de routeur (hsrp, vrrp, glbp)
 
1485606887426.pdf
1485606887426.pdf1485606887426.pdf
1485606887426.pdf
 
1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage
 
Cours routage dynamique (ri pv1,ripv2,ripng)
Cours routage dynamique (ri pv1,ripv2,ripng) Cours routage dynamique (ri pv1,ripv2,ripng)
Cours routage dynamique (ri pv1,ripv2,ripng)
 
Routing in 6lowpan (in French)
Routing in 6lowpan (in French) Routing in 6lowpan (in French)
Routing in 6lowpan (in French)
 
Reseau Ad hoc - Bachar Haydar
Reseau Ad hoc - Bachar HaydarReseau Ad hoc - Bachar Haydar
Reseau Ad hoc - Bachar Haydar
 

1301000.ppt

  • 1. Le protocole OSPF Guérin Julien 2005-2006 Mézerette Marius GTR FI 2A
  • 2. Plan  Introduction  Présentation du protocole OSPF  Fonctionnement global  Sous protocoles Hello, échange, Inondation  L’algorithme SPF  Notion de système autonome et de zone OSPF  Configuration d’un réseau OSPF  Présentation de la maquette  Configuration des routeurs  Mise en place de RIP  Validation de fonctionnement & Tests  Tests de connectivité  Fonctionnement entre zones OSPF  Cohabitation entre RIP et OSPF  Conclusion  Sources
  • 3. Introduction  OSPF pour Open Shortest Path First  Protocole de routage à état de liens  Conçu au sein de l’IETF (Internet Engineering Task Force) à la fin des années 80  But : Résoudre les principaux défauts du protocole RIP  Temps de convergence  Augmentation du nombre de routeurs  Structure réseau d’interconnexions de taille plus importante  Meilleure efficacité  Contrôle sur la propagation des informations de routage  Meilleure bande passante utile
  • 4. Présentation du protocole OSPF  Fonctionnement global  Chaque routeur test le fonctionnement de ses interconnexions avec les routeurs voisins  Chaque routeur tiens à jour une base d’état de lien  Élection d’un routeur : « Designated Routeur » (DR) et d’un BackupDR si le DR devient indisponible, qui sera chargé de diffuser les bases d’état de lien  Grâce aux bases d’état de lien chaque routeur calcul la route la moins « chère » pour atteindre les différents réseaux
  • 5. Présentation du protocole OSPF  Sous protocoles Hello  Message Hello envoyé périodiquement pour confirmer l’état de ses liens  Contient de nombreuses informations telles que :  Un identifiant  La fréquence d’émission des messages Hello (10s)  La durée au bout de laquelle un routeur ne répondant pas sera considéré comme mort (40s)  Le numéro de la zone à laquelle le routeur appartient  La priorité du routeur  @IP du DR et du BDR
  • 6. Présentation du protocole OSPF  Sous protocoles échange  Suite d’un échange réussi de messages Hello entre deux routeurs  Échange de Messages « Link State Advertisement » (LSA) contenant :  @IP du routeur  Coût de la liaison avec ses voisins  Numéro de séquence  Synchronisation des bases d’état de lien: Statut « FULL »  Chaque routeur exécute alors l’algorithme SPF
  • 7. Présentation du protocole OSPF  Sous protocoles Inondation  Utilisé lorsqu’un lien change d’état et pour des échanges toutes les 30minutes  Envoie des messages « Link State Update » (LSU)  Permet une mise à jour des tables de routages rapides :  Mise à jour des bases d’état de lien  Nouvelle exécution de l’algorithme SPF
  • 8. Présentation du protocole OSPF  L’algorithme SPF  Créé par Djikstra à la base pour calculer le moyen le plus rapide pour atteindre un point par l’intermédiaire de vecteur dans un plan  Utilisé pour calculer le chemin le plus rapide pour atteindre un réseau :  Un lien correspondant à un vecteur  La longueur du vecteur correspondant à un coût calculé selon le débit du lien : 10^8/ débit max (en bits/s) Lien Ethernet : 10 Lien Série 56Kb/s : 1785
  • 9. Présentation du protocole OSPF  Notion de système autonome  Le réseau internet est découpé en systèmes autonomes  Un système autonome est un réseau IP de grande taille comportant un grand nombre de routeur  OSPF intervient au niveau du routage Intra-domaine
  • 10. Présentation du protocole OSPF  Notion de zone OSPF  Un réseau OSPF ne peut contenir plus de 50 routeurs -> nécessité de découper un réseau en plusieurs zones OSPF  Entre chaque zones OSPF on place un ABR qui transmettra les bases d’état de lien entre zones voisines  Obligation d’avoir une zone « Backbone » numéroté 0 qui assure le transfert des tables de routages  Les zones secondaires sont numérotés de 1 à 4294996795
  • 11. Configuration d’un réseau OSPF  Présentation de la maquette
  • 12. Configuration d’un réseau OSPF  4 zones : zone backbone obligatoire située au centre car elle relie les autres zones entre-elles.  3 Cisco 2500  Zones secondaires :  Border Router : Cisco 2500  Un routeur Cisco 2600 interne à la zone.  Réseau terminal où une station est branchée.
  • 13. Configuration d’un réseau OSPF  Configuration des BR :  On active OSPF sur chacun d'eux   Liste des réseau auxquels ils sont rattachés >Conf t >router ospf <ID processus> // permet d'activer OSPF avec un numéro associé, ici 1 >network <n° de réseau> <masque inversé> area <n° de zone> // fourni la liste des réseaux où le routeur est relié plus le numéro de zone associé. >network ... // autant de fois que de réseaux reliés physiquement.
  • 14. Configuration d’un réseau OSPF  On procède de même pour les 2600 Exemple du Routeur R2600Haut : router ospf 1 network 192.168.70.0 0.0.0.255 area 1 //zone 1, lien vers la zone 0 network 192.168.80.0 0.0.0.255 area 1 //zone 1, lien vers le réseau
  • 15. Configuration d’un réseau OSPF  Cohabitation RIP & OSPF  Zone 1 en routage RIP  Désactiver le routage OSPF   « no router ospf 1 ».  Activer RIP et déclarer les routes à partager Sur le R2600Haut : router rip network 192.168.70.0 network 192.168.80.0
  • 16. Configuration d’un réseau OSPF  Le BR doit faire la traduction des routes RIP et OSPF : router ospf 1 redistribute rip subnets //redistribution des routes RIP en routes OPSF router rip redistribute ospf 1 network 192.168.70.0 //les routes apprises via OSPF seront émises sur le numéro de réseau 192.168.70.0 default-metric 10 //la métrique par défaut des routes exporté via OSPF sera de 10
  • 17. Validation de fonctionnement & Tests  Tests de connectivité  Vérification sur chaque routeur de l’état des connections : « sh int »  Pour vérifier l’accessibilité du routeur on effectue un ping à partir de la station vers le routeur
  • 18. Validation de fonctionnement & Tests  Tests spécifiques à OSPF :  Sh IP OSPF  Sh IP OSPF Interface : visualise les interfaces configurées pour opsf  Sh IP OSPF database : visualise les bases de données des routeurs  Sh IP OSPF database router : visualise les informations échangées et interroge les bases de données
  • 19. Validation de fonctionnement & Tests  Fonctionnement entre zones OSPF 1  On vérifie les tables de routages (exemple du routeur 2600 n°22) :
  • 20. Validation de fonctionnement & Tests  Fonctionnement entre zones OSPF 2  On peut vérifier l’accessiblité des stations grâce a des pings ou des traceroutes :
  • 21. Validation de fonctionnement & Tests  Cohabitation entre RIP et OSPF 1  On commence par vérifier les tables de routages des routeurs de la zone OPSF (exemple du routeur 2600 n°22) et de celui de la zone RIP :
  • 22. Validation de fonctionnement & Tests  Cohabitation entre RIP et OSPF 2  Pour confirmer l’accessibilité de la station situé dans la zone RIP à partir d’une zone OSPF on réalise un ping d’une zone OSPF vers la zone RIP et inversement :
  • 23. Conclusion  Ainsi OSPF tend à remplacer peu à peu le protocole RIP premier protocole de routage intra domaine.  Les limites de RIP sont aujourd’hui dépassées.  Ceci grâce à son calcul du plus court chemin à sa stabilité et à sa moindre consommation de bande passante et son amélioration du temps de convergence.  Il reste néanmoins plus ‘difficile’ à implémenter que RIP et demande plus de ressources processeur aux routeurs.  Mais comme RIP, OSPF reste limité au routage intra-domaine