SlideShare une entreprise Scribd logo
Formation
CCNP ENCOR 350-401 (2/8)
Routage
Une formation
Yazid AZIZI
Une formation
Yazid AZIZI
Consultant Instructeur Cisco – IT Manager - Chef de projet
ERP (SAP)
Certifications Cisco (CCNP R&S, CCNA R&S, CCNA Security,
CCNA CyberOps, DevNet,)
Présentation du formateur
Email: yazid.azizi1@gmail.com
LinkedIn : https://www.linkedin.com/in/yazid-azizi/
Rappel cursus CCNP ENCOR 350-401
Une formation
Introduction
1. Essentiels du routage IP
2. Protocole de routage EIGRP
3. Protocole de routage OSPFv2
4. Protocole de routage OSPFv2 avancé
5. Protocole de routage OSPFv3
6. Protocole de routage BGP
7. Protocole de routage BGP avancé
Conclusion
Plan de la formation
Une formation
Ingénieurs réseau de niveau intermédiaire
Administrateurs réseau
Techniciens d'assistance réseau
Techniciens du helpdesk
Public concerné
Certification CCNP 350-401
Une formation
Connaissances requises
Présentation du lab
Une formation
Yazid AZIZI
Une formation
Présentation des outils
Packet Tracer
Créer un compte Cisco NetAcad
Télécharger Packet Tracer
Utiliser Packet Tracer
EVE-NG
Télécharger EVE-NG
Intégrer les IOS sur EVE-NG
Utiliser EVE-NG
GNS 3
Télécharger GNS3
Intégrer les IOS sur GNS3
Utiliser GNS3
Packet Tracer
EVE-NG
GNS3
Télécharger et Installer
EVE-NG
Une formation
Yazid AZIZI
Télécharger et Installer
GNS3
Une formation
Yazid AZIZI
Connaitre les essentiels
du routage IP
Une formation
Yazid AZIZI
Protocole de routage
Les protocoles de routage dynamique
courants
RIPv2
EIGRP
OSPF
IS-IS
Protocole BGP
Algorithmes de vecteur de distance
Algorithmes de vecteur de distance améliorés
(EIGRP)
Un temps de convergence rapide
Des mises à jour uniquement en cas de modification du réseau
Pas de mises à jour complètes de la table de routage de manière périodique
Algorithmes de vecteur de distance améliorés
(EIGRP)
Paquet hello
bande passante, le délai, la fiabilité, la charge et (MTU)
Equilibrer la charge
Algorithmes d'état de lien
Paquet LSA
Algorithme de vecteur de chemin
Chemin système autonome (AS_Path)
Le discriminateur à sorties multiples (MED)
L'origine
Le prochain bond
La préférence locale
L'agrégat atomique
L'agrégateur
Sélectionner le chemin
Une formation
Yazid AZIZI
Sélection de chemin
1. Longueur du préfixe
2. Distance administrative
3. Métriques
Longueur du préfixe
La table de routage: 10.0.3.0/28, 10.0.3.0/26 et 10.0.3.0/24
Le tableau présente cette table de routage
Prefix IP Address Range Next Hop Outgoing Interface
10.0.3.0/28 10.0.3.0–10.0.3.15 10.1.1.1 Gigabit Ethernet 1/1
10.0.3.0/26 10.0.3.0–10.0.3.63 10.2.2.2 Gigabit Ethernet 2/2
10.0.3.0/24 10.0.3.0–10.0.3.255 10.3.3.3 Gigabit Ethernet 3/3
Distance administrative
Routing Protocol Distance Administrative par défaut
Interface 0
Static 1
EIGRP summary route 5
External BGP (eBGP) 20
EIGRP (internal) 90
OSPF 110
IS-IS 115
RIP 120
EIGRP (external) 170
Internal BGP (iBGP) 200
Chacun de ces trois protocoles tente d'installer la route vers 10.3.3.0/24 dans la
table de routage
Distance administrative
Routing Protocol AD Réseau S'installe dans le RIB
EIGRP 90 10.3.3.0/24
OSPF 110 10.3.3.0/24 X
IS-IS 115 10.3.3.0/24 X
Mesures de sélection de chemin Multipathing à coût
égal
Équilibrage de charge à coûts inégaux
Topologie avec quatre routeurs exécutant EIGRP
Comprendre le routage
statique
Une formation
Yazid AZIZI
Utilité des routes statiques
Types de route statique
Routes statiques directement connectées
Route statique récursive
Route statique entièrement spécifiée
Routage statique flottant
Routes statiques nulles
Une formation
La commande ip route network subnetmask next-hop-interface-id
Routes statiques directement connectées
Topologie série P2P avec R1 et R2 directement connectés avec
une connexion série
La commande ip route network subnet-mask next-hop-ip
Routes statiques récursives
Routes statiques entièrement spécifiées
La commande ip route network subnet-mask interface-id next-hop-ip
Routage statique flottant
Routes statiques nulles
Routes statiques IPv6
Configurées avec la commande ipv6 route network / prefix-length {next-hop-
interface-id | [id-interface-prochain-saut] adresse-IP suivante}
LAB
Découvrir le routage
et transfert virtuels (VRF)
Une formation
Yazid AZIZI
Routage et transfert virtuels et Table de routage VRF
instance de VRF de gestion nommée MGMT vrf definition vrf-name
La commande address-family {ipv4 | ipv6}
La commande vrf forwarding vrf-name
La commande vrf definition vrf-name
La commande address-family {ipv4 | ipv6}
La commande interface-id
La commande vrf forwarding vrf-name
IPv4 - ip address ip-address subnet-mask [secondary]
IPv6 - ipv6 address ipv6-address/prefix-length
Créer un VRF et l'affecter à une
interface
Une formation
Interfaces et d'adresses IP qui se chevauchent entre
la table de routage globale et l'instance VRF
Interface IP Address VRF Global
Gigabit Ethernet 0/1 10.0.3.1/24 --
Gigabit Ethernet 0/2 10.0.4.1/24 --
Gigabit Ethernet 0/3 10.0.3.1/24 MGMT --
Gigabit Ethernet 0/4 10.0.4.1/24 MGMT --
Découvrir les fondamentaux
EIGRP
Une formation
Yazid AZIZI
Systèmes autonomes
Chaque processus fonctionne dans le contexte d'un système autonome, qui
représente un domaine de routage commun
Terminologie EIGRP
Terme
Route successeur
successeur
Terminologie EIGRP
Terme
Distance faisable (FD)/
Feasible distance
Distance rapportée
(RD)/Reported distance
Terminologie EIGRP
Terme
Condition de
faisabilité
Successeur de
faisabilité
Préfixe de réseau
Voisins EIGRP qui ont annoncé ce préfixe
Mesures de chaque voisin (par exemple, distance
signalée, nombre de sauts)
Valeurs utilisées pour calculer la métrique
Charge
Fiabilité
délai total
bande passante minimale
Table de topologie
Une formation
Table de topologie
La commande show topology affichera
à la fois le successeur et les successeurs
possibles
Voisins EIGRP
Type Nom du Packet
1 Hello
2 Request
3 Update
4 Query
5 Reply
Calculer la métrique
de chemin
Une formation
Yazid AZIZI
Formule métrique classique EIGRP
Formule métrique classique EIGRP avec définitions
Formule métrique classique EIGRP avec valeurs K par
défaut
Propagation des attributs EIGRP
Mesures d'interface EIGRP par défaut pour les
mesures classiques
Type Interface Link Speed (kbps) Délais Métrique
Serial 64 20,000 μs 40,512,000
T1 1544 20,000 μs 2,170,031
Ethernet 10,000 1000 μs 281,600
FastEthernet 100,000 100 μs 28,160
GigabitEthernet 1,000,000 10 μs 2816
10 GigabitEthernet 10,000,000 10 μs 512
Formule EIGRP Wide Metrics
Compatibilité descendante métrique
Load Balancing
Commande show ip route
Détecter des pannes
et minuteries
Une formation
Yazid AZIZI
Convergence
Les routeurs en aval exécutent leur propre DUAL pour tous les préfixes
concernés afin de tenir compte des nouvelles métriques EIGRP
La figure illustre un tel scénario lorsque la liaison entre R1 et R3 échoue
Opérations effectuées par EGIRP
Répondre à la requête que le routeur n'a pas de route vers le préfixe
Si la requête ne provient pas du successeur de cet itinéraire, elle détecte le délai défini pour
l'infini mais l'ignore car il ne vient pas du successeur
Le routeur de réception répond avec les attributs EIGRP pour cet itinéraire
Si la requête provient du successeur de la route, le routeur de réception détecte le délai défini
pour l'infini, définit le préfixe comme actif dans la topologie EIGRP et envoie un paquet
d'interrogation à tous les voisins EIGRP en aval pour cette route
Processus de requête
Se poursuit de routeur en routeur jusqu'à ce qu'un
routeur établisse la limite de requête
Une limite de requête est établie lorsqu'un routeur
ne marque pas le préfixe comme actif
Il dit qu'il n'a pas de route vers le préfixe
Il répond avec des attributs EIGRP car la requête ne
provient pas du successeur
Une formation
Convergence
Termine le DUAL
Change la route en passive
Envoie un paquet de réponse à tous les routeurs en amont qui lui ont envoyé
un paquet de requête
La Figure montre une topologie où la liaison entre R1 et R2 a échoué
Lab Configuration EIGRP
Configurer la récapitulation
automatique EIGRP
Une formation
Yazid AZIZI
Réduction de l'étendue de la requête à l'aide
d'itinéraires récapitulatifs
Configuration de la récapitulation EIGRP
Réduit la taille des tables de routage sur les routeurs
Limite la portée de la requête
HQ Table de routage sans résumé
Activer auto-summarization sur router BRs
HQ Table de routage après résumé
LAB EIGRP - Résumés Auto
Configuration de la récapitulation manuelle
HQ BR1A après récapitulation manuelle
HQ RT après récapitulation manuelle
LAB EIGRP - Résumés Manuel
Configurer un routeur pour
propager une route par défaut
Une formation
Yazid AZIZI
Obtention de l'itinéraire par défaut
Une route par défaut configurée statiquement définie
localement avec la commande ip route 0.0.0.0 0.0.0.0
next-hop | interface
EIGRP peut redistribuer les routes par défaut définies
statiquement à l'aide de la commande de configuration
redistribute static
Tout réseau classfull résidant dans la table de routage
locale peut devenir un candidat par défaut lorsqu'il est
utilisé avec la commande de configuration ip default-
network
Une formation
Redistribution statique
Redistribution statique
LAB EIGRP - la route par default
Effectuer l'Authentification
EIGRP
Une formation
Yazid AZIZI
Options d'authentification
Configuration de l'authentification
EIGRP
Étape 1
Configurer la key chain
Étape 2
Configurer le mode d'authentification pour EIGRP
Étape 3
Activer l'authentification pour utiliser la ou les key
chains
Une formation
Configuration de l'authentification EIGRP
Configuration de l'authentification EIGRP
Configurer l'authentification de routage basée sur les
clés EIGRP
Configuration de l'authentification EIGRP Pour
IPv6
Configuration de l'authentification EIGRP
Pour IPv6
Configuration de l'authentification EIGRP
nommée
LAB EIGRP
Lab 03-05 Configuration de l'authentification EIGRP
Découvrir
les fondamentaux OSPF
Une formation
Yazid AZIZI
LSAs, LSDB et SPT
OSPF envoie des annonces d'état de liaison (LSA) aux routeurs voisins
Les LSA contiennent l'état du lien et la métrique du lien
Les LSA reçus sont stockés dans une base de données locale appelée base de données d'état des
liens (LSDB)
Le LSDB fournit la topologie du réseau
Le SPT contient toutes les destinations réseau dans le domaine OSPF
Architecture OSPF
Utilise plusieurs zones OSPF dans le domaine de routage
Utilise une architecture hiérarchique à deux niveaux, où la zone 0 est une zone spéciale connue
sous le nom de dorsale, à laquelle toutes les autres zones doivent se connecter
Les zones non fédérales annoncent des routes dans la dorsale
Le backbone annonce les routes vers d'autres zones non backbone
Communication inter-routeur
OSPF utilise l’attribué du protocole IPv4 89 et les adresses de multidiffusion 224.0.0.5 et
224.0.0.6 (routeurs DR) lorsque cela est possible pour réduire le trafic inutile
Le Tableau décrit brièvement les cinq types de paquets OSPF
Type Nom Packet
1 Hello
2 Database description (DBD) ou (DDP)
3 Link-state request (LSR)
4 Link-state update (LSU)
5 Link-state ack
Paquets Hello OSPF
Champ de données La description
Router ID (RID) Un ID 32 bits unique dans un domaine OSPF
Authentication options Entre les routeurs OSPF: aucun, texte clair ou authentification MD5
Area ID Zone OSPF d'une interface
Un nombre de 32 bits écrit au format décimal à points (0.0.1.0) ou décimal (256)
Interface address mask Masque de réseau d'adresse IP principale de l'interface
Interface priority La priorité de l'interface du routeur pour les élections DR
Hello interval La durée, en secondes, pendant laquelle un routeur envoie des paquets Hello
Dead interval La durée, en secondes, pendant laquelle un routeur attend d'entendre un bonjour d'un
routeur voisin avant de déclarer ce routeur hors service
DR and BDR Adresse IP du DR et du DR de secours (BDR) pour la liaison réseau
Active neighbor Une liste de voisins OSPF sur le segment de réseau. Un routeur doit avoir reçu un Hello
du voisin dans l'intervalle Dead
Tableau États voisins OSPF
Etat La description
Down L'état initial d'une relation de voisinage
Indique que le routeur n'a reçu aucun paquet Hello OSPF
Attempt Indique qu'aucune information n'a été reçue récemment, mais que le routeur tente toujours
de communiquer
Init Indique qu'un paquet Hello a été reçu d'un autre routeur, mais que la communication
bidirectionnelle n'a pas été établie
2-Way Communication bidirectionnelle établie
Si un DR ou un BDR est nécessaire, l'élection se produit pendant cet état
ExStart Le premier état à former une contiguïté
Les routeurs identifient quel routeur sera le maître ou l'esclave pour la synchronisation LSDB
Exchange Les routeurs échangent des états de liaison à l'aide de paquets DBD
Loading LSR envoyés au voisin demandant des LSA plus récents qui ont été découverts (mais non
reçus) dans l'état Exchange
Full Les routeurs voisins sont entièrement adjacents
DR et BDR
La figure montre comment un DR simplifie une topologie à quatre
routeurs avec seulement trois contiguïtés voisines
Configurer OSPFv2 zones
unique dans un réseau routé
Une formation
Yazid AZIZI
Déclaration de réseau OSPF
Les instructions de réseau
router ospf process-id
network ip-address wildcard-mask area area-id
Configuration spécifique à l'interface
La deuxième méthode pour activer OSPF sur une interface pour IOS
router ospf process-id
Interface Id-interface
ip ospf process-id area area-id
Exigences pour qu'un voisinage
OSPF soit formé
Les Routeurs ID
Les interfaces
Les MTU sur les interfaces
L'ID de zone
L'activation DR
Les minuteries OSPF Hello et dead timers.
Le type d'authentification et les informations
d'identification
Les indicateurs de type de zone
Une formation
Définir statiquement le RID et les interfaces passives
Sélection automatique du RID avec OSPF
l'adresse IPv4 la plus élevée de toutes les interfaces de bouclage actives sur le
routeur
Utilise l'adresse IPv4 la plus élevée parmi toutes les interfaces actives sans boucle
Sélection manuel du RID avec OSPF
Router-id router-id
Les interfaces passives
Passive interface interface-id
Passive interface default
Lab – Configuration OSPF Zone unique
Comprendre l'annonce
de la route par défaut
Une formation
Yazid AZIZI
Topologie et configuration de la route par
défaut
Default-information originate
[ always ] [ metric metric-value ] [ metric-type typevalue ] [ route-map map-
name ]
Lab : Configurer la route par default OSPF Zone unique
Optimisations OSPF
courantes
Une formation
Yazid AZIZI
Type Interface Coût OSPF
T1 64
Ethernet 10
FastEthernet 1
GigabitEthernet 1
10 GigabitEthernet 1
Coûts de liaison
Changer l’intervalle Hello :
ip ospf hello-interval 1–65535.
Changer l’intervalle Dead :
ip ospf dead-interval 1–65535
Affiché les minuteries pour une interface OSPF
show ip ospf interface
Détection d'échec
Afficher le rôle de l’interface OSPF :
show ip ospf interface brief
Élections DR et BDR
Modifier la priorité d’une l’interface OSPF :
ip ospf priority 0–255
Élections DR et BDR
R1(config)# interface G0/1
R1(config-if)# ip ospf priority 100
R4(config)# interface G0/1
R4(config-if)# ip ospf priority 0
Diffusion: ip ospf network broadcast
P2P : ip ospf network point-to-point
Loopback : activé par defaut
Optimisation des réseaux de diffusion
Lab – Configuration Hello, Dead Timer OSPF Zone
unique
Comprendre pourquoi OSPF
multi-zones est utilisé
Une formation
Yazid AZIZI
Une zone OSPF augmente en taille à mesure que le nombre de liaisons réseau
et de routeurs augmente dans la zone
Bien que l'utilisation d'une seule zone simplifie la topologie
OSPF Areas
Les ABR sont responsables de diffuser les annonces des itinéraires d'une zone
et de leur injection dans une zone OSPF différente
Zone OSPF 0 et ABR
Zone OSPF 0 et ABR
Une formation
L'ID de zone = un champ de 32 bits (0 à 4 294 967
295) ou (0.0.0.0 à 255.255.255.255)
OSPF annonce l'ID de zone au format décimal pointé
dans le paquet Hello OSPF
ID Area
Lab - Configurations OSPF multi-zones et vérification
des interfaces pour les ABR
Routes intra-zone et inter-zones OSPF
Routes intra-zone et inter-zones OSPF
Routes intra-zone et inter-zones OSPF
Découvrir les annonces
sur l'état des liens
LSA
Une formation
Yazid AZIZI
Les composants du LSA : le type de LSA, l'âge du LSA, le numéro de séquence et les
annonces du routeur
Âge et inondation/flooding LSA: 0-1800 secondes
Séquences LSA: Le numéro de séquence LSA est un numéro de 32 bits
Types de LSA
Composantes de la LSA
Lien de routeur
show ip ospf database network
Lien réseau
Lien réseau
Lien récapitulatif
La métrique dans le LSA de type 3 utilise la logique suivante
Si le LSA de type 3 est créé à partir d'un LSA de type 1
Si le LSA de type 3 est créé à partir d'un LSA de type 3 à partir de la zone 0
Le LSA de type 3 contient l'ID d'état de liaison
Lien récapitulatif
Lien récapitulatif
Type 4 LSA
Type 5 LSA
Le LSID est le numéro de réseau externe
Connecter des zones non
contiguës dans OSPFv2
Une formation
Yazid AZIZI
Exemple de réseau non contigu
Supposer que la route 10.34.1.0/24 apprise par la zone 23 serait alors annoncée
dans la zone 0 de R2 et se propagerait ensuite vers la zone 12, serait une erreur
Une formation
Les LSA de type 1 reçus d'une zone créent des LSA de
type 3 dans la zone dorsale et les zones non fédérales
Les LSA de type 3 reçus de la zone 0 sont créés pour la
zone non dorsale
Les LSA de type 3 reçus d'une zone non fédérales
s'insèrent uniquement dans la LSDB pour la zone
source
Les ABR ne créent pas de LSA de type 3 pour les autres
zones (y compris une zone segmentée 0)
Règles pour créer des LSA de type 3
Comprendre comment OSPF
détermine le meilleur chemin
Une formation
Yazid AZIZI
Routes intra-zone
Routes inter-zones et chemins multiples à coût égal
Le nombre maximum par défaut de chemins multiples à coût égal (ECMP)
est de quatre chemins
Configurer la récapitulation
entre les zones OSPF
Une formation
Yazid AZIZI
Exemple de récapitulation des itinéraires
Principes de base de la synthèse
La récapitulation peut éliminer le calcul SPF en dehors de la zone pour les
préfixes résumés car les préfixes plus petits sont masqués
Principes de base de la synthèse
Récapitulation inter-zones
La figure montre 15 LSA de type 1 (172.16.1.0/24 à 172.16.15.0/24) résumés
en un seul LSA de type 3 (le réseau 172.16.0.0/20)
Mesures de récapitulation
R1 résume trois préfixes avec différents coûts de chemin
Configuration des métriques inter zones
Commande
area area-id range network subnet-mask [advertise | not-advertise] [cost
metric]
Lab - Configuration des métriques inter
zones
Filtrer les routes dans OSPFv2
pour améliorer les performances
Une formation
Yazid AZIZI
Une formation
Avantages de filtrage dans
OSPFv2
Pour identifier sélectivement les itinéraires qui sont
annoncés ou reçus des routeurs voisins
Pour manipuler les flux de trafic, réduire l'utilisation
de la mémoire ou améliorer la sécurité
Le filtrage des routes avec des protocoles de
routage vectoriels est simple
Filtrage avec récapitulation
R2 peut filtrer tous les LSA de type 1 générés dans la zone 12 pour ne pas être
annoncés dans la zone 0
Filtrage de zone
Topologie de filtrage de zone
Filtrage de zone
Filtrage de zone
Filtrage OSPF local
Commande: distribute-list {acl-number | acl-name | prefix prefix-list-name | route-map route-
map-name} in
Découvrir les principes
de base d'OSPFv3
Une formation
Yazid AZIZI
Une formation
Caractéristiques OSPFv3
ID de routeur
Authentification
Adjacences voisines
Plusieurs sous-réseaux sur une interface
Instances multiples
Une formation
Annonce d'état de lien OSPFv3
OSPFv3 / Protocole 89
L'adresse lien-local
la structure du routeur LSA (type 1)
Il renomme le résumé du réseau LSA en préfixe interarea LSA
ASBR LSA en LSA du routeur inter zone
Le routeur LSA
Les informations d'adresse IP - types de LSA
Préfixe intra-zone LSA
Lien LSA local
La base de données d'état des liens (LSDB)
OSPFv3 LSA Types
Type LS Nom
0x2001 Router
0x2002 Network
0x2003 Inter zone Prefix
0x2004 Inter zone router
0x4005 AS externe
0x2007 NSSA
0x0008 Lien
0x2009 Intra zone prefix
Une formation
Communication OSPFv3
L'adresse de destination est soit une adresse de
liaison locale de monodiffusion, soit une adresse de
portée de liaison locale de multidiffusion
FF02 :: 05
FF02 :: 06
Types de paquets OSPFv3
Configurer OSPFv3 à zone
unique
Une formation
Yazid AZIZI
Une formation
Étapes de configuration OSPFv3
«ipv6 unicast-routing»
ID de routeur 32 bits
(Facultatif) Initialiser la famille d'adresses
Activer OSPFv3 sur une interface
Lab- Configuration OSPFv3
Vérifier OSPFv3 à zone
unique
Une formation
Yazid AZIZI
Lab- Vérifier OSPFv3
Récapitulation des routes OSPFv3
Comprendre la prise en
charge d'IPv4 dans OSPFv3.
Une formation
Yazid AZIZI
Une formation
Activation de la prise en charge IPv4
Interface IPv4 a une adresse IPv6 (globale ou lien
local)
ospfv3 process-id ipv4 area area-id
OSPFv3 Topologie
Ajouter la prise en charge d'IPv4 aux interfaces
existantes
ospfv3 process-id ipv4 area area-id (L'interface doit avoir une adresse IPv6 globale ou
lien-local)
Ajouter la prise en charge d'IPv4 aux interfaces
existantes
Vérification des routes IPv4
Show ip route ospfv3
Affichage des interfaces OSPFv3
Show ospfv3 interface brief
Vérification des voisins OSPFv3
Show ospfv3 Neighbor.
Découvrir les fondamentaux
BGP
Une formation
Yazid AZIZI
Numéros de système autonome
La RFC 4893 a étendu le champ ASN de 2 octets à 4 octets (plage de 32 bits)
Remplir les conditions suivantes pour attribution d’un ASN
Une plage de réseau publique
La connectivité Internet
Une politique de routage unique
Numéros AS incluent des plages d'adresses privées
Les ASN 64 512 à 65 535 /la plage ASN 16 bits
Les ASN 4 200 000 000–4 294 967 294 /la plage étendue de 32 bits
Une formation
Attributs de chemin
Obligatoire bien connu
Discrétionnaire bien connu
Transitif facultatif
Facultatif non transitif
Prévention des boucles
Familles d'adresses
Découvrir une connexion
de branche eBGP
Une formation
Yazid AZIZI
Communication inter-routeur
BGP n'utilise pas de paquets Hello
BGP utilise le port TCP 179
Le bit ne pas fragmenter (DF)
BGP utilise TCP
Une session BGP inter routeurs BGP. Et les sessions à sauts multiples
Types de session BGP
Les sessions BGP sont classées en deux types
BGP interne (iBGP)
BGP externe (eBGP)
Une formation
Types de session BGP
iBGP, n'est pas une solution viable pour les raisons
suivantes
Évolutivité
Routage personnalisé
Attributs de chemin
Une formation
Différences de comportement eBGP
et iBGP
iBGP permet des sessions multi-sauts
Le routeur annonceur modifie l'adresse du prochain
saut
Le routeur annonceur ajoute son ASN à la variable
AS_Path existante
Le routeur de réception vérifie que la variable
AS_Path
BGP Messages
TYPE Nom
1 OPEN
2 UPDATE
3 NOTIFICATION
4 KEEPALIVE
États voisins BGP
La session BGP peut signaler les états suivants
Idle
Connect
Active
OpenSent
OpenConfirm
Established
Configurer une connexion
de branche eBGP
Une formation
Yazid AZIZI
Une formation
La configuration du routeur BGP
La configuration du routeur BGP nécessite les
composants suivants
Paramètres de session BGP
Initialisation de la famille d'adresses
Activer la famille d'adresses sur les pairs BGP
Lab - configuration du BGP
Annonce de préfixe
Type de préfixe RIB
Réseau connecté
Route statique ou protocole de routage
router bgp 65200
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.12.1.1 remote-as 65100
!
address-family ipv4
network 10.12.1.0 mask 255.255.255.0
network 192.168.2.2 mask 255.255.255.255
neighbor 10.12.1.1 activate
exit-address-family
Réception et affichage des itinéraires
BGP utilise trois tables pour gérer le préfixe réseau et les PA pour une route
Adj-RIB-In
Loc-RIB
Adj-RIB-Out
La commande show bgp ipv4 unicast
La commande show bgp ipv4 unicast network
La commande show bgp ipv4 voisin ip-address
advertised-routes
Annonces de route BGP à partir de sources
indirectes
Comprendre la récapitulation
de l'itinéraire dans BGP
Une formation
Yazid AZIZI
Récapitulatif des préfixes
Il existe deux techniques de récapitulation BGP
Statique
Dynamique
R1
R1
Adresse agrégée
R1
router bgp 65100
bgp log-neighbor-changes
network 10.12.1.0 mask 255.255.255.0
network 192.168.1.1 mask 255.255.255.255
network 192.168.3.3 mask 255.255.255.255
network 192.168.4.4 mask 255.255.255.255
redistribute ospf 1
neighbor 10.12.1.2 remote-as 65200
R2
router bgp 65100
bgp log-neighbor-changes
neighbor 10.12.1.1 remote-as 65100
neighbor 10.23.1.3 remote-as 65300
!
address-family ipv4
aggregate-address 192.168.0.0 255.255.0.0
aggregate-address 172.16.0.0 255.255.240.0
redistribute connected
neighbor 10.12.1.1 activate
neighbor 10.23.1.3 activate
exit-address-family
Une formation
Agrégat atomique
Script
R2
router bgp 65200
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.12.1.1 remote-as 65100
neighbor 10.23.1.3 remote-as 65300
!
address-family ipv4
aggregate-address 192.168.0.0 255.255.0.0 summary-only
aggregate-address 172.16.0.0 255.255.240.0 summary-only
redistribute connected
neighbor 10.12.1.1 activate
neighbor 10.23.1.3 activate
exit-address-family
R2#show bgp ipv4 unicast 172.16.0.0
BGP routing table entry for 172.16.0.0/20, version 6
Paths: (1 available, best #1, table default)
Not advertised to any peer
Refresh Epoch 2
65200, (aggregated by 65200 192.168.2.2)
10.23.1.2 from 10.23.1.2 (192.168.2.2)
Origin IGP, metric 0,localpref 100, valid 32768, valid, external, atomic-aggregate, best
rx pathid: 0, tx pathid: 0x0
Une formation
Agrégation de routes avec AS_SET
R2#show running-config | section router bgp
router bgp 65200
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.12.1.1 remote-as 65100
neighbor 10.23.1.3 remote-as 65300
!
address-family ipv4
aggregate-address 192.168.0.0 255.255.0.0 as-set summary-only
aggregate-address 172.16.0.0 255.255.240.0 as-set summary-only
redistribute connected
neighbor 10.12.1.1 activate
neighbor 10.23.1.3 activate
exit-address-family
Découvrir BGP multi
protocole pour IPv6
Une formation
Yazid AZIZI
BGP multi protocole
Attributs facultatifs et non transitifs BGPv4
NLRI multiprotocole accessible
NLRI multiprotocole inaccessible
Configuration du BGP IPv6
R1
router bgp 65100
bgp router-id 192.168.1.1
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2001:DB8:0:12::2 remote-as 65200
!
address-family ipv6
redistribute connected
neighbor 2001:DB8:0:12::2 activate
exit-address-family
R2
router bgp 65200
bgp router-id 192.168.2.2
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 2001:DB8:0:12::1 remote-as 65100
neighbor 2001:DB8:0:23::3 remote-as 65300
!
address-family ipv6
network 2001:DB8::2/128
network 2001:DB8:0:12::/64
network 2001:db8:0:23::/64
neighbor 2001:DB8:0:12::1 activate
neighbor 2001:DB8:0:23::3 activate
exit-address-family
Une formation
Affichage des voisins BGP IPv6
R1# show bgp ipv6 unicast neighbors 2001:DB8:0:12::2
! Output omitted for brevity
BGP neighbor is 2001:DB8:0:12::2, remote AS 65200, external link
BGP version 4, remote router ID 192.168.2.2
BGP state = Established, up for 00:28:25
Last read 00:00:54, last write 00:00:34, hold time is 180, keepalive interval is
60 seconds
Neighbor sessions:
1 active, is not multisession capable (disabled)
Neighbor capabilities:
Route refresh: advertised and received(new)
Four-octets ASN Capability: advertised and received
Address family IPv6 Unicast: advertised and received
Enhanced Refresh Capability: advertised and received
La commande : show bgp ipv6 unicast neighbors
ip-address [detail]
Affichage des tables BGP IPv6
R2# show bgp ipv6 unicast | begin Network
Network Next Hop Metric LocPrf Weight Path
*> 2001:DB8::1/128 2001:DB8:0:12::1 0 0 65100 ?
*> 2001:DB8::2/128 :: 0 32768 i
*> 2001:DB8::3/128 2001:DB8:0:23::3 0 0 65300 i
*> 2001:DB8:0:1::/64 2001:DB8:0:12::1 0 0 65100 ?
*> 2001:DB8:0:3::/64 2001:DB8:0:23::3 0 0 65300 i
*> 2001:DB8:0:12::/64 :: 0 32768 i
* 2001:DB8:0:12::1 0 0 65100 ?
*> 2001:DB8:0:23::/64 :: 0 32768 i
2001:DB8:0:23::3 0 0 65300 i
Récapitulation des routes IPv6
Bits Nécessaire Adresse
récapitulative
Réseaux
2 2001:db8:0:0::/62 2001:db8:0:0::/64 - 2001:db8:0:3::/64
3 2001:db8:0:0::/61 2001:db8:0:0::/64 - 2001:db8:0:7::/64
4 2001:db8:0:0::/60 2001:db8:0:0::/64 - 2001:db8:0:F::/64
5 2001:db8:0:0::/59 2001:db8:0:0::/64 - 2001:db8:0:1F::/64
6 2001:db8:0:0::/58 2001:db8:0:0::/64 - 2001:db8:0:3F::/64
La commande : aggregate-address prefix/prefix-length [summary-only] [as-set]
Configurer BGP IPv6
Une formation
Yazid AZIZI
Lab
Comprendre le multihoming
BGP
Une formation
Yazid AZIZI
Résilience des fournisseurs de services
Routage de transit Internet
Acheminement du transit en succursale
Acheminement du transit en succursale
Le routage de transit au centre de données ou à d'autres emplacements planifiés est normal dans les
conceptions d'entreprise car ils ont pris en compte la bande passante
Découvrir les ACL et
la correspondance de préfixes
Une formation
Yazid AZIZI
Une formation
Listes de contrôle d'accès
Rappel : Les ACL sont classées en deux catégories
Standard et Extended
ACL standard
ACL étendues
ACL nommées
ACL standard
Étape 1
ip access-list standard {acl-number | acl-name}
Étape 2
[sequence] {permit | deny} source source-wildcard
Entrée ACE Réseau
permit any Permits tous le réseau
permit 172.16.0.0 0.0.255.255 Permits tous le réseau 172.16.0.0
permit host 192.168.1.1 Permits que l’hot 192.168.1.1/32 du réseau
ACL Etendues
Étape 1
ip access-list extended {acl-number | acl-name}
Étape 2
[sequence] {permit | deny} protocol source source-wildcard destination
destination-wildcard
Entrée ACE Réseau
permit any Autorise tous les réseaux
permit ip 172.16.0.0 0.0.255.255 Autorise la plage réseau 172.16.0.0
permit ip host 92.168.1.1 Autorise seulement 192.168.1.1/32
Sélection de réseau IGP ACL étendue
Entrée ACE Réseau
permit ip any any Autorise tous les réseaux
permit ip host 172.16.0.0 host 255.240.0.0 Autorise tous les réseaux de la plage 172.16.0.0/12
permit ip host 172.16.0.0 host 255.255.0.0 Autorise tous les réseaux de la plage 172.16.0.0/16
permit host 192.168.1.1 Autorise uniquement @ip 192.168.1.1/32
Sélection de réseau BGP ACL étendue
Sélection de réseau BGP ACL étendue
Une configuration de bits de poids fort et un nombre de bits de poids fort
Modèle de bits de poids fort comme adresse ou réseau, et le nombre de bits de
poids fort comme longueur de masque
Correspondance de préfixe avec les paramètres de
longueur
le: Inférieur ou égal à, <=
ge: Supérieur ou égal à, >=
Correspondance de préfixe avec les paramètres de
longueur
Listes de préfixes - IPv4
Commande : ip prefix-list prefix-listname [seq sequence-number] {permit |
deny} high-order-bit-pattern/high-order-bit-count [ge ge-value] [le le-value]
Note : nombre de bits de poids fort <ge-value <= le-value
Listes de préfixes – IPv6
Commande : ipv6 prefix-list prefix-listname [seq sequence-number] {permit |
deny} high-order-bit-pattern/high-order-bit-count [ge ge-value] [le le-value]
Expressions régulières (regex)
Commande : show bgp ip unicast regexp regex-pattern
Expression régulière Sens
^$ Routes d'origine locale
permit ^200_ Uniquement les routes du voisin AS 200
permit _200$ Uniquement les routes provenant de l'AS 200
permit _200_ Seuls les itinéraires qui passent par AS 200
permit ^[0-9]+ [0-9]+ [0-9]+? Routes avec trois entrées AS_Path ou moins
Comprendre le but
des routes-maps dans BGP
Une formation
Yazid AZIZI
Une formation
Composants et syntaxe de la routes-
maps
Une routes-maps comprend quatre éléments:
Numéro de séquence
Critères de correspondance conditionnelle
Action de traitement
Action facultative
la syntaxe de commande: route-map route-map-
name [permit | deny] [sequence-number]
Composants et syntaxe de la routes-maps
Correspondance conditionnelle de la carte
d'itinéraire
Commande Match
match as-path acl-number
match ip address {acl-number | acl-name}
match ip address prefix-list prefix-list-name
match local-preference local-preference
match metric {1-4294967295 | external 1-4294967295}[+- deviation]
match tag tag-value
Options et variables de correspondance multiples de
la carte d'itinéraire
Problèmes de correspondance complexes de la carte
d'itinéraire
Route-map « continue » Mot-clé
Sélection de réseau IGP ACL étendue
Filtrer et manipuler l'itinéraire BGP
pour améliorer les performances
Une formation
Yazid AZIZI
Une formation
Concepts de filtrage d'itinéraire BGP
Méthodes de filtrage des routes entrantes ou
sortantes pour un homologue BGP spécifique:
Distribute list
Prefix list
AS path ACL/filtering
Route maps
Concepts de filtrage d'itinéraire BGP
Commencer la référence de la table de routage
Filtrage de la liste de distribution BGP
la commande de configuration de la famille d'adresses BGP voisin : neighbor
ip-address distribute-list {acl-number | acl-name} {in|out}
Filtrage de la liste de distribution BGP
(résultat de la table de routage)
Résultat du filtrage de la liste de préfixes BGP et de
la table de routage
Filtrage d'ACL de chemin BGP AS
Filtrage d'ACL de chemin BGP AS
Une formation
Effacement des connexions BGP
BGP prend en charge deux méthodes pour effacer
une session
La réinitialisation matérielle arrête la session BGP
La réinitialisation logicielle
Réinitialisation matérielle avec la commande: clear
ip bgp ip-address [soft]
Les réinitialisations logicielles avec la commande
clear bgp afi safi {ip-address|*} soft [in | out]
Comprendre la fonction et le but
des communautés BGP
Une formation
Yazid AZIZI
Une formation
Communautés BGP
Les communautés BGP sont des attributs BGP
transitif facultatif
Une communauté BGP est un nombre 32
Une communauté BGP peut être affichée sous forme
de nombre complet de 32 bits (0–4 294 967 295) ou
de deux nombres de 16 bits (0–65535)
Une formation
Communautés bien connues
Internet
No_Advertise
No_Export
Activation de la prise en charge de la communauté
BGP
Les communautés standard sont envoyées par défaut
neighbor ip-address send-community [standard | extended | both]
Les communautés dans un nouveau format, avec la commande de configuration globale:
ip bgp-community new-format
Liste de la communauté BGP
Correspondance conditionnelle
Les listes de communautés standard : 1 à 99
Les listes de communautés étendues : de 100 à 500
« ip community-list {1-500 | nom-liste standard | nom-liste étendu} {permit |
deny} »
Liste de communauté BGP
Correspondance conditionnelle (résultat de la table de routage)
Définition de communautés BGP privées
Définition de communautés BGP privées
Connaitre les processus utilisés par BGP
pour la sélection de chemin
Une formation
Yazid AZIZI
Sélection de chemins de routage
Une formation
Algorithme du meilleur chemin BGP
BGP recalcule le meilleur chemin pour un préfixe sur
quatre événements possibles
Changement d'accessibilité du prochain saut BGP
Échec d'une interface connectée à un pair eBGP
Changement de redistribution
Réception de chemins nouveaux ou supprimés
pour un itinéraire
Une formation
Les attributs
Poids
Préférence locale - (LOCAL_PREF
Origine locale
Accumulated Interior Gateway Protocol (AIGP)
Le plus court AS_Path
Type d'origine
MED le plus bas
eBGP sur iBGP
Prochain bond IGP le plus
Le plus ancien chemin eBGP
ID de routeur
Longueur minimale de la liste de cluster
Adresse de voisin le plus
Conclusion
Une formation
Yazid AZIZI
Une formation
Essentiels et les concept du routage IP
Protocole de routage EIGRP et sont paramétrage
avancé
Protocole de routage OSPFv2 et sont paramétrage
avancé
Protocole de routage OSPFv3
Protocole de routage BGP et sont paramétrage
avancé
Bilan
Prochaine formation
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing

Contenu connexe

Tendances

Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : Conf...
Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : Conf...Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : Conf...
Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : Conf...
Alphorm
 
Alphorm.com Formation F5 BIG-IP LTM : Local Traffic Manager
Alphorm.com Formation F5 BIG-IP LTM : Local Traffic ManagerAlphorm.com Formation F5 BIG-IP LTM : Local Traffic Manager
Alphorm.com Formation F5 BIG-IP LTM : Local Traffic Manager
Alphorm
 
Alphorm.com Formation CCNA 200-301 version 2020 (1of6) : Les Fondamentaux des...
Alphorm.com Formation CCNA 200-301 version 2020 (1of6) : Les Fondamentaux des...Alphorm.com Formation CCNA 200-301 version 2020 (1of6) : Les Fondamentaux des...
Alphorm.com Formation CCNA 200-301 version 2020 (1of6) : Les Fondamentaux des...
Alphorm
 
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (1)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (1)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (1)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (1)
SmartnSkilled
 
configuration vpn-ipsec-routeur
 configuration vpn-ipsec-routeur configuration vpn-ipsec-routeur
configuration vpn-ipsec-routeur
JULIOR MIKALA
 
Alphorm.com Support de la Formation PromoxVE 4.x
Alphorm.com Support de la Formation PromoxVE 4.xAlphorm.com Support de la Formation PromoxVE 4.x
Alphorm.com Support de la Formation PromoxVE 4.x
Alphorm
 
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.xAlphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm
 
Alphorm.com Formation Azure Advanced Threat Protection
Alphorm.com Formation Azure Advanced Threat ProtectionAlphorm.com Formation Azure Advanced Threat Protection
Alphorm.com Formation Azure Advanced Threat Protection
Alphorm
 
Alphorm.com Formation pfSense (2/2) Le firewall open source de référence
Alphorm.com Formation pfSense (2/2) Le firewall open source de référenceAlphorm.com Formation pfSense (2/2) Le firewall open source de référence
Alphorm.com Formation pfSense (2/2) Le firewall open source de référence
Alphorm
 
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
Hackfest Communication
 
Cisco ASA
Cisco ASACisco ASA
Cisco ASA
Thomas Moegli
 
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (3)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (3)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (3)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (3)
SmartnSkilled
 
Alphorm.com Formation F5 BIG-IP DNS (anciennement GTM)
Alphorm.com Formation F5 BIG-IP DNS (anciennement GTM)Alphorm.com Formation F5 BIG-IP DNS (anciennement GTM)
Alphorm.com Formation F5 BIG-IP DNS (anciennement GTM)
Alphorm
 
Alphorm.com Formation Ansible : Le Guide Complet du Débutant
Alphorm.com Formation Ansible : Le Guide Complet du DébutantAlphorm.com Formation Ansible : Le Guide Complet du Débutant
Alphorm.com Formation Ansible : Le Guide Complet du Débutant
Alphorm
 
alphorm.com - Formation Windows Server Core 2008 (R2)
alphorm.com - Formation Windows Server Core 2008 (R2)alphorm.com - Formation Windows Server Core 2008 (R2)
alphorm.com - Formation Windows Server Core 2008 (R2)
Alphorm
 
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
SmartnSkilled
 
Alphorm.com Formation Palo Alto : Firewall Troubleshooting
Alphorm.com Formation Palo Alto : Firewall TroubleshootingAlphorm.com Formation Palo Alto : Firewall Troubleshooting
Alphorm.com Formation Palo Alto : Firewall Troubleshooting
Alphorm
 
Fr E Routing Slm V40
Fr E Routing Slm V40Fr E Routing Slm V40
Fr E Routing Slm V40boukna abdou
 

Tendances (20)

Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : Conf...
Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : Conf...Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : Conf...
Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : Conf...
 
Alphorm.com Formation F5 BIG-IP LTM : Local Traffic Manager
Alphorm.com Formation F5 BIG-IP LTM : Local Traffic ManagerAlphorm.com Formation F5 BIG-IP LTM : Local Traffic Manager
Alphorm.com Formation F5 BIG-IP LTM : Local Traffic Manager
 
Alphorm.com Formation CCNA 200-301 version 2020 (1of6) : Les Fondamentaux des...
Alphorm.com Formation CCNA 200-301 version 2020 (1of6) : Les Fondamentaux des...Alphorm.com Formation CCNA 200-301 version 2020 (1of6) : Les Fondamentaux des...
Alphorm.com Formation CCNA 200-301 version 2020 (1of6) : Les Fondamentaux des...
 
Ccnp formation-ccnp
Ccnp formation-ccnpCcnp formation-ccnp
Ccnp formation-ccnp
 
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (1)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (1)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (1)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (1)
 
configuration vpn-ipsec-routeur
 configuration vpn-ipsec-routeur configuration vpn-ipsec-routeur
configuration vpn-ipsec-routeur
 
Alphorm.com Support de la Formation PromoxVE 4.x
Alphorm.com Support de la Formation PromoxVE 4.xAlphorm.com Support de la Formation PromoxVE 4.x
Alphorm.com Support de la Formation PromoxVE 4.x
 
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.xAlphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
 
Alphorm.com Formation Azure Advanced Threat Protection
Alphorm.com Formation Azure Advanced Threat ProtectionAlphorm.com Formation Azure Advanced Threat Protection
Alphorm.com Formation Azure Advanced Threat Protection
 
Alphorm.com Formation pfSense (2/2) Le firewall open source de référence
Alphorm.com Formation pfSense (2/2) Le firewall open source de référenceAlphorm.com Formation pfSense (2/2) Le firewall open source de référence
Alphorm.com Formation pfSense (2/2) Le firewall open source de référence
 
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
 
Cisco ASA
Cisco ASACisco ASA
Cisco ASA
 
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (3)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (3)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (3)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (3)
 
Alphorm.com Formation F5 BIG-IP DNS (anciennement GTM)
Alphorm.com Formation F5 BIG-IP DNS (anciennement GTM)Alphorm.com Formation F5 BIG-IP DNS (anciennement GTM)
Alphorm.com Formation F5 BIG-IP DNS (anciennement GTM)
 
Alphorm.com Formation Ansible : Le Guide Complet du Débutant
Alphorm.com Formation Ansible : Le Guide Complet du DébutantAlphorm.com Formation Ansible : Le Guide Complet du Débutant
Alphorm.com Formation Ansible : Le Guide Complet du Débutant
 
alphorm.com - Formation Windows Server Core 2008 (R2)
alphorm.com - Formation Windows Server Core 2008 (R2)alphorm.com - Formation Windows Server Core 2008 (R2)
alphorm.com - Formation Windows Server Core 2008 (R2)
 
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
 
Alphorm.com Formation Palo Alto : Firewall Troubleshooting
Alphorm.com Formation Palo Alto : Firewall TroubleshootingAlphorm.com Formation Palo Alto : Firewall Troubleshooting
Alphorm.com Formation Palo Alto : Firewall Troubleshooting
 
Résumé vlsm et cidr
Résumé vlsm et cidrRésumé vlsm et cidr
Résumé vlsm et cidr
 
Fr E Routing Slm V40
Fr E Routing Slm V40Fr E Routing Slm V40
Fr E Routing Slm V40
 

Similaire à Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing

1485606887355.pdf
1485606887355.pdf1485606887355.pdf
1485606887355.pdf
Bader Nassiri
 
EIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relayEIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relay
mdyabi
 
Eigrp ccna v5
Eigrp ccna v5 Eigrp ccna v5
Eigrp ccna v5
Meriama Benrqiq
 
OSPF Presentation
OSPF PresentationOSPF Presentation
OSPF Presentation
Mohamed Righi
 
Ccna 2-module-2-v4
Ccna 2-module-2-v4Ccna 2-module-2-v4
Ccna 2-module-2-v4
Siham Tatiggit
 
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : ServicesAlphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
Alphorm
 
EIGRP - Configuration
EIGRP - ConfigurationEIGRP - Configuration
EIGRP - Configuration
mdyabi
 
Configuration ospf
Configuration ospfConfiguration ospf
Configuration ospf
Joeongala
 
Protocole EIGRP
Protocole EIGRPProtocole EIGRP
Protocole EIGRP
Thomas Moegli
 
1485606887426.pdf
1485606887426.pdf1485606887426.pdf
1485606887426.pdf
Bader Nassiri
 
Rip-ng vs ospf-v3
Rip-ng vs ospf-v3Rip-ng vs ospf-v3
Rip-ng vs ospf-v3
Islem mhalla
 
Configuration de-base-d
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
Nabil EL KASSOUMI
 
1301000.ppt
1301000.ppt1301000.ppt
1301000.ppt
YassineWerghi
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
Thomas Moegli
 
EIGRP - Résumé EIGRP
EIGRP - Résumé EIGRPEIGRP - Résumé EIGRP
EIGRP - Résumé EIGRP
mdyabi
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
ssuser9d2f89
 
Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
EL AMRI El Hassan
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
AlbertbenBarry1
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
ssuser9d2f89
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
amalbenramdhane
 

Similaire à Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing (20)

1485606887355.pdf
1485606887355.pdf1485606887355.pdf
1485606887355.pdf
 
EIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relayEIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relay
 
Eigrp ccna v5
Eigrp ccna v5 Eigrp ccna v5
Eigrp ccna v5
 
OSPF Presentation
OSPF PresentationOSPF Presentation
OSPF Presentation
 
Ccna 2-module-2-v4
Ccna 2-module-2-v4Ccna 2-module-2-v4
Ccna 2-module-2-v4
 
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : ServicesAlphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
Alphorm.com Formation CCNP ENCOR 350-401 4/8 : Services
 
EIGRP - Configuration
EIGRP - ConfigurationEIGRP - Configuration
EIGRP - Configuration
 
Configuration ospf
Configuration ospfConfiguration ospf
Configuration ospf
 
Protocole EIGRP
Protocole EIGRPProtocole EIGRP
Protocole EIGRP
 
1485606887426.pdf
1485606887426.pdf1485606887426.pdf
1485606887426.pdf
 
Rip-ng vs ospf-v3
Rip-ng vs ospf-v3Rip-ng vs ospf-v3
Rip-ng vs ospf-v3
 
Configuration de-base-d
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
 
1301000.ppt
1301000.ppt1301000.ppt
1301000.ppt
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
 
EIGRP - Résumé EIGRP
EIGRP - Résumé EIGRPEIGRP - Résumé EIGRP
EIGRP - Résumé EIGRP
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 
soutenance.ppt
soutenance.pptsoutenance.ppt
soutenance.ppt
 

Plus de Alphorm

Alphorm.com Formation Microsoft 365 (MS-500) : Administrateur Sécurité - Prot...
Alphorm.com Formation Microsoft 365 (MS-500) : Administrateur Sécurité - Prot...Alphorm.com Formation Microsoft 365 (MS-500) : Administrateur Sécurité - Prot...
Alphorm.com Formation Microsoft 365 (MS-500) : Administrateur Sécurité - Prot...
Alphorm
 
Alphorm.com Formation Google Sheets : Créer un Tableau de Bord Collaboratif a...
Alphorm.com Formation Google Sheets : Créer un Tableau de Bord Collaboratif a...Alphorm.com Formation Google Sheets : Créer un Tableau de Bord Collaboratif a...
Alphorm.com Formation Google Sheets : Créer un Tableau de Bord Collaboratif a...
Alphorm
 
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : SécuritéAlphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
Alphorm
 
Alphorm.com Formation Vue JS 3 : Créer une application de A à Z
Alphorm.com Formation Vue JS 3 : Créer une application de A à ZAlphorm.com Formation Vue JS 3 : Créer une application de A à Z
Alphorm.com Formation Vue JS 3 : Créer une application de A à Z
Alphorm
 
Alphorm.com Formation Blockchain : Maîtriser la Conception d'Architectures
Alphorm.com Formation Blockchain : Maîtriser la Conception d'ArchitecturesAlphorm.com Formation Blockchain : Maîtriser la Conception d'Architectures
Alphorm.com Formation Blockchain : Maîtriser la Conception d'Architectures
Alphorm
 
Alphorm.com Formation Sage : Gestion Commerciale
Alphorm.com Formation Sage : Gestion CommercialeAlphorm.com Formation Sage : Gestion Commerciale
Alphorm.com Formation Sage : Gestion Commerciale
Alphorm
 
Alphorm.com Formation PHP 8 (2/6) : L'héritage en orienté objet
Alphorm.com Formation PHP 8 (2/6) : L'héritage en orienté objetAlphorm.com Formation PHP 8 (2/6) : L'héritage en orienté objet
Alphorm.com Formation PHP 8 (2/6) : L'héritage en orienté objet
Alphorm
 
Alphorm.com Formation Excel 2019 : Concevoir un Tableau de Bord Interactif
Alphorm.com Formation Excel 2019 : Concevoir un Tableau de Bord InteractifAlphorm.com Formation Excel 2019 : Concevoir un Tableau de Bord Interactif
Alphorm.com Formation Excel 2019 : Concevoir un Tableau de Bord Interactif
Alphorm
 
Alphorm.com Formation Maya 3D : Créer un Design d'intérieur au Style Isométrique
Alphorm.com Formation Maya 3D : Créer un Design d'intérieur au Style IsométriqueAlphorm.com Formation Maya 3D : Créer un Design d'intérieur au Style Isométrique
Alphorm.com Formation Maya 3D : Créer un Design d'intérieur au Style Isométrique
Alphorm
 
Alphorm.com Formation VMware vSphere 7 : La Mise à Niveau
Alphorm.com Formation VMware vSphere 7 : La Mise à NiveauAlphorm.com Formation VMware vSphere 7 : La Mise à Niveau
Alphorm.com Formation VMware vSphere 7 : La Mise à Niveau
Alphorm
 
Alphorm.com Formation Apprendre les bonnes pratiques de CSS avec BEM : OOCSS ...
Alphorm.com Formation Apprendre les bonnes pratiques de CSS avec BEM : OOCSS ...Alphorm.com Formation Apprendre les bonnes pratiques de CSS avec BEM : OOCSS ...
Alphorm.com Formation Apprendre les bonnes pratiques de CSS avec BEM : OOCSS ...
Alphorm
 
Alphorm.com Formation Unity : Monétiser votre jeu 3D sur les plateformes Mobiles
Alphorm.com Formation Unity : Monétiser votre jeu 3D sur les plateformes MobilesAlphorm.com Formation Unity : Monétiser votre jeu 3D sur les plateformes Mobiles
Alphorm.com Formation Unity : Monétiser votre jeu 3D sur les plateformes Mobiles
Alphorm
 
Alphorm.com Formation PHP 8 : Les bases de la POO
Alphorm.com Formation PHP 8 : Les bases de la POOAlphorm.com Formation PHP 8 : Les bases de la POO
Alphorm.com Formation PHP 8 : Les bases de la POO
Alphorm
 
Alphorm.com Formation Power BI : Transformation de Données avec DAX et Power ...
Alphorm.com Formation Power BI : Transformation de Données avec DAX et Power ...Alphorm.com Formation Power BI : Transformation de Données avec DAX et Power ...
Alphorm.com Formation Power BI : Transformation de Données avec DAX et Power ...
Alphorm
 
Alphorm.com Formation Techniques de Blue Teaming : L'Essentiel pour l'Analyst...
Alphorm.com Formation Techniques de Blue Teaming : L'Essentiel pour l'Analyst...Alphorm.com Formation Techniques de Blue Teaming : L'Essentiel pour l'Analyst...
Alphorm.com Formation Techniques de Blue Teaming : L'Essentiel pour l'Analyst...
Alphorm
 
Alphorm.com Formation Améliorer le développement avec CSS-in-JS _ Styled Comp...
Alphorm.com Formation Améliorer le développement avec CSS-in-JS _ Styled Comp...Alphorm.com Formation Améliorer le développement avec CSS-in-JS _ Styled Comp...
Alphorm.com Formation Améliorer le développement avec CSS-in-JS _ Styled Comp...
Alphorm
 
Alphorm.com Formation Unity (6/7) : Maitriser l'Intelligence Artificielle de ...
Alphorm.com Formation Unity (6/7) : Maitriser l'Intelligence Artificielle de ...Alphorm.com Formation Unity (6/7) : Maitriser l'Intelligence Artificielle de ...
Alphorm.com Formation Unity (6/7) : Maitriser l'Intelligence Artificielle de ...
Alphorm
 
Alphorm.com Formation Architecture Microservices : Jenkins et SpringBoot
Alphorm.com Formation Architecture Microservices : Jenkins et SpringBootAlphorm.com Formation Architecture Microservices : Jenkins et SpringBoot
Alphorm.com Formation Architecture Microservices : Jenkins et SpringBoot
Alphorm
 
Alphorm.com Formation Active Directory 2022 : Multi Sites et Services
Alphorm.com Formation Active Directory 2022 : Multi Sites et ServicesAlphorm.com Formation Active Directory 2022 : Multi Sites et Services
Alphorm.com Formation Active Directory 2022 : Multi Sites et Services
Alphorm
 
Alphorm.com Formation Vue JS 3 : Exploiter la Composition API
Alphorm.com Formation Vue JS 3 : Exploiter la Composition APIAlphorm.com Formation Vue JS 3 : Exploiter la Composition API
Alphorm.com Formation Vue JS 3 : Exploiter la Composition API
Alphorm
 

Plus de Alphorm (20)

Alphorm.com Formation Microsoft 365 (MS-500) : Administrateur Sécurité - Prot...
Alphorm.com Formation Microsoft 365 (MS-500) : Administrateur Sécurité - Prot...Alphorm.com Formation Microsoft 365 (MS-500) : Administrateur Sécurité - Prot...
Alphorm.com Formation Microsoft 365 (MS-500) : Administrateur Sécurité - Prot...
 
Alphorm.com Formation Google Sheets : Créer un Tableau de Bord Collaboratif a...
Alphorm.com Formation Google Sheets : Créer un Tableau de Bord Collaboratif a...Alphorm.com Formation Google Sheets : Créer un Tableau de Bord Collaboratif a...
Alphorm.com Formation Google Sheets : Créer un Tableau de Bord Collaboratif a...
 
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : SécuritéAlphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
Alphorm.com Formation CCNP ENCOR 350-401 (6of8) : Sécurité
 
Alphorm.com Formation Vue JS 3 : Créer une application de A à Z
Alphorm.com Formation Vue JS 3 : Créer une application de A à ZAlphorm.com Formation Vue JS 3 : Créer une application de A à Z
Alphorm.com Formation Vue JS 3 : Créer une application de A à Z
 
Alphorm.com Formation Blockchain : Maîtriser la Conception d'Architectures
Alphorm.com Formation Blockchain : Maîtriser la Conception d'ArchitecturesAlphorm.com Formation Blockchain : Maîtriser la Conception d'Architectures
Alphorm.com Formation Blockchain : Maîtriser la Conception d'Architectures
 
Alphorm.com Formation Sage : Gestion Commerciale
Alphorm.com Formation Sage : Gestion CommercialeAlphorm.com Formation Sage : Gestion Commerciale
Alphorm.com Formation Sage : Gestion Commerciale
 
Alphorm.com Formation PHP 8 (2/6) : L'héritage en orienté objet
Alphorm.com Formation PHP 8 (2/6) : L'héritage en orienté objetAlphorm.com Formation PHP 8 (2/6) : L'héritage en orienté objet
Alphorm.com Formation PHP 8 (2/6) : L'héritage en orienté objet
 
Alphorm.com Formation Excel 2019 : Concevoir un Tableau de Bord Interactif
Alphorm.com Formation Excel 2019 : Concevoir un Tableau de Bord InteractifAlphorm.com Formation Excel 2019 : Concevoir un Tableau de Bord Interactif
Alphorm.com Formation Excel 2019 : Concevoir un Tableau de Bord Interactif
 
Alphorm.com Formation Maya 3D : Créer un Design d'intérieur au Style Isométrique
Alphorm.com Formation Maya 3D : Créer un Design d'intérieur au Style IsométriqueAlphorm.com Formation Maya 3D : Créer un Design d'intérieur au Style Isométrique
Alphorm.com Formation Maya 3D : Créer un Design d'intérieur au Style Isométrique
 
Alphorm.com Formation VMware vSphere 7 : La Mise à Niveau
Alphorm.com Formation VMware vSphere 7 : La Mise à NiveauAlphorm.com Formation VMware vSphere 7 : La Mise à Niveau
Alphorm.com Formation VMware vSphere 7 : La Mise à Niveau
 
Alphorm.com Formation Apprendre les bonnes pratiques de CSS avec BEM : OOCSS ...
Alphorm.com Formation Apprendre les bonnes pratiques de CSS avec BEM : OOCSS ...Alphorm.com Formation Apprendre les bonnes pratiques de CSS avec BEM : OOCSS ...
Alphorm.com Formation Apprendre les bonnes pratiques de CSS avec BEM : OOCSS ...
 
Alphorm.com Formation Unity : Monétiser votre jeu 3D sur les plateformes Mobiles
Alphorm.com Formation Unity : Monétiser votre jeu 3D sur les plateformes MobilesAlphorm.com Formation Unity : Monétiser votre jeu 3D sur les plateformes Mobiles
Alphorm.com Formation Unity : Monétiser votre jeu 3D sur les plateformes Mobiles
 
Alphorm.com Formation PHP 8 : Les bases de la POO
Alphorm.com Formation PHP 8 : Les bases de la POOAlphorm.com Formation PHP 8 : Les bases de la POO
Alphorm.com Formation PHP 8 : Les bases de la POO
 
Alphorm.com Formation Power BI : Transformation de Données avec DAX et Power ...
Alphorm.com Formation Power BI : Transformation de Données avec DAX et Power ...Alphorm.com Formation Power BI : Transformation de Données avec DAX et Power ...
Alphorm.com Formation Power BI : Transformation de Données avec DAX et Power ...
 
Alphorm.com Formation Techniques de Blue Teaming : L'Essentiel pour l'Analyst...
Alphorm.com Formation Techniques de Blue Teaming : L'Essentiel pour l'Analyst...Alphorm.com Formation Techniques de Blue Teaming : L'Essentiel pour l'Analyst...
Alphorm.com Formation Techniques de Blue Teaming : L'Essentiel pour l'Analyst...
 
Alphorm.com Formation Améliorer le développement avec CSS-in-JS _ Styled Comp...
Alphorm.com Formation Améliorer le développement avec CSS-in-JS _ Styled Comp...Alphorm.com Formation Améliorer le développement avec CSS-in-JS _ Styled Comp...
Alphorm.com Formation Améliorer le développement avec CSS-in-JS _ Styled Comp...
 
Alphorm.com Formation Unity (6/7) : Maitriser l'Intelligence Artificielle de ...
Alphorm.com Formation Unity (6/7) : Maitriser l'Intelligence Artificielle de ...Alphorm.com Formation Unity (6/7) : Maitriser l'Intelligence Artificielle de ...
Alphorm.com Formation Unity (6/7) : Maitriser l'Intelligence Artificielle de ...
 
Alphorm.com Formation Architecture Microservices : Jenkins et SpringBoot
Alphorm.com Formation Architecture Microservices : Jenkins et SpringBootAlphorm.com Formation Architecture Microservices : Jenkins et SpringBoot
Alphorm.com Formation Architecture Microservices : Jenkins et SpringBoot
 
Alphorm.com Formation Active Directory 2022 : Multi Sites et Services
Alphorm.com Formation Active Directory 2022 : Multi Sites et ServicesAlphorm.com Formation Active Directory 2022 : Multi Sites et Services
Alphorm.com Formation Active Directory 2022 : Multi Sites et Services
 
Alphorm.com Formation Vue JS 3 : Exploiter la Composition API
Alphorm.com Formation Vue JS 3 : Exploiter la Composition APIAlphorm.com Formation Vue JS 3 : Exploiter la Composition API
Alphorm.com Formation Vue JS 3 : Exploiter la Composition API
 

Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing

  • 1. Formation CCNP ENCOR 350-401 (2/8) Routage Une formation Yazid AZIZI
  • 2. Une formation Yazid AZIZI Consultant Instructeur Cisco – IT Manager - Chef de projet ERP (SAP) Certifications Cisco (CCNP R&S, CCNA R&S, CCNA Security, CCNA CyberOps, DevNet,) Présentation du formateur Email: yazid.azizi1@gmail.com LinkedIn : https://www.linkedin.com/in/yazid-azizi/
  • 3. Rappel cursus CCNP ENCOR 350-401
  • 4. Une formation Introduction 1. Essentiels du routage IP 2. Protocole de routage EIGRP 3. Protocole de routage OSPFv2 4. Protocole de routage OSPFv2 avancé 5. Protocole de routage OSPFv3 6. Protocole de routage BGP 7. Protocole de routage BGP avancé Conclusion Plan de la formation
  • 5. Une formation Ingénieurs réseau de niveau intermédiaire Administrateurs réseau Techniciens d'assistance réseau Techniciens du helpdesk Public concerné
  • 8.
  • 9. Présentation du lab Une formation Yazid AZIZI
  • 10. Une formation Présentation des outils Packet Tracer Créer un compte Cisco NetAcad Télécharger Packet Tracer Utiliser Packet Tracer EVE-NG Télécharger EVE-NG Intégrer les IOS sur EVE-NG Utiliser EVE-NG GNS 3 Télécharger GNS3 Intégrer les IOS sur GNS3 Utiliser GNS3
  • 13. GNS3
  • 14. Télécharger et Installer EVE-NG Une formation Yazid AZIZI
  • 15. Télécharger et Installer GNS3 Une formation Yazid AZIZI
  • 16. Connaitre les essentiels du routage IP Une formation Yazid AZIZI
  • 18. Les protocoles de routage dynamique courants RIPv2 EIGRP OSPF IS-IS Protocole BGP
  • 19. Algorithmes de vecteur de distance
  • 20. Algorithmes de vecteur de distance améliorés (EIGRP) Un temps de convergence rapide Des mises à jour uniquement en cas de modification du réseau Pas de mises à jour complètes de la table de routage de manière périodique
  • 21. Algorithmes de vecteur de distance améliorés (EIGRP) Paquet hello bande passante, le délai, la fiabilité, la charge et (MTU) Equilibrer la charge
  • 22. Algorithmes d'état de lien Paquet LSA
  • 23. Algorithme de vecteur de chemin Chemin système autonome (AS_Path) Le discriminateur à sorties multiples (MED) L'origine Le prochain bond La préférence locale L'agrégat atomique L'agrégateur
  • 24. Sélectionner le chemin Une formation Yazid AZIZI
  • 25. Sélection de chemin 1. Longueur du préfixe 2. Distance administrative 3. Métriques
  • 26. Longueur du préfixe La table de routage: 10.0.3.0/28, 10.0.3.0/26 et 10.0.3.0/24 Le tableau présente cette table de routage Prefix IP Address Range Next Hop Outgoing Interface 10.0.3.0/28 10.0.3.0–10.0.3.15 10.1.1.1 Gigabit Ethernet 1/1 10.0.3.0/26 10.0.3.0–10.0.3.63 10.2.2.2 Gigabit Ethernet 2/2 10.0.3.0/24 10.0.3.0–10.0.3.255 10.3.3.3 Gigabit Ethernet 3/3
  • 27. Distance administrative Routing Protocol Distance Administrative par défaut Interface 0 Static 1 EIGRP summary route 5 External BGP (eBGP) 20 EIGRP (internal) 90 OSPF 110 IS-IS 115 RIP 120 EIGRP (external) 170 Internal BGP (iBGP) 200
  • 28. Chacun de ces trois protocoles tente d'installer la route vers 10.3.3.0/24 dans la table de routage Distance administrative Routing Protocol AD Réseau S'installe dans le RIB EIGRP 90 10.3.3.0/24 OSPF 110 10.3.3.0/24 X IS-IS 115 10.3.3.0/24 X
  • 29. Mesures de sélection de chemin Multipathing à coût égal
  • 30. Équilibrage de charge à coûts inégaux Topologie avec quatre routeurs exécutant EIGRP
  • 31. Comprendre le routage statique Une formation Yazid AZIZI
  • 32. Utilité des routes statiques
  • 33. Types de route statique Routes statiques directement connectées Route statique récursive Route statique entièrement spécifiée Routage statique flottant Routes statiques nulles Une formation
  • 34. La commande ip route network subnetmask next-hop-interface-id Routes statiques directement connectées
  • 35. Topologie série P2P avec R1 et R2 directement connectés avec une connexion série
  • 36. La commande ip route network subnet-mask next-hop-ip Routes statiques récursives
  • 37. Routes statiques entièrement spécifiées La commande ip route network subnet-mask interface-id next-hop-ip
  • 40. Routes statiques IPv6 Configurées avec la commande ipv6 route network / prefix-length {next-hop- interface-id | [id-interface-prochain-saut] adresse-IP suivante}
  • 41. LAB
  • 42. Découvrir le routage et transfert virtuels (VRF) Une formation Yazid AZIZI
  • 43. Routage et transfert virtuels et Table de routage VRF instance de VRF de gestion nommée MGMT vrf definition vrf-name La commande address-family {ipv4 | ipv6} La commande vrf forwarding vrf-name
  • 44. La commande vrf definition vrf-name La commande address-family {ipv4 | ipv6} La commande interface-id La commande vrf forwarding vrf-name IPv4 - ip address ip-address subnet-mask [secondary] IPv6 - ipv6 address ipv6-address/prefix-length Créer un VRF et l'affecter à une interface Une formation
  • 45. Interfaces et d'adresses IP qui se chevauchent entre la table de routage globale et l'instance VRF Interface IP Address VRF Global Gigabit Ethernet 0/1 10.0.3.1/24 -- Gigabit Ethernet 0/2 10.0.4.1/24 -- Gigabit Ethernet 0/3 10.0.3.1/24 MGMT -- Gigabit Ethernet 0/4 10.0.4.1/24 MGMT --
  • 46. Découvrir les fondamentaux EIGRP Une formation Yazid AZIZI
  • 47. Systèmes autonomes Chaque processus fonctionne dans le contexte d'un système autonome, qui représente un domaine de routage commun
  • 49. Terminologie EIGRP Terme Distance faisable (FD)/ Feasible distance Distance rapportée (RD)/Reported distance
  • 51. Préfixe de réseau Voisins EIGRP qui ont annoncé ce préfixe Mesures de chaque voisin (par exemple, distance signalée, nombre de sauts) Valeurs utilisées pour calculer la métrique Charge Fiabilité délai total bande passante minimale Table de topologie Une formation
  • 52. Table de topologie La commande show topology affichera à la fois le successeur et les successeurs possibles
  • 53. Voisins EIGRP Type Nom du Packet 1 Hello 2 Request 3 Update 4 Query 5 Reply
  • 54. Calculer la métrique de chemin Une formation Yazid AZIZI
  • 56. Formule métrique classique EIGRP avec définitions
  • 57. Formule métrique classique EIGRP avec valeurs K par défaut
  • 59. Mesures d'interface EIGRP par défaut pour les mesures classiques Type Interface Link Speed (kbps) Délais Métrique Serial 64 20,000 μs 40,512,000 T1 1544 20,000 μs 2,170,031 Ethernet 10,000 1000 μs 281,600 FastEthernet 100,000 100 μs 28,160 GigabitEthernet 1,000,000 10 μs 2816 10 GigabitEthernet 10,000,000 10 μs 512
  • 64. Détecter des pannes et minuteries Une formation Yazid AZIZI
  • 65. Convergence Les routeurs en aval exécutent leur propre DUAL pour tous les préfixes concernés afin de tenir compte des nouvelles métriques EIGRP La figure illustre un tel scénario lorsque la liaison entre R1 et R3 échoue
  • 66. Opérations effectuées par EGIRP Répondre à la requête que le routeur n'a pas de route vers le préfixe Si la requête ne provient pas du successeur de cet itinéraire, elle détecte le délai défini pour l'infini mais l'ignore car il ne vient pas du successeur Le routeur de réception répond avec les attributs EIGRP pour cet itinéraire Si la requête provient du successeur de la route, le routeur de réception détecte le délai défini pour l'infini, définit le préfixe comme actif dans la topologie EIGRP et envoie un paquet d'interrogation à tous les voisins EIGRP en aval pour cette route
  • 67. Processus de requête Se poursuit de routeur en routeur jusqu'à ce qu'un routeur établisse la limite de requête Une limite de requête est établie lorsqu'un routeur ne marque pas le préfixe comme actif Il dit qu'il n'a pas de route vers le préfixe Il répond avec des attributs EIGRP car la requête ne provient pas du successeur Une formation
  • 68. Convergence Termine le DUAL Change la route en passive Envoie un paquet de réponse à tous les routeurs en amont qui lui ont envoyé un paquet de requête La Figure montre une topologie où la liaison entre R1 et R2 a échoué
  • 70. Configurer la récapitulation automatique EIGRP Une formation Yazid AZIZI
  • 71. Réduction de l'étendue de la requête à l'aide d'itinéraires récapitulatifs
  • 72. Configuration de la récapitulation EIGRP Réduit la taille des tables de routage sur les routeurs Limite la portée de la requête
  • 73. HQ Table de routage sans résumé
  • 75. HQ Table de routage après résumé
  • 76. LAB EIGRP - Résumés Auto
  • 77. Configuration de la récapitulation manuelle
  • 78. HQ BR1A après récapitulation manuelle
  • 79. HQ RT après récapitulation manuelle
  • 80. LAB EIGRP - Résumés Manuel
  • 81. Configurer un routeur pour propager une route par défaut Une formation Yazid AZIZI
  • 82. Obtention de l'itinéraire par défaut Une route par défaut configurée statiquement définie localement avec la commande ip route 0.0.0.0 0.0.0.0 next-hop | interface EIGRP peut redistribuer les routes par défaut définies statiquement à l'aide de la commande de configuration redistribute static Tout réseau classfull résidant dans la table de routage locale peut devenir un candidat par défaut lorsqu'il est utilisé avec la commande de configuration ip default- network Une formation
  • 85. LAB EIGRP - la route par default
  • 88. Configuration de l'authentification EIGRP Étape 1 Configurer la key chain Étape 2 Configurer le mode d'authentification pour EIGRP Étape 3 Activer l'authentification pour utiliser la ou les key chains Une formation
  • 91. Configurer l'authentification de routage basée sur les clés EIGRP
  • 95. LAB EIGRP Lab 03-05 Configuration de l'authentification EIGRP
  • 96. Découvrir les fondamentaux OSPF Une formation Yazid AZIZI
  • 97. LSAs, LSDB et SPT OSPF envoie des annonces d'état de liaison (LSA) aux routeurs voisins Les LSA contiennent l'état du lien et la métrique du lien Les LSA reçus sont stockés dans une base de données locale appelée base de données d'état des liens (LSDB) Le LSDB fournit la topologie du réseau Le SPT contient toutes les destinations réseau dans le domaine OSPF
  • 98. Architecture OSPF Utilise plusieurs zones OSPF dans le domaine de routage Utilise une architecture hiérarchique à deux niveaux, où la zone 0 est une zone spéciale connue sous le nom de dorsale, à laquelle toutes les autres zones doivent se connecter Les zones non fédérales annoncent des routes dans la dorsale Le backbone annonce les routes vers d'autres zones non backbone
  • 99. Communication inter-routeur OSPF utilise l’attribué du protocole IPv4 89 et les adresses de multidiffusion 224.0.0.5 et 224.0.0.6 (routeurs DR) lorsque cela est possible pour réduire le trafic inutile Le Tableau décrit brièvement les cinq types de paquets OSPF Type Nom Packet 1 Hello 2 Database description (DBD) ou (DDP) 3 Link-state request (LSR) 4 Link-state update (LSU) 5 Link-state ack
  • 100. Paquets Hello OSPF Champ de données La description Router ID (RID) Un ID 32 bits unique dans un domaine OSPF Authentication options Entre les routeurs OSPF: aucun, texte clair ou authentification MD5 Area ID Zone OSPF d'une interface Un nombre de 32 bits écrit au format décimal à points (0.0.1.0) ou décimal (256) Interface address mask Masque de réseau d'adresse IP principale de l'interface Interface priority La priorité de l'interface du routeur pour les élections DR Hello interval La durée, en secondes, pendant laquelle un routeur envoie des paquets Hello Dead interval La durée, en secondes, pendant laquelle un routeur attend d'entendre un bonjour d'un routeur voisin avant de déclarer ce routeur hors service DR and BDR Adresse IP du DR et du DR de secours (BDR) pour la liaison réseau Active neighbor Une liste de voisins OSPF sur le segment de réseau. Un routeur doit avoir reçu un Hello du voisin dans l'intervalle Dead
  • 101. Tableau États voisins OSPF Etat La description Down L'état initial d'une relation de voisinage Indique que le routeur n'a reçu aucun paquet Hello OSPF Attempt Indique qu'aucune information n'a été reçue récemment, mais que le routeur tente toujours de communiquer Init Indique qu'un paquet Hello a été reçu d'un autre routeur, mais que la communication bidirectionnelle n'a pas été établie 2-Way Communication bidirectionnelle établie Si un DR ou un BDR est nécessaire, l'élection se produit pendant cet état ExStart Le premier état à former une contiguïté Les routeurs identifient quel routeur sera le maître ou l'esclave pour la synchronisation LSDB Exchange Les routeurs échangent des états de liaison à l'aide de paquets DBD Loading LSR envoyés au voisin demandant des LSA plus récents qui ont été découverts (mais non reçus) dans l'état Exchange Full Les routeurs voisins sont entièrement adjacents
  • 102. DR et BDR La figure montre comment un DR simplifie une topologie à quatre routeurs avec seulement trois contiguïtés voisines
  • 103. Configurer OSPFv2 zones unique dans un réseau routé Une formation Yazid AZIZI
  • 105. Les instructions de réseau router ospf process-id network ip-address wildcard-mask area area-id
  • 106. Configuration spécifique à l'interface La deuxième méthode pour activer OSPF sur une interface pour IOS router ospf process-id Interface Id-interface ip ospf process-id area area-id
  • 107. Exigences pour qu'un voisinage OSPF soit formé Les Routeurs ID Les interfaces Les MTU sur les interfaces L'ID de zone L'activation DR Les minuteries OSPF Hello et dead timers. Le type d'authentification et les informations d'identification Les indicateurs de type de zone Une formation
  • 108. Définir statiquement le RID et les interfaces passives Sélection automatique du RID avec OSPF l'adresse IPv4 la plus élevée de toutes les interfaces de bouclage actives sur le routeur Utilise l'adresse IPv4 la plus élevée parmi toutes les interfaces actives sans boucle Sélection manuel du RID avec OSPF Router-id router-id Les interfaces passives Passive interface interface-id Passive interface default
  • 109. Lab – Configuration OSPF Zone unique
  • 110. Comprendre l'annonce de la route par défaut Une formation Yazid AZIZI
  • 111. Topologie et configuration de la route par défaut
  • 112. Default-information originate [ always ] [ metric metric-value ] [ metric-type typevalue ] [ route-map map- name ]
  • 113. Lab : Configurer la route par default OSPF Zone unique
  • 115. Type Interface Coût OSPF T1 64 Ethernet 10 FastEthernet 1 GigabitEthernet 1 10 GigabitEthernet 1 Coûts de liaison
  • 116. Changer l’intervalle Hello : ip ospf hello-interval 1–65535. Changer l’intervalle Dead : ip ospf dead-interval 1–65535 Affiché les minuteries pour une interface OSPF show ip ospf interface Détection d'échec
  • 117. Afficher le rôle de l’interface OSPF : show ip ospf interface brief Élections DR et BDR
  • 118. Modifier la priorité d’une l’interface OSPF : ip ospf priority 0–255 Élections DR et BDR R1(config)# interface G0/1 R1(config-if)# ip ospf priority 100 R4(config)# interface G0/1 R4(config-if)# ip ospf priority 0
  • 119. Diffusion: ip ospf network broadcast P2P : ip ospf network point-to-point Loopback : activé par defaut Optimisation des réseaux de diffusion
  • 120. Lab – Configuration Hello, Dead Timer OSPF Zone unique
  • 121. Comprendre pourquoi OSPF multi-zones est utilisé Une formation Yazid AZIZI
  • 122. Une zone OSPF augmente en taille à mesure que le nombre de liaisons réseau et de routeurs augmente dans la zone Bien que l'utilisation d'une seule zone simplifie la topologie OSPF Areas
  • 123. Les ABR sont responsables de diffuser les annonces des itinéraires d'une zone et de leur injection dans une zone OSPF différente Zone OSPF 0 et ABR
  • 124. Zone OSPF 0 et ABR
  • 125. Une formation L'ID de zone = un champ de 32 bits (0 à 4 294 967 295) ou (0.0.0.0 à 255.255.255.255) OSPF annonce l'ID de zone au format décimal pointé dans le paquet Hello OSPF ID Area
  • 126. Lab - Configurations OSPF multi-zones et vérification des interfaces pour les ABR
  • 127. Routes intra-zone et inter-zones OSPF
  • 128. Routes intra-zone et inter-zones OSPF
  • 129. Routes intra-zone et inter-zones OSPF
  • 130. Découvrir les annonces sur l'état des liens LSA Une formation Yazid AZIZI
  • 131. Les composants du LSA : le type de LSA, l'âge du LSA, le numéro de séquence et les annonces du routeur Âge et inondation/flooding LSA: 0-1800 secondes Séquences LSA: Le numéro de séquence LSA est un numéro de 32 bits Types de LSA Composantes de la LSA
  • 133. show ip ospf database network Lien réseau
  • 136. La métrique dans le LSA de type 3 utilise la logique suivante Si le LSA de type 3 est créé à partir d'un LSA de type 1 Si le LSA de type 3 est créé à partir d'un LSA de type 3 à partir de la zone 0 Le LSA de type 3 contient l'ID d'état de liaison Lien récapitulatif
  • 139. Type 5 LSA Le LSID est le numéro de réseau externe
  • 140. Connecter des zones non contiguës dans OSPFv2 Une formation Yazid AZIZI
  • 141. Exemple de réseau non contigu Supposer que la route 10.34.1.0/24 apprise par la zone 23 serait alors annoncée dans la zone 0 de R2 et se propagerait ensuite vers la zone 12, serait une erreur
  • 142. Une formation Les LSA de type 1 reçus d'une zone créent des LSA de type 3 dans la zone dorsale et les zones non fédérales Les LSA de type 3 reçus de la zone 0 sont créés pour la zone non dorsale Les LSA de type 3 reçus d'une zone non fédérales s'insèrent uniquement dans la LSDB pour la zone source Les ABR ne créent pas de LSA de type 3 pour les autres zones (y compris une zone segmentée 0) Règles pour créer des LSA de type 3
  • 143. Comprendre comment OSPF détermine le meilleur chemin Une formation Yazid AZIZI
  • 145. Routes inter-zones et chemins multiples à coût égal Le nombre maximum par défaut de chemins multiples à coût égal (ECMP) est de quatre chemins
  • 146. Configurer la récapitulation entre les zones OSPF Une formation Yazid AZIZI
  • 147. Exemple de récapitulation des itinéraires
  • 148. Principes de base de la synthèse La récapitulation peut éliminer le calcul SPF en dehors de la zone pour les préfixes résumés car les préfixes plus petits sont masqués
  • 149. Principes de base de la synthèse
  • 150. Récapitulation inter-zones La figure montre 15 LSA de type 1 (172.16.1.0/24 à 172.16.15.0/24) résumés en un seul LSA de type 3 (le réseau 172.16.0.0/20)
  • 151. Mesures de récapitulation R1 résume trois préfixes avec différents coûts de chemin
  • 152. Configuration des métriques inter zones Commande area area-id range network subnet-mask [advertise | not-advertise] [cost metric]
  • 153. Lab - Configuration des métriques inter zones
  • 154. Filtrer les routes dans OSPFv2 pour améliorer les performances Une formation Yazid AZIZI
  • 155. Une formation Avantages de filtrage dans OSPFv2 Pour identifier sélectivement les itinéraires qui sont annoncés ou reçus des routeurs voisins Pour manipuler les flux de trafic, réduire l'utilisation de la mémoire ou améliorer la sécurité Le filtrage des routes avec des protocoles de routage vectoriels est simple
  • 156. Filtrage avec récapitulation R2 peut filtrer tous les LSA de type 1 générés dans la zone 12 pour ne pas être annoncés dans la zone 0
  • 157. Filtrage de zone Topologie de filtrage de zone
  • 160. Filtrage OSPF local Commande: distribute-list {acl-number | acl-name | prefix prefix-list-name | route-map route- map-name} in
  • 161. Découvrir les principes de base d'OSPFv3 Une formation Yazid AZIZI
  • 162. Une formation Caractéristiques OSPFv3 ID de routeur Authentification Adjacences voisines Plusieurs sous-réseaux sur une interface Instances multiples
  • 163. Une formation Annonce d'état de lien OSPFv3 OSPFv3 / Protocole 89 L'adresse lien-local la structure du routeur LSA (type 1) Il renomme le résumé du réseau LSA en préfixe interarea LSA ASBR LSA en LSA du routeur inter zone Le routeur LSA Les informations d'adresse IP - types de LSA Préfixe intra-zone LSA Lien LSA local La base de données d'état des liens (LSDB)
  • 164. OSPFv3 LSA Types Type LS Nom 0x2001 Router 0x2002 Network 0x2003 Inter zone Prefix 0x2004 Inter zone router 0x4005 AS externe 0x2007 NSSA 0x0008 Lien 0x2009 Intra zone prefix
  • 165. Une formation Communication OSPFv3 L'adresse de destination est soit une adresse de liaison locale de monodiffusion, soit une adresse de portée de liaison locale de multidiffusion FF02 :: 05 FF02 :: 06
  • 166. Types de paquets OSPFv3
  • 167. Configurer OSPFv3 à zone unique Une formation Yazid AZIZI
  • 168. Une formation Étapes de configuration OSPFv3 «ipv6 unicast-routing» ID de routeur 32 bits (Facultatif) Initialiser la famille d'adresses Activer OSPFv3 sur une interface
  • 170. Vérifier OSPFv3 à zone unique Une formation Yazid AZIZI
  • 173. Comprendre la prise en charge d'IPv4 dans OSPFv3. Une formation Yazid AZIZI
  • 174. Une formation Activation de la prise en charge IPv4 Interface IPv4 a une adresse IPv6 (globale ou lien local) ospfv3 process-id ipv4 area area-id
  • 176. Ajouter la prise en charge d'IPv4 aux interfaces existantes ospfv3 process-id ipv4 area area-id (L'interface doit avoir une adresse IPv6 globale ou lien-local)
  • 177. Ajouter la prise en charge d'IPv4 aux interfaces existantes
  • 178. Vérification des routes IPv4 Show ip route ospfv3
  • 179. Affichage des interfaces OSPFv3 Show ospfv3 interface brief
  • 180. Vérification des voisins OSPFv3 Show ospfv3 Neighbor.
  • 181. Découvrir les fondamentaux BGP Une formation Yazid AZIZI
  • 182. Numéros de système autonome La RFC 4893 a étendu le champ ASN de 2 octets à 4 octets (plage de 32 bits) Remplir les conditions suivantes pour attribution d’un ASN Une plage de réseau publique La connectivité Internet Une politique de routage unique Numéros AS incluent des plages d'adresses privées Les ASN 64 512 à 65 535 /la plage ASN 16 bits Les ASN 4 200 000 000–4 294 967 294 /la plage étendue de 32 bits
  • 183. Une formation Attributs de chemin Obligatoire bien connu Discrétionnaire bien connu Transitif facultatif Facultatif non transitif
  • 186. Découvrir une connexion de branche eBGP Une formation Yazid AZIZI
  • 187. Communication inter-routeur BGP n'utilise pas de paquets Hello BGP utilise le port TCP 179 Le bit ne pas fragmenter (DF) BGP utilise TCP Une session BGP inter routeurs BGP. Et les sessions à sauts multiples
  • 188. Types de session BGP Les sessions BGP sont classées en deux types BGP interne (iBGP) BGP externe (eBGP)
  • 189. Une formation Types de session BGP iBGP, n'est pas une solution viable pour les raisons suivantes Évolutivité Routage personnalisé Attributs de chemin
  • 190. Une formation Différences de comportement eBGP et iBGP iBGP permet des sessions multi-sauts Le routeur annonceur modifie l'adresse du prochain saut Le routeur annonceur ajoute son ASN à la variable AS_Path existante Le routeur de réception vérifie que la variable AS_Path
  • 191. BGP Messages TYPE Nom 1 OPEN 2 UPDATE 3 NOTIFICATION 4 KEEPALIVE
  • 192. États voisins BGP La session BGP peut signaler les états suivants Idle Connect Active OpenSent OpenConfirm Established
  • 193. Configurer une connexion de branche eBGP Une formation Yazid AZIZI
  • 194. Une formation La configuration du routeur BGP La configuration du routeur BGP nécessite les composants suivants Paramètres de session BGP Initialisation de la famille d'adresses Activer la famille d'adresses sur les pairs BGP
  • 196. Annonce de préfixe Type de préfixe RIB Réseau connecté Route statique ou protocole de routage router bgp 65200 bgp log-neighbor-changes no bgp default ipv4-unicast neighbor 10.12.1.1 remote-as 65100 ! address-family ipv4 network 10.12.1.0 mask 255.255.255.0 network 192.168.2.2 mask 255.255.255.255 neighbor 10.12.1.1 activate exit-address-family
  • 197. Réception et affichage des itinéraires BGP utilise trois tables pour gérer le préfixe réseau et les PA pour une route Adj-RIB-In Loc-RIB Adj-RIB-Out
  • 198. La commande show bgp ipv4 unicast
  • 199. La commande show bgp ipv4 unicast network
  • 200. La commande show bgp ipv4 voisin ip-address advertised-routes
  • 201. Annonces de route BGP à partir de sources indirectes
  • 202. Comprendre la récapitulation de l'itinéraire dans BGP Une formation Yazid AZIZI
  • 203. Récapitulatif des préfixes Il existe deux techniques de récapitulation BGP Statique Dynamique R1
  • 204. R1 Adresse agrégée R1 router bgp 65100 bgp log-neighbor-changes network 10.12.1.0 mask 255.255.255.0 network 192.168.1.1 mask 255.255.255.255 network 192.168.3.3 mask 255.255.255.255 network 192.168.4.4 mask 255.255.255.255 redistribute ospf 1 neighbor 10.12.1.2 remote-as 65200 R2 router bgp 65100 bgp log-neighbor-changes neighbor 10.12.1.1 remote-as 65100 neighbor 10.23.1.3 remote-as 65300 ! address-family ipv4 aggregate-address 192.168.0.0 255.255.0.0 aggregate-address 172.16.0.0 255.255.240.0 redistribute connected neighbor 10.12.1.1 activate neighbor 10.23.1.3 activate exit-address-family
  • 205. Une formation Agrégat atomique Script R2 router bgp 65200 bgp log-neighbor-changes no bgp default ipv4-unicast neighbor 10.12.1.1 remote-as 65100 neighbor 10.23.1.3 remote-as 65300 ! address-family ipv4 aggregate-address 192.168.0.0 255.255.0.0 summary-only aggregate-address 172.16.0.0 255.255.240.0 summary-only redistribute connected neighbor 10.12.1.1 activate neighbor 10.23.1.3 activate exit-address-family R2#show bgp ipv4 unicast 172.16.0.0 BGP routing table entry for 172.16.0.0/20, version 6 Paths: (1 available, best #1, table default) Not advertised to any peer Refresh Epoch 2 65200, (aggregated by 65200 192.168.2.2) 10.23.1.2 from 10.23.1.2 (192.168.2.2) Origin IGP, metric 0,localpref 100, valid 32768, valid, external, atomic-aggregate, best rx pathid: 0, tx pathid: 0x0
  • 206. Une formation Agrégation de routes avec AS_SET R2#show running-config | section router bgp router bgp 65200 bgp log-neighbor-changes no bgp default ipv4-unicast neighbor 10.12.1.1 remote-as 65100 neighbor 10.23.1.3 remote-as 65300 ! address-family ipv4 aggregate-address 192.168.0.0 255.255.0.0 as-set summary-only aggregate-address 172.16.0.0 255.255.240.0 as-set summary-only redistribute connected neighbor 10.12.1.1 activate neighbor 10.23.1.3 activate exit-address-family
  • 207. Découvrir BGP multi protocole pour IPv6 Une formation Yazid AZIZI
  • 208. BGP multi protocole Attributs facultatifs et non transitifs BGPv4 NLRI multiprotocole accessible NLRI multiprotocole inaccessible
  • 209. Configuration du BGP IPv6 R1 router bgp 65100 bgp router-id 192.168.1.1 bgp log-neighbor-changes no bgp default ipv4-unicast neighbor 2001:DB8:0:12::2 remote-as 65200 ! address-family ipv6 redistribute connected neighbor 2001:DB8:0:12::2 activate exit-address-family R2 router bgp 65200 bgp router-id 192.168.2.2 bgp log-neighbor-changes no bgp default ipv4-unicast neighbor 2001:DB8:0:12::1 remote-as 65100 neighbor 2001:DB8:0:23::3 remote-as 65300 ! address-family ipv6 network 2001:DB8::2/128 network 2001:DB8:0:12::/64 network 2001:db8:0:23::/64 neighbor 2001:DB8:0:12::1 activate neighbor 2001:DB8:0:23::3 activate exit-address-family
  • 210. Une formation Affichage des voisins BGP IPv6 R1# show bgp ipv6 unicast neighbors 2001:DB8:0:12::2 ! Output omitted for brevity BGP neighbor is 2001:DB8:0:12::2, remote AS 65200, external link BGP version 4, remote router ID 192.168.2.2 BGP state = Established, up for 00:28:25 Last read 00:00:54, last write 00:00:34, hold time is 180, keepalive interval is 60 seconds Neighbor sessions: 1 active, is not multisession capable (disabled) Neighbor capabilities: Route refresh: advertised and received(new) Four-octets ASN Capability: advertised and received Address family IPv6 Unicast: advertised and received Enhanced Refresh Capability: advertised and received La commande : show bgp ipv6 unicast neighbors ip-address [detail]
  • 211. Affichage des tables BGP IPv6 R2# show bgp ipv6 unicast | begin Network Network Next Hop Metric LocPrf Weight Path *> 2001:DB8::1/128 2001:DB8:0:12::1 0 0 65100 ? *> 2001:DB8::2/128 :: 0 32768 i *> 2001:DB8::3/128 2001:DB8:0:23::3 0 0 65300 i *> 2001:DB8:0:1::/64 2001:DB8:0:12::1 0 0 65100 ? *> 2001:DB8:0:3::/64 2001:DB8:0:23::3 0 0 65300 i *> 2001:DB8:0:12::/64 :: 0 32768 i * 2001:DB8:0:12::1 0 0 65100 ? *> 2001:DB8:0:23::/64 :: 0 32768 i 2001:DB8:0:23::3 0 0 65300 i
  • 212. Récapitulation des routes IPv6 Bits Nécessaire Adresse récapitulative Réseaux 2 2001:db8:0:0::/62 2001:db8:0:0::/64 - 2001:db8:0:3::/64 3 2001:db8:0:0::/61 2001:db8:0:0::/64 - 2001:db8:0:7::/64 4 2001:db8:0:0::/60 2001:db8:0:0::/64 - 2001:db8:0:F::/64 5 2001:db8:0:0::/59 2001:db8:0:0::/64 - 2001:db8:0:1F::/64 6 2001:db8:0:0::/58 2001:db8:0:0::/64 - 2001:db8:0:3F::/64 La commande : aggregate-address prefix/prefix-length [summary-only] [as-set]
  • 213. Configurer BGP IPv6 Une formation Yazid AZIZI
  • 214. Lab
  • 215. Comprendre le multihoming BGP Une formation Yazid AZIZI
  • 217. Routage de transit Internet
  • 218. Acheminement du transit en succursale
  • 219. Acheminement du transit en succursale Le routage de transit au centre de données ou à d'autres emplacements planifiés est normal dans les conceptions d'entreprise car ils ont pris en compte la bande passante
  • 220. Découvrir les ACL et la correspondance de préfixes Une formation Yazid AZIZI
  • 221. Une formation Listes de contrôle d'accès Rappel : Les ACL sont classées en deux catégories Standard et Extended ACL standard ACL étendues ACL nommées
  • 222. ACL standard Étape 1 ip access-list standard {acl-number | acl-name} Étape 2 [sequence] {permit | deny} source source-wildcard Entrée ACE Réseau permit any Permits tous le réseau permit 172.16.0.0 0.0.255.255 Permits tous le réseau 172.16.0.0 permit host 192.168.1.1 Permits que l’hot 192.168.1.1/32 du réseau
  • 223. ACL Etendues Étape 1 ip access-list extended {acl-number | acl-name} Étape 2 [sequence] {permit | deny} protocol source source-wildcard destination destination-wildcard Entrée ACE Réseau permit any Autorise tous les réseaux permit ip 172.16.0.0 0.0.255.255 Autorise la plage réseau 172.16.0.0 permit ip host 92.168.1.1 Autorise seulement 192.168.1.1/32
  • 224. Sélection de réseau IGP ACL étendue Entrée ACE Réseau permit ip any any Autorise tous les réseaux permit ip host 172.16.0.0 host 255.240.0.0 Autorise tous les réseaux de la plage 172.16.0.0/12 permit ip host 172.16.0.0 host 255.255.0.0 Autorise tous les réseaux de la plage 172.16.0.0/16 permit host 192.168.1.1 Autorise uniquement @ip 192.168.1.1/32
  • 225. Sélection de réseau BGP ACL étendue
  • 226. Sélection de réseau BGP ACL étendue Une configuration de bits de poids fort et un nombre de bits de poids fort Modèle de bits de poids fort comme adresse ou réseau, et le nombre de bits de poids fort comme longueur de masque
  • 227. Correspondance de préfixe avec les paramètres de longueur le: Inférieur ou égal à, <= ge: Supérieur ou égal à, >=
  • 228. Correspondance de préfixe avec les paramètres de longueur
  • 229. Listes de préfixes - IPv4 Commande : ip prefix-list prefix-listname [seq sequence-number] {permit | deny} high-order-bit-pattern/high-order-bit-count [ge ge-value] [le le-value] Note : nombre de bits de poids fort <ge-value <= le-value
  • 230. Listes de préfixes – IPv6 Commande : ipv6 prefix-list prefix-listname [seq sequence-number] {permit | deny} high-order-bit-pattern/high-order-bit-count [ge ge-value] [le le-value]
  • 231. Expressions régulières (regex) Commande : show bgp ip unicast regexp regex-pattern Expression régulière Sens ^$ Routes d'origine locale permit ^200_ Uniquement les routes du voisin AS 200 permit _200$ Uniquement les routes provenant de l'AS 200 permit _200_ Seuls les itinéraires qui passent par AS 200 permit ^[0-9]+ [0-9]+ [0-9]+? Routes avec trois entrées AS_Path ou moins
  • 232. Comprendre le but des routes-maps dans BGP Une formation Yazid AZIZI
  • 233. Une formation Composants et syntaxe de la routes- maps Une routes-maps comprend quatre éléments: Numéro de séquence Critères de correspondance conditionnelle Action de traitement Action facultative la syntaxe de commande: route-map route-map- name [permit | deny] [sequence-number]
  • 234. Composants et syntaxe de la routes-maps
  • 235. Correspondance conditionnelle de la carte d'itinéraire Commande Match match as-path acl-number match ip address {acl-number | acl-name} match ip address prefix-list prefix-list-name match local-preference local-preference match metric {1-4294967295 | external 1-4294967295}[+- deviation] match tag tag-value
  • 236. Options et variables de correspondance multiples de la carte d'itinéraire
  • 237. Problèmes de correspondance complexes de la carte d'itinéraire
  • 238. Route-map « continue » Mot-clé Sélection de réseau IGP ACL étendue
  • 239. Filtrer et manipuler l'itinéraire BGP pour améliorer les performances Une formation Yazid AZIZI
  • 240. Une formation Concepts de filtrage d'itinéraire BGP Méthodes de filtrage des routes entrantes ou sortantes pour un homologue BGP spécifique: Distribute list Prefix list AS path ACL/filtering Route maps
  • 241. Concepts de filtrage d'itinéraire BGP Commencer la référence de la table de routage
  • 242. Filtrage de la liste de distribution BGP la commande de configuration de la famille d'adresses BGP voisin : neighbor ip-address distribute-list {acl-number | acl-name} {in|out}
  • 243. Filtrage de la liste de distribution BGP (résultat de la table de routage)
  • 244. Résultat du filtrage de la liste de préfixes BGP et de la table de routage
  • 245. Filtrage d'ACL de chemin BGP AS
  • 246. Filtrage d'ACL de chemin BGP AS
  • 247. Une formation Effacement des connexions BGP BGP prend en charge deux méthodes pour effacer une session La réinitialisation matérielle arrête la session BGP La réinitialisation logicielle Réinitialisation matérielle avec la commande: clear ip bgp ip-address [soft] Les réinitialisations logicielles avec la commande clear bgp afi safi {ip-address|*} soft [in | out]
  • 248. Comprendre la fonction et le but des communautés BGP Une formation Yazid AZIZI
  • 249. Une formation Communautés BGP Les communautés BGP sont des attributs BGP transitif facultatif Une communauté BGP est un nombre 32 Une communauté BGP peut être affichée sous forme de nombre complet de 32 bits (0–4 294 967 295) ou de deux nombres de 16 bits (0–65535)
  • 250. Une formation Communautés bien connues Internet No_Advertise No_Export
  • 251. Activation de la prise en charge de la communauté BGP Les communautés standard sont envoyées par défaut neighbor ip-address send-community [standard | extended | both] Les communautés dans un nouveau format, avec la commande de configuration globale: ip bgp-community new-format
  • 252. Liste de la communauté BGP Correspondance conditionnelle Les listes de communautés standard : 1 à 99 Les listes de communautés étendues : de 100 à 500 « ip community-list {1-500 | nom-liste standard | nom-liste étendu} {permit | deny} »
  • 253. Liste de communauté BGP Correspondance conditionnelle (résultat de la table de routage)
  • 256. Connaitre les processus utilisés par BGP pour la sélection de chemin Une formation Yazid AZIZI
  • 257. Sélection de chemins de routage
  • 258. Une formation Algorithme du meilleur chemin BGP BGP recalcule le meilleur chemin pour un préfixe sur quatre événements possibles Changement d'accessibilité du prochain saut BGP Échec d'une interface connectée à un pair eBGP Changement de redistribution Réception de chemins nouveaux ou supprimés pour un itinéraire
  • 259. Une formation Les attributs Poids Préférence locale - (LOCAL_PREF Origine locale Accumulated Interior Gateway Protocol (AIGP) Le plus court AS_Path Type d'origine MED le plus bas eBGP sur iBGP Prochain bond IGP le plus Le plus ancien chemin eBGP ID de routeur Longueur minimale de la liste de cluster Adresse de voisin le plus
  • 261. Une formation Essentiels et les concept du routage IP Protocole de routage EIGRP et sont paramétrage avancé Protocole de routage OSPFv2 et sont paramétrage avancé Protocole de routage OSPFv3 Protocole de routage BGP et sont paramétrage avancé Bilan