SlideShare une entreprise Scribd logo
1  sur  34
Réalisé par : Mlle Ben Targem Leila
Mr Mahfoudh Mohamed Bilel
Encadré par : Mr Elmahroug Sofiene
Mr Abdelmalek Anis
Etude et Mise en Place d’un réseau d’une haute
disponibilité LAN et WAN
2010/2011
Ministère de l’enseignement supérieur et de la recherche scientifique
Institut Supérieur des Etudes Technologiques de Radés
3
Plan
Conclusion
Partie WAN
Partie LAN
Etude du besoin
Présentation de la société
Présentation
Présentation de la société
 C’est l’Union Bancaire pour le Commerce et
l’industrie .
 Son Siège se situe à Tunis et ses deux cent
agences sont réparties sur toute la république.
 Elle bénéficie d’un accès direct au réseau mondial
du group BNP PARIBAS
4
Présentation
 Le Projet consiste à mettre en œuvre une solution de
communication unifiée pour l’UBCI en respectant les
contraintes suivantes:
5
Garantir la qualité de service
Assurer une haute disponibilité de service
Mise en place de protocole garantissant le basculement
vers des liaisons redondants.
Etude du besoin
6
Transfert du voix (VoIP )
UBCI
Visioconférence
QOS
MPLS
VLAN
VPN
Transfert des données
Accès rapide à Internet
Partie LAN
7
A
Solution LAN Proposée
B
Configuration des VLANs
C
Configuration du service DHCP
D
Configuration de VTP
E
Améliorer le protocole STP
F
Configuration des IP phones
Architecture LAN existante
8
Solution LAN Proposée
9
étage1 étage 2 étage 3 étage 4
Réalisation « LAN »
10
Crée les VLANs
- Vlan Data
- Vlan voix
- Vlan admin
Activation de protocole RSTP
Configuration de protocole
VTP
Sw1# spanning-tree mode rapid-pvst
SwI#vlan database
SwI(vlan)#vtp server
SwI(vlan)#vtp domain UBCI.com.tn
etage1#vlan database
etage1(vlan)#vtp client
etage1(vlan)#vtp domain UBCI.com.tn
Réalisation « LAN »
11
Configuration de protocole
DHCP
Configuration des IP phones
Siege (config) # ip dhcp pool data
Siege (dhcp-config) # network 10.142.2.1
255.255.254.0
Siege (dhcp-config) #default-router
10.142.2.1
Siege (dhcp-config) #exit
Siege (config)# ip dhcp excluded-address
10.142.2.1 10.142.2.2
Siege (config) # telephony-service
Siege (config- telephony) # max-dn 5
Siege (config- telephony) # max –ephones 5
Siege (config- telephony) # ip source
address 22.142.2.1 port 2000
Siege (config- telephony) # auto assign 4 to 6
Siege (config- telephony) # auto assign 1 to 5
Siege (config) # ip dhcp pool Voice
Siege (dhcp-config) # network 22.142.2.1
255.255.254.0
Siege (dhcp-config) #default-router
22.142.2.1
Siege (dhcp-config) #exit
Siege (config)# ip dhcp excluded-address
22.142.2.1 22.142.2.2
Siege (config) # ip dhcp pool Admin
Siege (dhcp-config) # network 11.142.2.1
255.255.254.0
Siege (dhcp-config) #default-router
11.142.2.1
Siege (dhcp-config) #exit
Siege (config)# ip dhcp excluded-address
11.142.2.1 11.142.2.2
Siege (config- telephony) # ephone-dn 1
Siege (config- telephony)# 125
Partie WAN
12
A
Solution WAN proposée
B
Configuration des liaisons MPLS
C
Configuration des liaisons VPN
D
L ’implémentation du protocol HSRP
Architecture WAN existante
13
Problématique
14
1
2
Et
Convergence de différent
flux tels que voix, data
Augmentation du
nombre d’utilisateurs
Augmentation de la taille des tables de routages
Augmentation des temps de traitement et de traversée
Problématique
15
Besoin de trouver une méthode plus
efficace pour la transmission de
paquets en garantissant la qualité de
service
MPLS
Solution WAN proposée
16
HSRP
Siége_VPN
Siége_MPLS
Maquette MPLS
17
10.142.249.0
/30
10.10.10.0/30
10.10.10.4/30
10.142.249.24/30
10.142.2.0/23
10.142.20.0/23
Implémentation de MPLS
18
1
Activation du routage IP classique
2
Activation MPLS
3
Activation MPLS/VPN
o Assignation des adresse IP par interface
o Assignation des adresse IP des loopback des routeur CE et PE
o Activation du routage IGP (OSPF)
o Activation de la commutation CEF
o Activation de la distribution des labels sur les interfaces participants
o Configuration de l’ IGP (OSPF)
o Configuration de VRF
o Assignation de VRF à une interfaces
o Configuration de MP-BGP entre les PE
oConfiguration de OSPF par VRF
o Redistribution de MP-BGP en OSPF et OSPF en MP-BGP
Implémentation de MPLS
19
 Extrait de configuration :
ip cef
mpls label protocol ldp
mpls ip
ip vrf site
rd 1:1
route-target export 1:1
route-target import 1:1
exit
interface Loopback 0
ip address 4.4.4.4 255.255.255.255
interface s1/0
ip address 10.10.10.5 255.255.255.252
mpls ip
Activation de la
commutation CEF
Activation de la
distribution de label
Configuration d’un
VRF
Assignation des
adresse loopback
Activation de la
distribution des labels
sur touts les interface P
et PE
Implémentation de MPLS
20
 Extrait de configuration :
int s1/1
ip vrf forwarding site
ip address 10.142.249.26 255.255.255.252
router ospf 10 vrf site
redistribute bgp 1 subnets
network 10.142.249.26 0.0.0.0 area 0
exit
router ospf 1
network 4.4.4.4 0.0.0.0 area 0
network 10.10.10.5 0.0.0.0 area 0
Assignation de VRF
a une interface
Configuration de
OSPF par VRF
Redistribuer BGP
en OSPF
Configuration de
routage IGP
(OSPF)
Implémentation de la QOS
21
QOS Diffserv
EF : Trafic voix
Haute priorité
BP: 80Kbits/s
AF: Best effort
DSCP
Implémentation de la QOS
22
 Extrait de configuration :
Megrine(config)# class-map match –all
voix
Megrine(config-cmap)# match ip rtp
16383 16000
Megrine(config-cmap)# exit
Megrine(config)# policy map out policy
Megrine(config-pmap)# class voix
Megrine(config-pmap-c)# set dscp ef
Megrine(config-pmap-c)# priority 80
Megrine(config-pmap-c)#exit
Megrine(config-pmap)#class class-default
Megrine(config-pmap-c)# set ip dscp
default
Megrine(config-pmap-c)#exit
Megrine(config-pmap)#exit
Megrine(config)#interface s1/0
Megrine(config-if)#service-policy output
out policy
Définir une classe pour
notre stratégie de QOS
Assuré le transfert
de la voix (EF)
L’algorithme traite
en priorité la voix et
lui garantie au
moins 80kbits/s de
la bande passante
Assuré le transfert
des données (best
effort )
Configuration des liaisons VPN
23
1
Mettre en place les Tunnels entre les deux sites
( définition des interfaces virtuelles).
2
Crypter les Tunnels.
3
Mettre en place le routage intersites
Définition de l’interface virtuelle
24
•interface Tunnel1
•ip address 172.16.254.2
255.255.255.252
•tunnel source Serial1/1
•tunnel destination
10.142.245.1
Cryptage du tunnel
25
•crypto isakmp policy 2
• authentication pre-share
• lifetime 3600
•crypto isakmp key UBCI address
10.142.245.2
•crypto ipsec transform-set
transfdes esp-des
•crypto map cryptvpn 2 ipsec-
isakmp
• set peer 10.142.245.2
• set security-association lifetime
kilobytes 102400
• set security-association lifetime
seconds 900
• set transform-set transfdes
• match address cryptolist
Routage intersites
26
•router ospf 20
• log-adjacency-changes
• network 10.142.2.0
0.0.1.255 area 0
• network 10.142.245.24
0.0.0.3 area 0
• network 172.16.254.0
0.0.0.3 area 0
Les accès Listes
27
ip access-list extended cryptolist
permit gre host 10.142.245.1 host 10.142.245.2
ip access-list extended natlist
deny ip 10.142.2.0 0.0.1.255 10.142.20.0 0.0.1.255
permit ip 10.142.2.0 0.0.1.255 any
ip access-list extended netin
permit tcp any host 10.142.245.1 established
permit udp any eq domain host 10.142.245.1
permit tcp any eq www host 10.142.245.1
permit tcp any eq 443 host 10.142.245.1
permit udp host 10.142.245.2 eq isakmp host 10.142.245.1 eq isakmp
permit esp host 10.142.245.2 host 10.142.245.1
ip access-list extended netout
permit udp host 10.142.245.1 any eq domain
permit tcp host 10.142.245.1 any eq www
permit tcp host 10.142.245.1 any eq 443
permit tcp any eq 443 host 10.142.245.1
permit udp host 10.142.245.1 eq isakmp host 10.142.245.2 eq isakmp
permit esp host 10.142.245.1 host 10.142.245.2
Implémentation du protocole HSRP
28
Siège MPLS
•standby 1 ip 10.142.2.3
•standby 1 priority 110
•standby 1 preempt
Siège VPN
•standby 1 ip 10.142.2.3
•standby 1 priority 100
•standby 1 preempt
Implémentation du protocole HSRP
29
Scénario 1
Implémentation du protocole HSRP
30
Scénario 2
Implémentation du protocole HSRP
31
Scénario 3
Implémentation du protocole HSRP
32
implémentation du paramètre « track »
•interface FastEthernet 2/0
•standby 1 track FastEthernet 2/1
•standby 1 track serial 1/0 3
•standby 1 1 track serial 1/1 3
Conclusion
33
A travers ce projet nous avons mis en place une solution
d’interconnexion LAN qui supporte la téléphonie IP et
tolérante aux pannes.
Nous a avons Implémenté une nouvelle architecture WAN
hautement disponible en garantissant la qualité de service
et tolérante aux pannes en prévoyant un basculement
automatique entre équipements en cas de problème.
Un tel réseau dans son ampleur a besoin d’un outil de
supervision ce qui lui fait défaut, pour ce la il faut penser à
mettre en place un outil qui assure la sécurité d’accès au
réseau LAN par exemples des firewalls.
34

Contenu connexe

Similaire à soutenance.ppt

Alphorm.com Formation pfSense: Le firewall open source de référence
Alphorm.com Formation pfSense: Le firewall open source de référenceAlphorm.com Formation pfSense: Le firewall open source de référence
Alphorm.com Formation pfSense: Le firewall open source de référence
Alphorm
 

Similaire à soutenance.ppt (20)

Version Final Presentation
Version Final PresentationVersion Final Presentation
Version Final Presentation
 
MPLS-VPN
MPLS-VPNMPLS-VPN
MPLS-VPN
 
Tout atm
Tout atmTout atm
Tout atm
 
Alphorm.com Formation pfSense: Le firewall open source de référence
Alphorm.com Formation pfSense: Le firewall open source de référenceAlphorm.com Formation pfSense: Le firewall open source de référence
Alphorm.com Formation pfSense: Le firewall open source de référence
 
Alphorm.com Formation Cisco CCNA v3 : mise à jour
Alphorm.com Formation Cisco CCNA v3 : mise à jourAlphorm.com Formation Cisco CCNA v3 : mise à jour
Alphorm.com Formation Cisco CCNA v3 : mise à jour
 
Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
 
Services IP
Services IPServices IP
Services IP
 
Configuration de-base-d
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
 
Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : L'es...
Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : L'es...Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : L'es...
Alphorm.com Formation Mettre en oeuvre Cisco MPLS (CCNP SP et CCIE SP) : L'es...
 
Astuces cisco
Astuces ciscoAstuces cisco
Astuces cisco
 
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
 
Tp voip
Tp voipTp voip
Tp voip
 
Vpn
VpnVpn
Vpn
 
vpn-site-a-site-avec-des-routeurs-cisco
 vpn-site-a-site-avec-des-routeurs-cisco vpn-site-a-site-avec-des-routeurs-cisco
vpn-site-a-site-avec-des-routeurs-cisco
 
Tuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-siteTuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-site
 
IPv6 training
IPv6 trainingIPv6 training
IPv6 training
 
Fr introbgp-sif
Fr introbgp-sifFr introbgp-sif
Fr introbgp-sif
 
E4 pt act_7_5_1
E4 pt act_7_5_1E4 pt act_7_5_1
E4 pt act_7_5_1
 
Memo
MemoMemo
Memo
 
Ccna 2-module-2-v4
Ccna 2-module-2-v4Ccna 2-module-2-v4
Ccna 2-module-2-v4
 

soutenance.ppt

  • 1.
  • 2. Réalisé par : Mlle Ben Targem Leila Mr Mahfoudh Mohamed Bilel Encadré par : Mr Elmahroug Sofiene Mr Abdelmalek Anis Etude et Mise en Place d’un réseau d’une haute disponibilité LAN et WAN 2010/2011 Ministère de l’enseignement supérieur et de la recherche scientifique Institut Supérieur des Etudes Technologiques de Radés
  • 3. 3 Plan Conclusion Partie WAN Partie LAN Etude du besoin Présentation de la société Présentation
  • 4. Présentation de la société  C’est l’Union Bancaire pour le Commerce et l’industrie .  Son Siège se situe à Tunis et ses deux cent agences sont réparties sur toute la république.  Elle bénéficie d’un accès direct au réseau mondial du group BNP PARIBAS 4
  • 5. Présentation  Le Projet consiste à mettre en œuvre une solution de communication unifiée pour l’UBCI en respectant les contraintes suivantes: 5 Garantir la qualité de service Assurer une haute disponibilité de service Mise en place de protocole garantissant le basculement vers des liaisons redondants.
  • 6. Etude du besoin 6 Transfert du voix (VoIP ) UBCI Visioconférence QOS MPLS VLAN VPN Transfert des données Accès rapide à Internet
  • 7. Partie LAN 7 A Solution LAN Proposée B Configuration des VLANs C Configuration du service DHCP D Configuration de VTP E Améliorer le protocole STP F Configuration des IP phones
  • 9. Solution LAN Proposée 9 étage1 étage 2 étage 3 étage 4
  • 10. Réalisation « LAN » 10 Crée les VLANs - Vlan Data - Vlan voix - Vlan admin Activation de protocole RSTP Configuration de protocole VTP Sw1# spanning-tree mode rapid-pvst SwI#vlan database SwI(vlan)#vtp server SwI(vlan)#vtp domain UBCI.com.tn etage1#vlan database etage1(vlan)#vtp client etage1(vlan)#vtp domain UBCI.com.tn
  • 11. Réalisation « LAN » 11 Configuration de protocole DHCP Configuration des IP phones Siege (config) # ip dhcp pool data Siege (dhcp-config) # network 10.142.2.1 255.255.254.0 Siege (dhcp-config) #default-router 10.142.2.1 Siege (dhcp-config) #exit Siege (config)# ip dhcp excluded-address 10.142.2.1 10.142.2.2 Siege (config) # telephony-service Siege (config- telephony) # max-dn 5 Siege (config- telephony) # max –ephones 5 Siege (config- telephony) # ip source address 22.142.2.1 port 2000 Siege (config- telephony) # auto assign 4 to 6 Siege (config- telephony) # auto assign 1 to 5 Siege (config) # ip dhcp pool Voice Siege (dhcp-config) # network 22.142.2.1 255.255.254.0 Siege (dhcp-config) #default-router 22.142.2.1 Siege (dhcp-config) #exit Siege (config)# ip dhcp excluded-address 22.142.2.1 22.142.2.2 Siege (config) # ip dhcp pool Admin Siege (dhcp-config) # network 11.142.2.1 255.255.254.0 Siege (dhcp-config) #default-router 11.142.2.1 Siege (dhcp-config) #exit Siege (config)# ip dhcp excluded-address 11.142.2.1 11.142.2.2 Siege (config- telephony) # ephone-dn 1 Siege (config- telephony)# 125
  • 12. Partie WAN 12 A Solution WAN proposée B Configuration des liaisons MPLS C Configuration des liaisons VPN D L ’implémentation du protocol HSRP
  • 14. Problématique 14 1 2 Et Convergence de différent flux tels que voix, data Augmentation du nombre d’utilisateurs Augmentation de la taille des tables de routages Augmentation des temps de traitement et de traversée
  • 15. Problématique 15 Besoin de trouver une méthode plus efficace pour la transmission de paquets en garantissant la qualité de service MPLS
  • 18. Implémentation de MPLS 18 1 Activation du routage IP classique 2 Activation MPLS 3 Activation MPLS/VPN o Assignation des adresse IP par interface o Assignation des adresse IP des loopback des routeur CE et PE o Activation du routage IGP (OSPF) o Activation de la commutation CEF o Activation de la distribution des labels sur les interfaces participants o Configuration de l’ IGP (OSPF) o Configuration de VRF o Assignation de VRF à une interfaces o Configuration de MP-BGP entre les PE oConfiguration de OSPF par VRF o Redistribution de MP-BGP en OSPF et OSPF en MP-BGP
  • 19. Implémentation de MPLS 19  Extrait de configuration : ip cef mpls label protocol ldp mpls ip ip vrf site rd 1:1 route-target export 1:1 route-target import 1:1 exit interface Loopback 0 ip address 4.4.4.4 255.255.255.255 interface s1/0 ip address 10.10.10.5 255.255.255.252 mpls ip Activation de la commutation CEF Activation de la distribution de label Configuration d’un VRF Assignation des adresse loopback Activation de la distribution des labels sur touts les interface P et PE
  • 20. Implémentation de MPLS 20  Extrait de configuration : int s1/1 ip vrf forwarding site ip address 10.142.249.26 255.255.255.252 router ospf 10 vrf site redistribute bgp 1 subnets network 10.142.249.26 0.0.0.0 area 0 exit router ospf 1 network 4.4.4.4 0.0.0.0 area 0 network 10.10.10.5 0.0.0.0 area 0 Assignation de VRF a une interface Configuration de OSPF par VRF Redistribuer BGP en OSPF Configuration de routage IGP (OSPF)
  • 21. Implémentation de la QOS 21 QOS Diffserv EF : Trafic voix Haute priorité BP: 80Kbits/s AF: Best effort DSCP
  • 22. Implémentation de la QOS 22  Extrait de configuration : Megrine(config)# class-map match –all voix Megrine(config-cmap)# match ip rtp 16383 16000 Megrine(config-cmap)# exit Megrine(config)# policy map out policy Megrine(config-pmap)# class voix Megrine(config-pmap-c)# set dscp ef Megrine(config-pmap-c)# priority 80 Megrine(config-pmap-c)#exit Megrine(config-pmap)#class class-default Megrine(config-pmap-c)# set ip dscp default Megrine(config-pmap-c)#exit Megrine(config-pmap)#exit Megrine(config)#interface s1/0 Megrine(config-if)#service-policy output out policy Définir une classe pour notre stratégie de QOS Assuré le transfert de la voix (EF) L’algorithme traite en priorité la voix et lui garantie au moins 80kbits/s de la bande passante Assuré le transfert des données (best effort )
  • 23. Configuration des liaisons VPN 23 1 Mettre en place les Tunnels entre les deux sites ( définition des interfaces virtuelles). 2 Crypter les Tunnels. 3 Mettre en place le routage intersites
  • 24. Définition de l’interface virtuelle 24 •interface Tunnel1 •ip address 172.16.254.2 255.255.255.252 •tunnel source Serial1/1 •tunnel destination 10.142.245.1
  • 25. Cryptage du tunnel 25 •crypto isakmp policy 2 • authentication pre-share • lifetime 3600 •crypto isakmp key UBCI address 10.142.245.2 •crypto ipsec transform-set transfdes esp-des •crypto map cryptvpn 2 ipsec- isakmp • set peer 10.142.245.2 • set security-association lifetime kilobytes 102400 • set security-association lifetime seconds 900 • set transform-set transfdes • match address cryptolist
  • 26. Routage intersites 26 •router ospf 20 • log-adjacency-changes • network 10.142.2.0 0.0.1.255 area 0 • network 10.142.245.24 0.0.0.3 area 0 • network 172.16.254.0 0.0.0.3 area 0
  • 27. Les accès Listes 27 ip access-list extended cryptolist permit gre host 10.142.245.1 host 10.142.245.2 ip access-list extended natlist deny ip 10.142.2.0 0.0.1.255 10.142.20.0 0.0.1.255 permit ip 10.142.2.0 0.0.1.255 any ip access-list extended netin permit tcp any host 10.142.245.1 established permit udp any eq domain host 10.142.245.1 permit tcp any eq www host 10.142.245.1 permit tcp any eq 443 host 10.142.245.1 permit udp host 10.142.245.2 eq isakmp host 10.142.245.1 eq isakmp permit esp host 10.142.245.2 host 10.142.245.1 ip access-list extended netout permit udp host 10.142.245.1 any eq domain permit tcp host 10.142.245.1 any eq www permit tcp host 10.142.245.1 any eq 443 permit tcp any eq 443 host 10.142.245.1 permit udp host 10.142.245.1 eq isakmp host 10.142.245.2 eq isakmp permit esp host 10.142.245.1 host 10.142.245.2
  • 28. Implémentation du protocole HSRP 28 Siège MPLS •standby 1 ip 10.142.2.3 •standby 1 priority 110 •standby 1 preempt Siège VPN •standby 1 ip 10.142.2.3 •standby 1 priority 100 •standby 1 preempt
  • 29. Implémentation du protocole HSRP 29 Scénario 1
  • 30. Implémentation du protocole HSRP 30 Scénario 2
  • 31. Implémentation du protocole HSRP 31 Scénario 3
  • 32. Implémentation du protocole HSRP 32 implémentation du paramètre « track » •interface FastEthernet 2/0 •standby 1 track FastEthernet 2/1 •standby 1 track serial 1/0 3 •standby 1 1 track serial 1/1 3
  • 33. Conclusion 33 A travers ce projet nous avons mis en place une solution d’interconnexion LAN qui supporte la téléphonie IP et tolérante aux pannes. Nous a avons Implémenté une nouvelle architecture WAN hautement disponible en garantissant la qualité de service et tolérante aux pannes en prévoyant un basculement automatique entre équipements en cas de problème. Un tel réseau dans son ampleur a besoin d’un outil de supervision ce qui lui fait défaut, pour ce la il faut penser à mettre en place un outil qui assure la sécurité d’accès au réseau LAN par exemples des firewalls.
  • 34. 34