SlideShare une entreprise Scribd logo
CCNP ROUTE
Implementation de Routage IP
Mohamed DYABI
Configuration de l’EIGRP
Bonjour
Instructeur : MOHAMED DYABI
Email : mohamed.dyabi@gmail.com
FB : facebook.com/med.dyabi
 Instructeur Cisco
• Certifié CISCO (CISCO ID CSCO12578708)
• Certifié MCT (MC ID 7343319)
• Expert Microsoft 2003,2008,2012 Server
• Certified VCP DATACENTER ,VCA Cloud ,DATACENTER ,Workforce Mobility
…..
Les Paquets EIGRP
3
LES PAQUETS EIGRP
 Hello :
• utilisés par EIGRP pour découvrir des voisins et former des contiguïtés avec ces
voisins
 mise à jour :
• utilisés par EIGRP pour propager des informations de routage.
• EIGRP n’envoie pas de mises à jour périodiques.
• Ils sont transmis uniquement en cas de nécessité.
• Les mises à jour EIGRP ne contiennent que les informations de routage nécessaires,
et ne sont envoyées qu’aux routeurs qui en ont besoin.
• Les paquets de mise à jour EIGRP utilisent la livraison fiable. Ils sont envoyés en
multicast lorsqu’ils concernent plusieurs routeurs, ou en unicast si seul un routeur
en a besoin
4
LES PAQUETS EIGRP
 Paquets de requête :
Ils sont utilisés lorsque le routeur EIGRP a perdu des informations sur un réseau et
n’a pas de chemins de sauvegarde. Le routeur envoie des paquets de requête à
ses voisins pour leur demander s'ils ont des informations sur ce réseau particulier.
 Paquets de réponse :
Ils sont utilisés pour répondre à des paquets de requête et ils sont fiables.
5
LES PAQUETS EIGRP
 Les paquets ACK (de reçu) :
sont envoyés par EIGRP lorsque la livraison fiable est utilisée. RTP utilise la
livraison fiable pour les paquets de mise à jour, de demande et de réponse
EIGRP. Les paquets d’accusé de réception EIGRP sont toujours envoyés en
unicast non fiable.
6
Configuration de l’ EIGRP
7
CONFIGURATION DE L’EIGRP
 Définir le numéro du système Autonome
 Pour échanger des mises à jour de routage, les routeurs EIGRP doivent
avoir le même ID de système autonome
router eigrp autonomous-system-id
Activer le routage EIGRP
Router(config)#
8
CONFIGURATION DE L’EIGRP
 Définir les réseaux EIGRP pour les annoncer aux voisins EIGRP
 Le paramètre network peut être un réseau, un sous-réseau, ou l'adresse
d'une interface directement connectée
 Le masque est un masque générique (masque inverse)
network network [mask]
Identifier les réseaux EIGRP
Router(config-router) #
9
CONFIGURATION DE L’EIGRP
 La plupart des références EIGRP affirment que le masque générique est
nécessaire.
 Cependant, depuis IOS 12.0 (4) T, le masque peut être configuré à l'aide
des bits de joker (wild card bits ) ou un masque de sous-réseau régulier.
 Par exemple, On peut utiliser les deux formats suivants pour configurer le
réseau 10.10.10.0
• network 10.10.10.0 0.0.0.3
ou
• network 10.10.10.0 255.255.255.252.
Note sur le masque générique
10
CONFIGURATION DE L’EIGRP
 Après cette commande le protocole EIGRP se comportera comme un
protocole de routage par classe
 On peut désactiver le résumé automatique à l’aide de la commande
no auto-summary
 no auto-summary est nécessaire parce que par défaut EIGRP se comporte
comme un protocole de routage par classe ce qui signifie qu'il ne va pas
annoncer le masque de sous-réseau.
auto-summary
Activer / Désactiver le résumé automatique
Router(config-router) #
11
CONFIGURATION DE L’EIGRP
Exemple de la configuration de l’EIGRP
R2(config)# no router eigrp 100
R2(config)# router eigrp 100
R2(config-router)# network 192.168.1.96 0.0.0.31
R2(config-router)# network 172.17.2.0 0.0.0.255
R2(config-router)# end
R1(config)# no router eigrp 100
R1(config)# router eigrp 100
R1(config-router)# network 192.168.1.96 0.0.0.31
R1(config-router)# network 172.16.1.0 0.0.0.255
R1(config-router)# end
12
CONFIGURATION DE L’EIGRP
 vérification de la configuration de l’EIGRP
R1# show ip protocols
Routing Protocol is "eigrp 100"
<output omitted>
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is in effect
Automatic address summarization:
192.168.1.0/24 for FastEthernet0/0
Summarizing with metric 40512000
172.16.0.0/16 for Serial0/0/0
Summarizing with metric 28160
Maximum path: 4
Routing for Networks:
172.16.1.0/24
192.168.1.96/27
Routing Information Sources:
Gateway Distance Last Update
(this router) 90 00:08:56
Gateway Distance Last Update
192.168.1.102 90 00:07:59
Distance: internal 90 external 170
13
CONFIGURATION DE L’EIGRP
 vérification de la configuration de l’EIGRP
R1# show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.1.102 Se0/0/0 11 00:09:17 22 2280 0 5
14
CONFIGURATION DE L’EIGRP
 vérification de la configuration de l’EIGRP
R1# show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(192.168.1.101)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.96/27, 1 successors, FD is 40512000
via Connected, Serial0/0/0
P 192.168.1.0/24, 1 successors, FD is 40512000
via Summary (40512000/0), Null0
P 172.16.0.0/16, 1 successors, FD is 28160
via Summary (28160/0), Null0
P 172.17.0.0/16, 1 successors, FD is 40514560
via 192.168.1.102 (40514560/28160), Serial0/0/0
P 172.16.1.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
15
CONFIGURATION DE L’EIGRP
 vérification de la configuration de l’EIGRP
R1# show ip route eigrp
D 172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:10:18, Serial0/0/0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 172.16.0.0/16 is a summary, 00:11:19, Null0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
D 192.168.1.0/24 is a summary, 00:11:19, Null0
R1#
R1# show ip route
<output omitted>
Gateway of last resort is not set
D 172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:10:35, Serial0/0/0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 172.16.0.0/16 is a summary, 00:11:37, Null0
C 172.16.1.0/24 is directly connected, FastEthernet0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.96/27 is directly connected, Serial0/0/0
D 192.168.1.0/24 is a summary, 00:11:37, Null0
16
CONFIGURATION DE L’EIGRP
 Empêcher les mises à jour EIGRP sur une interface de routeur
 L'option default définit toutes les interfaces de routeur passives.
 Pour l’EIGRP , la commande :
• Empêche les relations de voisinage d'être établie
• Les mises à jour de routage d'un voisin sont ignorés
• Permet à un sous-réseau sur une interface passive d’être annoncé
passive-interface type number [default]
Interface passive
Router(config-router) #
17
CONFIGURATION DE L’EIGRP
R1(config)# router eigrp 100
R1(config-router)# passive-interface fa0/0
R2(config)# router eigrp 100
R2(config-router)# passive-interface fa0/0
ou bien
R1(config)# router eigrp 100
R1(config-router)# passive-interface default
R1(config-router)# no passive-interface S0/0/0
18
CONFIGURATION DE L’EIGRP
 Définir les réseaux EIGRP pour les annoncer aux voisins EIGRP
 Le paramètre kilobits indique la bande passante prévue en Kbits/s.
• Par exemple, pour définir la bande passante de 512 000 bits/s, utilisez
la commande bandwidth 512
 La bande passante configurée est utilisée par les protocoles de routage
dans le calcul de métriques
 La commande ne modifie pas réellement la vitesse de l'interface.
bandwidth kilobits
Définir la bande passante de l’interface :
Router(config-if)#
19
CONFIGURATION DE L’EIGRP
Exemple de la commande ip route 0.0.0.0 0.0.0.0 next-hop
R2(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.2
R2(config)# router eigrp 100
R2(config-router)# network 0.0.0.0
R2(config-router)# redistribute static
R2(config-router)# do show ip route
<output omitted>
Gateway of last resort is 192.168.1.2 to network 0.0.0.0
172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 172.17.0.0/16 is a summary, 02:53:48, Null0
C 172.17.2.0/24 is directly connected, FastEthernet0/0
D 172.16.0.0/16 [90/40514560] via 192.168.1.101, 02:53:48, Serial0/0/0
192.168.1.0/27 is subnetted, 2 subnets
C 192.168.1.96 is directly connected, Serial0/0/0
C 192.168.1.0 is directly connected, Serial0/0/1
S* 0.0.0.0/0 [1/0] via 192.168.1.2
R2(config-router)# 20
Fin du chapitre
21

Contenu connexe

Tendances

Eigrp ccna v5
Eigrp ccna v5 Eigrp ccna v5
Eigrp ccna v5
Meriama Benrqiq
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
Thomas Moegli
 
Meilleures pratiques bgp
Meilleures pratiques bgpMeilleures pratiques bgp
Meilleures pratiques bgp
Aymen Bouzid
 
Travaux pratiques configuration du routage entre réseaux locaux virtuels
Travaux pratiques   configuration du routage entre réseaux locaux virtuelsTravaux pratiques   configuration du routage entre réseaux locaux virtuels
Travaux pratiques configuration du routage entre réseaux locaux virtuels
Mohamed Keita
 
Cours eigrp
Cours eigrpCours eigrp
Cours eigrp
Zidan Didi
 
Protocole EIGRP
Protocole EIGRPProtocole EIGRP
Protocole EIGRP
Thomas Moegli
 
Services IP
Services IPServices IP
Services IP
Thomas Moegli
 
E4 pt act_7_5_1
E4 pt act_7_5_1E4 pt act_7_5_1
E4 pt act_7_5_1
Simo Alaoui
 
1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage
Simo Qb
 
Weos routage dynamique OSPF
Weos routage dynamique OSPFWeos routage dynamique OSPF
Weos routage dynamique OSPF
Fabian Vandendyck
 
vpn-site-a-site-avec-des-routeurs-cisco
 vpn-site-a-site-avec-des-routeurs-cisco vpn-site-a-site-avec-des-routeurs-cisco
vpn-site-a-site-avec-des-routeurs-cisco
Camara Assane
 
EIGRP - Introduction
EIGRP - Introduction EIGRP - Introduction
EIGRP - Introduction
mdyabi
 
Cours routage inter-vlan
Cours routage inter-vlanCours routage inter-vlan
Cours routage inter-vlan
EL AMRI El Hassan
 
cours ospf
cours ospf cours ospf
cours ospf
EL AMRI El Hassan
 
CISCO HSRP VRRP GLBP
CISCO HSRP VRRP GLBPCISCO HSRP VRRP GLBP
CISCO HSRP VRRP GLBP
YACINE MESSAOUI
 
Fr introbgp-sif
Fr introbgp-sifFr introbgp-sif
Fr introbgp-sif
Aymen Bouzid
 
Présentation etherchannel
Présentation etherchannelPrésentation etherchannel
Présentation etherchannel
Lechoco Kado
 

Tendances (20)

Eigrp ccna v5
Eigrp ccna v5 Eigrp ccna v5
Eigrp ccna v5
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
 
Meilleures pratiques bgp
Meilleures pratiques bgpMeilleures pratiques bgp
Meilleures pratiques bgp
 
Travaux pratiques configuration du routage entre réseaux locaux virtuels
Travaux pratiques   configuration du routage entre réseaux locaux virtuelsTravaux pratiques   configuration du routage entre réseaux locaux virtuels
Travaux pratiques configuration du routage entre réseaux locaux virtuels
 
Cours eigrp
Cours eigrpCours eigrp
Cours eigrp
 
Protocole EIGRP
Protocole EIGRPProtocole EIGRP
Protocole EIGRP
 
Services IP
Services IPServices IP
Services IP
 
Routage
RoutageRoutage
Routage
 
E4 pt act_7_5_1
E4 pt act_7_5_1E4 pt act_7_5_1
E4 pt act_7_5_1
 
Cours3 ospf-eigrp
Cours3 ospf-eigrpCours3 ospf-eigrp
Cours3 ospf-eigrp
 
1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage
 
Weos routage dynamique OSPF
Weos routage dynamique OSPFWeos routage dynamique OSPF
Weos routage dynamique OSPF
 
vpn-site-a-site-avec-des-routeurs-cisco
 vpn-site-a-site-avec-des-routeurs-cisco vpn-site-a-site-avec-des-routeurs-cisco
vpn-site-a-site-avec-des-routeurs-cisco
 
EIGRP - Introduction
EIGRP - Introduction EIGRP - Introduction
EIGRP - Introduction
 
Cours routage inter-vlan
Cours routage inter-vlanCours routage inter-vlan
Cours routage inter-vlan
 
cours ospf
cours ospf cours ospf
cours ospf
 
CISCO HSRP VRRP GLBP
CISCO HSRP VRRP GLBPCISCO HSRP VRRP GLBP
CISCO HSRP VRRP GLBP
 
Ccna4
Ccna4Ccna4
Ccna4
 
Fr introbgp-sif
Fr introbgp-sifFr introbgp-sif
Fr introbgp-sif
 
Présentation etherchannel
Présentation etherchannelPrésentation etherchannel
Présentation etherchannel
 

Similaire à EIGRP - Configuration

Configuration de-base-d
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
Nabil EL KASSOUMI
 
Ccna 2-module-2-v4
Ccna 2-module-2-v4Ccna 2-module-2-v4
Ccna 2-module-2-v4
Siham Tatiggit
 
Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
EL AMRI El Hassan
 
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : RoutingAlphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm
 
leprotocoleriptoutescesversion-170309205133 (1).pptx
leprotocoleriptoutescesversion-170309205133 (1).pptxleprotocoleriptoutescesversion-170309205133 (1).pptx
leprotocoleriptoutescesversion-170309205133 (1).pptx
Franckdayan1
 
notions de routage IP
notions de routage IPnotions de routage IP
notions de routage IP
mohamednacim
 
1485606887355.pdf
1485606887355.pdf1485606887355.pdf
1485606887355.pdf
Bader Nassiri
 
Tuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-siteTuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-site
Dimitri LEMBOKOLO
 
Le protocole rip
Le protocole rip Le protocole rip
Astuces cisco
Astuces ciscoAstuces cisco
Astuces cisco
CONNECT Tunisia
 
laboratoire formation ccna cisco materiel .ppt
laboratoire formation ccna cisco materiel .pptlaboratoire formation ccna cisco materiel .ppt
laboratoire formation ccna cisco materiel .ppt
profsn
 
Composants routeur cisco et différent mode de Configuration
Composants routeur cisco et différent mode de ConfigurationComposants routeur cisco et différent mode de Configuration
Composants routeur cisco et différent mode de Configuration
ZakariaBouzzitMadrid
 
Configuration ospf
Configuration ospfConfiguration ospf
Configuration ospf
Joeongala
 
commande 2.pdf
commande 2.pdfcommande 2.pdf
commande 2.pdf
alirayss
 
Chapitre 6 - Protocoles TCP/IP, UDP/IP
Chapitre 6  - Protocoles TCP/IP, UDP/IPChapitre 6  - Protocoles TCP/IP, UDP/IP
Chapitre 6 - Protocoles TCP/IP, UDP/IP
Tarik Zakaria Benmerar
 
Rip-ng vs ospf-v3
Rip-ng vs ospf-v3Rip-ng vs ospf-v3
Rip-ng vs ospf-v3
Islem mhalla
 
Diapo zig bee_amin_jan11_final
Diapo zig bee_amin_jan11_finalDiapo zig bee_amin_jan11_final
Diapo zig bee_amin_jan11_final
Amin Ferjani
 
OPTIMISATION BGP
OPTIMISATION BGPOPTIMISATION BGP
OPTIMISATION BGP
Aymen Bouzid
 

Similaire à EIGRP - Configuration (20)

Configuration de-base-d
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
 
Ccna 2-module-2-v4
Ccna 2-module-2-v4Ccna 2-module-2-v4
Ccna 2-module-2-v4
 
Les commandes CISCO (routeur)
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
 
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : RoutingAlphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
Alphorm.com Formation CCNP ENCOR 350-401 (2of8) : Routing
 
leprotocoleriptoutescesversion-170309205133 (1).pptx
leprotocoleriptoutescesversion-170309205133 (1).pptxleprotocoleriptoutescesversion-170309205133 (1).pptx
leprotocoleriptoutescesversion-170309205133 (1).pptx
 
notions de routage IP
notions de routage IPnotions de routage IP
notions de routage IP
 
1485606887355.pdf
1485606887355.pdf1485606887355.pdf
1485606887355.pdf
 
Tuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-siteTuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-site
 
Le protocole rip
Le protocole rip Le protocole rip
Le protocole rip
 
Tout atm
Tout atmTout atm
Tout atm
 
Astuces cisco
Astuces ciscoAstuces cisco
Astuces cisco
 
laboratoire formation ccna cisco materiel .ppt
laboratoire formation ccna cisco materiel .pptlaboratoire formation ccna cisco materiel .ppt
laboratoire formation ccna cisco materiel .ppt
 
Composants routeur cisco et différent mode de Configuration
Composants routeur cisco et différent mode de ConfigurationComposants routeur cisco et différent mode de Configuration
Composants routeur cisco et différent mode de Configuration
 
Configuration ospf
Configuration ospfConfiguration ospf
Configuration ospf
 
commande 2.pdf
commande 2.pdfcommande 2.pdf
commande 2.pdf
 
Chapitre 6 - Protocoles TCP/IP, UDP/IP
Chapitre 6  - Protocoles TCP/IP, UDP/IPChapitre 6  - Protocoles TCP/IP, UDP/IP
Chapitre 6 - Protocoles TCP/IP, UDP/IP
 
Rip-ng vs ospf-v3
Rip-ng vs ospf-v3Rip-ng vs ospf-v3
Rip-ng vs ospf-v3
 
CCNA 3.pdf
CCNA 3.pdfCCNA 3.pdf
CCNA 3.pdf
 
Diapo zig bee_amin_jan11_final
Diapo zig bee_amin_jan11_finalDiapo zig bee_amin_jan11_final
Diapo zig bee_amin_jan11_final
 
OPTIMISATION BGP
OPTIMISATION BGPOPTIMISATION BGP
OPTIMISATION BGP
 

Dernier

Droits et devoirs, éthique universitaire..
Droits et devoirs, éthique universitaire..Droits et devoirs, éthique universitaire..
Droits et devoirs, éthique universitaire..
TarikBouchala
 
MÉDIATION ORALE - MON NOUVEL APPARTEMENT.pdf
MÉDIATION ORALE - MON NOUVEL APPARTEMENT.pdfMÉDIATION ORALE - MON NOUVEL APPARTEMENT.pdf
MÉDIATION ORALE - MON NOUVEL APPARTEMENT.pdf
lebaobabbleu
 
A1- Compréhension orale - présentations.pdf
A1- Compréhension orale - présentations.pdfA1- Compréhension orale - présentations.pdf
A1- Compréhension orale - présentations.pdf
lebaobabbleu
 
GUIDE POUR L’EVRAS BALISES ET APPRENTISSAGES
GUIDE POUR L’EVRAS BALISES ET APPRENTISSAGESGUIDE POUR L’EVRAS BALISES ET APPRENTISSAGES
GUIDE POUR L’EVRAS BALISES ET APPRENTISSAGES
DjibrilToure5
 
Auguste Herbin.pptx Peintre français
Auguste   Herbin.pptx Peintre   françaisAuguste   Herbin.pptx Peintre   français
Auguste Herbin.pptx Peintre français
Txaruka
 
La Révolution Bénédictine Casadéenne du Livradois-Forez: De Charlemagne à Fra...
La Révolution Bénédictine Casadéenne du Livradois-Forez: De Charlemagne à Fra...La Révolution Bénédictine Casadéenne du Livradois-Forez: De Charlemagne à Fra...
La Révolution Bénédictine Casadéenne du Livradois-Forez: De Charlemagne à Fra...
Editions La Dondaine
 
1e Espaces productifs 2024.Espaces productif
1e Espaces productifs 2024.Espaces productif1e Espaces productifs 2024.Espaces productif
1e Espaces productifs 2024.Espaces productif
NadineHG
 
1e geo metropolisation metropolisation x
1e geo metropolisation metropolisation x1e geo metropolisation metropolisation x
1e geo metropolisation metropolisation x
NadineHG
 
Zineb Mekouar.pptx Écrivaine marocaine
Zineb Mekouar.pptx   Écrivaine  marocaineZineb Mekouar.pptx   Écrivaine  marocaine
Zineb Mekouar.pptx Écrivaine marocaine
Txaruka
 
Burkina Faso libraries newsletter for June 2024
Burkina Faso libraries newsletter for June 2024Burkina Faso libraries newsletter for June 2024
Burkina Faso libraries newsletter for June 2024
Friends of African Village Libraries
 

Dernier (10)

Droits et devoirs, éthique universitaire..
Droits et devoirs, éthique universitaire..Droits et devoirs, éthique universitaire..
Droits et devoirs, éthique universitaire..
 
MÉDIATION ORALE - MON NOUVEL APPARTEMENT.pdf
MÉDIATION ORALE - MON NOUVEL APPARTEMENT.pdfMÉDIATION ORALE - MON NOUVEL APPARTEMENT.pdf
MÉDIATION ORALE - MON NOUVEL APPARTEMENT.pdf
 
A1- Compréhension orale - présentations.pdf
A1- Compréhension orale - présentations.pdfA1- Compréhension orale - présentations.pdf
A1- Compréhension orale - présentations.pdf
 
GUIDE POUR L’EVRAS BALISES ET APPRENTISSAGES
GUIDE POUR L’EVRAS BALISES ET APPRENTISSAGESGUIDE POUR L’EVRAS BALISES ET APPRENTISSAGES
GUIDE POUR L’EVRAS BALISES ET APPRENTISSAGES
 
Auguste Herbin.pptx Peintre français
Auguste   Herbin.pptx Peintre   françaisAuguste   Herbin.pptx Peintre   français
Auguste Herbin.pptx Peintre français
 
La Révolution Bénédictine Casadéenne du Livradois-Forez: De Charlemagne à Fra...
La Révolution Bénédictine Casadéenne du Livradois-Forez: De Charlemagne à Fra...La Révolution Bénédictine Casadéenne du Livradois-Forez: De Charlemagne à Fra...
La Révolution Bénédictine Casadéenne du Livradois-Forez: De Charlemagne à Fra...
 
1e Espaces productifs 2024.Espaces productif
1e Espaces productifs 2024.Espaces productif1e Espaces productifs 2024.Espaces productif
1e Espaces productifs 2024.Espaces productif
 
1e geo metropolisation metropolisation x
1e geo metropolisation metropolisation x1e geo metropolisation metropolisation x
1e geo metropolisation metropolisation x
 
Zineb Mekouar.pptx Écrivaine marocaine
Zineb Mekouar.pptx   Écrivaine  marocaineZineb Mekouar.pptx   Écrivaine  marocaine
Zineb Mekouar.pptx Écrivaine marocaine
 
Burkina Faso libraries newsletter for June 2024
Burkina Faso libraries newsletter for June 2024Burkina Faso libraries newsletter for June 2024
Burkina Faso libraries newsletter for June 2024
 

EIGRP - Configuration

  • 1. CCNP ROUTE Implementation de Routage IP Mohamed DYABI Configuration de l’EIGRP
  • 2. Bonjour Instructeur : MOHAMED DYABI Email : mohamed.dyabi@gmail.com FB : facebook.com/med.dyabi  Instructeur Cisco • Certifié CISCO (CISCO ID CSCO12578708) • Certifié MCT (MC ID 7343319) • Expert Microsoft 2003,2008,2012 Server • Certified VCP DATACENTER ,VCA Cloud ,DATACENTER ,Workforce Mobility …..
  • 4. LES PAQUETS EIGRP  Hello : • utilisés par EIGRP pour découvrir des voisins et former des contiguïtés avec ces voisins  mise à jour : • utilisés par EIGRP pour propager des informations de routage. • EIGRP n’envoie pas de mises à jour périodiques. • Ils sont transmis uniquement en cas de nécessité. • Les mises à jour EIGRP ne contiennent que les informations de routage nécessaires, et ne sont envoyées qu’aux routeurs qui en ont besoin. • Les paquets de mise à jour EIGRP utilisent la livraison fiable. Ils sont envoyés en multicast lorsqu’ils concernent plusieurs routeurs, ou en unicast si seul un routeur en a besoin 4
  • 5. LES PAQUETS EIGRP  Paquets de requête : Ils sont utilisés lorsque le routeur EIGRP a perdu des informations sur un réseau et n’a pas de chemins de sauvegarde. Le routeur envoie des paquets de requête à ses voisins pour leur demander s'ils ont des informations sur ce réseau particulier.  Paquets de réponse : Ils sont utilisés pour répondre à des paquets de requête et ils sont fiables. 5
  • 6. LES PAQUETS EIGRP  Les paquets ACK (de reçu) : sont envoyés par EIGRP lorsque la livraison fiable est utilisée. RTP utilise la livraison fiable pour les paquets de mise à jour, de demande et de réponse EIGRP. Les paquets d’accusé de réception EIGRP sont toujours envoyés en unicast non fiable. 6
  • 8. CONFIGURATION DE L’EIGRP  Définir le numéro du système Autonome  Pour échanger des mises à jour de routage, les routeurs EIGRP doivent avoir le même ID de système autonome router eigrp autonomous-system-id Activer le routage EIGRP Router(config)# 8
  • 9. CONFIGURATION DE L’EIGRP  Définir les réseaux EIGRP pour les annoncer aux voisins EIGRP  Le paramètre network peut être un réseau, un sous-réseau, ou l'adresse d'une interface directement connectée  Le masque est un masque générique (masque inverse) network network [mask] Identifier les réseaux EIGRP Router(config-router) # 9
  • 10. CONFIGURATION DE L’EIGRP  La plupart des références EIGRP affirment que le masque générique est nécessaire.  Cependant, depuis IOS 12.0 (4) T, le masque peut être configuré à l'aide des bits de joker (wild card bits ) ou un masque de sous-réseau régulier.  Par exemple, On peut utiliser les deux formats suivants pour configurer le réseau 10.10.10.0 • network 10.10.10.0 0.0.0.3 ou • network 10.10.10.0 255.255.255.252. Note sur le masque générique 10
  • 11. CONFIGURATION DE L’EIGRP  Après cette commande le protocole EIGRP se comportera comme un protocole de routage par classe  On peut désactiver le résumé automatique à l’aide de la commande no auto-summary  no auto-summary est nécessaire parce que par défaut EIGRP se comporte comme un protocole de routage par classe ce qui signifie qu'il ne va pas annoncer le masque de sous-réseau. auto-summary Activer / Désactiver le résumé automatique Router(config-router) # 11
  • 12. CONFIGURATION DE L’EIGRP Exemple de la configuration de l’EIGRP R2(config)# no router eigrp 100 R2(config)# router eigrp 100 R2(config-router)# network 192.168.1.96 0.0.0.31 R2(config-router)# network 172.17.2.0 0.0.0.255 R2(config-router)# end R1(config)# no router eigrp 100 R1(config)# router eigrp 100 R1(config-router)# network 192.168.1.96 0.0.0.31 R1(config-router)# network 172.16.1.0 0.0.0.255 R1(config-router)# end 12
  • 13. CONFIGURATION DE L’EIGRP  vérification de la configuration de l’EIGRP R1# show ip protocols Routing Protocol is "eigrp 100" <output omitted> EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0 EIGRP maximum hopcount 100 EIGRP maximum metric variance 1 Redistributing: eigrp 100 EIGRP NSF-aware route hold timer is 240s Automatic network summarization is in effect Automatic address summarization: 192.168.1.0/24 for FastEthernet0/0 Summarizing with metric 40512000 172.16.0.0/16 for Serial0/0/0 Summarizing with metric 28160 Maximum path: 4 Routing for Networks: 172.16.1.0/24 192.168.1.96/27 Routing Information Sources: Gateway Distance Last Update (this router) 90 00:08:56 Gateway Distance Last Update 192.168.1.102 90 00:07:59 Distance: internal 90 external 170 13
  • 14. CONFIGURATION DE L’EIGRP  vérification de la configuration de l’EIGRP R1# show ip eigrp neighbors IP-EIGRP neighbors for process 100 H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (ms) Cnt Num 0 192.168.1.102 Se0/0/0 11 00:09:17 22 2280 0 5 14
  • 15. CONFIGURATION DE L’EIGRP  vérification de la configuration de l’EIGRP R1# show ip eigrp topology IP-EIGRP Topology Table for AS(100)/ID(192.168.1.101) Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - reply Status, s - sia Status P 192.168.1.96/27, 1 successors, FD is 40512000 via Connected, Serial0/0/0 P 192.168.1.0/24, 1 successors, FD is 40512000 via Summary (40512000/0), Null0 P 172.16.0.0/16, 1 successors, FD is 28160 via Summary (28160/0), Null0 P 172.17.0.0/16, 1 successors, FD is 40514560 via 192.168.1.102 (40514560/28160), Serial0/0/0 P 172.16.1.0/24, 1 successors, FD is 28160 via Connected, FastEthernet0/0 15
  • 16. CONFIGURATION DE L’EIGRP  vérification de la configuration de l’EIGRP R1# show ip route eigrp D 172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:10:18, Serial0/0/0 172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks D 172.16.0.0/16 is a summary, 00:11:19, Null0 192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks D 192.168.1.0/24 is a summary, 00:11:19, Null0 R1# R1# show ip route <output omitted> Gateway of last resort is not set D 172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:10:35, Serial0/0/0 172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks D 172.16.0.0/16 is a summary, 00:11:37, Null0 C 172.16.1.0/24 is directly connected, FastEthernet0/0 192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks C 192.168.1.96/27 is directly connected, Serial0/0/0 D 192.168.1.0/24 is a summary, 00:11:37, Null0 16
  • 17. CONFIGURATION DE L’EIGRP  Empêcher les mises à jour EIGRP sur une interface de routeur  L'option default définit toutes les interfaces de routeur passives.  Pour l’EIGRP , la commande : • Empêche les relations de voisinage d'être établie • Les mises à jour de routage d'un voisin sont ignorés • Permet à un sous-réseau sur une interface passive d’être annoncé passive-interface type number [default] Interface passive Router(config-router) # 17
  • 18. CONFIGURATION DE L’EIGRP R1(config)# router eigrp 100 R1(config-router)# passive-interface fa0/0 R2(config)# router eigrp 100 R2(config-router)# passive-interface fa0/0 ou bien R1(config)# router eigrp 100 R1(config-router)# passive-interface default R1(config-router)# no passive-interface S0/0/0 18
  • 19. CONFIGURATION DE L’EIGRP  Définir les réseaux EIGRP pour les annoncer aux voisins EIGRP  Le paramètre kilobits indique la bande passante prévue en Kbits/s. • Par exemple, pour définir la bande passante de 512 000 bits/s, utilisez la commande bandwidth 512  La bande passante configurée est utilisée par les protocoles de routage dans le calcul de métriques  La commande ne modifie pas réellement la vitesse de l'interface. bandwidth kilobits Définir la bande passante de l’interface : Router(config-if)# 19
  • 20. CONFIGURATION DE L’EIGRP Exemple de la commande ip route 0.0.0.0 0.0.0.0 next-hop R2(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.2 R2(config)# router eigrp 100 R2(config-router)# network 0.0.0.0 R2(config-router)# redistribute static R2(config-router)# do show ip route <output omitted> Gateway of last resort is 192.168.1.2 to network 0.0.0.0 172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks D 172.17.0.0/16 is a summary, 02:53:48, Null0 C 172.17.2.0/24 is directly connected, FastEthernet0/0 D 172.16.0.0/16 [90/40514560] via 192.168.1.101, 02:53:48, Serial0/0/0 192.168.1.0/27 is subnetted, 2 subnets C 192.168.1.96 is directly connected, Serial0/0/0 C 192.168.1.0 is directly connected, Serial0/0/1 S* 0.0.0.0/0 [1/0] via 192.168.1.2 R2(config-router)# 20