SlideShare une entreprise Scribd logo
MiNET et ses services
Maisel INT NETwork par définition

28 Septembre 2010
Bienvenue


✤   Architecture physique

✤   Architecture logique

✤   Services en pagaille

✤   Et si on cassait tout ?
Architecture physique


✤   700 chambres reliées en ethernet dans des salles de brassage (une
    dans chaque batîment)

✤   6+1 batîments reliés à un routeur en fibre optique

✤   1 salle serveurs avec 20 lames Sun (Dual Opteron/2Go/60Go)

✤   2 serveurs TV au U6
Réseau MiNET
Architecture logique


✤   DISI nous donne 157.159.40.x jusqu’à 157.159.47.255 (2048 IPs)

✤   Diviser pour règner : chaque batîment Ui se voit attribué la plage
    157.159.4i.0 à 157.159.4i.255

✤   Protéger les services : créer un réseau interne pour les administrer
    (192.168.1.0 par exemple)

✤   Mettre du WIFI (172.16.x.x), etc..
Un peu le bazar...
Rangement en VLAN


✤   VLAN, pour Virtual LAN

✤   Dans le routeur on définit des sous-réseaux qui seront
    automatiquement propagés aux autres équipements


✤   On définit sur le switch ensuite vers quel VLAN orienté l’ordinateur
    connecté sur un port
Il habite à l’U4 donc VLAN 44
Il est connecté sur le
port 42 du RCOM 1
!
interface FastEthernet0/42
 description 4594
 switchport access vlan 44
 switchport mode access
 dot1x pae authenticator
 dot1x port-control auto
 dot1x host-mode multi-host
 dot1x violation-mode protect
 dot1x timeout tx-period 2
 dot1x timeout supp-timeout 5
 dot1x guest-vlan 15
 dot1x auth-fail vlan 15
 spanning-tree portfast
!
interface Vlan44
 ip address 157.159.44.1 255.255.255.0
 ip helper-address 192.168.1.3
 ip helper-address 192.168.1.5
 ip wccp web-cache redirect in
 ip pim version 1
 ip pim sparse-mode
 ip sap listen
end
Et d’autres VLANs
     !
     interface Vlan100
      description Admin
      ip address 192.168.1.1 255.255.255.0
      ip access-group vlan_admin in
      ip access-group vlan_admin out
      no ip redirects
      no ip unreachables
      no ip proxy-arp
      no ip route-cache cef
      no ip route-cache
      no ip mroute-cache
     end
     !
     interface Vlan10
      description Vlan WiFi
      no ip address
      ip pim version 1
      ip pim sparse-mode
      ip sap listen
     end
     !

qui ne sont pas routés sur Internet
Texte
OK !
On peut tous se connecter mais c’est pas très automatique tout ça
Gros mots


✤   LDAP

✤   RADIUS

✤   DHCP

✤   DNS

✤   Proxy
LDAP
Là où sont stockées toutes vos données
Chaque service en a besoin.
 S’il tombe, tout tombe !
RADIUS
autorise l’adhérent à utiliser le réseau
Réseau MiNET
Oups... mauvais mot de passe !

   ...
    dot1x guest-vlan 15
    dot1x auth-fail vlan 15
   ...
Réseau MiNET
Et si ça marche, on entre dans le VLAN 4i
Can I haz IP ?
DHCP
Oh hai ! I’m still here
Réseau MiNET
OK!
Le réseau se configure automatiquement,
      on va voir si Google marche.
Quel IP se cache derrière le domaine google.fr ?
$ nslookup google.fr
Server:! ! 157.159.40.55
Address:! 157.159.40.55#53

Non-authoritative answer:
Name:!google.fr
Address: 66.249.92.104
Il n’y a plus qu’à se connecter sur cette IP pour obtenir ma page.
   Comme elle n’appartient pas à mon réseau, pour l’atteindre,
               je passe par la passerelle par défaut.
Qui a fait l’association domaine/IP ?
                 Bind
options {
!   directory "/var/cache/bind/";

!    // Port de sortie 53
!    query-source address 157.159.40.55 port 53;

!    listen-on {
!    !    157.159.40.55;
!    !    192.168.1.55;
!    !    127.0.0.1;
!    !    172.16.0.55;
!    };
!
!    allow-query { any; };

     forwarders {
!    !   8.8.8.8;
!    !   157.159.10.12;
!    !   157.159.10.13;
!    !   157.159.11.13;
!    };
};
Plus vite, plus vite !
Faisons du cache avec un proxy (transparent) !
SQUID
     garde en cache les pages web
sait ce que vous regardez sur Internet
Vous en voulez encore ?



✤   Firewall

✤   VPN

✤   Nagios et serveur de logs
Bonus (à découvrir sur imagine.minet.net)



✤   Hébergement Web pour les adhérents et les assoces

✤   Mail @minet.net

✤   Listes de diffusion
Maintenant, on casse tout



✤   LDAP c’est has-been

✤   NoSQL, Document-store, Rails
Réseau MiNET
Réseau MiNET

Contenu connexe

Tendances

5.0 install de webiopi
5.0 install de webiopi5.0 install de webiopi
5.0 install de webiopi
Osi Pallière
 
Acces distant VPN (mode client) pour la domotique
Acces distant VPN (mode client) pour la domotiqueAcces distant VPN (mode client) pour la domotique
Acces distant VPN (mode client) pour la domotique
Benoît VAN DEN BULCKE
 
Installation de la clé orange sur ubuntu
Installation de la clé orange sur ubuntuInstallation de la clé orange sur ubuntu
Installation de la clé orange sur ubuntu
Rahma Ben Hammouda
 
Protocoles SSL/TLS
Protocoles SSL/TLSProtocoles SSL/TLS
Protocoles SSL/TLS
Thomas Moegli
 
Tp snmp-packet-tracer
Tp snmp-packet-tracerTp snmp-packet-tracer
Tp snmp-packet-tracer
Chris Dogny
 
Weos tunnel ssl hôte à site
Weos   tunnel ssl hôte à siteWeos   tunnel ssl hôte à site
Weos tunnel ssl hôte à site
Fabian Vandendyck
 
DevoxxFR 2019: Consul @Criteo
DevoxxFR 2019: Consul @CriteoDevoxxFR 2019: Consul @Criteo
DevoxxFR 2019: Consul @Criteo
Pierre Souchay
 
Protocole IKE/IPsec
Protocole IKE/IPsecProtocole IKE/IPsec
Protocole IKE/IPsec
Thomas Moegli
 
Exemple de configuration de serveur VPN distant avec NAT entrant pour le traf...
Exemple de configuration de serveur VPN distant avec NAT entrant pour le traf...Exemple de configuration de serveur VPN distant avec NAT entrant pour le traf...
Exemple de configuration de serveur VPN distant avec NAT entrant pour le traf...
Regis VPN
 
Cisco ASA
Cisco ASACisco ASA
Cisco ASA
Thomas Moegli
 
VTP(Virtual Trunking Protocol)
VTP(Virtual Trunking Protocol)VTP(Virtual Trunking Protocol)
VTP(Virtual Trunking Protocol)
Sirine Ibrahim
 
Ingénieur Réseaux Sécurité
Ingénieur Réseaux SécuritéIngénieur Réseaux Sécurité
Ingénieur Réseaux Sécurité
Aurore de Cosnac
 
Ccna 4 configuration-de_frame_ relay_hub_and_spoke
Ccna 4 configuration-de_frame_ relay_hub_and_spokeCcna 4 configuration-de_frame_ relay_hub_and_spoke
Ccna 4 configuration-de_frame_ relay_hub_and_spoke
Touré Kunda
 
Mise en place nagios
Mise en place nagiosMise en place nagios
Mise en place nagios
JeanFrancoisMARTIN5
 
TomatoUSB asus rtn66
TomatoUSB asus rtn66TomatoUSB asus rtn66
TomatoUSB asus rtn66
charlielefebvre14
 
Guide De Piratage Dun Reseau Wifi Domestique (Ou Commentexploserune Clef Wep)...
Guide De Piratage Dun Reseau Wifi Domestique (Ou Commentexploserune Clef Wep)...Guide De Piratage Dun Reseau Wifi Domestique (Ou Commentexploserune Clef Wep)...
Guide De Piratage Dun Reseau Wifi Domestique (Ou Commentexploserune Clef Wep)...
guest0b40ec
 
Stabiliser salt stack_avec_ansible
Stabiliser salt stack_avec_ansibleStabiliser salt stack_avec_ansible
Stabiliser salt stack_avec_ansible
Smaïne KAHLOUCH
 
Authentification des protocoles de routage
Authentification des protocoles de routageAuthentification des protocoles de routage
Authentification des protocoles de routage
Thomas Moegli
 

Tendances (20)

5.0 install de webiopi
5.0 install de webiopi5.0 install de webiopi
5.0 install de webiopi
 
Acces distant VPN (mode client) pour la domotique
Acces distant VPN (mode client) pour la domotiqueAcces distant VPN (mode client) pour la domotique
Acces distant VPN (mode client) pour la domotique
 
Installation de la clé orange sur ubuntu
Installation de la clé orange sur ubuntuInstallation de la clé orange sur ubuntu
Installation de la clé orange sur ubuntu
 
Protocoles SSL/TLS
Protocoles SSL/TLSProtocoles SSL/TLS
Protocoles SSL/TLS
 
Tp snmp-packet-tracer
Tp snmp-packet-tracerTp snmp-packet-tracer
Tp snmp-packet-tracer
 
Weos tunnel ssl hôte à site
Weos   tunnel ssl hôte à siteWeos   tunnel ssl hôte à site
Weos tunnel ssl hôte à site
 
DevoxxFR 2019: Consul @Criteo
DevoxxFR 2019: Consul @CriteoDevoxxFR 2019: Consul @Criteo
DevoxxFR 2019: Consul @Criteo
 
Protocole IKE/IPsec
Protocole IKE/IPsecProtocole IKE/IPsec
Protocole IKE/IPsec
 
Exemple de configuration de serveur VPN distant avec NAT entrant pour le traf...
Exemple de configuration de serveur VPN distant avec NAT entrant pour le traf...Exemple de configuration de serveur VPN distant avec NAT entrant pour le traf...
Exemple de configuration de serveur VPN distant avec NAT entrant pour le traf...
 
Version Final Presentation
Version Final PresentationVersion Final Presentation
Version Final Presentation
 
Cisco ASA
Cisco ASACisco ASA
Cisco ASA
 
Adsl cisco
Adsl ciscoAdsl cisco
Adsl cisco
 
VTP(Virtual Trunking Protocol)
VTP(Virtual Trunking Protocol)VTP(Virtual Trunking Protocol)
VTP(Virtual Trunking Protocol)
 
Ingénieur Réseaux Sécurité
Ingénieur Réseaux SécuritéIngénieur Réseaux Sécurité
Ingénieur Réseaux Sécurité
 
Ccna 4 configuration-de_frame_ relay_hub_and_spoke
Ccna 4 configuration-de_frame_ relay_hub_and_spokeCcna 4 configuration-de_frame_ relay_hub_and_spoke
Ccna 4 configuration-de_frame_ relay_hub_and_spoke
 
Mise en place nagios
Mise en place nagiosMise en place nagios
Mise en place nagios
 
TomatoUSB asus rtn66
TomatoUSB asus rtn66TomatoUSB asus rtn66
TomatoUSB asus rtn66
 
Guide De Piratage Dun Reseau Wifi Domestique (Ou Commentexploserune Clef Wep)...
Guide De Piratage Dun Reseau Wifi Domestique (Ou Commentexploserune Clef Wep)...Guide De Piratage Dun Reseau Wifi Domestique (Ou Commentexploserune Clef Wep)...
Guide De Piratage Dun Reseau Wifi Domestique (Ou Commentexploserune Clef Wep)...
 
Stabiliser salt stack_avec_ansible
Stabiliser salt stack_avec_ansibleStabiliser salt stack_avec_ansible
Stabiliser salt stack_avec_ansible
 
Authentification des protocoles de routage
Authentification des protocoles de routageAuthentification des protocoles de routage
Authentification des protocoles de routage
 

En vedette

Les cahiers de la cuisine 2.2
Les cahiers de la cuisine 2.2Les cahiers de la cuisine 2.2
Les cahiers de la cuisine 2.2
blackcatpower
 
Precios residentes Canarios
Precios residentes CanariosPrecios residentes Canarios
Precios residentes Canarios
CanariasViaja
 
Trabajo 100903104533-phpapp01
Trabajo 100903104533-phpapp01Trabajo 100903104533-phpapp01
Trabajo 100903104533-phpapp01
soijuanjo
 
Dalida - Douce Nuit, Sainte Nuit
Dalida - Douce Nuit, Sainte NuitDalida - Douce Nuit, Sainte Nuit
Dalida - Douce Nuit, Sainte Nuit
zorpar
 
Salón Manga
Salón MangaSalón Manga
Salón Manga
Marian Dunia
 
Plkj
PlkjPlkj
Habito 5. armando
Habito 5. armandoHabito 5. armando
Habito 5. armando
Armando Jesús Cauich Muñoz
 
Ley de formalizacion fredy marcos
Ley de formalizacion   fredy marcosLey de formalizacion   fredy marcos
Ley de formalizacion fredy marcos
Fredy Paredes
 
Maghreb
MaghrebMaghreb
Maghreb
School
 
Losmoluscos
LosmoluscosLosmoluscos
Losmoluscos
chony82
 
Andrea larissa
Andrea larissaAndrea larissa
Andrea larissa
Andiitha Arce
 
S1.problematique d'ensemble
S1.problematique d'ensembleS1.problematique d'ensemble
S1.problematique d'ensemble
Juan Matallana Camacho
 
Inuit tourisme langue
Inuit tourisme langueInuit tourisme langue
Inuit tourisme langue
IoanaDolcos
 
Présentation PLM
Présentation PLMPrésentation PLM
Présentation PLM
edanon
 
11 23 session 48
11 23 session 4811 23 session 48
11 23 session 48
nblock
 
Trabajo de sena amperimetro puntonumero 8
Trabajo de sena amperimetro puntonumero 8Trabajo de sena amperimetro puntonumero 8
Trabajo de sena amperimetro puntonumero 8
francisco giraldo
 

En vedette (20)

Les cahiers de la cuisine 2.2
Les cahiers de la cuisine 2.2Les cahiers de la cuisine 2.2
Les cahiers de la cuisine 2.2
 
Vademecum 2011
Vademecum 2011Vademecum 2011
Vademecum 2011
 
Precios residentes Canarios
Precios residentes CanariosPrecios residentes Canarios
Precios residentes Canarios
 
Trabajo 100903104533-phpapp01
Trabajo 100903104533-phpapp01Trabajo 100903104533-phpapp01
Trabajo 100903104533-phpapp01
 
Dalida - Douce Nuit, Sainte Nuit
Dalida - Douce Nuit, Sainte NuitDalida - Douce Nuit, Sainte Nuit
Dalida - Douce Nuit, Sainte Nuit
 
Salón Manga
Salón MangaSalón Manga
Salón Manga
 
Plkj
PlkjPlkj
Plkj
 
Habito 5. armando
Habito 5. armandoHabito 5. armando
Habito 5. armando
 
Le ballet
Le balletLe ballet
Le ballet
 
Ley de formalizacion fredy marcos
Ley de formalizacion   fredy marcosLey de formalizacion   fredy marcos
Ley de formalizacion fredy marcos
 
Maghreb
MaghrebMaghreb
Maghreb
 
Losmoluscos
LosmoluscosLosmoluscos
Losmoluscos
 
Odfnews Fr 20090605
Odfnews Fr 20090605Odfnews Fr 20090605
Odfnews Fr 20090605
 
Andrea larissa
Andrea larissaAndrea larissa
Andrea larissa
 
S1.problematique d'ensemble
S1.problematique d'ensembleS1.problematique d'ensemble
S1.problematique d'ensemble
 
Inuit tourisme langue
Inuit tourisme langueInuit tourisme langue
Inuit tourisme langue
 
Présentation PLM
Présentation PLMPrésentation PLM
Présentation PLM
 
11 23 session 48
11 23 session 4811 23 session 48
11 23 session 48
 
La opera de Paris
La opera de ParisLa opera de Paris
La opera de Paris
 
Trabajo de sena amperimetro puntonumero 8
Trabajo de sena amperimetro puntonumero 8Trabajo de sena amperimetro puntonumero 8
Trabajo de sena amperimetro puntonumero 8
 

Similaire à Réseau MiNET

F5 ltm administering big ip v11
F5 ltm administering big ip v11F5 ltm administering big ip v11
F5 ltm administering big ip v11
Amine Haddanou
 
Réseau MiNET - intro newbies
Réseau MiNET - intro newbiesRéseau MiNET - intro newbies
Réseau MiNET - intro newbies
Stephanie Ouillon
 
Installation et Configuration de Pfsense
Installation et Configuration de PfsenseInstallation et Configuration de Pfsense
Installation et Configuration de Pfsense
Ismail Rachdaoui
 
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
Hackfest Communication
 
Kit de survie pour l'IoT façon DIY
Kit de survie pour l'IoT façon DIYKit de survie pour l'IoT façon DIY
Kit de survie pour l'IoT façon DIY
laurenthuet
 
Tuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-siteTuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-site
Dimitri LEMBOKOLO
 
Présentation vbox fw104
Présentation vbox fw104Présentation vbox fw104
Présentation vbox fw104
Yacine Hamoudi
 
Présentation vbox fw104
Présentation vbox fw104Présentation vbox fw104
Présentation vbox fw104
Yacine Hamoudi
 
E4 pt act_7_5_1
E4 pt act_7_5_1E4 pt act_7_5_1
E4 pt act_7_5_1
Simo Alaoui
 
Domain Name System Security Extensions (aka. DNSSEC pour les intimes)
Domain Name System Security Extensions (aka. DNSSEC  pour les intimes)Domain Name System Security Extensions (aka. DNSSEC  pour les intimes)
Domain Name System Security Extensions (aka. DNSSEC pour les intimes)
felixaime
 
Extraction mots de passe par attaque Man-in-the-middle
Extraction mots de passe par attaque Man-in-the-middleExtraction mots de passe par attaque Man-in-the-middle
Extraction mots de passe par attaque Man-in-the-middle
Bruno Valentin
 
Comment paramétrer une connexion adsl sur un modem
Comment paramétrer une connexion adsl sur un modemComment paramétrer une connexion adsl sur un modem
Comment paramétrer une connexion adsl sur un modem
CONNECT Tunisia
 
sshGate
sshGatesshGate
sshGate
LINAGORA
 
Petit potam slides-rtfm-ossir
Petit potam slides-rtfm-ossirPetit potam slides-rtfm-ossir
Petit potam slides-rtfm-ossir
LionelTopotam
 
Presentation
PresentationPresentation
Presentation
Bayrem GHARSELLAOUI
 
Colloque cyber 2010 les botnets
Colloque cyber 2010   les botnetsColloque cyber 2010   les botnets
Colloque cyber 2010 les botnets
michelcusin
 
ssh, bien plus qu'un telnet sécurisé
ssh, bien plus qu'un telnet sécuriséssh, bien plus qu'un telnet sécurisé
ssh, bien plus qu'un telnet sécurisé
Tryphon
 

Similaire à Réseau MiNET (20)

F5 ltm administering big ip v11
F5 ltm administering big ip v11F5 ltm administering big ip v11
F5 ltm administering big ip v11
 
Apache Open SSL
Apache Open SSLApache Open SSL
Apache Open SSL
 
Réseau MiNET - intro newbies
Réseau MiNET - intro newbiesRéseau MiNET - intro newbies
Réseau MiNET - intro newbies
 
Installation et Configuration de Pfsense
Installation et Configuration de PfsenseInstallation et Configuration de Pfsense
Installation et Configuration de Pfsense
 
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
802.1X filaire, un monde idéal illusoire? (Olivier Bilodeau)
 
Kit de survie pour l'IoT façon DIY
Kit de survie pour l'IoT façon DIYKit de survie pour l'IoT façon DIY
Kit de survie pour l'IoT façon DIY
 
BSidesQuebec2013-ssl
BSidesQuebec2013-sslBSidesQuebec2013-ssl
BSidesQuebec2013-ssl
 
Tuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-siteTuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-site
 
Présentation vbox fw104
Présentation vbox fw104Présentation vbox fw104
Présentation vbox fw104
 
Présentation vbox fw104
Présentation vbox fw104Présentation vbox fw104
Présentation vbox fw104
 
E4 pt act_7_5_1
E4 pt act_7_5_1E4 pt act_7_5_1
E4 pt act_7_5_1
 
Domain Name System Security Extensions (aka. DNSSEC pour les intimes)
Domain Name System Security Extensions (aka. DNSSEC  pour les intimes)Domain Name System Security Extensions (aka. DNSSEC  pour les intimes)
Domain Name System Security Extensions (aka. DNSSEC pour les intimes)
 
Extraction mots de passe par attaque Man-in-the-middle
Extraction mots de passe par attaque Man-in-the-middleExtraction mots de passe par attaque Man-in-the-middle
Extraction mots de passe par attaque Man-in-the-middle
 
Ocs
OcsOcs
Ocs
 
Comment paramétrer une connexion adsl sur un modem
Comment paramétrer une connexion adsl sur un modemComment paramétrer une connexion adsl sur un modem
Comment paramétrer une connexion adsl sur un modem
 
sshGate
sshGatesshGate
sshGate
 
Petit potam slides-rtfm-ossir
Petit potam slides-rtfm-ossirPetit potam slides-rtfm-ossir
Petit potam slides-rtfm-ossir
 
Presentation
PresentationPresentation
Presentation
 
Colloque cyber 2010 les botnets
Colloque cyber 2010   les botnetsColloque cyber 2010   les botnets
Colloque cyber 2010 les botnets
 
ssh, bien plus qu'un telnet sécurisé
ssh, bien plus qu'un telnet sécuriséssh, bien plus qu'un telnet sécurisé
ssh, bien plus qu'un telnet sécurisé
 

Réseau MiNET

  • 1. MiNET et ses services Maisel INT NETwork par définition 28 Septembre 2010
  • 2. Bienvenue ✤ Architecture physique ✤ Architecture logique ✤ Services en pagaille ✤ Et si on cassait tout ?
  • 3. Architecture physique ✤ 700 chambres reliées en ethernet dans des salles de brassage (une dans chaque batîment) ✤ 6+1 batîments reliés à un routeur en fibre optique ✤ 1 salle serveurs avec 20 lames Sun (Dual Opteron/2Go/60Go) ✤ 2 serveurs TV au U6
  • 5. Architecture logique ✤ DISI nous donne 157.159.40.x jusqu’à 157.159.47.255 (2048 IPs) ✤ Diviser pour règner : chaque batîment Ui se voit attribué la plage 157.159.4i.0 à 157.159.4i.255 ✤ Protéger les services : créer un réseau interne pour les administrer (192.168.1.0 par exemple) ✤ Mettre du WIFI (172.16.x.x), etc..
  • 6. Un peu le bazar...
  • 7. Rangement en VLAN ✤ VLAN, pour Virtual LAN ✤ Dans le routeur on définit des sous-réseaux qui seront automatiquement propagés aux autres équipements ✤ On définit sur le switch ensuite vers quel VLAN orienté l’ordinateur connecté sur un port
  • 8. Il habite à l’U4 donc VLAN 44 Il est connecté sur le port 42 du RCOM 1
  • 9. ! interface FastEthernet0/42 description 4594 switchport access vlan 44 switchport mode access dot1x pae authenticator dot1x port-control auto dot1x host-mode multi-host dot1x violation-mode protect dot1x timeout tx-period 2 dot1x timeout supp-timeout 5 dot1x guest-vlan 15 dot1x auth-fail vlan 15 spanning-tree portfast !
  • 10. interface Vlan44 ip address 157.159.44.1 255.255.255.0 ip helper-address 192.168.1.3 ip helper-address 192.168.1.5 ip wccp web-cache redirect in ip pim version 1 ip pim sparse-mode ip sap listen end
  • 11. Et d’autres VLANs ! interface Vlan100 description Admin ip address 192.168.1.1 255.255.255.0 ip access-group vlan_admin in ip access-group vlan_admin out no ip redirects no ip unreachables no ip proxy-arp no ip route-cache cef no ip route-cache no ip mroute-cache end ! interface Vlan10 description Vlan WiFi no ip address ip pim version 1 ip pim sparse-mode ip sap listen end ! qui ne sont pas routés sur Internet
  • 12. Texte
  • 13. OK ! On peut tous se connecter mais c’est pas très automatique tout ça
  • 14. Gros mots ✤ LDAP ✤ RADIUS ✤ DHCP ✤ DNS ✤ Proxy
  • 15. LDAP Là où sont stockées toutes vos données
  • 16. Chaque service en a besoin. S’il tombe, tout tombe !
  • 17. RADIUS autorise l’adhérent à utiliser le réseau
  • 19. Oups... mauvais mot de passe ! ... dot1x guest-vlan 15 dot1x auth-fail vlan 15 ...
  • 21. Et si ça marche, on entre dans le VLAN 4i
  • 22. Can I haz IP ?
  • 23. DHCP
  • 24. Oh hai ! I’m still here
  • 26. OK! Le réseau se configure automatiquement, on va voir si Google marche.
  • 27. Quel IP se cache derrière le domaine google.fr ?
  • 28. $ nslookup google.fr Server:! ! 157.159.40.55 Address:! 157.159.40.55#53 Non-authoritative answer: Name:!google.fr Address: 66.249.92.104
  • 29. Il n’y a plus qu’à se connecter sur cette IP pour obtenir ma page. Comme elle n’appartient pas à mon réseau, pour l’atteindre, je passe par la passerelle par défaut.
  • 30. Qui a fait l’association domaine/IP ? Bind
  • 31. options { ! directory "/var/cache/bind/"; ! // Port de sortie 53 ! query-source address 157.159.40.55 port 53; ! listen-on { ! ! 157.159.40.55; ! ! 192.168.1.55; ! ! 127.0.0.1; ! ! 172.16.0.55; ! }; ! ! allow-query { any; }; forwarders { ! ! 8.8.8.8; ! ! 157.159.10.12; ! ! 157.159.10.13; ! ! 157.159.11.13; ! }; };
  • 32. Plus vite, plus vite ! Faisons du cache avec un proxy (transparent) !
  • 33. SQUID garde en cache les pages web sait ce que vous regardez sur Internet
  • 34. Vous en voulez encore ? ✤ Firewall ✤ VPN ✤ Nagios et serveur de logs
  • 35. Bonus (à découvrir sur imagine.minet.net) ✤ Hébergement Web pour les adhérents et les assoces ✤ Mail @minet.net ✤ Listes de diffusion
  • 36. Maintenant, on casse tout ✤ LDAP c’est has-been ✤ NoSQL, Document-store, Rails